source: projects/specs/trunk/s/stunnel/stunnel-vl.spec @ 9789

Revision 9789, 15.0 KB checked in by tomop, 9 years ago (diff)

stunnel-5.25-1

Line 
1%define ver 5.25
2%define rel 1
3
4Summary: An SSL-encrypting socket wrapper
5Name: stunnel
6Version: %{ver}
7Release: %{rel}%{?_dist_release}
8License: GPLv2
9Group: Applications/Internet
10URL: https://www.stunnel.org/
11Source0: https://www.stunnel.org/downloads/stunnel-%{version}.tar.gz
12Source1: https://www.stunnel.org/downloads/stunnel-%{version}.tar.gz.asc
13Source2: Certificate-Creation
14Source3: sfinger.xinetd
15Source4: stunnel-sfinger.conf
16Source5: pop3-redirect.xinetd
17Source6: stunnel-pop3s-client.conf
18Source100: stunnel.init
19Patch0: stunnel-5.25-authpriv.patch
20Patch1: stunnel-5.25-config.patch
21Buildroot: %{_tmppath}/stunnel-root
22# util-linux is needed for rename
23BuildRequires: openssl-devel
24BuildRequires: pkgconfig
25BuildRequires: tcp_wrappers
26BuildRequires: util-linux
27
28Vendor: Project Vine
29Distribution: Vine Linux
30Packager: iwaim
31
32%description
33Stunnel is a socket wrapper which can provide SSL (Secure Sockets
34Layer) support to ordinary applications. For example, it can be used
35in conjunction with imapd to create an SSL secure IMAP server.
36
37%prep
38%setup -q
39%patch0 -p1 -b .authpriv
40%patch1 -p1 -b .config
41
42%build
43CFLAGS="$RPM_OPT_FLAGS -fPIC"; export CFLAGS
44if pkg-config openssl ; then
45        CFLAGS="$CFLAGS `pkg-config --cflags openssl`";
46        LDFLAGS="`pkg-config --libs-only-L openssl`"; export LDFLAGS
47fi
48%configure --disable-fips --enable-ipv6 \
49        CPPFLAGS="-UPIDFILE -DPIDFILE='\"%{_localstatedir}/run/stunnel.pid\"'"
50make LDADD="-pie -Wl,-z,defs,-z,relro,-z,now"
51
52%install
53rm -rf $RPM_BUILD_ROOT
54mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/stunnel/conf.d
55touch $RPM_BUILD_ROOT%{_sysconfdir}/stunnel/stunnel.pem
56make install DESTDIR=$RPM_BUILD_ROOT
57# Move the translated man pages to the right subdirectories, and strip off the
58# language suffixes.
59for lang in pl ; do
60        mkdir -p $RPM_BUILD_ROOT/%{_mandir}/${lang}/man8
61        mv $RPM_BUILD_ROOT/%{_mandir}/man8/*.${lang}.8* $RPM_BUILD_ROOT/%{_mandir}/${lang}/man8/
62        rename ".${lang}" "" $RPM_BUILD_ROOT/%{_mandir}/${lang}/man8/*
63done
64
65install -d -m755 %{buildroot}%{_initdir}
66install -m755 %{SOURCE100} %{buildroot}%{_initdir}/stunnel
67
68install -d m755 %{buildroot}%{_sysconfdir}/sysconfig
69cat <<EOF > %{buildroot}%{_sysconfdir}/sysconfig/stunnel
70ENABLED=0
71EOF
72
73mkdir -p srpm-docs
74cp %{SOURCE2} %{SOURCE3} %{SOURCE4} %{SOURCE5} %{SOURCE6} srpm-docs
75
76%clean
77rm -rf $RPM_BUILD_ROOT
78
79%pre
80getent group stunnel >/dev/null || groupadd -r stunnel
81getent passwd stunnel >/dev/null || \
82useradd -r -g stunnel -d /dev/null -s /sbin/nologin \
83  -c "stunnel service account" stunnel
84
85%post
86/sbin/chkconfig --add stunnel
87
88%preun
89if [ $1 -eq 0 ]; then
90  /sbin/chkconfig --del stunnel
91fi
92
93%files
94%defattr(-,root,root)
95%doc AUTHORS BUGS ChangeLog COPY* CREDITS PORTS README TODO
96%doc tools/stunnel.conf-sample
97%doc srpm-docs/*
98%lang(en) %doc doc/en/*
99%lang(po) %doc doc/pl/*
100%{_bindir}/stunnel
101%{_initdir}/stunnel
102%exclude %{_bindir}/stunnel3
103%exclude %{_datadir}/doc/stunnel
104%{_libdir}/stunnel
105%exclude %{_libdir}/stunnel/libstunnel.la
106%{_mandir}/man8/stunnel.8*
107%lang(pl) %{_mandir}/pl/man8/stunnel.8*
108%dir %{_sysconfdir}/%{name}
109%dir %{_sysconfdir}/%{name}/conf.d
110%exclude %{_sysconfdir}/stunnel/stunnel.conf-sample
111%exclude %{_sysconfdir}/stunnel/stunnel.pem
112%config(noreplace) %{_sysconfdir}/sysconfig/%{name}
113
114%changelog
115* Fri Nov  6 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.25-1
116- new upstream release.
117- fixed dates in %%changelog.
118- updated all patches.
119
120* Tue Jan 15 2013 IWAI, Masaharu <iwai@alib.jp> 4.54-1
121- initial build for Vine Linux
122
123*Mon Dec 10 2012 Avesh Agarwal <avagarwa@redhat.com> - 4.54-2
124- 884183: support for full relro.
125
126*Tue Oct 16 2012 Avesh Agarwal <avagarwa@redhat.com> - 4.54-1
127- New upstream realease 4.54
128- Updated local patches
129
130* Sat Jul 21 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.53-2
131- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
132
133* Mon May 14 2012 Avesh Agarwal <avagarwa@redhat.com> - 4.53-1
134- New upstream realease 4.53
135- Updated local patches
136
137* Tue Mar 6 2012 Avesh Agarwal <avagarwa@redhat.com> - 4.52-1
138- New upstream realease 4.52
139- Updated local patches
140
141* Sat Jan 14 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.50-2
142- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
143
144* Tue Jan 3 2012 Avesh Agarwal <avagarwa@redhat.com> - 4.50-1
145- New upstream realease 4.50
146- Updated local patches
147
148* Tue Sep 20 2011 Avesh Agarwal <avagarwa@redhat.com> - 4.44-1
149- New upstream realease 4.44
150- Updated local patches
151
152* Fri Aug 19 2011 Avesh Agarwal <avagarwa@redhat.com> - 4.42-1
153- New upstream realease 4.42
154- Updated local patches
155- Fixes #732069
156
157* Mon Aug 1 2011 Avesh Agarwal <avagarwa@redhat.com> - 4.41-1
158- New upstream realease 4.41
159- Updated local patches to match the new release
160
161* Tue Jun 28 2011 Avesh Agarwal <avagarwa@redhat.com> - 4.37-1
162- New upstream realease 4.37
163- Updated local patches to match the new release
164
165* Mon Apr 4 2011 Avesh Agarwal <avagarwa@redhat.com> - 4.35-1
166- New upstream realease 4.35
167- Updated authpriv and sample patches to match the new release
168
169* Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.34-2
170- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
171
172* Mon Oct 4 2010 Avesh Agarwal <avagarwa@redhat.com> - 4.34-1
173- New upstream realease 4.34
174- Updated authpriv and sample patches to match the new release
175
176* Wed Apr 7 2010 Avesh Agarwal <avagarwa@redhat.com> - 4.33-1
177- New upstream realease 4.33
178- Updated authpriv and sample patches to match the new release
179- Addresses bz 580117 (inted mode support issue)
180
181* Mon Mar 29 2010 Avesh Agarwal <avagarwa@redhat.com> - 4.32-1
182- New upstream realease 4.32
183- Updated authpriv and sample patches to match the new release
184
185* Tue Feb 16 2010 Avesh Agarwal <avagarwa@redhat.com> - 4.31-1
186- New upstream realease 4.31
187- Updated authpriv and sample patches to match the new release
188
189* Tue Jan 26 2010 Avesh Agarwal <avagarwa@redhat.com> - 4.30-1
190- New upstream realease 4.30
191- Updated authpriv and sample patches for the new release
192
193* Wed Dec 09 2009 Avesh Agarwal <avagarwa@redhat.com> - 4.29-1
194- New upstream realease 4.29
195- Updated authpriv and sample patches for the new release
196- Modified spec file to include dist tag
197
198* Fri Aug 21 2009 Tomas Mraz <tmraz@redhat.com> - 4.27-5
199- rebuilt with new openssl
200
201* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.27-4
202- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
203
204* Sun May  3 2009 Miloslav Trmač <mitr@redhat.com> - 4.27-3
205- Fix the previous patch.
206
207* Wed Apr 29 2009 Miloslav Trmač <mitr@redhat.com> - 4.27-2
208- Avoid aliasing undefined by ISO C
209
210* Thu Apr 16 2009 Miloslav Trmač <mitr@redhat.com> - 4.27-1
211- Update to stunnel-4.27.
212
213* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.26-3
214- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
215
216* Sun Jan 18 2009 Tomas Mraz <tmraz@redhat.com> - 4.26-2
217- disable openssl upstream fips mode
218
219* Mon Sep 22 2008 Miloslav Trmač <mitr@redhat.com> - 4.26-1
220- Update to stunnel-4.26.
221
222* Sun Jun  8 2008 Miloslav Trmač <mitr@redhat.com> - 4.25-2
223- Use a clearer error message if the service name is unknown in "accept"
224  Resolves: #450344
225
226* Mon Jun  2 2008 Miloslav Trmač <mitr@redhat.com> - 4.25-1
227- Update to stunnel-4.25
228
229* Tue May 20 2008 Miloslav Trmač <mitr@redhat.com> - 4.24-2
230- Drop stunnel3
231  Resolves: #442842
232
233* Mon May 19 2008 Miloslav Trmač <mitr@redhat.com> - 4.24-1
234- Update to stunnel-4.24
235
236* Fri Mar 28 2008 Miloslav Trmač <mitr@redhat.com> - 4.22-1
237- Update to stunnel-4.22
238
239* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 4.20-6
240- Autorebuild for GCC 4.3
241
242* Tue Dec  4 2007 Miloslav Trmač <mitr@redhat.com> - 4.20-5
243- Rebuild with openssl-0.9.8g
244
245* Tue Oct 16 2007 Miloslav Trmač <mitr@redhat.com> - 4.20-4
246- Revert the port to NSS, wait for NSS-based stunnel 5.x instead
247  Resolves: #301971
248- Mark localized man pages with %%lang (patch by Ville Skyttä)
249  Resolves: #322281
250
251* Tue Aug 28 2007 Miloslav Trmač <mitr@redhat.com> - 4.20-3.nss
252- Port to NSS
253
254* Mon Dec  4 2006 Miloslav Trmac <mitr@redhat.com> - 4.20-2
255- Update BuildRequires for the separate tcp_wrappers-devel package
256
257* Thu Nov 30 2006 Miloslav Trmac <mitr@redhat.com> - 4.20-1
258- Update to stunnel-4.20
259
260* Sat Nov 11 2006 Miloslav Trmac <mitr@redhat.com> - 4.19-1
261- Update to stunnel-4.19
262
263* Wed Oct 25 2006 Miloslav Trmac <mitr@redhat.com> - 4.18-1
264- Update to stunnel-4.18
265- Remove unused stunnel.cnf from the src.rpm
266- Fix some rpmlint warnings
267
268* Fri Aug 18 2006 Jesse Keating <jkeating@redhat.com> - 4.15-2
269- rebuilt with latest binutils to pick up 64K -z commonpagesize on ppc*
270  (#203001)
271
272* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 4.15-1.1
273- rebuild
274
275* Sat Mar 18 2006 Miloslav Trmac <mitr@redhat.com> - 4.15-1
276- Update to stunnel-4.15
277
278* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 4.14-3.2
279- bump again for double-long bug on ppc(64)
280
281* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 4.14-3.1
282- rebuilt for new gcc4.1 snapshot and glibc changes
283
284* Tue Jan 31 2006 Miloslav Trmac <mitr@redhat.com> - 4.14-3
285- Use pthread threading to fix crash on x86_64 (#179236)
286
287* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
288- rebuilt
289
290* Wed Nov  9 2005 Miloslav Trmac <mitr@redhat.com> - 4.14-2
291- Rebuild with newer openssl
292
293* Thu Nov  3 2005 Miloslav Trmac <mitr@redhat.com> - 4.14-1
294- Update to stunnel-4.14
295- Override changed default pid file location, keep it in %%{_localstatedir}/run
296
297* Sat Oct 22 2005 Miloslav Trmac <mitr@redhat.com> - 4.13-1
298- Update to stunnel-4.13
299
300* Fri Sep 30 2005 Miloslav Trmac <mitr@redhat.com> - 4.12-1
301- Update to stunnel-4.12
302
303* Thu Sep 22 2005 Miloslav Trmac <mitr@redhat.com> - 4.11-2
304- Enable IPv6 (#169050, patch by Peter Bieringer)
305- Don't ship another copy of man pages in HTML
306
307* Tue Jul 12 2005 Miloslav Trmac <mitr@redhat.com> - 4.11-1
308- Update to stunnel-4.11
309- Fix int/size_t mismatches in stack_info ()
310- Update Certificate-Creation for /etc/pki
311
312* Wed Jun  1 2005 Miloslav Trmac <mitr@redhat.com> - 4.10-2
313- Fix inetd mode
314- Remove unnecessary Requires: and BuildRequires:
315- Clean up the spec file
316
317* Tue Apr 26 2005 Nalin Dahyabhai <nalin@redhat.com> 4.10-1
318- update to 4.10
319
320* Tue Apr 26 2005 Nalin Dahyabhai <nalin@redhat.com> 4.08-2
321- add buildprereqs on libtool, util-linux; change textutils/fileutils dep to
322  coreutils (#133961)
323
324* Wed Mar 16 2005 Nalin Dahyabhai <nalin@redhat.com> 4.08-1
325- update to 4.08
326- build stunnel as a PIE binary
327
328* Mon Nov 22 2004 Miloslav Trmac <mitr@redhat.com> - 4.05-4
329- Convert man pages to UTF-8
330
331* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
332- rebuilt
333
334* Thu May 27 2004 Nalin Dahyabhai <nalin@redhat.com> 4.05-2
335- move the sample configuration to %%doc, it shouldn't be used as-is (#124373)
336
337* Thu Mar 11 2004 Nalin Dahyabhai <nalin@redhat.com> 4.05-1
338- update to 4.05
339
340* Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
341- rebuilt
342
343* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
344- rebuilt
345
346* Thu Aug  7 2003 Elliot Lee <sopwith@redhat.com> 4.04-6
347- Fix libtool
348
349* Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
350- rebuilt
351
352* Fri Mar 21 2003 Nalin Dahyabhai <nalin@redhat.com> 4.04-4
353- fix xinetd configuration samples
354
355* Mon Feb 10 2003 Nalin Dahyabhai <nalin@redhat.com> 4.04-3
356- rebuild
357
358* Wed Jan 22 2003 Tim Powers <timp@redhat.com>
359- rebuilt
360
361* Wed Jan 15 2003 Nalin Dahyabhai <nalin@redhat.com> 4.04-1
362- update to 4.04
363
364* Tue Jan  7 2003 Nalin Dahyabhai <nalin@redhat.com> 4.03-1
365- use pkgconfig for information about openssl, if available
366
367* Fri Jan  3 2003 Nalin Dahyabhai <nalin@redhat.com>
368- update to 4.03
369
370* Mon Oct 21 2002 Nalin Dahyabhai <nalin@redhat.com> 4.02-1
371- update to 4.02
372
373* Fri Oct  4 2002 Nalin Dahyabhai <nalin@redhat.com> 4.00-1
374- don't create a dummy cert
375
376* Wed Sep 25 2002 Nalin Dahyabhai <nalin@redhat.com>
377- update to 4.00
378- remove textutils and fileutils as buildreqs, add automake/autoconf
379
380* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
381- automated rebuild
382
383* Sun May 26 2002 Tim Powers <timp@redhat.com>
384- automated rebuild
385
386* Fri May 17 2002 Nalin Dahyabhai <nalin@redhat.com> 3.22-2
387- rebuild in new environment
388
389* Wed Jan  2 2002 Nalin Dahyabhai <nalin@redhat.com> 3.22-1
390- update to 3.22, correcting a format-string vulnerability
391
392* Wed Oct 31 2001 Nalin Dahyabhai <nalin@redhat.com> 3.21a-1
393- update to 3.21a
394
395* Tue Aug 28 2001 Nalin Dahyabhai <nalin@redhat.com> 3.20-1
396- log using LOG_AUTHPRIV facility by default (#47289)
397- make permissions on stunnel binary 0755
398- implicitly trust certificates in %%{_datadir}/ssl/trusted (#24034)
399
400* Fri Aug 10 2001 Nalin Dahyabhai <nalin@redhat.com> 3.19-1
401- update to 3.19 to avoid problems with stunnel being multithreaded, but
402  tcp wrappers not being thrad-safe
403
404* Mon Jul 30 2001 Nalin Dahyabhai <nalin@redhat.com>
405- update to 3.17
406
407* Mon Jul 23 2001 Nalin Dahyabhai <nalin@redhat.com>
408- update to 3.16
409
410* Mon Jul 16 2001 Nalin Dahyabhai <nalin@redhat.com>
411- update to 3.15
412- enable tcp-wrappers support
413
414* Tue May 29 2001 Nalin Dahyabhai <nalin@redhat.com>
415- remove explicit requirement on openssl (specific version isn't enough,
416  we have to depend on shared library version anyway)
417
418* Fri Apr 27 2001 Nalin Dahyabhai <nalin@redhat.com>
419- update to 3.14
420
421* Mon Mar 26 2001 Preston Brown <pbrown@redhat.com>
422- depend on make (#33148)
423
424* Fri Mar  2 2001 Nalin Dahyabhai <nalin@redhat.com>
425- rebuild in new environment
426
427* Tue Feb  6 2001 Nalin Dahyabhai <nalin@redhat.com>
428- update to 3.13 to get pthread, OOB, 64-bit fixes
429- don't need sdf any more
430
431* Thu Dec 28 2000 Nalin Dahyabhai <nalin@redhat.com>
432- pull in sdf to build the man page (#22892)
433
434* Fri Dec 22 2000 Nalin Dahyabhai <nalin@redhat.com>
435- update to 3.11
436- chuck the SIGHUP patch (went upstream)
437- chuck parts of the 64-bit clean patch (went upstream)
438
439* Thu Dec 21 2000 Nalin Dahyabhai <nalin@redhat.com>
440- update to 3.10
441- more 64-bit clean changes, hopefully the last bunch
442
443* Wed Dec 20 2000 Nalin Dahyabhai <nalin@redhat.com>
444- change piddir from the default /var/stunnel to /var/run
445- clean out pid file on SIGHUP
446
447* Fri Dec 15 2000 Nalin Dahyabhai <nalin@redhat.com>
448- update to 3.9 to get a security fix
449
450* Wed Oct 25 2000 Matt Wilson <msw@redhat.com>
451- change all unsigned longs to u_int32_t when dealing with network
452  addresses
453
454* Fri Aug 18 2000 Nalin Dahyabhai <nalin@redhat.com>
455- make stunnel.pem also be (missingok)
456
457* Thu Jun 29 2000 Nalin Dahyabhai <nalin@redhat.com>
458- move to Applications/Internet group
459- clean up %%post script
460- make stunnel.pem %%ghost %%config(noreplace)
461- provide a sample file for use with xinetd
462
463* Thu Jun  8 2000 Nalin Dahyabhai <nalin@redhat.com>
464- FHS compliance fixes
465- modify defaults
466
467* Tue Mar 14 2000 Florian La Roche <Florian.LaRoche@redhat.com>
468- update to 3.8
469- do not create certificate if one already exists
470
471* Mon Feb 21 2000 Florian La Roche <Florian.LaRoche@redhat.com>
472- update to 3.7
473- add patch to find /usr/share/ssl
474- change some perms
475
476* Sat Oct 30 1999 Bernhard Rosenkraenzer <bero@redhat.com>
477- Modify spec file to match Red Hat standards
478
479* Thu Aug 12 1999 Damien Miller <damien@ibs.com.au>
480- Updated to 3.4a
481- Patched for OpenSSL 0.9.4
482- Cleaned up files section
483
484* Sun Jul 11 1999 Damien Miller <dmiller@ilogic.com.au>
485- Updated to 3.3
486
487* Sat Nov 28 1998 Damien Miller <dmiller@ilogic.com.au>
488- Initial RPMification
Note: See TracBrowser for help on using the repository browser.