source: projects/specs/trunk/s/stunnel/stunnel-vl.spec @ 10081

Revision 10081, 15.1 KB checked in by tomop, 8 years ago (diff)

stunnel-5.31-1

Line 
1%define ver 5.31
2%define rel 1
3
4Summary: An SSL-encrypting socket wrapper
5Name: stunnel
6Version: %{ver}
7Release: %{rel}%{?_dist_release}
8License: GPLv2
9Group: Applications/Internet
10URL: https://www.stunnel.org/
11Source0: https://www.stunnel.org/downloads/stunnel-%{version}.tar.gz
12Source1: https://www.stunnel.org/downloads/stunnel-%{version}.tar.gz.asc
13Source2: Certificate-Creation
14Source3: sfinger.xinetd
15Source4: stunnel-sfinger.conf
16Source5: pop3-redirect.xinetd
17Source6: stunnel-pop3s-client.conf
18Source100: stunnel.init
19Patch0: stunnel-5.25-authpriv.patch
20Patch1: stunnel-5.25-config.patch
21Buildroot: %{_tmppath}/stunnel-root
22# util-linux is needed for rename
23BuildRequires: openssl-devel
24BuildRequires: pkgconfig
25BuildRequires: tcp_wrappers
26BuildRequires: util-linux
27
28Vendor: Project Vine
29Distribution: Vine Linux
30Packager: iwaim
31
32%description
33Stunnel is a socket wrapper which can provide SSL (Secure Sockets
34Layer) support to ordinary applications. For example, it can be used
35in conjunction with imapd to create an SSL secure IMAP server.
36
37%prep
38%setup -q
39%patch0 -p1 -b .authpriv
40%patch1 -p1 -b .config
41
42%build
43CFLAGS="$RPM_OPT_FLAGS -fPIC"; export CFLAGS
44if pkg-config openssl ; then
45        CFLAGS="$CFLAGS `pkg-config --cflags openssl`";
46        LDFLAGS="`pkg-config --libs-only-L openssl`"; export LDFLAGS
47fi
48%configure --disable-fips --enable-ipv6 \
49        CPPFLAGS="-UPIDFILE -DPIDFILE='\"%{_localstatedir}/run/stunnel.pid\"'"
50make LDADD="-pie -Wl,-z,defs,-z,relro,-z,now"
51
52%install
53rm -rf $RPM_BUILD_ROOT
54mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/stunnel/conf.d
55touch $RPM_BUILD_ROOT%{_sysconfdir}/stunnel/stunnel.pem
56make install DESTDIR=$RPM_BUILD_ROOT
57# Move the translated man pages to the right subdirectories, and strip off the
58# language suffixes.
59for lang in pl ; do
60        mkdir -p $RPM_BUILD_ROOT/%{_mandir}/${lang}/man8
61        mv $RPM_BUILD_ROOT/%{_mandir}/man8/*.${lang}.8* $RPM_BUILD_ROOT/%{_mandir}/${lang}/man8/
62        rename ".${lang}" "" $RPM_BUILD_ROOT/%{_mandir}/${lang}/man8/*
63done
64
65install -d -m755 %{buildroot}%{_initdir}
66install -m755 %{SOURCE100} %{buildroot}%{_initdir}/stunnel
67
68install -d m755 %{buildroot}%{_sysconfdir}/sysconfig
69cat <<EOF > %{buildroot}%{_sysconfdir}/sysconfig/stunnel
70ENABLED=0
71EOF
72
73mkdir -p srpm-docs
74cp %{SOURCE2} %{SOURCE3} %{SOURCE4} %{SOURCE5} %{SOURCE6} srpm-docs
75
76%clean
77rm -rf $RPM_BUILD_ROOT
78
79%pre
80getent group stunnel >/dev/null || groupadd -r stunnel
81getent passwd stunnel >/dev/null || \
82useradd -r -g stunnel -d /dev/null -s /sbin/nologin \
83  -c "stunnel service account" stunnel
84
85%post
86/sbin/chkconfig --add stunnel
87
88%preun
89if [ $1 -eq 0 ]; then
90  /sbin/chkconfig --del stunnel
91fi
92
93%files
94%defattr(-,root,root)
95%doc AUTHORS BUGS ChangeLog COPY* CREDITS PORTS README TODO
96%doc tools/stunnel.conf-sample
97%doc srpm-docs/*
98%lang(en) %doc doc/en/*
99%lang(po) %doc doc/pl/*
100%{_bindir}/stunnel
101%{_initdir}/stunnel
102%exclude %{_bindir}/stunnel3
103%exclude %{_datadir}/doc/stunnel
104%{_libdir}/stunnel
105%exclude %{_libdir}/stunnel/libstunnel.la
106%{_mandir}/man8/stunnel.8*
107%lang(pl) %{_mandir}/pl/man8/stunnel.8*
108%dir %{_sysconfdir}/%{name}
109%dir %{_sysconfdir}/%{name}/conf.d
110%exclude %{_sysconfdir}/stunnel/stunnel.conf-sample
111%exclude %{_sysconfdir}/stunnel/stunnel.pem
112%config(noreplace) %{_sysconfdir}/sysconfig/%{name}
113
114%changelog
115* Tue Mar 15 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.31-1
116- new upstream release.
117
118* Fri Nov  6 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.25-1
119- new upstream release.
120- fixed dates in %%changelog.
121- updated all patches.
122
123* Tue Jan 15 2013 IWAI, Masaharu <iwai@alib.jp> 4.54-1
124- initial build for Vine Linux
125
126*Mon Dec 10 2012 Avesh Agarwal <avagarwa@redhat.com> - 4.54-2
127- 884183: support for full relro.
128
129*Tue Oct 16 2012 Avesh Agarwal <avagarwa@redhat.com> - 4.54-1
130- New upstream realease 4.54
131- Updated local patches
132
133* Sat Jul 21 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.53-2
134- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
135
136* Mon May 14 2012 Avesh Agarwal <avagarwa@redhat.com> - 4.53-1
137- New upstream realease 4.53
138- Updated local patches
139
140* Tue Mar 6 2012 Avesh Agarwal <avagarwa@redhat.com> - 4.52-1
141- New upstream realease 4.52
142- Updated local patches
143
144* Sat Jan 14 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.50-2
145- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
146
147* Tue Jan 3 2012 Avesh Agarwal <avagarwa@redhat.com> - 4.50-1
148- New upstream realease 4.50
149- Updated local patches
150
151* Tue Sep 20 2011 Avesh Agarwal <avagarwa@redhat.com> - 4.44-1
152- New upstream realease 4.44
153- Updated local patches
154
155* Fri Aug 19 2011 Avesh Agarwal <avagarwa@redhat.com> - 4.42-1
156- New upstream realease 4.42
157- Updated local patches
158- Fixes #732069
159
160* Mon Aug 1 2011 Avesh Agarwal <avagarwa@redhat.com> - 4.41-1
161- New upstream realease 4.41
162- Updated local patches to match the new release
163
164* Tue Jun 28 2011 Avesh Agarwal <avagarwa@redhat.com> - 4.37-1
165- New upstream realease 4.37
166- Updated local patches to match the new release
167
168* Mon Apr 4 2011 Avesh Agarwal <avagarwa@redhat.com> - 4.35-1
169- New upstream realease 4.35
170- Updated authpriv and sample patches to match the new release
171
172* Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.34-2
173- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
174
175* Mon Oct 4 2010 Avesh Agarwal <avagarwa@redhat.com> - 4.34-1
176- New upstream realease 4.34
177- Updated authpriv and sample patches to match the new release
178
179* Wed Apr 7 2010 Avesh Agarwal <avagarwa@redhat.com> - 4.33-1
180- New upstream realease 4.33
181- Updated authpriv and sample patches to match the new release
182- Addresses bz 580117 (inted mode support issue)
183
184* Mon Mar 29 2010 Avesh Agarwal <avagarwa@redhat.com> - 4.32-1
185- New upstream realease 4.32
186- Updated authpriv and sample patches to match the new release
187
188* Tue Feb 16 2010 Avesh Agarwal <avagarwa@redhat.com> - 4.31-1
189- New upstream realease 4.31
190- Updated authpriv and sample patches to match the new release
191
192* Tue Jan 26 2010 Avesh Agarwal <avagarwa@redhat.com> - 4.30-1
193- New upstream realease 4.30
194- Updated authpriv and sample patches for the new release
195
196* Wed Dec 09 2009 Avesh Agarwal <avagarwa@redhat.com> - 4.29-1
197- New upstream realease 4.29
198- Updated authpriv and sample patches for the new release
199- Modified spec file to include dist tag
200
201* Fri Aug 21 2009 Tomas Mraz <tmraz@redhat.com> - 4.27-5
202- rebuilt with new openssl
203
204* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.27-4
205- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
206
207* Sun May  3 2009 Miloslav Trmač <mitr@redhat.com> - 4.27-3
208- Fix the previous patch.
209
210* Wed Apr 29 2009 Miloslav Trmač <mitr@redhat.com> - 4.27-2
211- Avoid aliasing undefined by ISO C
212
213* Thu Apr 16 2009 Miloslav Trmač <mitr@redhat.com> - 4.27-1
214- Update to stunnel-4.27.
215
216* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.26-3
217- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
218
219* Sun Jan 18 2009 Tomas Mraz <tmraz@redhat.com> - 4.26-2
220- disable openssl upstream fips mode
221
222* Mon Sep 22 2008 Miloslav Trmač <mitr@redhat.com> - 4.26-1
223- Update to stunnel-4.26.
224
225* Sun Jun  8 2008 Miloslav Trmač <mitr@redhat.com> - 4.25-2
226- Use a clearer error message if the service name is unknown in "accept"
227  Resolves: #450344
228
229* Mon Jun  2 2008 Miloslav Trmač <mitr@redhat.com> - 4.25-1
230- Update to stunnel-4.25
231
232* Tue May 20 2008 Miloslav Trmač <mitr@redhat.com> - 4.24-2
233- Drop stunnel3
234  Resolves: #442842
235
236* Mon May 19 2008 Miloslav Trmač <mitr@redhat.com> - 4.24-1
237- Update to stunnel-4.24
238
239* Fri Mar 28 2008 Miloslav Trmač <mitr@redhat.com> - 4.22-1
240- Update to stunnel-4.22
241
242* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 4.20-6
243- Autorebuild for GCC 4.3
244
245* Tue Dec  4 2007 Miloslav Trmač <mitr@redhat.com> - 4.20-5
246- Rebuild with openssl-0.9.8g
247
248* Tue Oct 16 2007 Miloslav Trmač <mitr@redhat.com> - 4.20-4
249- Revert the port to NSS, wait for NSS-based stunnel 5.x instead
250  Resolves: #301971
251- Mark localized man pages with %%lang (patch by Ville Skyttä)
252  Resolves: #322281
253
254* Tue Aug 28 2007 Miloslav Trmač <mitr@redhat.com> - 4.20-3.nss
255- Port to NSS
256
257* Mon Dec  4 2006 Miloslav Trmac <mitr@redhat.com> - 4.20-2
258- Update BuildRequires for the separate tcp_wrappers-devel package
259
260* Thu Nov 30 2006 Miloslav Trmac <mitr@redhat.com> - 4.20-1
261- Update to stunnel-4.20
262
263* Sat Nov 11 2006 Miloslav Trmac <mitr@redhat.com> - 4.19-1
264- Update to stunnel-4.19
265
266* Wed Oct 25 2006 Miloslav Trmac <mitr@redhat.com> - 4.18-1
267- Update to stunnel-4.18
268- Remove unused stunnel.cnf from the src.rpm
269- Fix some rpmlint warnings
270
271* Fri Aug 18 2006 Jesse Keating <jkeating@redhat.com> - 4.15-2
272- rebuilt with latest binutils to pick up 64K -z commonpagesize on ppc*
273  (#203001)
274
275* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 4.15-1.1
276- rebuild
277
278* Sat Mar 18 2006 Miloslav Trmac <mitr@redhat.com> - 4.15-1
279- Update to stunnel-4.15
280
281* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 4.14-3.2
282- bump again for double-long bug on ppc(64)
283
284* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 4.14-3.1
285- rebuilt for new gcc4.1 snapshot and glibc changes
286
287* Tue Jan 31 2006 Miloslav Trmac <mitr@redhat.com> - 4.14-3
288- Use pthread threading to fix crash on x86_64 (#179236)
289
290* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
291- rebuilt
292
293* Wed Nov  9 2005 Miloslav Trmac <mitr@redhat.com> - 4.14-2
294- Rebuild with newer openssl
295
296* Thu Nov  3 2005 Miloslav Trmac <mitr@redhat.com> - 4.14-1
297- Update to stunnel-4.14
298- Override changed default pid file location, keep it in %%{_localstatedir}/run
299
300* Sat Oct 22 2005 Miloslav Trmac <mitr@redhat.com> - 4.13-1
301- Update to stunnel-4.13
302
303* Fri Sep 30 2005 Miloslav Trmac <mitr@redhat.com> - 4.12-1
304- Update to stunnel-4.12
305
306* Thu Sep 22 2005 Miloslav Trmac <mitr@redhat.com> - 4.11-2
307- Enable IPv6 (#169050, patch by Peter Bieringer)
308- Don't ship another copy of man pages in HTML
309
310* Tue Jul 12 2005 Miloslav Trmac <mitr@redhat.com> - 4.11-1
311- Update to stunnel-4.11
312- Fix int/size_t mismatches in stack_info ()
313- Update Certificate-Creation for /etc/pki
314
315* Wed Jun  1 2005 Miloslav Trmac <mitr@redhat.com> - 4.10-2
316- Fix inetd mode
317- Remove unnecessary Requires: and BuildRequires:
318- Clean up the spec file
319
320* Tue Apr 26 2005 Nalin Dahyabhai <nalin@redhat.com> 4.10-1
321- update to 4.10
322
323* Tue Apr 26 2005 Nalin Dahyabhai <nalin@redhat.com> 4.08-2
324- add buildprereqs on libtool, util-linux; change textutils/fileutils dep to
325  coreutils (#133961)
326
327* Wed Mar 16 2005 Nalin Dahyabhai <nalin@redhat.com> 4.08-1
328- update to 4.08
329- build stunnel as a PIE binary
330
331* Mon Nov 22 2004 Miloslav Trmac <mitr@redhat.com> - 4.05-4
332- Convert man pages to UTF-8
333
334* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
335- rebuilt
336
337* Thu May 27 2004 Nalin Dahyabhai <nalin@redhat.com> 4.05-2
338- move the sample configuration to %%doc, it shouldn't be used as-is (#124373)
339
340* Thu Mar 11 2004 Nalin Dahyabhai <nalin@redhat.com> 4.05-1
341- update to 4.05
342
343* Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
344- rebuilt
345
346* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
347- rebuilt
348
349* Thu Aug  7 2003 Elliot Lee <sopwith@redhat.com> 4.04-6
350- Fix libtool
351
352* Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
353- rebuilt
354
355* Fri Mar 21 2003 Nalin Dahyabhai <nalin@redhat.com> 4.04-4
356- fix xinetd configuration samples
357
358* Mon Feb 10 2003 Nalin Dahyabhai <nalin@redhat.com> 4.04-3
359- rebuild
360
361* Wed Jan 22 2003 Tim Powers <timp@redhat.com>
362- rebuilt
363
364* Wed Jan 15 2003 Nalin Dahyabhai <nalin@redhat.com> 4.04-1
365- update to 4.04
366
367* Tue Jan  7 2003 Nalin Dahyabhai <nalin@redhat.com> 4.03-1
368- use pkgconfig for information about openssl, if available
369
370* Fri Jan  3 2003 Nalin Dahyabhai <nalin@redhat.com>
371- update to 4.03
372
373* Mon Oct 21 2002 Nalin Dahyabhai <nalin@redhat.com> 4.02-1
374- update to 4.02
375
376* Fri Oct  4 2002 Nalin Dahyabhai <nalin@redhat.com> 4.00-1
377- don't create a dummy cert
378
379* Wed Sep 25 2002 Nalin Dahyabhai <nalin@redhat.com>
380- update to 4.00
381- remove textutils and fileutils as buildreqs, add automake/autoconf
382
383* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
384- automated rebuild
385
386* Sun May 26 2002 Tim Powers <timp@redhat.com>
387- automated rebuild
388
389* Fri May 17 2002 Nalin Dahyabhai <nalin@redhat.com> 3.22-2
390- rebuild in new environment
391
392* Wed Jan  2 2002 Nalin Dahyabhai <nalin@redhat.com> 3.22-1
393- update to 3.22, correcting a format-string vulnerability
394
395* Wed Oct 31 2001 Nalin Dahyabhai <nalin@redhat.com> 3.21a-1
396- update to 3.21a
397
398* Tue Aug 28 2001 Nalin Dahyabhai <nalin@redhat.com> 3.20-1
399- log using LOG_AUTHPRIV facility by default (#47289)
400- make permissions on stunnel binary 0755
401- implicitly trust certificates in %%{_datadir}/ssl/trusted (#24034)
402
403* Fri Aug 10 2001 Nalin Dahyabhai <nalin@redhat.com> 3.19-1
404- update to 3.19 to avoid problems with stunnel being multithreaded, but
405  tcp wrappers not being thrad-safe
406
407* Mon Jul 30 2001 Nalin Dahyabhai <nalin@redhat.com>
408- update to 3.17
409
410* Mon Jul 23 2001 Nalin Dahyabhai <nalin@redhat.com>
411- update to 3.16
412
413* Mon Jul 16 2001 Nalin Dahyabhai <nalin@redhat.com>
414- update to 3.15
415- enable tcp-wrappers support
416
417* Tue May 29 2001 Nalin Dahyabhai <nalin@redhat.com>
418- remove explicit requirement on openssl (specific version isn't enough,
419  we have to depend on shared library version anyway)
420
421* Fri Apr 27 2001 Nalin Dahyabhai <nalin@redhat.com>
422- update to 3.14
423
424* Mon Mar 26 2001 Preston Brown <pbrown@redhat.com>
425- depend on make (#33148)
426
427* Fri Mar  2 2001 Nalin Dahyabhai <nalin@redhat.com>
428- rebuild in new environment
429
430* Tue Feb  6 2001 Nalin Dahyabhai <nalin@redhat.com>
431- update to 3.13 to get pthread, OOB, 64-bit fixes
432- don't need sdf any more
433
434* Thu Dec 28 2000 Nalin Dahyabhai <nalin@redhat.com>
435- pull in sdf to build the man page (#22892)
436
437* Fri Dec 22 2000 Nalin Dahyabhai <nalin@redhat.com>
438- update to 3.11
439- chuck the SIGHUP patch (went upstream)
440- chuck parts of the 64-bit clean patch (went upstream)
441
442* Thu Dec 21 2000 Nalin Dahyabhai <nalin@redhat.com>
443- update to 3.10
444- more 64-bit clean changes, hopefully the last bunch
445
446* Wed Dec 20 2000 Nalin Dahyabhai <nalin@redhat.com>
447- change piddir from the default /var/stunnel to /var/run
448- clean out pid file on SIGHUP
449
450* Fri Dec 15 2000 Nalin Dahyabhai <nalin@redhat.com>
451- update to 3.9 to get a security fix
452
453* Wed Oct 25 2000 Matt Wilson <msw@redhat.com>
454- change all unsigned longs to u_int32_t when dealing with network
455  addresses
456
457* Fri Aug 18 2000 Nalin Dahyabhai <nalin@redhat.com>
458- make stunnel.pem also be (missingok)
459
460* Thu Jun 29 2000 Nalin Dahyabhai <nalin@redhat.com>
461- move to Applications/Internet group
462- clean up %%post script
463- make stunnel.pem %%ghost %%config(noreplace)
464- provide a sample file for use with xinetd
465
466* Thu Jun  8 2000 Nalin Dahyabhai <nalin@redhat.com>
467- FHS compliance fixes
468- modify defaults
469
470* Tue Mar 14 2000 Florian La Roche <Florian.LaRoche@redhat.com>
471- update to 3.8
472- do not create certificate if one already exists
473
474* Mon Feb 21 2000 Florian La Roche <Florian.LaRoche@redhat.com>
475- update to 3.7
476- add patch to find /usr/share/ssl
477- change some perms
478
479* Sat Oct 30 1999 Bernhard Rosenkraenzer <bero@redhat.com>
480- Modify spec file to match Red Hat standards
481
482* Thu Aug 12 1999 Damien Miller <damien@ibs.com.au>
483- Updated to 3.4a
484- Patched for OpenSSL 0.9.4
485- Cleaned up files section
486
487* Sun Jul 11 1999 Damien Miller <dmiller@ilogic.com.au>
488- Updated to 3.3
489
490* Sat Nov 28 1998 Damien Miller <dmiller@ilogic.com.au>
491- Initial RPMification
Note: See TracBrowser for help on using the repository browser.