source: projects/specs/trunk/s/sqlite/sqlite-vl.spec @ 9461

Revision 9461, 5.1 KB checked in by inagaki, 9 years ago (diff)

2015-03-22 Ryoichi INAGAKI <ryo1@…>

  • ftp, tftp: rebuilt without readline
  • gftp, lftp, lua, python, python3, sqlite, sqlite3: rebuilt


Line 
1%define name sqlite
2%define version 2.8.17
3%define release 4%{?_dist_release}
4
5Name: %{name}
6Summary: SQLite is a C library that implements an embeddable SQL database engine
7Summary(ja): SQLite は組み込み型SQLデータベースエンジンを実装するCライブラリです。
8Version: %{version}
9Release: %{release}
10Group: System Environment/Libraries
11URL: http://www.sqlite.org
12License: Public Domain
13
14Source: %{name}-%{version}.tar.gz
15Patch0: %{name}-2.8.15-ja-patch
16Patch1: %{name}-2.8.14-lib64.patch.bz2
17Patch2: %{name}-64bit-fixes.patch.bz2
18
19BuildRoot: %{_tmppath}/%{name}-%{version}-root
20BuildRequires: tcl-devel, chrpath, ncurses-devel, readline-devel
21
22%description
23SQLite is a C library that implements an embeddable SQL database engine.
24Programs that link with the SQLite library can have SQL database access
25without running a separate RDBMS process. The distribution comes with a
26standalone command-line access program (sqlite) that can be used to
27administer an SQLite database and which serves as an example of how to
28use the SQLite library.
29%description -l ja
30SQLite は組み込み型SQLデータベースエンジンを実装するCライブラリです。
31SQLiteライブラリにリンクされたプログラムではSQLデータベースアクセスが
32できるようになります。その際、別のRDBMSプロセスは不要です。
33
34
35%package devel
36Summary: Header files and libraries for developing apps which will use sqlite
37Summary(ja): SQLiteを使ってアプリを開発するためのヘッダファイルやライブラリ
38Group: Development/Libraries
39Requires: %{name} = %{version}-%{release}
40
41%description devel
42The sqlite-devel package contains the header files and libraries needed
43to develop programs that use the sqlite database library.
44
45%description devel -l ja
46qlite-develパッケージはSQLiteデータベースライブラリを使ってプログラムを
47開発するために必要なヘッダファイルやライブラリを含んでいます。
48
49%package        static-devel
50Summary:        Static development library for the SQLite library
51Summary(ja):    SQLiteライブラリのstaticな開発用ライブラリ
52Group:          Development/Libraries
53Requires:       %{name}-devel = %{version}-%{release}
54Provides:       %{name}-static-devel = %{version}-%{release}
55
56%description    static-devel
57The sqlite-static-devel package contains the static header files
58and libraries needed to develop programs that use the sqlite database library.
59
60%description    static-devel -l ja
61sqlite-static-develはSQLiteデータベースライブラリを使ってプログラムを開発する時に必要なstaticなヘッダファイルとライブラリを含んでいます
62
63%package        tools
64Summary:        Command line tools for managing the sqlite library.
65Summary(ja):    SQLiteライブラリを管理するコマンドラインツール
66Group:          Applications/Databases
67Requires:       %{name} = %{version}-%{release}
68
69%description    tools
70The sqlite-tool package contains command line tools for managing
71the sqlite library.
72
73%description    tools -l ja
74sqlite-toolはSQLiteライブラリを管理するコマンドラインツールです。
75
76%prep
77%setup -q
78%patch0 -p0 -b .jp
79%patch1 -p0 -b .lib64
80%patch2 -p1 -b .64bit-fixes
81
82%build
83CFLAGS="%optflags -DNDEBUG=1" CXXFLAGS="%optflags -DNDEBUG=1" %configure -enable-utf8
84
85make
86make doc
87
88%install
89[ "%{buildroot}" != "/" ] && rm -rf %{buildroot}
90
91install -d %{buildroot}%{_bindir}
92install -d %{buildroot}%{_includedir}
93install -d %{buildroot}%{_libdir}
94install -d %{buildroot}%{_mandir}/man1
95
96%makeinstall
97install -m644 sqlite.1 %{buildroot}%{_mandir}/man1/
98chrpath -d %{buildroot}%{_bindir}/*
99## remove unuse files
100rm -rf $RPM_BUILD_ROOT%{_libdir}/*.la
101
102
103%clean
104[ "%{buildroot}" != "/" ] && rm -rf %{buildroot}
105
106
107%post -p /sbin/ldconfig
108
109%postun -p /sbin/ldconfig
110
111
112%files
113%defattr(-, root, root)
114%doc README
115%{_libdir}/*.so.*
116
117%files  devel
118%defattr(-, root, root)
119%doc doc/*.html doc/*.png
120%{_libdir}/*.a
121#%{_libdir}/*.la
122%{_libdir}/lib*.so
123%{_includedir}/*.h
124%{_libdir}/pkgconfig/*.pc
125
126%files static-devel
127%defattr(-, root, root)
128%{_libdir}/lib*.a
129
130%files tools
131%defattr(-, root, root)
132%{_bindir}/*
133%{_mandir}/man1/*
134
135%changelog
136* Sun Mar 22 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 2.8.17-4
137- rebuilt with readline 6.3
138- changed BuildRequires: tcl-devel instead of tcl
139
140* Mon Jan 12 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.17-3
141- rebuild with VineSeed environment
142
143* Sun Oct 03 2010 Shu KONNO <owa@bg.wakwak.com> 2.8.17-2
144- rebuilt with rpm-4.8.1 for pkg-config
145
146* Sat Sep 20 2008 Shu KONNO <owa@bg.wakwak.com> 2.8.17-1vl5
147- applied new versioning policy, spec in utf-8
148- removed *.la
149
150* Mon May 08 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.8.17-0vl1
151- updated to 2.8.17
152- changed Group:
153- run /sbin/ldconfig at %post, %postun
154
155* Mon Nov 08 2004 Satoshi MACHINO <machino@vinelinux.org> 2.8.15-0vl2
156- added BuildRequires: chrpath, ncurses-devel, readline-devel
157- separated sub packages to static-devel, tool
158- added ja subscription
159
160* Tue Aug 17 2004 HOTTA Michihide <hotta@net-newbie.com> 2.8.15-0vl1
161- add BuildRequires: tcl
162- upstream release
163
164* Tue Nov 11 2003 HOTTA Michihide <hotta@net-newbie.com> 2.8.6-0vl1
165- 1st release
Note: See TracBrowser for help on using the repository browser.