source: projects/specs/trunk/s/speech-dispatcher/speech-dispatcher-vl.spec @ 9357

Revision 9357, 12.3 KB checked in by inagaki, 9 years ago (diff)

2015-02-17 Ryoichi INAGAKI <ryo1@…>

  • brltty, flite: updated
  • speech-dispatcher: rebuilt


Line 
1%define with_nas   1
2%define with_pulse 1
3%define with_flite 1
4
5Name:           speech-dispatcher
6Version:        0.8.1
7Release:        2%{?_dist_release}
8Summary:        To provide a high-level device independent layer for speech synthesis
9Group:          System Environment/Libraries
10
11# Almost all files are under GPLv2+, however
12# src/c/clients/spdsend/spdsend.h is licensed under GPLv2,
13# which makes %%_bindir/spdsend GPLv2.
14License:        GPLv2+ and GPLv2
15URL:            http://www.freebsoft.org/pub/projects/speechd/
16Source0:        http://www.freebsoft.org/pub/projects/speechd/%{name}-%{version}.tar.gz
17Source1:        http://www.nsitonline.in/hemant/stuff/speechd-rpm/speech-dispatcherd
18
19BuildRoot:     %{_tmppath}/%{name}-%{version}-root
20BuildRequires: espeak-devel
21BuildRequires: alsa-lib-devel
22BuildRequires: dotconf-devel
23BuildRequires: texinfo
24BuildRequires: libraw1394-devel
25BuildRequires: pulseaudio-libs-devel
26BuildRequires: libao-devel
27BuildRequires: glib2-devel
28BuildRequires: flite-devel
29BuildRequires: nas-devel
30BuildRequires: libtool-ltdl-devel
31
32Requires(post): /sbin/chkconfig
33Requires(preun): /sbin/chkconfig /sbin/service
34Requires(postun): /sbin/service
35
36Obsoletes:      %{name}-python < 0.8.0
37
38%description
39* Common interface to different TTS engines
40* Handling concurrent synthesis requests – requests may come
41  asynchronously from multiple sources within an application
42  and/or from more different applications.
43* Subsequent serialization, resolution of conflicts and
44  priorities of incoming requests
45* Context switching – state is maintained for each client
46  connection independently, event for connections from
47  within one application.
48* High-level client interfaces for popular programming languages
49* Common sound output handling – audio playback is handled by
50  Speech Dispatcher rather than the TTS engine, since most engines
51  have limited sound output capabilities.
52
53%package        devel
54Summary:        Development files for %{name}
55Summary(ja):    %{name} の開発用ファイル
56Group:          Development/Libraries
57License:        GPLv2+
58Requires:       speech-dispatcher = %{version}-%{release}
59
60%description    devel
61The %{name}-devel package contains libraries and header files for
62developing applications that use %{name}.
63
64%package doc
65Summary:        Documentation for speech-dispatcher
66Summary(ja):    speech-dispatcher のドキュメント
67License:        GPLv2+
68Group:          Applications/Documentation
69BuildArch:      noarch
70Requires:       speech-dispatcher = %{version}-%{release}
71Requires(post): /sbin/install-info
72Requires(preun):/sbin/install-info
73
74%description doc
75speechd documentation
76
77
78%prep
79%setup -q
80
81%build
82# only for configure
83export LIBS="-lpulse -lpulse-simple"
84%configure \
85        --disable-static \
86        --with-alsa \
87        --with-pulse \
88        --with-flite \
89        --sysconfdir=%{_sysconfdir} \
90        --with-default-audio-method=pulse
91
92make %{?_smp_mflags}
93
94%install
95rm -rf $RPM_BUILD_ROOT
96
97for dir in \
98 config/ doc/ include/ src/audio/ src/api/ src/modules/ src/tests/ src/server/ src/clients/
99do
100    pushd $dir
101    make install DESTDIR=$RPM_BUILD_ROOT INSTALL="install -p"
102    popd
103done
104
105#Install the init shell script
106mkdir -p $RPM_BUILD_ROOT%{_initrddir}
107install -p -m 0755 %{SOURCE1} $RPM_BUILD_ROOT%{_initrddir}/
108
109#Remove %{_infodir}/dir file
110rm -f $RPM_BUILD_ROOT%{_infodir}/dir
111
112cd ../../
113find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} ';'
114
115# Move the config files from /usr/share to /etc
116mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/speech-dispatcher/clients
117mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/speech-dispatcher/modules
118mv $RPM_BUILD_ROOT%{_datadir}/speech-dispatcher/conf/speechd.conf $RPM_BUILD_ROOT%{_sysconfdir}/speech-dispatcher/
119mv $RPM_BUILD_ROOT%{_datadir}/speech-dispatcher/conf/clients/* $RPM_BUILD_ROOT%{_sysconfdir}/speech-dispatcher/clients
120mv $RPM_BUILD_ROOT%{_datadir}/speech-dispatcher/conf/modules/* $RPM_BUILD_ROOT%{_sysconfdir}/speech-dispatcher/modules
121
122# Remove dummy sound
123rm -rf $RPM_BUILD_ROOT/%{_datadir}/sounds/
124
125# Create log dir
126mkdir -p -m 0700 $RPM_BUILD_ROOT%{_localstatedir}/log/speech-dispatcher/
127
128# enable pulseaudio as default with a fallback to alsa
129sed 's/# AudioOutputMethod "pulse,alsa"/AudioOutputMethod "pulse,alsa"/' %{buildroot}%{_sysconfdir}/speech-dispatcher/speechd.conf
130
131%clean
132rm -rf $RPM_BUILD_ROOT
133
134%post
135/sbin/ldconfig
136/sbin/chkconfig --add speech-dispatcherd
137
138%postun
139/sbin/ldconfig
140
141if [ "$1" -ge "1" ] ; then
142  /sbin/service speech-dispatcherd condrestart >/dev/null 2>&1 || :
143fi
144
145%preun
146if [ $1 = 0 ] ; then
147    /sbin/service speech-dispatcherd stop >/dev/null 2>&1
148    /sbin/chkconfig --del speech-dispatcherd
149fi
150
151%post doc
152/sbin/install-info %{_infodir}/%{name}.info %{_infodir}/dir || :
153/sbin/install-info %{_infodir}/spd-say.info %{_infodir}/dir || :
154/sbin/install-info %{_infodir}/ssip.info %{_infodir}/dir || :
155/sbin/install-info %{_infodir}/%{name}-cs.info %{_infodir}/dir || :
156
157%preun doc
158if [ $1 = 0 ]; then
159    /sbin/install-info --delete %{_infodir}/%{name}.info %{_infodir}/dir || :
160    /sbin/install-info --delete %{_infodir}/spd-say.info %{_infodir}/dir || :
161    /sbin/install-info --delete %{_infodir}/ssip.info %{_infodir}/dir || :
162    /sbin/install-info --delete %{_infodir}/%{name}-cs.info %{_infodir}/dir || :
163fi
164
165
166%files
167%defattr(-,root,root,-)
168%doc AUTHORS ChangeLog NEWS README TODO COPYING
169%config(noreplace) %{_sysconfdir}/speech-dispatcher/speechd.conf
170%config(noreplace) %{_sysconfdir}/speech-dispatcher/clients/*.conf
171%config(noreplace) %{_sysconfdir}/speech-dispatcher/modules/*.conf
172%dir %{_sysconfdir}/speech-dispatcher/
173%dir %{_sysconfdir}/speech-dispatcher/clients
174%dir %{_sysconfdir}/speech-dispatcher/modules
175
176%{_bindir}/*
177%{_libdir}/speech-dispatcher-modules/sd_*
178%dir %{_libdir}/speech-dispatcher-modules
179
180%{_libdir}/libspeechd.so.*
181%dir %{_libdir}/speech-dispatcher
182%{_libdir}/speech-dispatcher/spd*.so
183
184%dir %attr(0700, root, root) %{_localstatedir}/log/speech-dispatcher/
185%attr(0755,root,root)%{_initrddir}/speech-dispatcherd
186
187%files devel
188%defattr(-,root,root,-)
189%{_includedir}/*
190%{_libdir}/lib*.so
191
192%files doc
193%defattr(-,root,root,-)
194%{_infodir}/*
195
196
197%changelog
198* Tue Feb 17 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> - 0.8.1-2
199- rebuilt with flite 2.0
200- changed doc subpackage to noarch
201
202* Sun Dec 07 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 0.8.1-1
203- new upstream release
204- remove %%{name}-python subpackage
205- add BuildRequires: libtool-ltdl-devel
206
207* Sun Feb 19 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 0.7.1-2
208- rebuild with python-2.7.2
209
210* Sat Nov 05 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 0.7.1-1
211- new upstream release
212- remove all patches
213
214* Sun Mar 14 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 0.6.7-5
215- Initial build for Vine Linux
216
217* Wed Mar  3 2010 Peter Robinson <pbrobinson@gmail.com> - 0.6.7-4
218- Add patch to fix dso linking. Bug 564851
219
220* Sat Jan  9 2010 Peter Robinson <pbrobinson@gmail.com> - 0.6.7-3
221- Updated to the new python sysarch spec file reqs
222
223* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.6.7-2
224- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
225
226* Wed May 20 2009 Peter Robinson <pbrobinson@gmail.com> - 0.6.7-1
227- New upstream release, some spec file cleanups.
228
229* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.6.6-21
230- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
231
232* Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 0.6.6-20
233- Rebuild for Python 2.6
234
235* Sun Sep 21 2008 Ville Skyttä <ville.skytta at iki.fi> - 0.6.6-19
236- Fix Patch0:/%%patch mismatch.
237
238* Wed Jul 16 2008    Hemant Goyal <goyal.hemant@gmail.com> 0.6.6-18
239- removed suid permission for speech-dispatcher binary.
240
241* Wed Jul 16 2008    Hemant Goyal <goyal.hemant@gmail.com> 0.6.6-17
242- changing permissions of speech-dispatcher to 6711 (setuid and setguid)
243- relocating configuration files in case of OLPC branch.
244- excluding init script in case of OLPC branch.
245
246* Wed Jul 16 2008    Hemant Goyal <goyal.hemant@gmail.com> 0.6.6-16
247- yet another release bump required :-/
248
249* Wed Jul 16 2008    Hemant Goyal <goyal.hemant@gmail.com> 0.6.6-15
250- release bump
251
252* Sun Jul 13 2008    Hemant Goyal <goyal.hemant@gmail.com> 0.6.6-14
253- conditional build required for OLPC Branch - Building without nas and
254  pulse-audio support.
255
256* Mon Jun 23 2008    Hemant Goyal <goyal.hemant@gmail.com> 0.6.6-13
257- changed permission of speech-dispatcherd to 0644 too.
258
259* Fri Jun 20 2008    Hemant Goyal <goyal.hemant@gmail.com> 0.6.6-12
260- added BuildRequires: texinfo (for makeinfo)
261- changed permissions of Sourcex to 0644
262- incorporated modified init script by mtasaka
263- fixed a few more macros in changelog
264- modified location of Source1 and Patch0 to point to online locations
265
266* Wed Jun 18 2008    Hemant Goyal <goyal.hemant@gmail.com> 0.6.6-11
267- fixed encoding of speech-dispatcher-cs.info file to UTF-8
268
269* Wed Jun 11 2008    Hemant Goyal <goyal.hemant@gmail.com> 0.6.6-10
270- removed Requires(preun) duplicates
271- applied -p option correctly to install command
272- fixed macros in changelog to prevent them from exapnding
273- fixed the init script
274- added patch to change log directory of speech-dispatcher and start only espeak
275
276* Sun Jun 08 2008    Hemant Goyal <goyal.hemant@gmail.com> 0.6.6-9
277- removed %%{_infodir}/dir file
278
279* Sat Jun 07 2008    Hemant Goyal <goyal.hemant@gmail.com> 0.6.6-8
280- converted speech-dispatcher-cs.info to UTF-8 encoding
281- removed multiple file listings of /usr/lib/python2.5/site-packages/speechd/_test.py
282  and fixed its mode
283- added init script as a SOURCE instead as a patch
284- duplicate Requires have now been removed
285- Timestamping of files has now been added
286- Install script fixed
287- init script fixed
288
289* Tue Jun 03 2008    Hemant Goyal <goyal.hemant@gmail.com> 0.6.6-7
290- changed license of base package to GPLv2+ and GPL
291- changed license of all other packages to GPLv2+
292- fixed install sequence using cleaner for loop and pushd and popd commands
293- added init script for speech-dispatcher daemon
294- added COPYING to doc in base package
295- removed comment after /sbin/ldconfig
296- resolved rpmlint errors for base package [except UTF-8 encoding error for (cs) documentation file]
297- renamed long_message to spd_long_message and run_test to spd_run_test
298- reset mode of _test.py to 0755
299
300* Sun Apr 27 2008    Hemant Goyal <goyal.hemant@gmail.com> 0.6.6-6
301- changed BR to pulseaudio-lib-devel
302- removed dotconf BR
303- gave ownership of /%%{python_sitelib}/speechd-0.3-py2.5.egg-info to python package if package is built for Fedora 9 or above
304
305* Sun Apr 13 2008    Hemant Goyal <goyal.hemant@gmail.com> 0.6.6-5
306- Removed conitional building options
307- Added BuildRequires for dotconf-devel
308
309* Mon Feb 18 2008    Hemant Goyal <goyal.hemant@gmail.com> 0.6.6-4
310- Manually specyfying make install for each src directory to be installed
311- Installing python package seprately by by-passing make install
312
313* Sun Feb 17 2008   Hemant Goyal <goyal.hemant@gmail.com> 0.6.6-3
314- Added Requires(post), Requires(preun) for -doc package
315- Changed scriptlet from postun to preun for -doc package
316- Removed Epoch
317- Moved %%{_libdir}/lib*.so back to devel pacakge
318- Require dependecny on base pacakge is now set to %%{version}-%%{release} instead of %%{version}
319- removed --prefix=$RPM_BUILD_ROOT/%%{_prefix}  against configure macro.
320  -- -python subpackage does not build anymore.
321- removed python subpackag rules from SPEC file.
322
323* Sat Feb 16 2008   Hemant Goyal <goyal.hemant@gmail.com> 0.6.6-2
324- fixed directory ownerships
325
326* Sat Feb 16 2008   Hemant Goyal <goyal.hemant@gmail.com> 0.6.6-1
327- using newest version of speech-dispatcher
328- updated %%{_libdir}/libspeechd.so.2.0.4 to %%{_libdir}/libspeechd.so.2.0.5
329- python packages are being generated correctly now
330- must force prefix=$RPM_BUILD_ROOT/%%{_prefix} to enable python packages to get installed correctly.
331- finding and deleting .*la files in $RPM_BUILD_ROOT to avoid unpackaged files error.
332
333* Sat Feb 16 2008   Hemant Goyal <goyal.hemant@gmail.com> 0.6.5-4
334- updated build root
335
336* Sat Feb 16 2008   Hemant Goyal <goyal.hemant@gmail.com> 0.6.5-3
337- added macro to prevent error from stopping build for not including *.la files
338- added epoch to the SPEC
339- conditional build seems to be working correctly the old way only??
340- unified changelogs
341
342* Fri Feb 15 2008  Hemant Goyal <goyal.hemant@gmail.com> 0.6.5-2
343- Removed .la files
344- Removed doc-cs packages and merged it into doc package
345- Removed packaging of static files, and tested -without static_libs option for configure script
346- Moved symlink .so files from devel package to main package
347- Commented /sbin/ldconfig for devel package.
Note: See TracBrowser for help on using the repository browser.