source: projects/specs/trunk/s/speech-dispatcher/speech-dispatcher-vl.spec @ 10405

Revision 10405, 13.2 KB checked in by Takemikaduchi, 8 years ago (diff)

gcc-5.4.0 & python3-3.5.2

Line 
1%{!?python3_sitearch: %define python3_sitearch %(python3 -c "from distutils.sysconfig import get_python_lib; print(get_python_lib(1))")}
2
3%define with_nas   1
4%define with_pulse 1
5%define with_flite 1
6
7Name:           speech-dispatcher
8Version:        0.8.2
9Release:        2%{?_dist_release}
10Summary:        To provide a high-level device independent layer for speech synthesis
11Group:          System Environment/Libraries
12
13# Almost all files are under GPLv2+, however
14# src/c/clients/spdsend/spdsend.h is licensed under GPLv2,
15# which makes %%_bindir/spdsend GPLv2.
16License:        GPLv2+ and GPLv2
17URL:            http://www.freebsoft.org/pub/projects/speechd/
18Source0:        http://www.freebsoft.org/pub/projects/speechd/%{name}-%{version}.tar.gz
19Source1:        http://www.nsitonline.in/hemant/stuff/speechd-rpm/speech-dispatcherd
20
21BuildRoot:     %{_tmppath}/%{name}-%{version}-root
22BuildRequires: espeak-devel
23BuildRequires: alsa-lib-devel
24BuildRequires: dotconf-devel
25BuildRequires: texinfo
26BuildRequires: libraw1394-devel
27BuildRequires: pulseaudio-libs-devel
28BuildRequires: libao-devel
29BuildRequires: glib2-devel
30BuildRequires: flite-devel
31BuildRequires: nas-devel
32BuildRequires: libtool-ltdl-devel
33BuildRequires: python3-devel
34
35Requires(post): /sbin/chkconfig
36Requires(preun): /sbin/chkconfig /sbin/service
37Requires(postun): /sbin/service
38
39Obsoletes:      %{name}-python < 0.8.0
40
41%description
42* Common interface to different TTS engines
43* Handling concurrent synthesis requests – requests may come
44  asynchronously from multiple sources within an application
45  and/or from more different applications.
46* Subsequent serialization, resolution of conflicts and
47  priorities of incoming requests
48* Context switching – state is maintained for each client
49  connection independently, event for connections from
50  within one application.
51* High-level client interfaces for popular programming languages
52* Common sound output handling – audio playback is handled by
53  Speech Dispatcher rather than the TTS engine, since most engines
54  have limited sound output capabilities.
55
56%package        devel
57Summary:        Development files for %{name}
58Summary(ja):    %{name} の開発用ファイル
59Group:          Development/Libraries
60License:        GPLv2+
61Requires:       speech-dispatcher = %{version}-%{release}
62
63%description    devel
64The %{name}-devel package contains libraries and header files for
65developing applications that use %{name}.
66
67%package doc
68Summary:        Documentation for speech-dispatcher
69Summary(ja):    speech-dispatcher のドキュメント
70License:        GPLv2+
71Group:          Applications/Documentation
72BuildArch:      noarch
73Requires:       speech-dispatcher = %{version}-%{release}
74Requires(post): /sbin/install-info
75Requires(preun):/sbin/install-info
76
77%description doc
78speechd documentation
79
80%package -n python3-%{name}
81Summary:        Python Client API for speech-dispatcher
82Summary(ja):    speech-dispacher の python3 モジュール
83License:        GPLv2+
84Group:          Development/Libraries
85Requires:       speech-dispatcher = %{version}-%{release}
86Requires:       python3
87
88%description -n python3-%{name}
89speechd python3 module
90
91
92%prep
93%setup -q
94
95%build
96# only for configure
97export LIBS="-lpulse -lpulse-simple"
98%configure \
99        --disable-static \
100        --with-alsa \
101        --with-pulse \
102        --with-flite \
103        --sysconfdir=%{_sysconfdir} \
104        --with-default-audio-method=pulse
105
106make %{?_smp_mflags}
107
108%install
109rm -rf $RPM_BUILD_ROOT
110
111for dir in \
112 config/ doc/ include/ src/audio/ src/api/ src/modules/ src/tests/ src/server/ src/clients/
113do
114    pushd $dir
115    make install DESTDIR=$RPM_BUILD_ROOT INSTALL="install -p"
116    popd
117done
118
119#Install the init shell script
120mkdir -p $RPM_BUILD_ROOT%{_initrddir}
121install -p -m 0755 %{SOURCE1} $RPM_BUILD_ROOT%{_initrddir}/
122
123#Remove %{_infodir}/dir file
124rm -f $RPM_BUILD_ROOT%{_infodir}/dir
125
126cd ../../
127find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} ';'
128
129# Move the config files from /usr/share to /etc
130mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/speech-dispatcher/clients
131mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/speech-dispatcher/modules
132mv $RPM_BUILD_ROOT%{_datadir}/speech-dispatcher/conf/speechd.conf $RPM_BUILD_ROOT%{_sysconfdir}/speech-dispatcher/
133mv $RPM_BUILD_ROOT%{_datadir}/speech-dispatcher/conf/clients/* $RPM_BUILD_ROOT%{_sysconfdir}/speech-dispatcher/clients
134mv $RPM_BUILD_ROOT%{_datadir}/speech-dispatcher/conf/modules/* $RPM_BUILD_ROOT%{_sysconfdir}/speech-dispatcher/modules
135
136# Remove dummy sound
137rm -rf $RPM_BUILD_ROOT/%{_datadir}/sounds/
138
139# Create log dir
140mkdir -p -m 0700 $RPM_BUILD_ROOT%{_localstatedir}/log/speech-dispatcher/
141
142# enable pulseaudio as default with a fallback to alsa
143sed 's/# AudioOutputMethod "pulse,alsa"/AudioOutputMethod "pulse,alsa"/' %{buildroot}%{_sysconfdir}/speech-dispatcher/speechd.conf
144
145%clean
146rm -rf $RPM_BUILD_ROOT
147
148%post
149/sbin/ldconfig
150/sbin/chkconfig --add speech-dispatcherd
151
152%postun
153/sbin/ldconfig
154
155if [ "$1" -ge "1" ] ; then
156  /sbin/service speech-dispatcherd condrestart >/dev/null 2>&1 || :
157fi
158
159%preun
160if [ $1 = 0 ] ; then
161    /sbin/service speech-dispatcherd stop >/dev/null 2>&1
162    /sbin/chkconfig --del speech-dispatcherd
163fi
164
165%post doc
166/sbin/install-info %{_infodir}/%{name}.info %{_infodir}/dir || :
167/sbin/install-info %{_infodir}/spd-say.info %{_infodir}/dir || :
168/sbin/install-info %{_infodir}/ssip.info %{_infodir}/dir || :
169/sbin/install-info %{_infodir}/%{name}-cs.info %{_infodir}/dir || :
170
171%preun doc
172if [ $1 = 0 ]; then
173    /sbin/install-info --delete %{_infodir}/%{name}.info %{_infodir}/dir || :
174    /sbin/install-info --delete %{_infodir}/spd-say.info %{_infodir}/dir || :
175    /sbin/install-info --delete %{_infodir}/ssip.info %{_infodir}/dir || :
176    /sbin/install-info --delete %{_infodir}/%{name}-cs.info %{_infodir}/dir || :
177fi
178
179
180%files
181%defattr(-,root,root,-)
182%doc AUTHORS ChangeLog NEWS README TODO COPYING
183%config(noreplace) %{_sysconfdir}/speech-dispatcher/speechd.conf
184%config(noreplace) %{_sysconfdir}/speech-dispatcher/clients/*.conf
185%config(noreplace) %{_sysconfdir}/speech-dispatcher/modules/*.conf
186%dir %{_sysconfdir}/speech-dispatcher/
187%dir %{_sysconfdir}/speech-dispatcher/clients
188%dir %{_sysconfdir}/speech-dispatcher/modules
189
190%{_bindir}/*
191%{_libdir}/speech-dispatcher-modules/sd_*
192%{_datadir}/%{name}/conf/desktop/speechd.desktop
193%dir %{_libdir}/speech-dispatcher-modules
194
195%{_libdir}/libspeechd.so.*
196%dir %{_libdir}/speech-dispatcher
197%{_libdir}/speech-dispatcher/spd*.so
198
199%dir %attr(0700, root, root) %{_localstatedir}/log/speech-dispatcher/
200%attr(0755,root,root)%{_initrddir}/speech-dispatcherd
201
202%files devel
203%defattr(-,root,root,-)
204%{_includedir}/*
205%{_libdir}/lib*.so
206
207%files doc
208%defattr(-,root,root,-)
209%{_infodir}/*
210
211%files -n python3-%{name}
212%defattr(-,root,root,-)
213%{python3_sitearch}/speechd*
214
215
216%changelog
217* Tue Jun 28 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 0.8.2-2
218- rebuild with python3-3.5.2
219
220* Wed Apr 01 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 0.8.2-1
221- new upstream release
222- add BuildRequires: python3-devel
223- create python3-speech-dispatcher subpackage
224
225* Tue Feb 17 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> - 0.8.1-2
226- rebuilt with flite 2.0
227- changed doc subpackage to noarch
228
229* Sun Dec 07 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 0.8.1-1
230- new upstream release
231- remove %%{name}-python subpackage
232- add BuildRequires: libtool-ltdl-devel
233
234* Sun Feb 19 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 0.7.1-2
235- rebuild with python-2.7.2
236
237* Sat Nov 05 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 0.7.1-1
238- new upstream release
239- remove all patches
240
241* Sun Mar 14 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 0.6.7-5
242- Initial build for Vine Linux
243
244* Wed Mar  3 2010 Peter Robinson <pbrobinson@gmail.com> - 0.6.7-4
245- Add patch to fix dso linking. Bug 564851
246
247* Sat Jan  9 2010 Peter Robinson <pbrobinson@gmail.com> - 0.6.7-3
248- Updated to the new python sysarch spec file reqs
249
250* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.6.7-2
251- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
252
253* Wed May 20 2009 Peter Robinson <pbrobinson@gmail.com> - 0.6.7-1
254- New upstream release, some spec file cleanups.
255
256* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.6.6-21
257- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
258
259* Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 0.6.6-20
260- Rebuild for Python 2.6
261
262* Sun Sep 21 2008 Ville Skyttä <ville.skytta at iki.fi> - 0.6.6-19
263- Fix Patch0:/%%patch mismatch.
264
265* Wed Jul 16 2008    Hemant Goyal <goyal.hemant@gmail.com> 0.6.6-18
266- removed suid permission for speech-dispatcher binary.
267
268* Wed Jul 16 2008    Hemant Goyal <goyal.hemant@gmail.com> 0.6.6-17
269- changing permissions of speech-dispatcher to 6711 (setuid and setguid)
270- relocating configuration files in case of OLPC branch.
271- excluding init script in case of OLPC branch.
272
273* Wed Jul 16 2008    Hemant Goyal <goyal.hemant@gmail.com> 0.6.6-16
274- yet another release bump required :-/
275
276* Wed Jul 16 2008    Hemant Goyal <goyal.hemant@gmail.com> 0.6.6-15
277- release bump
278
279* Sun Jul 13 2008    Hemant Goyal <goyal.hemant@gmail.com> 0.6.6-14
280- conditional build required for OLPC Branch - Building without nas and
281  pulse-audio support.
282
283* Mon Jun 23 2008    Hemant Goyal <goyal.hemant@gmail.com> 0.6.6-13
284- changed permission of speech-dispatcherd to 0644 too.
285
286* Fri Jun 20 2008    Hemant Goyal <goyal.hemant@gmail.com> 0.6.6-12
287- added BuildRequires: texinfo (for makeinfo)
288- changed permissions of Sourcex to 0644
289- incorporated modified init script by mtasaka
290- fixed a few more macros in changelog
291- modified location of Source1 and Patch0 to point to online locations
292
293* Wed Jun 18 2008    Hemant Goyal <goyal.hemant@gmail.com> 0.6.6-11
294- fixed encoding of speech-dispatcher-cs.info file to UTF-8
295
296* Wed Jun 11 2008    Hemant Goyal <goyal.hemant@gmail.com> 0.6.6-10
297- removed Requires(preun) duplicates
298- applied -p option correctly to install command
299- fixed macros in changelog to prevent them from exapnding
300- fixed the init script
301- added patch to change log directory of speech-dispatcher and start only espeak
302
303* Sun Jun 08 2008    Hemant Goyal <goyal.hemant@gmail.com> 0.6.6-9
304- removed %%{_infodir}/dir file
305
306* Sat Jun 07 2008    Hemant Goyal <goyal.hemant@gmail.com> 0.6.6-8
307- converted speech-dispatcher-cs.info to UTF-8 encoding
308- removed multiple file listings of /usr/lib/python2.5/site-packages/speechd/_test.py
309  and fixed its mode
310- added init script as a SOURCE instead as a patch
311- duplicate Requires have now been removed
312- Timestamping of files has now been added
313- Install script fixed
314- init script fixed
315
316* Tue Jun 03 2008    Hemant Goyal <goyal.hemant@gmail.com> 0.6.6-7
317- changed license of base package to GPLv2+ and GPL
318- changed license of all other packages to GPLv2+
319- fixed install sequence using cleaner for loop and pushd and popd commands
320- added init script for speech-dispatcher daemon
321- added COPYING to doc in base package
322- removed comment after /sbin/ldconfig
323- resolved rpmlint errors for base package [except UTF-8 encoding error for (cs) documentation file]
324- renamed long_message to spd_long_message and run_test to spd_run_test
325- reset mode of _test.py to 0755
326
327* Sun Apr 27 2008    Hemant Goyal <goyal.hemant@gmail.com> 0.6.6-6
328- changed BR to pulseaudio-lib-devel
329- removed dotconf BR
330- gave ownership of /%%{python_sitelib}/speechd-0.3-py2.5.egg-info to python package if package is built for Fedora 9 or above
331
332* Sun Apr 13 2008    Hemant Goyal <goyal.hemant@gmail.com> 0.6.6-5
333- Removed conitional building options
334- Added BuildRequires for dotconf-devel
335
336* Mon Feb 18 2008    Hemant Goyal <goyal.hemant@gmail.com> 0.6.6-4
337- Manually specyfying make install for each src directory to be installed
338- Installing python package seprately by by-passing make install
339
340* Sun Feb 17 2008   Hemant Goyal <goyal.hemant@gmail.com> 0.6.6-3
341- Added Requires(post), Requires(preun) for -doc package
342- Changed scriptlet from postun to preun for -doc package
343- Removed Epoch
344- Moved %%{_libdir}/lib*.so back to devel pacakge
345- Require dependecny on base pacakge is now set to %%{version}-%%{release} instead of %%{version}
346- removed --prefix=$RPM_BUILD_ROOT/%%{_prefix}  against configure macro.
347  -- -python subpackage does not build anymore.
348- removed python subpackag rules from SPEC file.
349
350* Sat Feb 16 2008   Hemant Goyal <goyal.hemant@gmail.com> 0.6.6-2
351- fixed directory ownerships
352
353* Sat Feb 16 2008   Hemant Goyal <goyal.hemant@gmail.com> 0.6.6-1
354- using newest version of speech-dispatcher
355- updated %%{_libdir}/libspeechd.so.2.0.4 to %%{_libdir}/libspeechd.so.2.0.5
356- python packages are being generated correctly now
357- must force prefix=$RPM_BUILD_ROOT/%%{_prefix} to enable python packages to get installed correctly.
358- finding and deleting .*la files in $RPM_BUILD_ROOT to avoid unpackaged files error.
359
360* Sat Feb 16 2008   Hemant Goyal <goyal.hemant@gmail.com> 0.6.5-4
361- updated build root
362
363* Sat Feb 16 2008   Hemant Goyal <goyal.hemant@gmail.com> 0.6.5-3
364- added macro to prevent error from stopping build for not including *.la files
365- added epoch to the SPEC
366- conditional build seems to be working correctly the old way only??
367- unified changelogs
368
369* Fri Feb 15 2008  Hemant Goyal <goyal.hemant@gmail.com> 0.6.5-2
370- Removed .la files
371- Removed doc-cs packages and merged it into doc package
372- Removed packaging of static files, and tested -without static_libs option for configure script
373- Moved symlink .so files from devel package to main package
374- Commented /sbin/ldconfig for devel package.
Note: See TracBrowser for help on using the repository browser.