source: projects/specs/trunk/s/speech-dispatcher/speech-dispatcher-vl.spec @ 9140

Revision 9140, 12.0 KB checked in by Takemikaduchi, 9 years ago (diff)

perl-WWW-Curl: NEW
dotconf,perl-HTTP-Server-Simple,speech-dispatcher: new upstream release
others: rebuild

Line 
1%define with_nas   1
2%define with_pulse 1
3%define with_flite 1
4
5Name:           speech-dispatcher
6Version:        0.8.1
7Release:        1%{?_dist_release}
8Summary:        To provide a high-level device independent layer for speech synthesis
9Group:          System Environment/Libraries
10
11# Almost all files are under GPLv2+, however
12# src/c/clients/spdsend/spdsend.h is licensed under GPLv2,
13# which makes %%_bindir/spdsend GPLv2.
14License:        GPLv2+ and GPLv2
15URL:            http://www.freebsoft.org/pub/projects/speechd/
16Source0:        http://www.freebsoft.org/pub/projects/speechd/%{name}-%{version}.tar.gz
17Source1:        http://www.nsitonline.in/hemant/stuff/speechd-rpm/speech-dispatcherd
18
19BuildRoot:     %{_tmppath}/%{name}-%{version}-root
20BuildRequires: espeak-devel
21BuildRequires: alsa-lib-devel
22BuildRequires: dotconf-devel
23BuildRequires: texinfo
24BuildRequires: libraw1394-devel
25BuildRequires: pulseaudio-lib-devel
26BuildRequires: libao-devel
27BuildRequires: glib2-devel
28BuildRequires: flite-devel
29BuildRequires: nas-devel
30BuildRequires: libtool-ltdl-devel
31
32Requires(post): /sbin/chkconfig
33Requires(preun): /sbin/chkconfig /sbin/service
34Requires(postun): /sbin/service
35
36Obsoletes:      %{name}-python < 0.8.0
37
38%description
39* Common interface to different TTS engines
40* Handling concurrent synthesis requests – requests may come
41  asynchronously from multiple sources within an application
42  and/or from more different applications.
43* Subsequent serialization, resolution of conflicts and
44  priorities of incoming requests
45* Context switching – state is maintained for each client
46  connection independently, event for connections from
47  within one application.
48* High-level client interfaces for popular programming languages
49* Common sound output handling – audio playback is handled by
50  Speech Dispatcher rather than the TTS engine, since most engines
51  have limited sound output capabilities.
52
53%package        devel
54Summary:        Development files for %{name}
55Group:          Development/Libraries
56Requires:       speech-dispatcher = %{version}-%{release}
57License:        GPLv2+
58
59%description    devel
60The %{name}-devel package contains libraries and header files for
61developing applications that use %{name}.
62
63%package doc
64Summary:        Documentation for speech-dispatcher
65License:        GPLv2+
66Group:          Applications/Documentation
67Requires:       speech-dispatcher = %{version}-%{release}
68Requires(post): /sbin/install-info
69Requires(preun):/sbin/install-info
70
71%description doc
72speechd documentation
73
74
75%prep
76%setup -q
77
78%build
79%configure \
80        --disable-static \
81        --with-alsa \
82        --with-pulse \
83        --with-flite \
84        --sysconfdir=%{_sysconfdir} \
85        --with-default-audio-method=pulse
86
87make %{?_smp_mflags}
88
89%install
90rm -rf $RPM_BUILD_ROOT
91
92for dir in \
93 config/ doc/ include/ src/audio/ src/api/ src/modules/ src/tests/ src/server/ src/clients/
94 do
95  pushd $dir
96  make install DESTDIR=$RPM_BUILD_ROOT INSTALL="install -p"
97 popd
98done
99
100#Install the init shell script
101mkdir -p $RPM_BUILD_ROOT%{_initrddir}
102install -p -m 0755 %{SOURCE1} $RPM_BUILD_ROOT%{_initrddir}/
103
104#Remove %{_infodir}/dir file
105rm -f $RPM_BUILD_ROOT%{_infodir}/dir
106
107cd ../../
108find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} ';'
109
110# Move the config files from /usr/share to /etc
111mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/speech-dispatcher/clients
112mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/speech-dispatcher/modules
113mv $RPM_BUILD_ROOT%{_datadir}/speech-dispatcher/conf/speechd.conf $RPM_BUILD_ROOT%{_sysconfdir}/speech-dispatcher/
114mv $RPM_BUILD_ROOT%{_datadir}/speech-dispatcher/conf/clients/* $RPM_BUILD_ROOT%{_sysconfdir}/speech-dispatcher/clients
115mv $RPM_BUILD_ROOT%{_datadir}/speech-dispatcher/conf/modules/* $RPM_BUILD_ROOT%{_sysconfdir}/speech-dispatcher/modules
116
117# Remove dummy sound
118rm -rf $RPM_BUILD_ROOT/%{_datadir}/sounds/
119
120# Create log dir
121mkdir -p -m 0700 $RPM_BUILD_ROOT%{_localstatedir}/log/speech-dispatcher/
122
123# enable pulseaudio as default with a fallback to alsa
124sed 's/# AudioOutputMethod "pulse,alsa"/AudioOutputMethod "pulse,alsa"/' %{buildroot}%{_sysconfdir}/speech-dispatcher/speechd.conf
125
126%clean
127rm -rf $RPM_BUILD_ROOT
128
129%post
130/sbin/ldconfig
131/sbin/chkconfig --add speech-dispatcherd
132
133%postun
134/sbin/ldconfig
135
136if [ "$1" -ge "1" ] ; then
137  /sbin/service speech-dispatcherd condrestart >/dev/null 2>&1 || :
138fi
139
140%preun
141if [ $1 = 0 ] ; then
142 /sbin/service speech-dispatcherd stop >/dev/null 2>&1
143 /sbin/chkconfig --del speech-dispatcherd
144fi
145
146%post doc
147/sbin/install-info %{_infodir}/%{name}.info %{_infodir}/dir || :
148/sbin/install-info %{_infodir}/spd-say.info %{_infodir}/dir || :
149/sbin/install-info %{_infodir}/ssip.info %{_infodir}/dir || :
150/sbin/install-info %{_infodir}/%{name}-cs.info %{_infodir}/dir || :
151
152%preun doc
153if [ $1 = 0 ]; then
154 /sbin/install-info --delete %{_infodir}/%{name}.info %{_infodir}/dir || :
155 /sbin/install-info --delete %{_infodir}/spd-say.info %{_infodir}/dir || :
156 /sbin/install-info --delete %{_infodir}/ssip.info %{_infodir}/dir || :
157 /sbin/install-info --delete %{_infodir}/%{name}-cs.info %{_infodir}/dir || :
158fi
159
160
161%files
162%defattr(-,root,root,-)
163%doc AUTHORS ChangeLog NEWS README TODO COPYING
164%config(noreplace) %{_sysconfdir}/speech-dispatcher/speechd.conf
165%config(noreplace) %{_sysconfdir}/speech-dispatcher/clients/*.conf
166%config(noreplace) %{_sysconfdir}/speech-dispatcher/modules/*.conf
167%dir %{_sysconfdir}/speech-dispatcher/
168%dir %{_sysconfdir}/speech-dispatcher/clients
169%dir %{_sysconfdir}/speech-dispatcher/modules
170
171%{_bindir}/*
172%{_libdir}/speech-dispatcher-modules/sd_*
173%dir %{_libdir}/speech-dispatcher-modules
174
175%{_libdir}/libspeechd.so.*
176%dir %{_libdir}/speech-dispatcher
177%{_libdir}/speech-dispatcher/spd*.so
178
179%dir %attr(0700, root, root) %{_localstatedir}/log/speech-dispatcher/
180%attr(0755,root,root)%{_initrddir}/speech-dispatcherd
181
182%files devel
183%defattr(-,root,root,-)
184%{_includedir}/*
185%{_libdir}/lib*.so
186
187%files doc
188%defattr(-,root,root,-)
189%{_infodir}/*
190
191
192%changelog
193* Sun Dec 07 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 0.8.1-1
194- new upstream release
195- remove %%{name}-python subpackage
196- add BuildRequires: libtool-ltdl-devel
197
198* Sun Feb 19 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 0.7.1-2
199- rebuild with python-2.7.2
200
201* Sat Nov 05 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 0.7.1-1
202- new upstream release
203- remove all patches
204
205* Sun Mar 14 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 0.6.7-5
206- Initial build for Vine Linux
207
208* Wed Mar  3 2010 Peter Robinson <pbrobinson@gmail.com> - 0.6.7-4
209- Add patch to fix dso linking. Bug 564851
210
211* Sat Jan  9 2010 Peter Robinson <pbrobinson@gmail.com> - 0.6.7-3
212- Updated to the new python sysarch spec file reqs
213
214* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.6.7-2
215- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
216
217* Wed May 20 2009 Peter Robinson <pbrobinson@gmail.com> - 0.6.7-1
218- New upstream release, some spec file cleanups.
219
220* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.6.6-21
221- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
222
223* Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 0.6.6-20
224- Rebuild for Python 2.6
225
226* Sun Sep 21 2008 Ville Skyttä <ville.skytta at iki.fi> - 0.6.6-19
227- Fix Patch0:/%%patch mismatch.
228
229* Wed Jul 16 2008    Hemant Goyal <goyal.hemant@gmail.com> 0.6.6-18
230- removed suid permission for speech-dispatcher binary.
231
232* Wed Jul 16 2008    Hemant Goyal <goyal.hemant@gmail.com> 0.6.6-17
233- changing permissions of speech-dispatcher to 6711 (setuid and setguid)
234- relocating configuration files in case of OLPC branch.
235- excluding init script in case of OLPC branch.
236
237* Wed Jul 16 2008    Hemant Goyal <goyal.hemant@gmail.com> 0.6.6-16
238- yet another release bump required :-/
239
240* Wed Jul 16 2008    Hemant Goyal <goyal.hemant@gmail.com> 0.6.6-15
241- release bump
242
243* Sun Jul 13 2008    Hemant Goyal <goyal.hemant@gmail.com> 0.6.6-14
244- conditional build required for OLPC Branch - Building without nas and
245  pulse-audio support.
246
247* Mon Jun 23 2008    Hemant Goyal <goyal.hemant@gmail.com> 0.6.6-13
248- changed permission of speech-dispatcherd to 0644 too.
249
250* Fri Jun 20 2008    Hemant Goyal <goyal.hemant@gmail.com> 0.6.6-12
251- added BuildRequires: texinfo (for makeinfo)
252- changed permissions of Sourcex to 0644
253- incorporated modified init script by mtasaka
254- fixed a few more macros in changelog
255- modified location of Source1 and Patch0 to point to online locations
256
257* Wed Jun 18 2008    Hemant Goyal <goyal.hemant@gmail.com> 0.6.6-11
258- fixed encoding of speech-dispatcher-cs.info file to UTF-8
259
260* Wed Jun 11 2008    Hemant Goyal <goyal.hemant@gmail.com> 0.6.6-10
261- removed Requires(preun) duplicates
262- applied -p option correctly to install command
263- fixed macros in changelog to prevent them from exapnding
264- fixed the init script
265- added patch to change log directory of speech-dispatcher and start only espeak
266
267* Sun Jun 08 2008    Hemant Goyal <goyal.hemant@gmail.com> 0.6.6-9
268- removed %%{_infodir}/dir file
269
270* Sat Jun 07 2008    Hemant Goyal <goyal.hemant@gmail.com> 0.6.6-8
271- converted speech-dispatcher-cs.info to UTF-8 encoding
272- removed multiple file listings of /usr/lib/python2.5/site-packages/speechd/_test.py
273  and fixed its mode
274- added init script as a SOURCE instead as a patch
275- duplicate Requires have now been removed
276- Timestamping of files has now been added
277- Install script fixed
278- init script fixed
279
280* Tue Jun 03 2008    Hemant Goyal <goyal.hemant@gmail.com> 0.6.6-7
281- changed license of base package to GPLv2+ and GPL
282- changed license of all other packages to GPLv2+
283- fixed install sequence using cleaner for loop and pushd and popd commands
284- added init script for speech-dispatcher daemon
285- added COPYING to doc in base package
286- removed comment after /sbin/ldconfig
287- resolved rpmlint errors for base package [except UTF-8 encoding error for (cs) documentation file]
288- renamed long_message to spd_long_message and run_test to spd_run_test
289- reset mode of _test.py to 0755
290
291* Sun Apr 27 2008    Hemant Goyal <goyal.hemant@gmail.com> 0.6.6-6
292- changed BR to pulseaudio-lib-devel
293- removed dotconf BR
294- gave ownership of /%%{python_sitelib}/speechd-0.3-py2.5.egg-info to python package if package is built for Fedora 9 or above
295
296* Sun Apr 13 2008    Hemant Goyal <goyal.hemant@gmail.com> 0.6.6-5
297- Removed conitional building options
298- Added BuildRequires for dotconf-devel
299
300* Mon Feb 18 2008    Hemant Goyal <goyal.hemant@gmail.com> 0.6.6-4
301- Manually specyfying make install for each src directory to be installed
302- Installing python package seprately by by-passing make install
303
304* Sun Feb 17 2008   Hemant Goyal <goyal.hemant@gmail.com> 0.6.6-3
305- Added Requires(post), Requires(preun) for -doc package
306- Changed scriptlet from postun to preun for -doc package
307- Removed Epoch
308- Moved %%{_libdir}/lib*.so back to devel pacakge
309- Require dependecny on base pacakge is now set to %%{version}-%%{release} instead of %%{version}
310- removed --prefix=$RPM_BUILD_ROOT/%%{_prefix}  against configure macro.
311  -- -python subpackage does not build anymore.
312- removed python subpackag rules from SPEC file.
313
314* Sat Feb 16 2008   Hemant Goyal <goyal.hemant@gmail.com> 0.6.6-2
315- fixed directory ownerships
316
317* Sat Feb 16 2008   Hemant Goyal <goyal.hemant@gmail.com> 0.6.6-1
318- using newest version of speech-dispatcher
319- updated %%{_libdir}/libspeechd.so.2.0.4 to %%{_libdir}/libspeechd.so.2.0.5
320- python packages are being generated correctly now
321- must force prefix=$RPM_BUILD_ROOT/%%{_prefix} to enable python packages to get installed correctly.
322- finding and deleting .*la files in $RPM_BUILD_ROOT to avoid unpackaged files error.
323
324* Sat Feb 16 2008   Hemant Goyal <goyal.hemant@gmail.com> 0.6.5-4
325- updated build root
326
327* Sat Feb 16 2008   Hemant Goyal <goyal.hemant@gmail.com> 0.6.5-3
328- added macro to prevent error from stopping build for not including *.la files
329- added epoch to the SPEC
330- conditional build seems to be working correctly the old way only??
331- unified changelogs
332
333* Fri Feb 15 2008  Hemant Goyal <goyal.hemant@gmail.com> 0.6.5-2
334- Removed .la files
335- Removed doc-cs packages and merged it into doc package
336- Removed packaging of static files, and tested -without static_libs option for configure script
337- Moved symlink .so files from devel package to main package
338- Commented /sbin/ldconfig for devel package.
Note: See TracBrowser for help on using the repository browser.