source: projects/specs/trunk/s/speech-dispatcher/speech-dispatcher-vl.spec @ 5701

Revision 5701, 12.7 KB checked in by Takemikaduchi, 12 years ago (diff)

python-2.7.2

Line 
1%{!?python_sitearch: %global python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
2
3%define with_nas   1
4%define with_pulse 1
5%define with_flite 1
6
7Name:           speech-dispatcher
8Version:        0.7.1
9Release:        2%{?_dist_release}
10Summary:        To provide a high-level device independent layer for speech synthesis
11Group:          System Environment/Libraries
12
13# Almost all files are under GPLv2+, however
14# src/c/clients/spdsend/spdsend.h is licensed under GPLv2,
15# which makes %%_bindir/spdsend GPLv2.
16License:        GPLv2+ and GPLv2
17URL:            http://www.freebsoft.org/pub/projects/speechd/
18Source0:        http://www.freebsoft.org/pub/projects/speechd/%{name}-%{version}.tar.gz
19Source1:        http://www.nsitonline.in/hemant/stuff/speechd-rpm/speech-dispatcherd
20
21BuildRoot:     %{_tmppath}/%{name}-%{version}-root
22BuildRequires: python-setuptools
23BuildRequires: espeak-devel
24BuildRequires: alsa-lib-devel
25BuildRequires: dotconf-devel
26BuildRequires: texinfo
27BuildRequires: libraw1394-devel
28Buildrequires: pulseaudio-lib-devel
29Buildrequires: glib2-devel
30BuildRequires: flite-devel
31Buildrequires: nas-devel
32
33Requires(post): /sbin/chkconfig
34Requires(preun): /sbin/chkconfig /sbin/service
35Requires(postun): /sbin/service
36
37%description
38* Common interface to different TTS engines
39* Handling concurrent synthesis requests – requests may come
40  asynchronously from multiple sources within an application
41  and/or from more different applications.
42* Subsequent serialization, resolution of conflicts and
43  priorities of incoming requests
44* Context switching – state is maintained for each client
45  connection independently, event for connections from
46  within one application.
47* High-level client interfaces for popular programming languages
48* Common sound output handling – audio playback is handled by
49  Speech Dispatcher rather than the TTS engine, since most engines
50  have limited sound output capabilities.
51
52%package        devel
53Summary:        Development files for %{name}
54Group:          Development/Libraries
55Requires:       speech-dispatcher = %{version}-%{release}
56License:        GPLv2+
57
58%description    devel
59The %{name}-devel package contains libraries and header files for
60developing applications that use %{name}.
61
62%package doc
63Summary:        Documentation for speech-dispatcher
64License:        GPLv2+
65Group:          Applications/Documentation
66Requires:       speech-dispatcher = %{version}-%{release}
67Requires(post): /sbin/install-info
68Requires(preun):/sbin/install-info
69
70%description doc
71speechd documentation
72
73%package python
74Summary:        Python Client API for speech-dispatcher
75License:        GPLv2+
76Group:          Development/Libraries
77Requires:       speech-dispatcher = %{version}-%{release}
78
79%description python
80speechd python module
81
82%prep
83%setup -q
84
85%build
86iconv -f ISO-8859-2 -t UTF-8 doc/speech-dispatcher-cs.texi -o doc/speech-dispatcher-cs_c.texi
87mv doc/speech-dispatcher-cs_c.texi doc/speech-dispatcher-cs.texi
88
89%configure --disable-static --with-alsa --with-pulse --without-flite --sysconfdir=%{_sysconfdir}
90
91make %{?_smp_mflags}
92
93%install
94rm -rf $RPM_BUILD_ROOT
95
96for dir in \
97 config/ doc/ src/audio/ src/c/ src/modules/ src/tests/ src/server/ src/python/
98 do
99  pushd $dir
100  make install DESTDIR=$RPM_BUILD_ROOT INSTALL="install -p"
101 popd
102done
103
104#Install the init shell script
105mkdir -p $RPM_BUILD_ROOT%{_initrddir}
106install -p -m 0755 %{SOURCE1} $RPM_BUILD_ROOT%{_initrddir}/
107
108#Rename certain generically named binaries
109mv $RPM_BUILD_ROOT%{_bindir}/long_message $RPM_BUILD_ROOT%{_bindir}/spd_long_message
110mv $RPM_BUILD_ROOT%{_bindir}/run_test $RPM_BUILD_ROOT%{_bindir}/spd_run_test
111
112#Remove %{_infodir}/dir file
113rm -f $RPM_BUILD_ROOT%{_infodir}/dir
114
115cd ../../
116find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} ';'
117
118# Move the config files from /usr/share to /etc
119mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/speech-dispatcher/clients
120mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/speech-dispatcher/modules
121mv $RPM_BUILD_ROOT%{_datadir}/speech-dispatcher/conf/speechd.conf $RPM_BUILD_ROOT%{_sysconfdir}/speech-dispatcher/
122mv $RPM_BUILD_ROOT%{_datadir}/speech-dispatcher/conf/clients/* $RPM_BUILD_ROOT%{_sysconfdir}/speech-dispatcher/clients
123mv $RPM_BUILD_ROOT%{_datadir}/speech-dispatcher/conf/modules/* $RPM_BUILD_ROOT%{_sysconfdir}/speech-dispatcher/modules
124
125# Now move the files, change ownerships, apply setuid settings incase build is for
126# olpc.
127
128#if 0%{?olpc}
129# #Move the speech-dispatcher configuration files to olpc writable location.
130# mkdir -p $RPM_BUILD_ROOT/home/olpc/.speechd
131# mv $RPM_BUILD_ROOT%{_sysconfdir}/speech-dispatcher/* $RPM_BUILD_ROOT/home/olpc/.speechd
132#endif
133
134# Remove dummy sound
135rm -rf $RPM_BUILD_ROOT/%{_datadir}/sounds/
136
137# Create log dir
138mkdir -p -m 0700 $RPM_BUILD_ROOT%{_localstatedir}/log/speech-dispatcher/
139
140%clean
141rm -rf $RPM_BUILD_ROOT
142
143%post
144/sbin/ldconfig
145/sbin/chkconfig --add speech-dispatcherd
146
147%postun
148/sbin/ldconfig
149
150if [ "$1" -ge "1" ] ; then
151  /sbin/service speech-dispatcherd condrestart >/dev/null 2>&1 || :
152fi
153
154%preun
155if [ $1 = 0 ] ; then
156 /sbin/service speech-dispatcherd stop >/dev/null 2>&1
157 /sbin/chkconfig --del speech-dispatcherd
158fi
159
160%post doc
161/sbin/install-info %{_infodir}/%{name}.info %{_infodir}/dir || :
162/sbin/install-info %{_infodir}/spd-say.info %{_infodir}/dir || :
163/sbin/install-info %{_infodir}/ssip.info %{_infodir}/dir || :
164/sbin/install-info %{_infodir}/%{name}-cs.info %{_infodir}/dir || :
165
166%preun doc
167if [ $1 = 0 ]; then
168 /sbin/install-info --delete %{_infodir}/%{name}.info %{_infodir}/dir || :
169 /sbin/install-info --delete %{_infodir}/spd-say.info %{_infodir}/dir || :
170 /sbin/install-info --delete %{_infodir}/ssip.info %{_infodir}/dir || :
171 /sbin/install-info --delete %{_infodir}/%{name}-cs.info %{_infodir}/dir || :
172fi
173
174
175%files
176%defattr(-,root,root,-)
177%doc AUTHORS ChangeLog NEWS README TODO COPYING
178%config(noreplace) %{_sysconfdir}/speech-dispatcher/speechd.conf
179%config(noreplace) %{_sysconfdir}/speech-dispatcher/clients/*.conf
180%config(noreplace) %{_sysconfdir}/speech-dispatcher/modules/*.conf
181%dir %{_sysconfdir}/speech-dispatcher/
182%dir %{_sysconfdir}/speech-dispatcher/clients
183%dir %{_sysconfdir}/speech-dispatcher/modules
184
185%{_bindir}/*
186%{_libdir}/speech-dispatcher-modules/sd_*
187%dir %{_libdir}/speech-dispatcher-modules
188
189%{_libdir}/libspeechd.so.*
190%dir %{_libdir}/speech-dispatcher
191%{_libdir}/speech-dispatcher/lib*.so
192%{_libdir}/speech-dispatcher/libsdaudio.so.*
193
194%dir %attr(0700, root, root) %{_localstatedir}/log/speech-dispatcher/
195%attr(0755,root,root)%{_initrddir}/speech-dispatcherd
196
197%files devel
198%defattr(-,root,root,-)
199%{_includedir}/*
200%{_libdir}/lib*.so
201
202%files doc
203%defattr(-,root,root,-)
204%{_infodir}/*
205
206%files python
207%defattr(-,root,root,-)
208%{python_sitearch}/speechd*
209
210%changelog
211* Sun Feb 19 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 0.7.1-2
212- rebuild with python-2.7.2
213
214* Sat Nov 05 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 0.7.1-1
215- new upstream release
216- remove all patches
217
218* Sun Mar 14 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 0.6.7-5
219- Initial build for Vine Linux
220
221* Wed Mar  3 2010 Peter Robinson <pbrobinson@gmail.com> - 0.6.7-4
222- Add patch to fix dso linking. Bug 564851
223
224* Sat Jan  9 2010 Peter Robinson <pbrobinson@gmail.com> - 0.6.7-3
225- Updated to the new python sysarch spec file reqs
226
227* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.6.7-2
228- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
229
230* Wed May 20 2009 Peter Robinson <pbrobinson@gmail.com> - 0.6.7-1
231- New upstream release, some spec file cleanups.
232
233* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.6.6-21
234- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
235
236* Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 0.6.6-20
237- Rebuild for Python 2.6
238
239* Sun Sep 21 2008 Ville Skyttä <ville.skytta at iki.fi> - 0.6.6-19
240- Fix Patch0:/%%patch mismatch.
241
242* Wed Jul 16 2008    Hemant Goyal <goyal.hemant@gmail.com> 0.6.6-18
243- removed suid permission for speech-dispatcher binary.
244
245* Wed Jul 16 2008    Hemant Goyal <goyal.hemant@gmail.com> 0.6.6-17
246- changing permissions of speech-dispatcher to 6711 (setuid and setguid)
247- relocating configuration files in case of OLPC branch.
248- excluding init script in case of OLPC branch.
249
250* Wed Jul 16 2008    Hemant Goyal <goyal.hemant@gmail.com> 0.6.6-16
251- yet another release bump required :-/
252
253* Wed Jul 16 2008    Hemant Goyal <goyal.hemant@gmail.com> 0.6.6-15
254- release bump
255
256* Mon Jul 13 2008    Hemant Goyal <goyal.hemant@gmail.com> 0.6.6-14
257- conditional build required for OLPC Branch - Building without nas and
258  pulse-audio support.
259
260* Mon Jun 23 2008    Hemant Goyal <goyal.hemant@gmail.com> 0.6.6-13
261- changed permission of speech-dispatcherd to 0644 too.
262
263* Fri Jun 20 2008    Hemant Goyal <goyal.hemant@gmail.com> 0.6.6-12
264- added BuildRequires: texinfo (for makeinfo)
265- changed permissions of Sourcex to 0644
266- incorporated modified init script by mtasaka
267- fixed a few more macros in changelog
268- modified location of Source1 and Patch0 to point to online locations
269
270* Wed Jun 18 2008    Hemant Goyal <goyal.hemant@gmail.com> 0.6.6-11
271- fixed encoding of speech-dispatcher-cs.info file to UTF-8
272
273* Wed Jun 11 2008    Hemant Goyal <goyal.hemant@gmail.com> 0.6.6-10
274- removed Requires(preun) duplicates
275- applied -p option correctly to install command
276- fixed macros in changelog to prevent them from exapnding
277- fixed the init script
278- added patch to change log directory of speech-dispatcher and start only espeak
279
280* Sun Jun 08 2008    Hemant Goyal <goyal.hemant@gmail.com> 0.6.6-9
281- removed %%{_infodir}/dir file
282
283* Sat Jun 07 2008    Hemant Goyal <goyal.hemant@gmail.com> 0.6.6-8
284- converted speech-dispatcher-cs.info to UTF-8 encoding
285- removed multiple file listings of /usr/lib/python2.5/site-packages/speechd/_test.py
286  and fixed its mode
287- added init script as a SOURCE instead as a patch
288- duplicate Requires have now been removed
289- Timestamping of files has now been added
290- Install script fixed
291- init script fixed
292
293* Tue Jun 03 2008    Hemant Goyal <goyal.hemant@gmail.com> 0.6.6-7
294- changed license of base package to GPLv2+ and GPL
295- changed license of all other packages to GPLv2+
296- fixed install sequence using cleaner for loop and pushd and popd commands
297- added init script for speech-dispatcher daemon
298- added COPYING to doc in base package
299- removed comment after /sbin/ldconfig
300- resolved rpmlint errors for base package [except UTF-8 encoding error for (cs) documentation file]
301- renamed long_message to spd_long_message and run_test to spd_run_test
302- reset mode of _test.py to 0755
303
304* Sun Apr 27 2008    Hemant Goyal <goyal.hemant@gmail.com> 0.6.6-6
305- changed BR to pulseaudio-lib-devel
306- removed dotconf BR
307- gave ownership of /%%{python_sitelib}/speechd-0.3-py2.5.egg-info to python package if package is built for Fedora 9 or above
308
309* Sun Apr 13 2008    Hemant Goyal <goyal.hemant@gmail.com> 0.6.6-5
310- Removed conitional building options
311- Added BuildRequires for dotconf-devel
312
313* Mon Feb 18 2008    Hemant Goyal <goyal.hemant@gmail.com> 0.6.6-4
314- Manually specyfying make install for each src directory to be installed
315- Installing python package seprately by by-passing make install
316
317* Sun Feb 17 2008   Hemant Goyal <goyal.hemant@gmail.com> 0.6.6-3
318- Added Requires(post), Requires(preun) for -doc package
319- Changed scriptlet from postun to preun for -doc package
320- Removed Epoch
321- Moved %%{_libdir}/lib*.so back to devel pacakge
322- Require dependecny on base pacakge is now set to %%{version}-%%{release} instead of %%{version}
323- removed --prefix=$RPM_BUILD_ROOT/%%{_prefix}  against configure macro.
324  -- -python subpackage does not build anymore.
325- removed python subpackag rules from SPEC file.
326
327* Sat Feb 16 2008   Hemant Goyal <goyal.hemant@gmail.com> 0.6.6-2
328- fixed directory ownerships
329
330* Sat Feb 16 2008   Hemant Goyal <goyal.hemant@gmail.com> 0.6.6-1
331- using newest version of speech-dispatcher
332- updated %%{_libdir}/libspeechd.so.2.0.4 to %%{_libdir}/libspeechd.so.2.0.5
333- python packages are being generated correctly now
334- must force prefix=$RPM_BUILD_ROOT/%%{_prefix} to enable python packages to get installed correctly.
335- finding and deleting .*la files in $RPM_BUILD_ROOT to avoid unpackaged files error.
336
337* Sat Feb 16 2008   Hemant Goyal <goyal.hemant@gmail.com> 0.6.5-4
338- updated build root
339
340* Sat Feb 16 2008   Hemant Goyal <goyal.hemant@gmail.com> 0.6.5-3
341- added macro to prevent error from stopping build for not including *.la files
342- added epoch to the SPEC
343- conditional build seems to be working correctly the old way only??
344- unified changelogs
345
346* Fri Feb 15 2008  Hemant Goyal <goyal.hemant@gmail.com> 0.6.5-2
347- Removed .la files
348- Removed doc-cs packages and merged it into doc package
349- Removed packaging of static files, and tested -without static_libs option for configure script
350- Moved symlink .so files from devel package to main package
351- Commented /sbin/ldconfig for devel package.
Note: See TracBrowser for help on using the repository browser.