source: projects/specs/trunk/s/sox/sox-vl.spec @ 8884

Revision 8884, 6.7 KB checked in by Takemikaduchi, 10 years ago (diff)

t1lib: rebuild
others: new upstream release

Line 
1##
2## disable gsm for Vine Linux
3%define nogsm 1
4## disable libmad
5%define nomad 1
6
7Summary:     A general purpose sound file conversion tool.
8Summary(ja): 汎用サウンドファイル変換ツール
9Name: sox
10Version: 14.4.1
11Release: 1%{?_dist_release}
12License: LGPL
13Group: Applications/Multimedia
14Source:  http://prdownloads.sourceforge.net/sox/sox-%{version}.tar.bz2
15URL: http://sox.sourceforge.net/
16BuildRoot: %{_tmppath}/%{name}-%{version}-root
17
18BuildRequires: alsa-lib-devel
19BuildRequires: pulseaudio-lib-devel
20Build%{?nomad:Conflicts}%{!?nomad:Requires}: libmad-devel
21Build%{?nogsm:Conflicts}%{!?nogsm:Requires}: gsm-devel
22
23
24%description
25SoX (Sound eXchange) is a sound file format converter for Linux, UNIX
26and DOS PCs. The 'Swiss Army knife of sound tools,' SoX can convert
27between many different digitized sound formats and perform simple
28sound manipulation functions, including sound effects.
29
30%description -l ja
31SoX (Sound eXchange) は Linux, UNIX, DOS PC 用サウンドファイルフォーマット
32変換ツールです.SoX は「サウンドツール界のスイスアーミーナイフ」で,
33様々なデジタルサウンドフォーマットを相互に変換したり,
34簡単なサウンドエフェクト等の処理も行うことが出来ます.
35
36
37%package -n  sox-devel
38Summary: The SoX sound file format converter libraries.
39Summary(ja): SoX サウンドファイル変換ライブラリ
40Group: Development/Libraries
41
42%description -n sox-devel
43This package contains the library needed for compiling applications
44which will use the SoX sound file format converter.
45
46Install sox-devel if you want to develop applications which will use
47SoX.
48
49%description -n sox-devel -l ja
50このパッケージには SoX サウンドファイルフォーマット変換ツールを
51利用するアプリケーションをコンパイルするのに必要なライブラリが
52収められています.
53
54SoX を利用するプログラムを開発する場合は sox-devel パッケージを
55インストールして下さい.
56
57
58%prep
59%setup -q
60
61%build
62%configure \
63        --disable-static \
64        --includedir=%{_includedir}/sox \
65%{!?nogsm: --with-gsm}
66make
67
68
69%install
70rm -rf $RPM_BUILD_ROOT
71
72mkdir -p $RPM_BUILD_ROOT%{_bindir}
73mkdir -p $RPM_BUILD_ROOT%{_libdir}
74mkdir -p $RPM_BUILD_ROOT%{_mandir}/man1/
75mkdir -p $RPM_BUILD_ROOT%{_mandir}/man3/
76
77make install DESTDIR=$RPM_BUILD_ROOT
78
79echo "#!/bin/sh" > $RPM_BUILD_ROOT%{_bindir}/soxplay
80echo "" >> $RPM_BUILD_ROOT%{_bindir}/soxplay
81echo '%{_bindir}/sox $1 -t .au - > /dev/audio' >> $RPM_BUILD_ROOT%{_bindir}/soxplay
82chmod 755 $RPM_BUILD_ROOT%{_bindir}/soxplay
83
84strip $RPM_BUILD_ROOT%{_bindir}/sox
85
86ln -snf play $RPM_BUILD_ROOT%{_bindir}/rec
87rm -f $RPM_BUILD_ROOT%{_mandir}/man1/rec.1
88ln -snf play.1 $RPM_BUILD_ROOT%{_mandir}/man1/rec.1
89ln -snf sox.1 $RPM_BUILD_ROOT%{_mandir}/man1/soxmix.1
90
91mkdir -p $RPM_BUILD_ROOT%{_includedir}/sox
92install -m 644 src/*.h $RPM_BUILD_ROOT%{_includedir}/sox
93
94find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} \;
95
96
97%clean
98rm -rf $RPM_BUILD_ROOT
99
100%post -p /sbin/ldconfig
101
102%postun -p /sbin/ldconfig
103
104%files
105%defattr(-,root,root)
106%doc Changelog README TODO INSTALL
107%{_bindir}/*
108%{_libdir}/libsox.so.*
109%{_mandir}/man1/*
110
111%files -n sox-devel
112%defattr(-,root,root)
113%{_includedir}/*
114%{_libdir}/libsox.so
115%{_libdir}/pkgconfig/sox.pc
116%{_mandir}/man3/*
117%{_mandir}/man7/*
118
119
120%changelog
121* Sun Aug 03 2014 Yoji TOYODA <owa@bg.wakwak.com> 14.4.1-1
122- update to 14.4.1
123
124* Sat Nov 05 2011 Yoji TOYODA <owa@bg.wakwak.com> 14.3.2-1
125- new upstream release
126- add BuildRequires: pulseaudio-lib-devel
127
128* Sun Apr 17 2011 Shu KONNO <owa@bg.wakwak.com> 12.18.1-2
129- rebuilt with rpm-4.8.1-3
130
131* Sat Aug 16 2008 Shu KONNO <owa@bg.wakwak.com> 12.18.1-1vl5
132- applied new versioning policy, spec in utf-8
133
134* Fri Apr 06 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 12.18.1-0vl3
135- fix installing play.1 man page (<BTS:510>)
136- add BuildRequires: alsa-lib-devel (alsa stuffs are now in main repo)
137
138* Mon Sep 04 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 12.18.1-0vl2
139- add "%%define nomad 1" to disable libmad dependency
140
141* Fri Aug 25 2006 NAKAMURA Kenta <kenta@vinelinux.org> 12.18.1-0vl1
142- new upstream release
143- dropped sox-vorberr.patch and sox-CAN-2004-0557.patch
144
145* Wed Aug 25 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 12.17.3-12vl2
146- add patch for buffer overflow in wav code (CAN-2004-0557, #128158)
147- fixed %files section
148
149* Thu Jul  3 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 12.17.3-12vl1
150- based on 12.17.3-12 from Rawhide
151- rebuild with new toolchains
152- to use License tag instead of Copyright
153- fix License (from distributable to LGPL)
154
155* Fri Jan 12 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
156- 12.17.1-1vl1
157- based on 12.17.1-1 from Rawhide
158- use better macros (%%{_bindir}, %%{_libdir}, %%{_includedir})
159- added Japanese summary and description
160- disable gsm stuff for Vine Linux
161
162* Tue Jan  2 2001 Bill Nottingham <notting@redhat.com>
163- re-enable gsm stuff
164- update to 12.17.1
165
166* Fri Dec 01 2000 Bill Nottingham <notting@redhat.com>
167- rebuild because of broken fileutils
168
169* Mon Nov 13 2000 Bill Nottingham <notting@redhat.com>
170- update to 12.17
171- yank out gsm stuff
172
173* Mon Aug  7 2000 Bill Nottingham <notting@redhat.com>
174- fix playing of sounds on cards that don't support mono
175
176* Sat Aug  5 2000 Bill Nottingham <notting@redhat.com>
177- fix playing of sounds on cards that don't support 8-bit
178
179* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
180- automatic rebuild
181
182* Thu Feb 03 2000 Bill Nottingham <notting@redhat.com>
183- fix manpage link the Right Way(tm)
184
185* Thu Feb 03 2000 Bernhard Rosenkraenzer <bero@redhat.com>
186- Fix rec manpage link - now that man pages are compressed, it should point to
187  play.1.gz, not play.1
188
189* Wed Feb 02 2000 Cristian Gafton <gafton@redhat.com>
190- fix description
191
192* Tue Sep 28 1999 Bill Nottingham <notting@redhat.com>
193- Grrr. Arrrrgh. Fix link.
194
195* Fri Sep 24 1999 Bill Nottingham <notting@redhat.com>
196- add some more files to devel
197
198* Fri Sep 17 1999 Bill Nottingham <notting@redhat.com>
199- fix link
200
201* Fri Jul 30 1999 Bill Nottingham <notting@redhat.com>
202- update to 12.16
203
204* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
205- auto rebuild in the new build environment (release 4)
206
207* Wed Jan 20 1999 Bill Nottingham <notting@redhat.com>
208- allow spaces in filenames for play/rec
209
210* Wed Dec  9 1998 Bill Nottingham <notting@redhat.com>
211- fix docs
212
213* Mon Nov 23 1998 Bill Nottingham <notting@redhat.com>
214- update to 12.15
215
216* Sat Oct 10 1998 Michael Maher <mike@redhat.com>
217- fixed broken spec file
218
219* Mon Jul 13 1998 Michael Maher <mike@redhat.com>
220- updated source from Chris Bagwell.
221
222* Tue Jun 23 1998 Michael Maher <mike@redhat.com>
223- made patch to fix the '-e' option. BUG 580
224- added buildroot
225
226* Fri May 08 1998 Prospector System <bugs@redhat.com>
227- translations modified for de, fr, tr
228
229* Thu Nov 06 1997 Erik Troan <ewt@redhat.com>
230- built against glibc
Note: See TracBrowser for help on using the repository browser.