source: projects/specs/trunk/s/sox/sox-vl.spec @ 10593

Revision 10593, 7.2 KB checked in by tomop, 8 years ago (diff)

sox-14.4.2-1

Line 
1##
2## disable gsm for Vine Linux
3%define nogsm 1
4## disable libmad
5%define nomad 1
6
7Summary:     A general purpose sound file conversion tool.
8Summary(ja): 汎用サウンドファイル変換ツール
9Name: sox
10Version: 14.4.2
11Release: 1%{?_dist_release}
12License: LGPL
13Group: Applications/Multimedia
14Source:  http://prdownloads.sourceforge.net/sox/sox-%{version}.tar.bz2
15
16URL: http://sox.sourceforge.net/
17BuildRoot: %{_tmppath}/%{name}-%{version}-root
18
19BuildRequires: alsa-lib-devel
20BuildRequires: pulseaudio-lib-devel
21BuildRequires: flac-devel
22BuildRequires: libvorbis-devel
23Build%{?nomad:Conflicts}%{!?nomad:Requires}: libmad-devel
24Build%{?nogsm:Conflicts}%{!?nogsm:Requires}: gsm-devel
25
26Vendor: Project Vine
27Distribution: Vine Linux
28
29%description
30SoX (Sound eXchange) is a sound file format converter for Linux, UNIX
31and DOS PCs. The 'Swiss Army knife of sound tools,' SoX can convert
32between many different digitized sound formats and perform simple
33sound manipulation functions, including sound effects.
34
35%description -l ja
36SoX (Sound eXchange) は Linux, UNIX, DOS PC 用サウンドファイルフォーマット
37変換ツールです.SoX は「サウンドツール界のスイスアーミーナイフ」で,
38様々なデジタルサウンドフォーマットを相互に変換したり,
39簡単なサウンドエフェクト等の処理も行うことが出来ます.
40
41
42%package -n  sox-devel
43Summary: The SoX sound file format converter libraries.
44Summary(ja): SoX サウンドファイル変換ライブラリ
45Group: Development/Libraries
46Requires: %{name} = %{version}
47
48%description -n sox-devel
49This package contains the library needed for compiling applications
50which will use the SoX sound file format converter.
51
52Install sox-devel if you want to develop applications which will use
53SoX.
54
55%description -n sox-devel -l ja
56このパッケージには SoX サウンドファイルフォーマット変換ツールを
57利用するアプリケーションをコンパイルするのに必要なライブラリが
58収められています.
59
60SoX を利用するプログラムを開発する場合は sox-devel パッケージを
61インストールして下さい.
62
63
64%prep
65%setup -q
66
67%build
68%configure \
69        --disable-static \
70        --includedir=%{_includedir}/sox \
71%{!?nogsm: --with-gsm}
72make
73
74%install
75rm -rf $RPM_BUILD_ROOT
76
77mkdir -p $RPM_BUILD_ROOT%{_bindir}
78mkdir -p $RPM_BUILD_ROOT%{_libdir}
79mkdir -p $RPM_BUILD_ROOT%{_mandir}/man1/
80mkdir -p $RPM_BUILD_ROOT%{_mandir}/man3/
81
82make install DESTDIR=$RPM_BUILD_ROOT
83
84echo "#!/bin/sh" > $RPM_BUILD_ROOT%{_bindir}/soxplay
85echo "" >> $RPM_BUILD_ROOT%{_bindir}/soxplay
86echo '%{_bindir}/sox $1 -t .au - > /dev/audio' >> $RPM_BUILD_ROOT%{_bindir}/soxplay
87chmod 755 $RPM_BUILD_ROOT%{_bindir}/soxplay
88
89strip $RPM_BUILD_ROOT%{_bindir}/sox
90
91ln -snf play $RPM_BUILD_ROOT%{_bindir}/rec
92rm -f $RPM_BUILD_ROOT%{_mandir}/man1/rec.1
93ln -snf play.1 $RPM_BUILD_ROOT%{_mandir}/man1/rec.1
94ln -snf sox.1 $RPM_BUILD_ROOT%{_mandir}/man1/soxmix.1
95
96mkdir -p $RPM_BUILD_ROOT%{_includedir}/sox
97install -m 644 src/*.h $RPM_BUILD_ROOT%{_includedir}/sox
98
99find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} \;
100
101
102%clean
103rm -rf $RPM_BUILD_ROOT
104
105%post
106/sbin/ldconfig
107
108%postun
109/sbin/ldconfig
110
111%files
112%defattr(-,root,root)
113%doc Changelog README TODO INSTALL
114%{_bindir}/*
115%{_libdir}/libsox.so.*
116%{_mandir}/man1/*
117
118%files -n sox-devel
119%defattr(-,root,root)
120%{_includedir}/*
121%{_libdir}/libsox.so
122%{_libdir}/pkgconfig/sox.pc
123%{_mandir}/man3/*
124%{_mandir}/man7/*
125
126
127%changelog
128* Mon Jul 11 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 14.4.2-1
129- new upstream release.
130- added R:sox to sox-devel.
131- dropped Patch100: fixed in upstream.
132
133* Thu Jan  8 2015 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 14.4.1-2
134- add patch100 for fix CVE-2014-8145
135- add BR: flac-devel, libvorbis-devel
136- add Vendor/Distri tags
137
138* Sun Aug 03 2014 Yoji TOYODA <owa@bg.wakwak.com> 14.4.1-1
139- update to 14.4.1
140
141* Sat Nov 05 2011 Yoji TOYODA <owa@bg.wakwak.com> 14.3.2-1
142- new upstream release
143- add BuildRequires: pulseaudio-lib-devel
144
145* Sun Apr 17 2011 Shu KONNO <owa@bg.wakwak.com> 12.18.1-2
146- rebuilt with rpm-4.8.1-3
147
148* Sat Aug 16 2008 Shu KONNO <owa@bg.wakwak.com> 12.18.1-1vl5
149- applied new versioning policy, spec in utf-8
150
151* Fri Apr 06 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 12.18.1-0vl3
152- fix installing play.1 man page (<BTS:510>)
153- add BuildRequires: alsa-lib-devel (alsa stuffs are now in main repo)
154
155* Mon Sep 04 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 12.18.1-0vl2
156- add "%%define nomad 1" to disable libmad dependency
157
158* Fri Aug 25 2006 NAKAMURA Kenta <kenta@vinelinux.org> 12.18.1-0vl1
159- new upstream release
160- dropped sox-vorberr.patch and sox-CAN-2004-0557.patch
161
162* Wed Aug 25 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 12.17.3-12vl2
163- add patch for buffer overflow in wav code (CAN-2004-0557, #128158)
164- fixed %files section
165
166* Thu Jul  3 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 12.17.3-12vl1
167- based on 12.17.3-12 from Rawhide
168- rebuild with new toolchains
169- to use License tag instead of Copyright
170- fix License (from distributable to LGPL)
171
172* Fri Jan 12 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
173- 12.17.1-1vl1
174- based on 12.17.1-1 from Rawhide
175- use better macros (%%{_bindir}, %%{_libdir}, %%{_includedir})
176- added Japanese summary and description
177- disable gsm stuff for Vine Linux
178
179* Tue Jan  2 2001 Bill Nottingham <notting@redhat.com>
180- re-enable gsm stuff
181- update to 12.17.1
182
183* Fri Dec 01 2000 Bill Nottingham <notting@redhat.com>
184- rebuild because of broken fileutils
185
186* Mon Nov 13 2000 Bill Nottingham <notting@redhat.com>
187- update to 12.17
188- yank out gsm stuff
189
190* Mon Aug  7 2000 Bill Nottingham <notting@redhat.com>
191- fix playing of sounds on cards that don't support mono
192
193* Sat Aug  5 2000 Bill Nottingham <notting@redhat.com>
194- fix playing of sounds on cards that don't support 8-bit
195
196* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
197- automatic rebuild
198
199* Thu Feb 03 2000 Bill Nottingham <notting@redhat.com>
200- fix manpage link the Right Way(tm)
201
202* Thu Feb 03 2000 Bernhard Rosenkraenzer <bero@redhat.com>
203- Fix rec manpage link - now that man pages are compressed, it should point to
204  play.1.gz, not play.1
205
206* Wed Feb 02 2000 Cristian Gafton <gafton@redhat.com>
207- fix description
208
209* Tue Sep 28 1999 Bill Nottingham <notting@redhat.com>
210- Grrr. Arrrrgh. Fix link.
211
212* Fri Sep 24 1999 Bill Nottingham <notting@redhat.com>
213- add some more files to devel
214
215* Fri Sep 17 1999 Bill Nottingham <notting@redhat.com>
216- fix link
217
218* Fri Jul 30 1999 Bill Nottingham <notting@redhat.com>
219- update to 12.16
220
221* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
222- auto rebuild in the new build environment (release 4)
223
224* Wed Jan 20 1999 Bill Nottingham <notting@redhat.com>
225- allow spaces in filenames for play/rec
226
227* Wed Dec  9 1998 Bill Nottingham <notting@redhat.com>
228- fix docs
229
230* Mon Nov 23 1998 Bill Nottingham <notting@redhat.com>
231- update to 12.15
232
233* Sat Oct 10 1998 Michael Maher <mike@redhat.com>
234- fixed broken spec file
235
236* Mon Jul 13 1998 Michael Maher <mike@redhat.com>
237- updated source from Chris Bagwell.
238
239* Tue Jun 23 1998 Michael Maher <mike@redhat.com>
240- made patch to fix the '-e' option. BUG 580
241- added buildroot
242
243* Fri May 08 1998 Prospector System <bugs@redhat.com>
244- translations modified for de, fr, tr
245
246* Thu Nov 06 1997 Erik Troan <ewt@redhat.com>
247- built against glibc
Note: See TracBrowser for help on using the repository browser.