source: projects/specs/trunk/s/sound-juicer/sound-juicer-vl.spec @ 6011

Revision 6011, 9.0 KB checked in by Takemikaduchi, 12 years ago (diff)

new upstream release

Line 
1Name:           sound-juicer
2Summary:        Clean and lean CD ripper
3Summary(ja):    シンプルで簡単なCDリッピングツール
4Version:        3.4.0
5Release:        1%{?_dist_release}
6License:        GPL
7Group:          Applications/Multimedia
8Source0:        http://ftp.gnome.org/pub/GNOME/sources/sound-juicer/3.4/%{name}-%{version}.tar.xz
9
10BuildRoot:      %{_tmppath}/%{name}-%{version}-root
11Requires:       cdparanoia
12BuildRequires:  libgnome-media-profiles-devel >= 3.0.0
13BuildRequires:  libmusicbrainz-devel >= 2.1.1
14BuildRequires:  glib2-devel >= 2.26.0
15BuildRequires:  gstreamer-devel >= 0.10.30
16BuildRequires:  gstreamer-plugins-base-devel >= 0.10.30
17BuildRequires:  gstreamer-plugins-good-flac
18BuildRequires:  gnome-doc-utils
19BuildRequires:  GConf2-devel >= 2.32.0
20BuildRequires:  hal-devel >= 0.5.9
21BuildRequires:  scrollkeeper >= 0.3.5
22BuildRequires:  brasero-devel
23BuildRequires:  gcc-c++
24BuildRequires:  autoconf
25BuildRequires:  libcanberra-gtk3-devel
26BuildRequires:  libmusicbrainz3-devel
27BuildRequires:  gnome-common
28Requires(pre): GConf2
29Requires(post): GConf2
30Requires(preun): GConf2
31# http://bugzilla.gnome.org/show_bug.cgi?id=157772
32ExcludeArch: s390 s390x
33
34Vendor: Project Vine
35Distribution: Vine Linux
36
37
38%description
39GStreamer-based CD ripping tool. Saves audio CDs to Ogg/vorbis.
40
41%description -l ja
42Sound Juicer は GStreamer ベースの CD リッピングツールです。
43CD を Ogg/vorbis に変換します。
44
45%prep
46%setup -q
47
48%build
49autoreconf -if
50%configure \
51        --with-gtk=3.0 \
52        --disable-scrollkeeper \
53        --disable-schemas-install \
54        --disable-scrollkeeper
55
56%__make AM_CFLAGS=-export-dynamic
57
58%install
59rm -rf $RPM_BUILD_ROOT
60export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1;
61make install DESTDIR=$RPM_BUILD_ROOT
62unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
63
64rm -rf $RPM_BUILD_ROOT%{_localstatedir}/scrollkeeper
65rm -rf $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/icon-theme.cache
66
67%find_lang %{name}
68
69%clean
70rm -rf $RPM_BUILD_ROOT
71
72%pre
73if [ "$1" -gt 1 ]; then
74    export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
75    gconftool-2 --makefile-uninstall-rule \
76        %{_sysconfdir}/gconf/schemas/sound-juicer.schemas >& /dev/null ||:
77fi
78
79%preun
80if [ "$1" -eq 0 ]; then
81    export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
82    gconftool-2 --makefile-uninstall-rule \
83        %{_sysconfdir}/gconf/schemas/sound-juicer.schemas > /dev/null ||:
84fi
85
86%post
87export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
88gconftool-2 --makefile-install-rule %{_sysconfdir}/gconf/schemas/sound-juicer.schemas > /dev/null ||:
89touch --no-create %{_datadir}/icons/hicolor
90if [ -x /usr/bin/gtk-update-icon-cache ]; then
91  /usr/bin/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor ||:
92fi
93
94%postun
95touch --no-create %{_datadir}/icons/hicolor
96if [ -x /usr/bin/gtk-update-icon-cache ]; then
97  /usr/bin/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor ||:
98fi
99
100
101%files -f sound-juicer.lang
102%defattr(-, root, root)
103%doc AUTHORS COPYING ChangeLog README NEWS
104%{_bindir}/sound-juicer
105%{_sysconfdir}/gconf/schemas/sound-juicer.schemas
106%{_datadir}/sound-juicer
107%{_datadir}/applications/sound-juicer.desktop
108%{_datadir}/gnome/help/sound-juicer
109%{_datadir}/omf/sound-juicer
110%{_datadir}/icons/hicolor/*
111%{_mandir}/man1/*
112
113%changelog
114* Thu Apr 19 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.0-1
115- new upstream release
116- remove Patch0
117- remove Source1
118
119* Wed Aug 17 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0-2
120- add configure option: --with-gtk=3.0
121- change BuildRequires: libgnome-media-profiles-devel instead of gnome-media-devel
122- change BuildRequires: libcanberra-gtk3-devel instead of libcanberra-devel
123- add Patch0 (sound-juicer-2.32.0-git20110523.patch)
124- add Source1 (sound-juicer-256.png)
125- add BuildRequires: gnome-common
126
127* Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0-1
128- new upstream release
129- add BuildRequires: libmusicbrainz3-devel
130- remove BuildRequires: libgnomeui-devel
131- fix BuildRequires: gnome-media-devel instead of gnome-media
132
133* Sun Apr 25 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.2-1
134- new upstream release
135
136* Sat Jan 16 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.1-1
137- new upstream release
138- remove configure option: --enable-hal (unrecognized option)
139- add BuildRequires: gstreamer-plugins-base-devel >= 0.10.5
140- add BuildRequires: gstreamer-plugins-good-flac
141
142* Sat Apr 25 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.1-1
143- new upstream release
144
145* Tue Apr 07 2009 Shu KONNO <owa@bg.wakwak.com> 2.26.0-2
146- add BR: libcanberra-devel
147
148* Mon Mar 23 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
149- new upstream release
150- add BR: brasero-devel instead of nautilus-cd-burner
151- add BR: gnome-doc-utils
152- add Requires(pre,post,postun): GConf2
153- remove unneeded Requires:
154
155* Sat Oct 25 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.24.0-1vl5
156- new upstream release
157
158* Sat Oct 11 2008 Shu KONNO <owa@bg.wakwak.com> 2.16.4-1vl5
159- applied new versioning policy, spec in utf-8
160
161* Thu May 17 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.16.4-0vl2
162- rebuild with new environment/toolchain
163
164* Sat Apr 28 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.16.4-0vl1
165- new upstream release
166
167* Sun Jun 04 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.4-0vl1
168- new upstream release
169
170* Sat Apr 15 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.2-0vl1
171- new upstream release
172
173* Tue Apr 05 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.1-0vl1
174- initial build for Vine Linux based on FC package
175- new upstream release
176
177* Wed Mar 23 2005 John (J5) Palmieri <johnp@redhat.com> 2.10.0-2
178- Rebuild for libmusicbrainz-2.1.1
179
180* Fri Mar 11 2005 John (J5) Palmieri <johnp@redhat.com> 2.10.0-1
181- Update to upstream version 2.10.0
182
183* Tue Mar 08 2005 John (J5) Palmieri <johnp@redhat.com> 2.9.91-3
184- Build in rawhide
185- Disable build on s390 and s390x
186
187* Fri Feb 25 2005 John (J5) Palmieri <johnp@redhat.com> 2.9.91-2
188- Reenabled BuildRequires for hal-devel >= 0.5.0
189- Added (Build)Requires for nautilus-cd-burner(-devel) >= 2.9.6
190
191* Wed Feb 23 2005 John (J5) Palmieri <johnp@redhat.com> 2.9.91-1
192- New upstream version (version jump resulted from sound-juicer using gnome
193  versioning scheme)
194 
195* Fri Feb 04 2005 Colin Walters <walters@redhat.com> 0.6.0-1
196- New upstream version
197- Remove obsoleted sound-juicer-idle-safety.patch
198- BR latest gnome-media
199
200* Fri Nov 12 2004 Warren Togami <wtogami@redhat.com> 0.5.14-5
201- minor spec cleanups
202- req cdparanoia and gstreamer-plugins
203
204* Tue Nov 09 2004 Colin Walters <walters@redhat.com> 0.5.14-4
205- Add sound-juicer-idle-safety.patch (bug 137847)
206
207* Wed Oct 27 2004 Colin Walters <walters@redhat.com> 0.5.14-2
208- Actually enable HAL
209- BR hal-devel
210
211* Wed Oct 13 2004 Colin Walters <walters@redhat.com> 0.5.14-1
212- New upstream
213- This release fixes corruption on re-read, upstream 153085
214- Remove upstreamed sound-juicer-0.5.13-prefs-crash.patch
215
216* Mon Oct 04 2004 Colin Walters <walters@redhat.com> 0.5.13-2
217- Apply patch to avoid prefs crash
218
219* Tue Sep 28 2004 Colin Walters <walters@redhat.com> 0.5.13-1
220- New upstream 0.5.13
221
222* Mon Sep 27 2004 Colin Walters <walters@redhat.com> 0.5.12.cvs20040927-1
223- New upstream CVS snapshot, 20040927
224
225* Mon Sep 20 2004 Colin Walters <walters@redhat.com> 0.5.12-1
226- New upstream version 0.5.12
227- Delete upstreamed patch sound-juicer-0.5.9-pref-help.patch
228- Delete upstreamed patch sound-juicer-0.5.10-gstreamer.patch
229- Delete call to autoconf
230
231* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
232- rebuilt
233
234* Tue Mar 16 2004 Jeremy Katz <katzj@redhat.com> 0.5.10.1-8
235- rebuild for new gstreamer
236
237* Thu Mar 11 2004 Brent Fox <bfox@redhat.com> 0.5.10.1-5
238- rebuild
239
240* Fri Feb 27 2004 Brent Fox <bfox@redhat.com> 0.5.10.1-3
241- rebuild
242
243* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
244- rebuilt
245
246* Thu Feb  5 2004 Brent Fox <bfox@redhat.com> 0.5.10.1-1
247- new version
248
249* Wed Jan 28 2004 Alexander Larsson <alexl@redhat.com> 0.5.9-4
250- rebuild to use new gstreamer
251
252* Fri Jan 16 2004 Brent Fox <bfox@redhat.com> 0.5.9-3
253- add %preun to clean up GConf entries on uninstall
254
255* Wed Jan 14 2004 Brent Fox <bfox@redhat.com> 0.5.9-2
256- create init patch to make help work
257
258* Tue Jan 13 2004 Brent Fox <bfox@redhat.com> 0.5.9-1
259- update to 0.5.9
260
261* Mon Dec 15 2003 Christopher Blizzard <blizzard@redhat.com> 0.5.8-1
262- Add upstream patch that fixes permissions of created directories.
263
264* Wed Dec 03 2003 Christopher Blizzard <blizzard@redhat.com> 0.5.8-0
265- Update to 0.5.8
266
267* Tue Oct 21 2003 Brent Fox <bfox@redhat.com> 0.5.5-1
268- update to 0.5.5-1
269
270* Mon Sep  1 2003 Jonathan Blandford <jrb@redhat.com>
271- warning dialog fix
272- add a quality option
273
274* Fri Aug 29 2003 Elliot Lee <sopwith@redhat.com> 0.5.2-5
275- scrollkeeper stuff should be removed
276
277* Wed Aug 27 2003 Brent Fox <bfox@redhat.com> 0.5.2-4
278- remove ExcludeArches since libmusicbrainz is building on all arches now
279
280* Wed Aug 27 2003 Brent Fox <bfox@redhat.com> 0.5.2-3
281- bump relnum
282
283* Wed Aug 27 2003 Brent Fox <bfox@redhat.com> 0.5.2-2
284- spec file cleanups
285- add exclude arch for ia64, x86_64, ppc64, and s390x
286- add %file macros
287- remove Requires for gstreamer-cdparanoia and gstreamer-vorbis
288
289* Tue Apr 22 2003 Frederic Crozat <fcrozat@mandrakesoft.com>
290- Use more macros
291
292* Sun Apr 20 2003 Ronald Bultje <rbultje@ronald.bitfreak.net>
293- Make spec file for sound-juicer (based on netRB spec file)
Note: See TracBrowser for help on using the repository browser.