source: projects/specs/trunk/s/sound-juicer/sound-juicer-vl.spec @ 4616

Revision 4616, 9.0 KB checked in by Takemikaduchi, 13 years ago (diff)

X.Org, compiz, GNOME3, etc...

Line 
1Name:           sound-juicer
2Summary:        Clean and lean CD ripper
3Summary(ja):    シンプルで簡単なCDリッピングツール
4Version:        2.32.0
5Release:        2%{?_dist_release}
6License:        GPL
7Group:          Applications/Multimedia
8Source0:        http://ftp.gnome.org/pub/GNOME/sources/sound-juicer/2.32/%{name}-%{version}.tar.bz2
9Source1:        sound-juicer-256.png
10
11Patch0:         sound-juicer-2.32.0-git20110523.patch
12
13BuildRoot:      %{_tmppath}/%{name}-%{version}-root
14Requires:       cdparanoia
15BuildRequires:  libgnome-media-profiles-devel >= 3.0.0
16BuildRequires:  libmusicbrainz-devel >= 2.1.1
17BuildRequires:  glib2-devel >= 2.26.0
18BuildRequires:  gstreamer-devel >= 0.10.30
19BuildRequires:  gstreamer-plugins-base-devel >= 0.10.30
20BuildRequires:  gstreamer-plugins-good-flac
21BuildRequires:  gnome-doc-utils
22BuildRequires:  GConf2-devel >= 2.32.0
23BuildRequires:  hal-devel >= 0.5.9
24BuildRequires:  scrollkeeper >= 0.3.5
25BuildRequires:  brasero-devel
26BuildRequires:  gcc-c++
27BuildRequires:  autoconf
28BuildRequires:  libcanberra-gtk3-devel
29BuildRequires:  libmusicbrainz3-devel
30BuildRequires:  gnome-common
31Requires(pre): GConf2
32Requires(post): GConf2
33Requires(preun): GConf2
34# http://bugzilla.gnome.org/show_bug.cgi?id=157772
35ExcludeArch: s390 s390x
36
37Vendor: Project Vine
38Distribution: Vine Linux
39
40
41%description
42GStreamer-based CD ripping tool. Saves audio CDs to Ogg/vorbis.
43
44%description -l ja
45Sound Juicer は GStreamer ベースの CD リッピングツールです。
46CD を Ogg/vorbis に変換します。
47
48%prep
49%setup -q
50%patch0 -p1 -b .git
51
52cp -f %{SOURCE1} data/
53
54%build
55autoreconf -if
56%configure \
57        --with-gtk=3.0 \
58        --disable-scrollkeeper \
59        --disable-schemas-install \
60        --disable-scrollkeeper
61
62%__make AM_CFLAGS=-export-dynamic
63
64%install
65rm -rf $RPM_BUILD_ROOT
66export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1;
67make install DESTDIR=$RPM_BUILD_ROOT
68unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
69
70rm -rf $RPM_BUILD_ROOT%{_localstatedir}/scrollkeeper
71rm -rf $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/icon-theme.cache
72
73%find_lang %{name}
74
75%clean
76rm -rf $RPM_BUILD_ROOT
77
78%pre
79if [ "$1" -gt 1 ]; then
80    export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
81    gconftool-2 --makefile-uninstall-rule \
82        %{_sysconfdir}/gconf/schemas/sound-juicer.schemas >& /dev/null ||:
83fi
84
85%preun
86if [ "$1" -eq 0 ]; then
87    export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
88    gconftool-2 --makefile-uninstall-rule \
89        %{_sysconfdir}/gconf/schemas/sound-juicer.schemas > /dev/null ||:
90fi
91
92%post
93export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
94gconftool-2 --makefile-install-rule %{_sysconfdir}/gconf/schemas/sound-juicer.schemas > /dev/null ||:
95touch --no-create %{_datadir}/icons/hicolor
96if [ -x /usr/bin/gtk-update-icon-cache ]; then
97  /usr/bin/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor ||:
98fi
99
100%postun
101touch --no-create %{_datadir}/icons/hicolor
102if [ -x /usr/bin/gtk-update-icon-cache ]; then
103  /usr/bin/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor ||:
104fi
105
106
107%files -f sound-juicer.lang
108%defattr(-, root, root)
109%doc AUTHORS COPYING ChangeLog README NEWS
110%{_bindir}/sound-juicer
111%{_sysconfdir}/gconf/schemas/sound-juicer.schemas
112%{_datadir}/sound-juicer
113%{_datadir}/applications/sound-juicer.desktop
114%{_datadir}/gnome/help/sound-juicer
115%{_datadir}/omf/sound-juicer
116%{_datadir}/icons/hicolor/*
117%{_mandir}/man1/*
118
119%changelog
120* Wed Aug 17 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0-2
121- add configure option: --with-gtk=3.0
122- change BuildRequires: libgnome-media-profiles-devel instead of gnome-media-devel
123- change BuildRequires: libcanberra-gtk3-devel instead of libcanberra-devel
124- add Patch0 (sound-juicer-2.32.0-git20110523.patch)
125- add Source1 (sound-juicer-256.png)
126- add BuildRequires: gnome-common
127
128* Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0-1
129- new upstream release
130- add BuildRequires: libmusicbrainz3-devel
131- remove BuildRequires: libgnomeui-devel
132- fix BuildRequires: gnome-media-devel instead of gnome-media
133
134* Sun Apr 25 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.2-1
135- new upstream release
136
137* Sat Jan 16 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.1-1
138- new upstream release
139- remove configure option: --enable-hal (unrecognized option)
140- add BuildRequires: gstreamer-plugins-base-devel >= 0.10.5
141- add BuildRequires: gstreamer-plugins-good-flac
142
143* Sat Apr 25 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.1-1
144- new upstream release
145
146* Tue Apr 07 2009 Shu KONNO <owa@bg.wakwak.com> 2.26.0-2
147- add BR: libcanberra-devel
148
149* Mon Mar 23 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
150- new upstream release
151- add BR: brasero-devel instead of nautilus-cd-burner
152- add BR: gnome-doc-utils
153- add Requires(pre,post,postun): GConf2
154- remove unneeded Requires:
155
156* Sat Oct 25 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.24.0-1vl5
157- new upstream release
158
159* Sat Oct 11 2008 Shu KONNO <owa@bg.wakwak.com> 2.16.4-1vl5
160- applied new versioning policy, spec in utf-8
161
162* Thu May 17 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.16.4-0vl2
163- rebuild with new environment/toolchain
164
165* Sat Apr 28 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.16.4-0vl1
166- new upstream release
167
168* Sun Jun 04 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.4-0vl1
169- new upstream release
170
171* Sat Apr 15 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.2-0vl1
172- new upstream release
173
174* Tue Apr 05 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.1-0vl1
175- initial build for Vine Linux based on FC package
176- new upstream release
177
178* Wed Mar 23 2005 John (J5) Palmieri <johnp@redhat.com> 2.10.0-2
179- Rebuild for libmusicbrainz-2.1.1
180
181* Fri Mar 11 2005 John (J5) Palmieri <johnp@redhat.com> 2.10.0-1
182- Update to upstream version 2.10.0
183
184* Tue Mar 08 2005 John (J5) Palmieri <johnp@redhat.com> 2.9.91-3
185- Build in rawhide
186- Disable build on s390 and s390x
187
188* Fri Feb 25 2005 John (J5) Palmieri <johnp@redhat.com> 2.9.91-2
189- Reenabled BuildRequires for hal-devel >= 0.5.0
190- Added (Build)Requires for nautilus-cd-burner(-devel) >= 2.9.6
191
192* Wed Feb 23 2005 John (J5) Palmieri <johnp@redhat.com> 2.9.91-1
193- New upstream version (version jump resulted from sound-juicer using gnome
194  versioning scheme)
195 
196* Fri Feb 04 2005 Colin Walters <walters@redhat.com> 0.6.0-1
197- New upstream version
198- Remove obsoleted sound-juicer-idle-safety.patch
199- BR latest gnome-media
200
201* Fri Nov 12 2004 Warren Togami <wtogami@redhat.com> 0.5.14-5
202- minor spec cleanups
203- req cdparanoia and gstreamer-plugins
204
205* Tue Nov 09 2004 Colin Walters <walters@redhat.com> 0.5.14-4
206- Add sound-juicer-idle-safety.patch (bug 137847)
207
208* Wed Oct 27 2004 Colin Walters <walters@redhat.com> 0.5.14-2
209- Actually enable HAL
210- BR hal-devel
211
212* Wed Oct 13 2004 Colin Walters <walters@redhat.com> 0.5.14-1
213- New upstream
214- This release fixes corruption on re-read, upstream 153085
215- Remove upstreamed sound-juicer-0.5.13-prefs-crash.patch
216
217* Mon Oct 04 2004 Colin Walters <walters@redhat.com> 0.5.13-2
218- Apply patch to avoid prefs crash
219
220* Tue Sep 28 2004 Colin Walters <walters@redhat.com> 0.5.13-1
221- New upstream 0.5.13
222
223* Mon Sep 27 2004 Colin Walters <walters@redhat.com> 0.5.12.cvs20040927-1
224- New upstream CVS snapshot, 20040927
225
226* Mon Sep 20 2004 Colin Walters <walters@redhat.com> 0.5.12-1
227- New upstream version 0.5.12
228- Delete upstreamed patch sound-juicer-0.5.9-pref-help.patch
229- Delete upstreamed patch sound-juicer-0.5.10-gstreamer.patch
230- Delete call to autoconf
231
232* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
233- rebuilt
234
235* Tue Mar 16 2004 Jeremy Katz <katzj@redhat.com> 0.5.10.1-8
236- rebuild for new gstreamer
237
238* Thu Mar 11 2004 Brent Fox <bfox@redhat.com> 0.5.10.1-5
239- rebuild
240
241* Fri Feb 27 2004 Brent Fox <bfox@redhat.com> 0.5.10.1-3
242- rebuild
243
244* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
245- rebuilt
246
247* Thu Feb  5 2004 Brent Fox <bfox@redhat.com> 0.5.10.1-1
248- new version
249
250* Wed Jan 28 2004 Alexander Larsson <alexl@redhat.com> 0.5.9-4
251- rebuild to use new gstreamer
252
253* Fri Jan 16 2004 Brent Fox <bfox@redhat.com> 0.5.9-3
254- add %preun to clean up GConf entries on uninstall
255
256* Wed Jan 14 2004 Brent Fox <bfox@redhat.com> 0.5.9-2
257- create init patch to make help work
258
259* Tue Jan 13 2004 Brent Fox <bfox@redhat.com> 0.5.9-1
260- update to 0.5.9
261
262* Mon Dec 15 2003 Christopher Blizzard <blizzard@redhat.com> 0.5.8-1
263- Add upstream patch that fixes permissions of created directories.
264
265* Wed Dec 03 2003 Christopher Blizzard <blizzard@redhat.com> 0.5.8-0
266- Update to 0.5.8
267
268* Tue Oct 21 2003 Brent Fox <bfox@redhat.com> 0.5.5-1
269- update to 0.5.5-1
270
271* Mon Sep  1 2003 Jonathan Blandford <jrb@redhat.com>
272- warning dialog fix
273- add a quality option
274
275* Fri Aug 29 2003 Elliot Lee <sopwith@redhat.com> 0.5.2-5
276- scrollkeeper stuff should be removed
277
278* Wed Aug 27 2003 Brent Fox <bfox@redhat.com> 0.5.2-4
279- remove ExcludeArches since libmusicbrainz is building on all arches now
280
281* Wed Aug 27 2003 Brent Fox <bfox@redhat.com> 0.5.2-3
282- bump relnum
283
284* Wed Aug 27 2003 Brent Fox <bfox@redhat.com> 0.5.2-2
285- spec file cleanups
286- add exclude arch for ia64, x86_64, ppc64, and s390x
287- add %file macros
288- remove Requires for gstreamer-cdparanoia and gstreamer-vorbis
289
290* Tue Apr 22 2003 Frederic Crozat <fcrozat@mandrakesoft.com>
291- Use more macros
292
293* Sun Apr 20 2003 Ronald Bultje <rbultje@ronald.bitfreak.net>
294- Make spec file for sound-juicer (based on netRB spec file)
Note: See TracBrowser for help on using the repository browser.