source: projects/specs/trunk/s/slang/slang-vl.spec @ 8073

Revision 8073, 9.2 KB checked in by Takemikaduchi, 10 years ago (diff)

new upstream release or rebuild

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3Summary: The shared library for the S-Lang extension language
4Summary(ja): S-Lang 拡張言語ライブラリ
5Name: slang
6Version: 2.1.4
7Release: 5%{?_dist_release}
8
9License: GPLv2+
10Group: System Environment/Libraries
11URL: http://www.jedsoft.org/slang/
12
13Source: ftp://space.mit.edu/pub/davis/slang/v2.1/%{name}-%{version}.tar.bz2
14Patch1: slang-2.1.4-makefile.patch
15Patch2: slang-nointerlibc2.patch
16
17BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
18BuildRequires: libpng-devel
19BuildRequires: oniguruma-devel
20BuildRequires: pcre-devel
21
22Vendor: Project Vine
23Distribution: Vine Linux
24Packager: Daisuke SUZUKI <daisuke@linux.or.jp>
25
26%description
27S-lang (pronounced `sssslang'') is a powerful stack based interpreter
28that supports a C-like syntax.  It has been designed from the beginning
29to be easily embedded into a program to make it extensible. Slang also
30provides a way to quickly develop and debug the application embedding it
31in a safe and efficient manner.  Since slang resembles C, it is easy to
32recode slang procedures in C if the need arises.
33
34%description -l ja
35S-lang (`sssslang'' と発音します)は、Cとよく似た文法のスタックベース
36・インタプリタです。開発初期から、プログラムに容易に組み込めるように
37デザインされてきました。また、S-lang を用いると、アプリケーションを安
38全にかつ効率良くデバッグ・開発できます。S-lang は C と似ていますから、
39必要になれば、S-lang の手続きをCに簡単に変換することもできます。
40
41%package slsh
42Summary: Interpreter for S-Lang scripts
43Summary(ja): S-Lang スクリプトインタプリタ
44Group: Development/Languages
45Requires: %{name} = %{version}-%{release}
46
47%description slsh
48slsh (slang-shell) is a program for interpreting S-Lang scripts.
49It supports dynamic loading of S-Lang modules and includes a readline
50interface for interactive use.
51
52This package also includes S-Lang modules that are distributed with
53the S-Lang distribution.
54
55%package devel
56Summary: Development package for %{name}
57Summary(ja): %{name} の開発パッケージ
58Group: Development/Libraries
59Requires: %{name} = %{version}-%{release}
60
61%description devel
62This package contains files which you'll need if you want to
63develop S-Lang based applications.  Documentation which may help
64you write S-Lang based applications is also included.
65
66Install the slang-devel package if you want to develop applications
67based on the S-Lang extension language.
68#'
69
70%description devel -l ja
71このパッケージには S-lang を用いたアプリケーションの開発に必要な静的
72ライブラリとヘッダファイルが含まれています。S-lang を記述する助けに
73なるようなドキュメントも含まれています。
74
75もし S-lang を使ったアプリケーションを開発するなら、このパッケージを
76インストールしてください。
77
78## to build compat32 for x86_64 architecture support
79%package -n compat32-%{name}
80Summary: The shared library for the S-Lang extension language
81Summary(ja): S-Lang 拡張言語ライブラリ
82Group: System Environment/Libraries
83Requires: %{name} = %{version}-%{release}
84
85%description -n compat32-%{name}
86S-lang (pronounced `sssslang'') is a powerful stack based interpreter
87that supports a C-like syntax.  It has been designed from the beginning
88to be easily embedded into a program to make it extensible. Slang also
89provides a way to quickly develop and debug the application embedding it
90in a safe and efficient manner.  Since slang resembles C, it is easy to
91recode slang procedures in C if the need arises.
92
93%description -n compat32-%{name} -l ja
94S-lang (`sssslang'' と発音します)は、Cとよく似た文法のスタックベース
95・インタプリタです。開発初期から、プログラムに容易に組み込めるように
96デザインされてきました。また、S-lang を用いると、アプリケーションを安
97全にかつ効率良くデバッグ・開発できます。S-lang は C と似ていますから、
98必要になれば、S-lang の手続きをCに簡単に変換することもできます。
99
100%package -n compat32-%{name}-devel
101Summary: Development package for %{name}
102Summary(ja): %{name} の開発パッケージ
103Group: Development/Libraries
104Requires: compat32-%{name} = %{version}-%{release}
105Requires: %{name}-devel = %{version}-%{release}
106
107%description -n compat32-%{name}-devel
108This package contains files which you'll need if you want to
109develop S-Lang based applications.  Documentation which may help
110you write S-Lang based applications is also included.
111
112Install the slang-devel package if you want to develop applications
113based on the S-Lang extension language.
114#'
115
116%prep
117%setup -q
118%patch1 -p1 -b .makefile
119%patch2 -p1 -b .nointerlibc2
120
121%build
122%configure --includedir=%{_includedir}/slang
123make %{?_smp_mflags} install_doc_dir=%{_docdir}/%{name}-%{version}
124
125%install
126rm -rf ${RPM_BUILD_ROOT}
127
128make install-all INSTALL="install -p" DESTDIR=$RPM_BUILD_ROOT
129rm -rf $RPM_BUILD_ROOT%{_docdir}/{slang,slsh}
130
131%clean
132rm -rf ${RPM_BUILD_ROOT}
133
134%post -p /sbin/ldconfig
135
136%postun -p /sbin/ldconfig
137
138%post -n compat32-%{name} -p /sbin/ldconfig
139
140%postun -n compat32-%{name} -p /sbin/ldconfig
141
142
143%files
144%defattr(-,root,root)
145%doc COPYING doc/README changes.txt doc/*/slang*.txt doc/*.txt
146%{_libdir}/libslang*.so.*
147
148%files slsh
149%defattr(-,root,root)
150%doc slsh/doc/html/slsh*.html
151%config(noreplace) %{_sysconfdir}/slsh.rc
152%{_bindir}/slsh
153%{_libdir}/slang
154%{_mandir}/man1/slsh.1*
155%{_datadir}/slsh
156
157%files devel
158%defattr(-,root,root)
159%doc doc/*/cslang*.txt doc/*/cref.txt
160%{_libdir}/libslang*.so
161%{_libdir}/libslang*.a
162%{_includedir}/slang
163
164%if %{build_compat32}
165%files -n compat32-%{name}
166%defattr(- , root, root)
167%{_libdir}/libslang.so.*
168
169%files -n compat32-%{name}-devel
170%defattr(- , root, root)
171%{_libdir}/libslang.a
172%{_libdir}/libslang.so
173%endif
174
175
176%changelog
177* Sun Dec 29 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.1.4-5
178- rebuild with VineSeed environment
179
180* Tue Mar 22 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.1.4-4
181- rebuilt with new toolchains
182
183* Sun Jul 05 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.1.4-3
184- removed unneccesary %if !%{build_compat32} case condition
185
186* Thu Mar 19 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.1.4-2
187- rebuilt with oniguruma-5.9.1
188
189* Wed Mar 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.4-1
190- new upstream release
191
192* Sat May 10 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.3-1
193- new upstream release
194- drop slang_jp patch
195
196* Sun Aug 06 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.9-0vl1
197- update to slang-1.4.9
198- rediffed slang_jp patch
199
200* Thu Feb 16 2006 Shu KONNO <owa@bg.wakwak.com> 1.4.4-0vl5
201- change ./configure to %%configure
202- uncommented a script to make symbolic link of %%{_libdir}/libslang.so.1
203- added compat32-* packages for x86_64 architecture support
204
205* Fri Jul 18 2003 Ryoiochi INAGAKI <ryo1@bc.wakwak.com> 1.4.4-0vl4
206- rebuild with new toolchains
207- s/Copyright/License/
208
209* Sat Feb  9 2002 MATUBARA Kazuyuki <matubara@mb.asmnet.ne.jp> 1.4.4-0vl3
210- bug fixed canna input for jed
211- change patch: bug fixed slsng-console.patch
212
213* Mon Jan 21 2002 MATUBARA Kazuyuki <matubara@mb.asmnet.ne.jp> 1.4.4-0vl2
214- rebuild with glibc-2.2.4
215
216* Wed Jun 27 2001 MATUBARA Kazuyuki <matubara@mb.asmnet.ne.jp> 1.4.4-0vl1
217- update to 1.4.4
218- use jp0 patch
219- use better macros
220- use Release No for Vine Linux
221
222* Fri Jan  7 2000 Jun Nishii <jun@vinelinux.org>
223[1.2.2_jp-7]
224- Japanese summary and description
225- change group
226
227* Sun Sep 12 1999 Norihito Ohmori <ohmori@flatout.org>
228- rebuild for new environment.
229
230* Fri Jul 16 1999 Daisuke SUZUKI <daisuke@linux.or.jp>
231[1.2.2_jp-5]
232- Updated to 1.2.2j056
233
234* Sun Feb 21 1999 MATSUMOTO Shoji <vine@flatout.org>
235[1.2.2_jp-4]
236- fix box bug with KANJI
237
238* Tue Feb 16 1999 Daisuke SUZUKI <daisuke@linux.or.jp>
239[1.2.2_jp-2]
240- Updated to 1.2.2j054
241
242* Mon Dec 21 1998 MATSUMOTO Shoji <shom@flatout.org>
243[1.2.2j052-2]
244- patch for linux console and kon
245- bug fix for no-kanji version
246- separate devel
247
248* Sat Jul  4 1998 Daisuke SUZUKI <daisuke@linux.or.jp>
249[1.2.1j-1]
250- Updated to 1.2.2 (j052)
251
252* Fri Jun  5 1998 Daisuke SUZUKI <daisuke@linux.or.jp>
253[1.2.1j-1]
254- japanize patch added
255
256* Mon Apr 13 1998 Manoj Kasichainula <manojk@io.com>
257[1.2.1-1]
258- Updated to 1.2.1
259
260* Sun Apr 12 1998 Manoj Kasichainula <manojk@io.com>
261[1.2.0-1]
262- Updated to 1.2.0, the first 1.x non-beta version
263
264* Wed Feb 11 1998 Manoj Kasichainula <manojk@io.com>
265[1.0.3-1]
266- Updated to 1.0.3
267- Minor fixes
268
269* Tue Feb 3 1998 Manoj Kasichainula <manojk@io.com>
270
271- Earlier changes were lost, because of misplacement of RPM:
272 - BuildRoot
273 - RPM_OPT_FLAGS
274 - %clean section
275 - other minor spec file changes
276- Should be buildable by non-root now
277- Included untic, a very cool terminfo interpreter (this probably out to be
278  split out eventually)
279- Added bug fix from JED
280
281* Thu Jan 29 1998 Bill Nottingham <wen1@cec.wustl.edu>
282
283- upgraded to 1.0.2
284
285* Wed Jan 28 1998 Bill Nottingham <wen1@cec.wustl.edu>
286
287- Apparently so, Donnie. :)
288- upgraded to 1.0.0beta
289
290* Tue Oct 14 1997 Donnie Barnes <djb@redhat.com>
291
292- spec file cleanups
293
294* Mon Sep 1 1997 Donnie Barnes <djb@redhat.com>
295
296- upgraded to 0.99.38 (will it EVER go 1.0???)
297- all patches removed (all appear to be in this version)
298
299* Thu Jun 19 1997 Erik Troan <ewt@redhat.com>
300
301- built against glibc
Note: See TracBrowser for help on using the repository browser.