source: projects/specs/trunk/s/slang/slang-vl.spec @ 12215

Revision 12215, 9.8 KB checked in by tomop, 5 years ago (diff)

updated 4 packages

NetworkManager-1.20.2-1

newt-0.52.21-1

popt-1.16-3

slang-2.3.2-1

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3Summary: The shared library for the S-Lang extension language
4Summary(ja): S-Lang 拡張言語ライブラリ
5Name: slang
6Version: 2.3.2
7Release: 1%{?_dist_release}
8
9License: GPLv2+
10Group: System Environment/Libraries
11URL: https://www.jedsoft.org/slang/
12
13Source: ftp://space.mit.edu/pub/davis/slang/v2.1/%{name}-%{version}.tar.bz2
14
15# don't use memcpy() on overlapping buffers
16Patch1:         slang-getkey-memmove.patch
17# disable test that fails with SIGHUP ignored (e.g. in koji)
18Patch2:         slang-sighuptest.patch
19
20BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
21BuildRequires: libpng-devel
22BuildRequires: oniguruma-devel
23BuildRequires: pcre-devel
24BuildRequires: zlib-devel
25
26Vendor: Project Vine
27Distribution: Vine Linux
28Packager: Daisuke SUZUKI <daisuke@linux.or.jp>
29
30%description
31S-lang (pronounced `sssslang'') is a powerful stack based interpreter
32that supports a C-like syntax.  It has been designed from the beginning
33to be easily embedded into a program to make it extensible. Slang also
34provides a way to quickly develop and debug the application embedding it
35in a safe and efficient manner.  Since slang resembles C, it is easy to
36recode slang procedures in C if the need arises.
37
38%description -l ja
39S-lang (`sssslang'' と発音します)は、Cとよく似た文法のスタックベース
40・インタプリタです。開発初期から、プログラムに容易に組み込めるように
41デザインされてきました。また、S-lang を用いると、アプリケーションを安
42全にかつ効率良くデバッグ・開発できます。S-lang は C と似ていますから、
43必要になれば、S-lang の手続きをCに簡単に変換することもできます。
44
45%package slsh
46Summary: Interpreter for S-Lang scripts
47Summary(ja): S-Lang スクリプトインタプリタ
48Group: Development/Languages
49Requires: %{name} = %{version}-%{release}
50
51%description slsh
52slsh (slang-shell) is a program for interpreting S-Lang scripts.
53It supports dynamic loading of S-Lang modules and includes a readline
54interface for interactive use.
55
56This package also includes S-Lang modules that are distributed with
57the S-Lang distribution.
58
59%package devel
60Summary: Development package for %{name}
61Summary(ja): %{name} の開発パッケージ
62Group: Development/Libraries
63Requires: %{name} = %{version}-%{release}
64
65%description devel
66This package contains files which you'll need if you want to
67develop S-Lang based applications.  Documentation which may help
68you write S-Lang based applications is also included.
69
70Install the slang-devel package if you want to develop applications
71based on the S-Lang extension language.
72#'
73
74%description devel -l ja
75このパッケージには S-lang を用いたアプリケーションの開発に必要な静的
76ライブラリとヘッダファイルが含まれています。S-lang を記述する助けに
77なるようなドキュメントも含まれています。
78
79もし S-lang を使ったアプリケーションを開発するなら、このパッケージを
80インストールしてください。
81
82## to build compat32 for x86_64 architecture support
83%package -n compat32-%{name}
84Summary: The shared library for the S-Lang extension language
85Summary(ja): S-Lang 拡張言語ライブラリ
86Group: System Environment/Libraries
87Requires: %{name} = %{version}-%{release}
88
89%description -n compat32-%{name}
90S-lang (pronounced `sssslang'') is a powerful stack based interpreter
91that supports a C-like syntax.  It has been designed from the beginning
92to be easily embedded into a program to make it extensible. Slang also
93provides a way to quickly develop and debug the application embedding it
94in a safe and efficient manner.  Since slang resembles C, it is easy to
95recode slang procedures in C if the need arises.
96
97%description -n compat32-%{name} -l ja
98S-lang (`sssslang'' と発音します)は、Cとよく似た文法のスタックベース
99・インタプリタです。開発初期から、プログラムに容易に組み込めるように
100デザインされてきました。また、S-lang を用いると、アプリケーションを安
101全にかつ効率良くデバッグ・開発できます。S-lang は C と似ていますから、
102必要になれば、S-lang の手続きをCに簡単に変換することもできます。
103
104%package -n compat32-%{name}-devel
105Summary: Development package for %{name}
106Summary(ja): %{name} の開発パッケージ
107Group: Development/Libraries
108Requires: compat32-%{name} = %{version}-%{release}
109Requires: %{name}-devel = %{version}-%{release}
110
111%description -n compat32-%{name}-devel
112This package contains files which you'll need if you want to
113develop S-Lang based applications.  Documentation which may help
114you write S-Lang based applications is also included.
115
116Install the slang-devel package if you want to develop applications
117based on the S-Lang extension language.
118#'
119
120%prep
121%setup -q
122%patch1 -p1 -b .getkey-memmove
123%patch2 -p1 -b .sighuptest
124
125# fix permissions of installed modules
126sed -i '/^INSTALL_MODULE=/s/_DATA//' configure
127
128# disable test failing on 32-bit archs
129sed -i '/TEST_SCRIPTS_SLC = /s/array //' src/test/Makefile
130
131%build
132%configure \
133        --includedir=%{_includedir}/slang \
134        --with-{pcre,png,z,onig}lib=%{_libdir} \
135        --with-{pcre,png,z,onig}inc=%{_includedir} \
136;
137
138make RPATH="" install_doc_dir=%{_docdir}/%{name}-%{version} all
139
140%install
141rm -rf ${RPM_BUILD_ROOT}
142
143make install-all INSTALL="install -p" RPATH="" DESTDIR=$RPM_BUILD_ROOT
144rm -rf $RPM_BUILD_ROOT%{_docdir}/{slang,slsh}
145
146%clean
147rm -rf ${RPM_BUILD_ROOT}
148
149%post -p /sbin/ldconfig
150
151%postun -p /sbin/ldconfig
152
153%post -n compat32-%{name} -p /sbin/ldconfig
154
155%postun -n compat32-%{name} -p /sbin/ldconfig
156
157
158%files
159%defattr(-,root,root)
160%doc COPYING doc/README changes.txt doc/*/slang*.txt doc/*.txt
161%{_libdir}/libslang*.so.*
162
163%files slsh
164%defattr(-,root,root)
165%doc slsh/doc/html/slsh*.html
166%config(noreplace) %{_sysconfdir}/slsh.rc
167%{_bindir}/slsh
168%{_libdir}/slang
169%{_mandir}/man1/slsh.1*
170%{_datadir}/slsh
171
172%files devel
173%defattr(-,root,root)
174%doc doc/*/cslang*.txt doc/*/cref.txt
175%{_libdir}/libslang*.so
176%{_libdir}/pkgconfig/slang.pc
177%{_libdir}/libslang*.a
178%{_includedir}/slang
179
180%if %{build_compat32}
181%files -n compat32-%{name}
182%defattr(- , root, root)
183%{_libdir}/libslang.so.*
184
185%files -n compat32-%{name}-devel
186%defattr(- , root, root)
187%{_libdir}/libslang.a
188%{_libdir}/libslang.so
189%endif
190
191
192%changelog
193* Sun Sep 15 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.3.2-1
194- new upstream release.
195- dropped Patch1 and 2.
196- imported Patch1 and 2 from rawhide.
197
198* Sun Dec 29 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.1.4-5
199- rebuild with VineSeed environment
200
201* Tue Mar 22 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.1.4-4
202- rebuilt with new toolchains
203
204* Sun Jul 05 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.1.4-3
205- removed unneccesary %if !%{build_compat32} case condition
206
207* Thu Mar 19 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.1.4-2
208- rebuilt with oniguruma-5.9.1
209
210* Wed Mar 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.4-1
211- new upstream release
212
213* Sat May 10 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.3-1
214- new upstream release
215- drop slang_jp patch
216
217* Sun Aug 06 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.9-0vl1
218- update to slang-1.4.9
219- rediffed slang_jp patch
220
221* Thu Feb 16 2006 Shu KONNO <owa@bg.wakwak.com> 1.4.4-0vl5
222- change ./configure to %%configure
223- uncommented a script to make symbolic link of %%{_libdir}/libslang.so.1
224- added compat32-* packages for x86_64 architecture support
225
226* Fri Jul 18 2003 Ryoiochi INAGAKI <ryo1@bc.wakwak.com> 1.4.4-0vl4
227- rebuild with new toolchains
228- s/Copyright/License/
229
230* Sat Feb  9 2002 MATUBARA Kazuyuki <matubara@mb.asmnet.ne.jp> 1.4.4-0vl3
231- bug fixed canna input for jed
232- change patch: bug fixed slsng-console.patch
233
234* Mon Jan 21 2002 MATUBARA Kazuyuki <matubara@mb.asmnet.ne.jp> 1.4.4-0vl2
235- rebuild with glibc-2.2.4
236
237* Wed Jun 27 2001 MATUBARA Kazuyuki <matubara@mb.asmnet.ne.jp> 1.4.4-0vl1
238- update to 1.4.4
239- use jp0 patch
240- use better macros
241- use Release No for Vine Linux
242
243* Fri Jan  7 2000 Jun Nishii <jun@vinelinux.org>
244[1.2.2_jp-7]
245- Japanese summary and description
246- change group
247
248* Sun Sep 12 1999 Norihito Ohmori <ohmori@flatout.org>
249- rebuild for new environment.
250
251* Fri Jul 16 1999 Daisuke SUZUKI <daisuke@linux.or.jp>
252[1.2.2_jp-5]
253- Updated to 1.2.2j056
254
255* Sun Feb 21 1999 MATSUMOTO Shoji <vine@flatout.org>
256[1.2.2_jp-4]
257- fix box bug with KANJI
258
259* Tue Feb 16 1999 Daisuke SUZUKI <daisuke@linux.or.jp>
260[1.2.2_jp-2]
261- Updated to 1.2.2j054
262
263* Mon Dec 21 1998 MATSUMOTO Shoji <shom@flatout.org>
264[1.2.2j052-2]
265- patch for linux console and kon
266- bug fix for no-kanji version
267- separate devel
268
269* Sat Jul  4 1998 Daisuke SUZUKI <daisuke@linux.or.jp>
270[1.2.1j-1]
271- Updated to 1.2.2 (j052)
272
273* Fri Jun  5 1998 Daisuke SUZUKI <daisuke@linux.or.jp>
274[1.2.1j-1]
275- japanize patch added
276
277* Mon Apr 13 1998 Manoj Kasichainula <manojk@io.com>
278[1.2.1-1]
279- Updated to 1.2.1
280
281* Sun Apr 12 1998 Manoj Kasichainula <manojk@io.com>
282[1.2.0-1]
283- Updated to 1.2.0, the first 1.x non-beta version
284
285* Wed Feb 11 1998 Manoj Kasichainula <manojk@io.com>
286[1.0.3-1]
287- Updated to 1.0.3
288- Minor fixes
289
290* Tue Feb 3 1998 Manoj Kasichainula <manojk@io.com>
291
292- Earlier changes were lost, because of misplacement of RPM:
293 - BuildRoot
294 - RPM_OPT_FLAGS
295 - %clean section
296 - other minor spec file changes
297- Should be buildable by non-root now
298- Included untic, a very cool terminfo interpreter (this probably out to be
299  split out eventually)
300- Added bug fix from JED
301
302* Thu Jan 29 1998 Bill Nottingham <wen1@cec.wustl.edu>
303
304- upgraded to 1.0.2
305
306* Wed Jan 28 1998 Bill Nottingham <wen1@cec.wustl.edu>
307
308- Apparently so, Donnie. :)
309- upgraded to 1.0.0beta
310
311* Tue Oct 14 1997 Donnie Barnes <djb@redhat.com>
312
313- spec file cleanups
314
315* Mon Sep 1 1997 Donnie Barnes <djb@redhat.com>
316
317- upgraded to 0.99.38 (will it EVER go 1.0???)
318- all patches removed (all appear to be in this version)
319
320* Thu Jun 19 1997 Erik Troan <ewt@redhat.com>
321
322- built against glibc
Note: See TracBrowser for help on using the repository browser.