source: projects/specs/trunk/s/slang/slang-vl.spec @ 521

Revision 521, 9.0 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3Summary: The shared library for the S-Lang extension language
4Summary(ja): S-Lang 拡張言語ライブラリ
5Name: slang
6Version: 2.1.4
7Release: 3%{?_dist_release}
8License: GPLv2+
9Group: System Environment/Libraries
10Source: ftp://space.mit.edu/pub/davis/slang/v2.1/%{name}-%{version}.tar.bz2
11Patch1: slang-2.1.4-makefile.patch
12Patch2: slang-nointerlibc2.patch
13URL: http://www.jedsoft.org/slang/
14
15BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
16BuildRequires: libpng-devel, oniguruma-devel, pcre-devel
17
18Vendor: Project Vine
19Distribution: Vine Linux
20Packager: Daisuke SUZUKI <daisuke@linux.or.jp>
21
22
23
24%description
25S-lang (pronounced `sssslang'') is a powerful stack based interpreter
26that supports a C-like syntax.  It has been designed from the beginning
27to be easily embedded into a program to make it extensible. Slang also
28provides a way to quickly develop and debug the application embedding it
29in a safe and efficient manner.  Since slang resembles C, it is easy to
30recode slang procedures in C if the need arises.
31
32%description -l ja
33S-lang (`sssslang'' と発音します)は、Cとよく似た文法のスタックベース
34・インタプリタです。開発初期から、プログラムに容易に組み込めるように
35デザインされてきました。また、S-lang を用いると、アプリケーションを安
36全にかつ効率良くデバッグ・開発できます。S-lang は C と似ていますから、
37必要になれば、S-lang の手続きをCに簡単に変換することもできます。
38
39
40%package slsh
41Summary: Interpreter for S-Lang scripts
42Summary(ja): S-Lang スクリプトインタプリタ
43Group: Development/Languages
44Requires: %{name} = %{version}-%{release}
45
46%description slsh
47slsh (slang-shell) is a program for interpreting S-Lang scripts.
48It supports dynamic loading of S-Lang modules and includes a readline
49interface for interactive use.
50
51This package also includes S-Lang modules that are distributed with
52the S-Lang distribution.
53
54%package devel
55Summary: Development package for %{name}
56Summary(ja): %{name} の開発パッケージ
57Group: Development/Libraries
58Requires: %{name} = %{version}-%{release}
59
60%description devel
61This package contains files which you'll need if you want to
62develop S-Lang based applications.  Documentation which may help
63you write S-Lang based applications is also included.
64
65Install the slang-devel package if you want to develop applications
66based on the S-Lang extension language.
67#'
68
69%description devel -l ja
70このパッケージには S-lang を用いたアプリケーションの開発に必要な静的
71ライブラリとヘッダファイルが含まれています。S-lang を記述する助けに
72なるようなドキュメントも含まれています。
73
74もし S-lang を使ったアプリケーションを開発するなら、このパッケージを
75インストールしてください。
76
77## to build compat32 for x86_64 architecture support
78%package -n compat32-%{name}
79Summary: The shared library for the S-Lang extension language
80Summary(ja): S-Lang 拡張言語ライブラリ
81Group: System Environment/Libraries
82Requires: %{name} = %{version}-%{release}
83
84%description -n compat32-%{name}
85S-lang (pronounced `sssslang'') is a powerful stack based interpreter
86that supports a C-like syntax.  It has been designed from the beginning
87to be easily embedded into a program to make it extensible. Slang also
88provides a way to quickly develop and debug the application embedding it
89in a safe and efficient manner.  Since slang resembles C, it is easy to
90recode slang procedures in C if the need arises.
91
92%description -n compat32-%{name} -l ja
93S-lang (`sssslang'' と発音します)は、Cとよく似た文法のスタックベース
94・インタプリタです。開発初期から、プログラムに容易に組み込めるように
95デザインされてきました。また、S-lang を用いると、アプリケーションを安
96全にかつ効率良くデバッグ・開発できます。S-lang は C と似ていますから、
97必要になれば、S-lang の手続きをCに簡単に変換することもできます。
98
99%package -n compat32-%{name}-devel
100Summary: Development package for %{name}
101Summary(ja): %{name} の開発パッケージ
102Group: Development/Libraries
103Requires: compat32-%{name} = %{version}-%{release}
104Requires: %{name}-devel = %{version}-%{release}
105
106%description -n compat32-%{name}-devel
107This package contains files which you'll need if you want to
108develop S-Lang based applications.  Documentation which may help
109you write S-Lang based applications is also included.
110
111Install the slang-devel package if you want to develop applications
112based on the S-Lang extension language.
113#'
114
115%prep
116%setup -q
117%patch1 -p1 -b .makefile
118%patch2 -p1 -b .nointerlibc2
119
120%build
121%configure --includedir=%{_includedir}/slang
122make %{?_smp_mflags} install_doc_dir=%{_docdir}/%{name}-%{version}
123
124%install
125rm -rf ${RPM_BUILD_ROOT}
126
127make install-all INSTALL="install -p" DESTDIR=$RPM_BUILD_ROOT
128rm -rf $RPM_BUILD_ROOT%{_docdir}/{slang,slsh}
129
130%clean
131rm -rf ${RPM_BUILD_ROOT}
132
133%post -p /sbin/ldconfig
134
135%postun -p /sbin/ldconfig
136
137%post -n compat32-%{name} -p /sbin/ldconfig
138
139%postun -n compat32-%{name} -p /sbin/ldconfig
140
141
142%files
143%defattr(-,root,root)
144%doc COPYING doc/README changes.txt doc/*/slang*.txt doc/*.txt
145%{_libdir}/libslang*.so.*
146
147%files slsh
148%defattr(-,root,root)
149%doc slsh/doc/html/slsh*.html
150%config(noreplace) %{_sysconfdir}/slsh.rc
151%{_bindir}/slsh
152%{_libdir}/slang
153%{_mandir}/man1/slsh.1*
154%{_datadir}/slsh
155
156%files devel
157%defattr(-,root,root)
158%doc doc/*/cslang*.txt doc/*/cref.txt
159%{_libdir}/libslang*.so
160%{_libdir}/libslang*.a
161%{_includedir}/slang
162
163%if %{build_compat32}
164%files -n compat32-%{name}
165%defattr(- , root, root)
166%{_libdir}/libslang.so.*
167
168%files -n compat32-%{name}-devel
169%defattr(- , root, root)
170%{_libdir}/libslang.a
171%{_libdir}/libslang.so
172%endif
173
174
175%changelog
176* Sun Jul 05 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.1.4-3
177- removed unneccesary %if !%{build_compat32} case condition
178
179* Thu Mar 19 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.1.4-2
180- rebuilt with oniguruma-5.9.1
181
182* Wed Mar 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.4-1
183- new upstream release
184
185* Sat May 10 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.3-1
186- new upstream release
187- drop slang_jp patch
188
189* Sun Aug 06 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.9-0vl1
190- update to slang-1.4.9
191- rediffed slang_jp patch
192
193* Thu Feb 16 2006 Shu KONNO <owa@bg.wakwak.com> 1.4.4-0vl5
194- change ./configure to %%configure
195- uncommented a script to make symbolic link of %%{_libdir}/libslang.so.1
196- added compat32-* packages for x86_64 architecture support
197
198* Fri Jul 18 2003 Ryoiochi INAGAKI <ryo1@bc.wakwak.com> 1.4.4-0vl4
199- rebuild with new toolchains
200- s/Copyright/License/
201
202* Sat Feb  9 2002 MATUBARA Kazuyuki <matubara@mb.asmnet.ne.jp> 1.4.4-0vl3
203- bug fixed canna input for jed
204- change patch: bug fixed slsng-console.patch
205
206* Mon Jan 21 2002 MATUBARA Kazuyuki <matubara@mb.asmnet.ne.jp> 1.4.4-0vl2
207- rebuild with glibc-2.2.4
208
209* Wed Jun 27 2001 MATUBARA Kazuyuki <matubara@mb.asmnet.ne.jp> 1.4.4-0vl1
210- update to 1.4.4
211- use jp0 patch
212- use better macros
213- use Release No for Vine Linux
214
215* Fri Jan  7 2000 Jun Nishii <jun@vinelinux.org>
216[1.2.2_jp-7]
217- Japanese summary and description
218- change group
219
220* Mon Sep 12 1999 Norihito Ohmori <ohmori@flatout.org>
221- rebuild for new environment.
222
223* Fri Jul 16 1999 Daisuke SUZUKI <daisuke@linux.or.jp>
224[1.2.2_jp-5]
225- Updated to 1.2.2j056
226
227* Sun Feb 21 1999 MATSUMOTO Shoji <vine@flatout.org>
228[1.2.2_jp-4]
229- fix box bug with KANJI
230
231* Tue Feb 16 1999 Daisuke SUZUKI <daisuke@linux.or.jp>
232[1.2.2_jp-2]
233- Updated to 1.2.2j054
234
235* Mon Dec 21 1998 MATSUMOTO Shoji <shom@flatout.org>
236[1.2.2j052-2]
237- patch for linux console and kon
238- bug fix for no-kanji version
239- separate devel
240
241* Sat Jul  4 1998 Daisuke SUZUKI <daisuke@linux.or.jp>
242[1.2.1j-1]
243- Updated to 1.2.2 (j052)
244
245* Fri Jun  5 1998 Daisuke SUZUKI <daisuke@linux.or.jp>
246[1.2.1j-1]
247- japanize patch added
248
249* Mon Apr 13 1998 Manoj Kasichainula <manojk@io.com>
250[1.2.1-1]
251- Updated to 1.2.1
252
253* Sun Apr 12 1998 Manoj Kasichainula <manojk@io.com>
254[1.2.0-1]
255- Updated to 1.2.0, the first 1.x non-beta version
256
257* Wed Feb 11 1998 Manoj Kasichainula <manojk@io.com>
258[1.0.3-1]
259- Updated to 1.0.3
260- Minor fixes
261
262* Tue Feb 3 1998 Manoj Kasichainula <manojk@io.com>
263
264- Earlier changes were lost, because of misplacement of RPM:
265 - BuildRoot
266 - RPM_OPT_FLAGS
267 - %clean section
268 - other minor spec file changes
269- Should be buildable by non-root now
270- Included untic, a very cool terminfo interpreter (this probably out to be
271  split out eventually)
272- Added bug fix from JED
273
274* Thu Jan 29 1998 Bill Nottingham <wen1@cec.wustl.edu>
275
276- upgraded to 1.0.2
277
278* Wed Jan 28 1998 Bill Nottingham <wen1@cec.wustl.edu>
279
280- Apparently so, Donnie. :)
281- upgraded to 1.0.0beta
282
283* Tue Oct 14 1997 Donnie Barnes <djb@redhat.com>
284
285- spec file cleanups
286
287* Mon Sep 1 1997 Donnie Barnes <djb@redhat.com>
288
289- upgraded to 0.99.38 (will it EVER go 1.0???)
290- all patches removed (all appear to be in this version)
291
292* Thu Jun 19 1997 Erik Troan <ewt@redhat.com>
293
294- built against glibc
Note: See TracBrowser for help on using the repository browser.