source: projects/specs/trunk/s/skrooge/skrooge-vl.spec @ 9208

Revision 9208, 6.8 KB checked in by inagaki, 9 years ago (diff)

2014-12-31 Ryoichi INAGAKI <ryo1@…>

  • gitolite, openbabel, pommed: rebuilt
  • skrooge: updated


Line 
1Name:           skrooge
2Summary:        Personal finances manager
3Summary(ja):    個人向け財務管理ツール
4Version:        1.10.0
5Release:        1%{?_dist_release}
6
7Group:          Applications/Productivity
8License:        GPLv3+
9URL:            http://skrooge.org
10
11Source0:        http://download.kde.org/stable/skrooge/%{name}-%{version}.tar.bz2
12
13BuildRoot:      %{_tmppath}/%{name}-%{version}-root
14BuildRequires:  akonadi-devel
15BuildRequires:  grantlee-devel
16BuildRequires:  kdelibs4-devel
17BuildRequires:  kdepimlibs-devel
18BuildRequires:  libofx-devel
19BuildRequires:  qca2-devel
20BuildRequires:  qjson-devel
21BuildRequires:  shared-mime-info >= 0.23
22BuildRequires:  soprano-devel
23BuildRequires:  sqlite3-devel
24BuildRequires:  gettext
25BuildRequires:  desktop-file-utils
26
27Requires:       %{name}-libs = %{version}-%{release}
28Requires(post): gtk2
29Requires(post): desktop-file-utils
30Requires(post): shared-mime-info
31Requires(postun): gtk2
32Requires(postun): desktop-file-utils
33Requires(postun): shared-mime-info
34
35%description   
36%{name} is a personal finances manager,
37aiming at being simple and intuitive.
38It allows you to keep track of your expenses and incomes,
39categorize them, and build reports of them.
40
41%package libs
42Summary:        Skrooge libraries
43Summary(ja):    Skrooge ライブラリ
44Group:          System Environment/Libraries
45Requires:       kdelibs4 >= 4.4.0
46
47%description libs
48%{name} libraries.
49
50%package devel
51Summary:        Development files for %{name}
52Summary(ja):    %{name} の開発用ファイル
53Group:          Development/Libraries
54Requires:       %{name}-libs = %{version}-%{release}
55
56%description devel
57The %{name}-devel package contains libraries for
58developing applications that use %{name}.
59
60%prep
61%setup -q
62
63## to prevent spurious-executable-perm in -debuginfo
64chmod -x skgbasegui/skglineedit.h
65chmod -x skgbasegui/skglineedit.cpp
66chmod -x skgbasegui/skglineeditdesignerplugin.h
67chmod -x skgbasegui/skgtablewidgetdesignerplugin.h
68chmod -x skgbasegui/skglineeditdesignerplugin.cpp
69chmod -x skgbasegui/skgtablewidgetdesignerplugin.cpp
70
71%build
72mkdir -p %{_target_platform}
73pushd %{_target_platform}
74#unset QTDIR || : ; . /etc/profile.d/qt4.sh
75## the -DCMAKE is needed to prevent unused-direct-shlib-dependency in -libs
76## cant be fixed upstream, see: https://bugs.kde.org/show_bug.cgi?id=209912
77%{cmake} \
78    -Wno-dev \
79    -DCMAKE_BUILD_TYPE=release \
80    -DDATA_INSTALL_DIR:PATH=%{_datadir}/kde4/apps \
81    -DINCLUDE_INSTALL_DIR:PATH=%{_includedir}/kde4 \
82    -DLIBEXEC_INSTALL_DIR:PATH=%{_libexecdir}/kde4 \
83    -DCMAKE_SHARED_LINKER_FLAGS="-Wl,--as-needed" \
84    ..
85popd
86
87make %{?_smp_mflags} -C %{_target_platform}
88
89
90%install
91rm -rf %{buildroot}
92make install/fast -C %{_target_platform} DESTDIR=%{buildroot}
93
94%find_lang %{name}
95
96
97%clean
98rm -rf %{buildroot}
99
100%check
101desktop-file-validate %{buildroot}%{_datadir}/applications/kde4/skrooge.desktop
102
103%post
104touch --no-create %{_datadir}/icons/hicolor &>/dev/null || :
105
106%postun
107if [ $1 -eq 0 ] ; then
108   touch --no-create %{_datadir}/icons/hicolor &>/dev/null
109   gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
110   update-desktop-database -q &> /dev/null
111   update-mime-database %{_datadir}/mime &> /dev/null
112fi
113
114%posttrans
115gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null || :
116update-desktop-database -q &> /dev/null
117update-mime-database %{_datadir}/mime &> /dev/null
118
119%post libs -p /sbin/ldconfig
120
121%postun libs -p /sbin/ldconfig
122
123
124%files -f %{name}.lang
125%defattr(-,root,root,-)
126%doc AUTHORS CHANGELOG COPYING README TODO
127%{_bindir}/*
128%{_datadir}/akonadi/agents/*.desktop
129%{_datadir}/applications/kde4/skrooge.desktop
130%{_datadir}/config/skrooge_*.knsrc
131%{_datadir}/config.kcfg/*.kcfg
132%{_datadir}/icons/hicolor/*/*/*
133%{_datadir}/kde4/apps/skrooge*/
134%{_datadir}/kde4/apps/skg*
135%{_datadir}/kde4/services/*.desktop
136%{_datadir}/kde4/servicetypes/*.desktop
137%{_datadir}/mime/packages/x-skg.xml
138%{_datadir}/doc/HTML/*/skrooge/
139
140%files libs
141%defattr(-,root,root,-)
142%{_libdir}/kde4/plugins/grantlee/*/*.so
143%{_libdir}/kde4/*.so
144%{_libdir}/lib*.so.*
145
146%files devel
147%defattr(-,root,root,-)
148%{_libdir}/lib*.so
149#{_libdir}/kde4/plugins/designer/libskg*.so
150
151%changelog
152* Wed Dec 31 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 1.10.0-1
153- updated to 1.10.0
154- updated BuildRequires
155- built on current VineSeed
156
157* Sun May 15 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.0-2
158- add BuildRequires:  soprano-devel
159
160* Sun Jan 16 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.8.0-1
161- Initial build for Vine Linux
162
163* Mon May 17 2010 Thomas Janssen <thomasj@fedoraproject.org> 0.7.1-1
164- skrooge 0.7.1 bugfix release
165
166* Mon Apr 26 2010 Thomas Janssen <thomasj@fedoraproject.org> 0.7.0-1
167- Skrooge 0.7.0
168
169* Wed Feb 10 2010 Thomas Janssen <thomasj@fedoraproject.org> 0.6.0-1
170- New upstream source 0.6.0
171
172* Thu Jan 28 2010 Rex Dieter <rdieter@fedoraproject.org> 0.5.5-2
173- use %%{_kde4_version}, don't rely on kde4-config --version parsing
174
175* Sun Dec 27 2009 Thomas Janssen <thomasj@fedoraproject.org> 0.5.5-1
176- Update to new upstream release
177- Corrects a lot of bugs and problems. See the CHANGELOG for details.
178
179* Sun Nov 30 2009 Thomas Janssen <thomasj@fedoraproject.org> 0.5.4-1
180- Update to new upstream version
181- Corrects a lot of bugs and problems. See the changelog for details.
182
183* Sun Nov 01 2009 Thomas Janssen <thomasj@fedoraproject.org> 0.5.3-1
184- Updated to new upstream version
185- Readded a -DCMAKE workaround (please keep it for now)
186- Useing chmod -x to prevent spurious-executable-perm. Bug filed.
187
188* Wed Oct 14 2009 Rex Dieter <rdieter@fedoraproject.org> 0.5.2-2
189- (HTML) docs patch, use %%find_lang --with-kde
190- own %%{_kde4_appsdir}/skrooge*/ dirs
191- %%check: omit extraneous desktop-file-validate's
192
193* Thu Oct 08 2009 Thomas Janssen <thomasj@fedoraproject.org> 0.5.2-1
194- Changed to final 0.5.2 version
195- Bugfixes, including a nasty bug where one thinks the data is gone
196- added HTML documentation
197- added localizations
198
199* Tue Sep 22 2009 Thomas Janssen <thomasj@fedoraproject.org> 0.5.2-0.1.beta
200- Changed to new upstream Version 0.5.2_beta (lots of bugfixes)
201
202* Mon Sep 21 2009 Thomas Janssen <thomasj@fedoraproject.org> 0.5.1-0.5.beta
203- Added -libs Requires libofx
204
205* Mon Sep 21 2009 Rex Dieter <rdieter@fedoraproject.org> 0.5.1-0.4.beta
206- misc cosmetics
207- mime scriptlets
208- move icons to hicolor
209- -libs: drop dup'd docs, add min kdelibs4 dep
210
211* Thu Sep 17 2009 Thomas Janssen <thomasj@fedoraproject.org>  0.5.1-0.3.beta
212- Spec file corrections and Version correction
213
214* Wed Sep 16 2009 Thomas Janssen <thomasj@fedoraproject.org>  0.5.1-beta2
215- cleaned up desktop files
216
217* Tue Sep 15 2009 Thomas Janssen <thomasj@fedoraproject.org>  0.5.1-beta1
218- changed version to 0.5.1 beta with fixed rpmlint output
219
220* Sun Sep 13 2009 Thomas Janssen <thomasj@fedoraproject.org>  0.5.0-2
221- Fixed the spec and rpmlintoutput debuginfo-without-source
222
223* Fri Sep 11 2009 Thomas Janssen <thomasj@fedoraproject.org>  0.5.0-1
224- Initial Release 0.5.0
Note: See TracBrowser for help on using the repository browser.