source: projects/specs/trunk/s/skrooge/skrooge-vl.spec @ 10771

Revision 10771, 6.7 KB checked in by ara_t, 8 years ago (diff)

rebuild with gcc-5.4.0

Line 
1Name:           skrooge
2Summary:        Personal finances manager
3Summary(ja):    個人向け財務管理ツール
4Version:        1.10.0
5Release:        3%{?_dist_release}
6
7Group:          Applications/Productivity
8License:        GPLv3+
9URL:            http://skrooge.org
10
11Source0:        http://download.kde.org/stable/skrooge/%{name}-%{version}.tar.bz2
12
13BuildRoot:      %{_tmppath}/%{name}-%{version}-root
14BuildRequires:  akonadi-devel
15BuildRequires:  grantlee-devel
16BuildRequires:  kdelibs4-devel
17BuildRequires:  kdepimlibs-devel
18BuildRequires:  libofx-devel
19BuildRequires:  qca2-devel
20BuildRequires:  qjson-devel
21BuildRequires:  shared-mime-info >= 0.23
22BuildRequires:  soprano-devel
23BuildRequires:  sqlite3-devel
24BuildRequires:  gettext
25BuildRequires:  desktop-file-utils
26
27Requires:       %{name}-libs = %{version}-%{release}
28Requires(post): gtk2
29Requires(post): desktop-file-utils
30Requires(post): shared-mime-info
31Requires(postun): gtk2
32Requires(postun): desktop-file-utils
33Requires(postun): shared-mime-info
34
35%description   
36%{name} is a personal finances manager,
37aiming at being simple and intuitive.
38It allows you to keep track of your expenses and incomes,
39categorize them, and build reports of them.
40
41%package libs
42Summary:        Skrooge libraries
43Summary(ja):    Skrooge ライブラリ
44Group:          System Environment/Libraries
45Requires:       kdelibs4 >= 4.4.0
46
47%description libs
48%{name} libraries.
49
50%package devel
51Summary:        Development files for %{name}
52Summary(ja):    %{name} の開発用ファイル
53Group:          Development/Libraries
54Requires:       %{name}-libs = %{version}-%{release}
55
56%description devel
57The %{name}-devel package contains libraries for
58developing applications that use %{name}.
59
60%prep
61%setup -q
62
63## to prevent spurious-executable-perm in -debuginfo
64chmod -x skgbasegui/skglineedit.h
65chmod -x skgbasegui/skglineedit.cpp
66chmod -x skgbasegui/skglineeditdesignerplugin.h
67chmod -x skgbasegui/skgtablewidgetdesignerplugin.h
68chmod -x skgbasegui/skglineeditdesignerplugin.cpp
69chmod -x skgbasegui/skgtablewidgetdesignerplugin.cpp
70
71%build
72mkdir -p %{_target_platform}
73pushd %{_target_platform}
74%{cmake} \
75    -Wno-dev \
76    -DCMAKE_BUILD_TYPE=release \
77    -DDATA_INSTALL_DIR:PATH=%{_datadir}/kde4/apps \
78    -DINCLUDE_INSTALL_DIR:PATH=%{_includedir}/kde4 \
79    -DLIBEXEC_INSTALL_DIR:PATH=%{_libexecdir}/kde4 \
80    -DCMAKE_SHARED_LINKER_FLAGS="-Wl,--as-needed" \
81    ..
82popd
83
84make %{?_smp_mflags} -C %{_target_platform}
85
86
87%install
88rm -rf %{buildroot}
89make install/fast -C %{_target_platform} DESTDIR=%{buildroot}
90
91%find_lang %{name}
92
93
94%clean
95rm -rf %{buildroot}
96
97%check
98desktop-file-validate %{buildroot}%{_datadir}/applications/kde4/skrooge.desktop
99
100%post
101touch --no-create %{_datadir}/icons/hicolor &>/dev/null || :
102
103%postun
104if [ $1 -eq 0 ] ; then
105   touch --no-create %{_datadir}/icons/hicolor &>/dev/null
106   gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
107   update-desktop-database -q &> /dev/null
108   update-mime-database %{_datadir}/mime &> /dev/null
109fi
110
111%posttrans
112gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null || :
113update-desktop-database -q &> /dev/null
114update-mime-database %{_datadir}/mime &> /dev/null
115
116%post libs -p /sbin/ldconfig
117
118%postun libs -p /sbin/ldconfig
119
120
121%files -f %{name}.lang
122%defattr(-,root,root,-)
123%doc AUTHORS CHANGELOG COPYING README TODO
124%{_bindir}/*
125%{_datadir}/akonadi/agents/*.desktop
126%{_datadir}/applications/kde4/skrooge.desktop
127%{_datadir}/config/skrooge_*.knsrc
128%{_datadir}/config.kcfg/*.kcfg
129%{_datadir}/icons/hicolor/*/*/*
130%{_datadir}/kde4/apps/skrooge*/
131%{_datadir}/kde4/apps/skg*
132%{_datadir}/kde4/services/*.desktop
133%{_datadir}/kde4/servicetypes/*.desktop
134%{_datadir}/mime/packages/x-skg.xml
135%{_datadir}/doc/HTML/*/skrooge/
136
137%files libs
138%defattr(-,root,root,-)
139%{_libdir}/kde4/plugins/grantlee/*/*.so
140%{_libdir}/kde4/*.so
141%{_libdir}/lib*.so.*
142
143%files devel
144%defattr(-,root,root,-)
145%{_libdir}/lib*.so
146#{_libdir}/kde4/plugins/designer/libskg*.so
147
148%changelog
149* Fri Sep 02 2016 Toshiaki Ara <ara_t@384.jp> 1.10.0-3
150- rebuild with gcc-5.4.0
151
152* Mon Mar  9 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 1.10.0-2
153- rebuilt with libofx 0.9.10
154
155* Wed Dec 31 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 1.10.0-1
156- updated to 1.10.0
157- updated BuildRequires
158- built on current VineSeed
159
160* Sun May 15 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.0-2
161- add BuildRequires:  soprano-devel
162
163* Sun Jan 16 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.8.0-1
164- Initial build for Vine Linux
165
166* Mon May 17 2010 Thomas Janssen <thomasj@fedoraproject.org> 0.7.1-1
167- skrooge 0.7.1 bugfix release
168
169* Mon Apr 26 2010 Thomas Janssen <thomasj@fedoraproject.org> 0.7.0-1
170- Skrooge 0.7.0
171
172* Wed Feb 10 2010 Thomas Janssen <thomasj@fedoraproject.org> 0.6.0-1
173- New upstream source 0.6.0
174
175* Thu Jan 28 2010 Rex Dieter <rdieter@fedoraproject.org> 0.5.5-2
176- use %%{_kde4_version}, don't rely on kde4-config --version parsing
177
178* Sun Dec 27 2009 Thomas Janssen <thomasj@fedoraproject.org> 0.5.5-1
179- Update to new upstream release
180- Corrects a lot of bugs and problems. See the CHANGELOG for details.
181
182* Sun Nov 30 2009 Thomas Janssen <thomasj@fedoraproject.org> 0.5.4-1
183- Update to new upstream version
184- Corrects a lot of bugs and problems. See the changelog for details.
185
186* Sun Nov 01 2009 Thomas Janssen <thomasj@fedoraproject.org> 0.5.3-1
187- Updated to new upstream version
188- Readded a -DCMAKE workaround (please keep it for now)
189- Useing chmod -x to prevent spurious-executable-perm. Bug filed.
190
191* Wed Oct 14 2009 Rex Dieter <rdieter@fedoraproject.org> 0.5.2-2
192- (HTML) docs patch, use %%find_lang --with-kde
193- own %%{_kde4_appsdir}/skrooge*/ dirs
194- %%check: omit extraneous desktop-file-validate's
195
196* Thu Oct 08 2009 Thomas Janssen <thomasj@fedoraproject.org> 0.5.2-1
197- Changed to final 0.5.2 version
198- Bugfixes, including a nasty bug where one thinks the data is gone
199- added HTML documentation
200- added localizations
201
202* Tue Sep 22 2009 Thomas Janssen <thomasj@fedoraproject.org> 0.5.2-0.1.beta
203- Changed to new upstream Version 0.5.2_beta (lots of bugfixes)
204
205* Mon Sep 21 2009 Thomas Janssen <thomasj@fedoraproject.org> 0.5.1-0.5.beta
206- Added -libs Requires libofx
207
208* Mon Sep 21 2009 Rex Dieter <rdieter@fedoraproject.org> 0.5.1-0.4.beta
209- misc cosmetics
210- mime scriptlets
211- move icons to hicolor
212- -libs: drop dup'd docs, add min kdelibs4 dep
213
214* Thu Sep 17 2009 Thomas Janssen <thomasj@fedoraproject.org>  0.5.1-0.3.beta
215- Spec file corrections and Version correction
216
217* Wed Sep 16 2009 Thomas Janssen <thomasj@fedoraproject.org>  0.5.1-beta2
218- cleaned up desktop files
219
220* Tue Sep 15 2009 Thomas Janssen <thomasj@fedoraproject.org>  0.5.1-beta1
221- changed version to 0.5.1 beta with fixed rpmlint output
222
223* Sun Sep 13 2009 Thomas Janssen <thomasj@fedoraproject.org>  0.5.0-2
224- Fixed the spec and rpmlintoutput debuginfo-without-source
225
226* Fri Sep 11 2009 Thomas Janssen <thomasj@fedoraproject.org>  0.5.0-1
227- Initial Release 0.5.0
Note: See TracBrowser for help on using the repository browser.