source: projects/specs/trunk/s/skrooge/skrooge-vl.spec @ 2775

Revision 2775, 6.3 KB checked in by inagaki, 13 years ago (diff)

updated: choqok, k3b, kaffeine, kdevelop, kdevplatform,

konversation, kde-partitionmanager, qjson, self-build-k3b-extra

NEW: skrooge

Line 
1Name:           skrooge
2Summary:        Personal finances manager
3Summary(ja):    個人向け財務管理ツール
4Version:        0.8.0
5Release:        1%{?_dist_release}
6
7Group:          Applications/Productivity
8License:        GPLv3+
9URL:            http://skrooge.org
10
11Source0:        http://skrooge.org/files/%{name}-%{version}.tar.bz2
12
13BuildRoot:      %{_tmppath}/%{name}-%{version}-root
14BuildRequires:  qca2-devel
15BuildRequires:  libofx-devel
16BuildRequires:  sqlite3-devel
17BuildRequires:  kdelibs4-devel
18BuildRequires:  gettext
19
20Requires:       %{name}-libs = %{version}-%{release}
21
22%description   
23%{name} is a personal finances manager,
24aiming at being simple and intuitive.
25It allows you to keep track of your expenses and incomes,
26categorize them, and build reports of them.
27
28%package libs
29Summary:        Skrooge libraries
30Summary(ja):    Skrooge ライブラリ
31Group:          System Environment/Libraries
32#Requires:       %{name} = %{version}-%{release}
33Requires:       kdelibs4 >= 4.4.0
34
35%description libs
36%{name} libraries.
37
38%package devel
39Summary:        Development files for %{name}
40Summary(ja):    %{name} の開発用ファイル
41Group:          Development/Libraries
42Requires:       %{name}-libs = %{version}-%{release}
43
44%description devel
45The %{name}-devel package contains libraries for
46developing applications that use %{name}.
47
48%prep
49%setup -q
50
51## to prevent spurious-executable-perm in -debuginfo
52chmod -x skgbasegui/skglineedit.h
53chmod -x skgbasegui/skglineedit.cpp
54chmod -x skgbasegui/skglineeditdesignerplugin.h
55chmod -x skgbasegui/skgtablewidgetdesignerplugin.h
56chmod -x skgbasegui/skglineeditdesignerplugin.cpp
57chmod -x skgbasegui/skgtablewidgetdesignerplugin.cpp
58
59%build
60mkdir -p %{_target_platform}
61pushd %{_target_platform}
62unset QTDIR || : ; . /etc/profile.d/qt4.sh
63## the -DCMAKE is needed to prevent unused-direct-shlib-dependency in -libs
64## cant be fixed upstream, see: https://bugs.kde.org/show_bug.cgi?id=209912
65%{cmake} \
66    -Wno-dev \
67    -DCMAKE_BUILD_TYPE=release \
68    -DDATA_INSTALL_DIR:PATH=%{_datadir}/kde4/apps \
69    -DINCLUDE_INSTALL_DIR:PATH=%{_includedir}/kde4 \
70    -DLIBEXEC_INSTALL_DIR:PATH=%{_libexecdir}/kde4 \
71    -DCMAKE_SHARED_LINKER_FLAGS="-Wl,--as-needed" \
72    ..
73popd
74
75make %{?_smp_mflags} -C %{_target_platform}
76
77
78%install
79rm -rf %{buildroot}
80make install/fast -C %{_target_platform} DESTDIR=%{buildroot}
81%find_lang %{name} --with-kde
82
83# hack to support non-oxygen icon users (gnome), drop when/if skrooge
84# ever provides hicolor icons (too).
85mv %{buildroot}%{_datadir}/icons/oxygen %{buildroot}%{_datadir}/icons/hicolor
86
87
88%clean
89rm -rf %{buildroot}
90
91%check
92desktop-file-validate %{buildroot}%{_datadir}/applications/kde4/skrooge.desktop
93
94%post
95touch --no-create %{_datadir}/icons/hicolor &>/dev/null || :
96
97%postun
98if [ $1 -eq 0 ] ; then
99   touch --no-create %{_datadir}/icons/hicolor &>/dev/null
100   gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
101   update-desktop-database -q &> /dev/null
102   update-mime-database %{_datadir}/mime &> /dev/null
103fi
104
105%posttrans
106gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null || :
107update-desktop-database -q &> /dev/null
108update-mime-database %{_datadir}/mime &> /dev/null
109
110%post libs -p /sbin/ldconfig
111
112%postun libs -p /sbin/ldconfig
113
114
115%files -f %{name}.lang
116%defattr(-,root,root,-)
117%doc AUTHORS CHANGELOG COPYING README TODO
118%{_bindir}/skrooge
119%{_datadir}/applications/kde4/skrooge.desktop
120%{_datadir}/config.kcfg/*.kcfg
121%{_datadir}/icons/hicolor/*/*/*
122%{_datadir}/kde4/apps/skrooge*/
123%{_datadir}/kde4/apps/skg*
124%{_datadir}/kde4/services/*.desktop
125%{_datadir}/kde4/servicetypes/skg-plugin.desktop
126%{_datadir}/mime/packages/x-skg.xml
127%{_datadir}/doc/HTML/*/skrooge/
128
129%files libs
130%defattr(-,root,root,-)
131%{_libdir}/kde4/plugins/designer/*.so.*
132%{_libdir}/kde4/*.so
133%{_libdir}/lib*.so.*
134
135%files devel
136%defattr(-,root,root,-)
137%{_libdir}/libskg*.so
138%{_libdir}/kde4/plugins/designer/libskg*.so
139
140%changelog
141* Sun Jan 16 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.8.0-1
142- Initial build for Vine Linux
143
144* Mon May 17 2010 Thomas Janssen <thomasj@fedoraproject.org> 0.7.1-1
145- skrooge 0.7.1 bugfix release
146
147* Mon Apr 26 2010 Thomas Janssen <thomasj@fedoraproject.org> 0.7.0-1
148- Skrooge 0.7.0
149
150* Wed Feb 10 2010 Thomas Janssen <thomasj@fedoraproject.org> 0.6.0-1
151- New upstream source 0.6.0
152
153* Thu Jan 28 2010 Rex Dieter <rdieter@fedoraproject.org> 0.5.5-2
154- use %%{_kde4_version}, don't rely on kde4-config --version parsing
155
156* Sun Dec 27 2009 Thomas Janssen <thomasj@fedoraproject.org> 0.5.5-1
157- Update to new upstream release
158- Corrects a lot of bugs and problems. See the CHANGELOG for details.
159
160* Sun Nov 30 2009 Thomas Janssen <thomasj@fedoraproject.org> 0.5.4-1
161- Update to new upstream version
162- Corrects a lot of bugs and problems. See the changelog for details.
163
164* Sun Nov 01 2009 Thomas Janssen <thomasj@fedoraproject.org> 0.5.3-1
165- Updated to new upstream version
166- Readded a -DCMAKE workaround (please keep it for now)
167- Useing chmod -x to prevent spurious-executable-perm. Bug filed.
168
169* Wed Oct 14 2009 Rex Dieter <rdieter@fedoraproject.org> 0.5.2-2
170- (HTML) docs patch, use %%find_lang --with-kde
171- own %%{_kde4_appsdir}/skrooge*/ dirs
172- %%check: omit extraneous desktop-file-validate's
173
174* Thu Oct 08 2009 Thomas Janssen <thomasj@fedoraproject.org> 0.5.2-1
175- Changed to final 0.5.2 version
176- Bugfixes, including a nasty bug where one thinks the data is gone
177- added HTML documentation
178- added localizations
179
180* Tue Sep 22 2009 Thomas Janssen <thomasj@fedoraproject.org> 0.5.2-0.1.beta
181- Changed to new upstream Version 0.5.2_beta (lots of bugfixes)
182
183* Mon Sep 21 2009 Thomas Janssen <thomasj@fedoraproject.org> 0.5.1-0.5.beta
184- Added -libs Requires libofx
185
186* Mon Sep 21 2009 Rex Dieter <rdieter@fedoraproject.org> 0.5.1-0.4.beta
187- misc cosmetics
188- mime scriptlets
189- move icons to hicolor
190- -libs: drop dup'd docs, add min kdelibs4 dep
191
192* Thu Sep 17 2009 Thomas Janssen <thomasj@fedoraproject.org>  0.5.1-0.3.beta
193- Spec file corrections and Version correction
194
195* Wed Sep 16 2009 Thomas Janssen <thomasj@fedoraproject.org>  0.5.1-beta2
196- cleaned up desktop files
197
198* Tue Sep 15 2009 Thomas Janssen <thomasj@fedoraproject.org>  0.5.1-beta1
199- changed version to 0.5.1 beta with fixed rpmlint output
200
201* Sun Sep 13 2009 Thomas Janssen <thomasj@fedoraproject.org>  0.5.0-2
202- Fixed the spec and rpmlintoutput debuginfo-without-source
203
204* Fri Sep 11 2009 Thomas Janssen <thomasj@fedoraproject.org>  0.5.0-1
205- Initial Release 0.5.0
Note: See TracBrowser for help on using the repository browser.