source: projects/specs/trunk/s/sip/sip-vl.spec @ 7712

Revision 7712, 8.6 KB checked in by Takemikaduchi, 11 years ago (diff)

new upstream release

Line 
1%{!?python_sitearch:%global python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
2%{!?python_inc:%global python_inc %(%{__python} -c "from distutils.sysconfig import get_python_inc; print get_python_inc(1)")}
3%define py_ver %(python -c 'import sys;print(sys.version[0:3])')
4
5Name:           sip
6Summary:        Python/C++ Bindings Generator
7Summary(ja):    Python/C++ インターフェイス生成ツール
8Version:        4.14.6
9Release:        1%{?_dist_release}
10
11License:        GPLv2 or GPLv3
12Group:          Development/Tools
13URL:            http://www.riverbankcomputing.co.uk/software/sip/intro
14
15Source0:        http://www.riverbankcomputing.co.uk/static/Downloads/sip4/%{name}-%{version}.tar.gz
16Patch0:         disable-rpaths.diff
17
18BuildRoot:      %{_tmppath}/%{name}-%{version}-root
19BuildRequires:  python-devel
20BuildRequires:  sed
21
22Vendor:         Project Vine
23Distribution:   Vine Linux
24
25%description
26SIP is a tool for generating bindings for C++ classes so that they can be
27accessed as normal Python classes. SIP takes many of its ideas from SWIG but,
28because it is specifically designed for C++ and Python, is able to generate
29tighter bindings. SIP is so called because it is a small SWIG.
30
31SIP was originally designed to generate Python bindings for KDE and so has
32explicit support for the signal slot mechanism used by the Qt/KDE class
33libraries. However, SIP can be used to generate Python bindings for any C++
34class library.
35
36
37%package devel
38Summary:        Files needed to generate Python bindings for any C++ class library
39Summary(ja):    Python/C++ インタフェース作成に必要なライブラリやヘッダファイル
40Group:          Development/Libraries
41Requires:       %{name} = %{version}-%{release}
42Requires:       python-devel
43Provides:       libsip-devel = %{version}-%{release}
44
45%description devel
46This package contains files needed to generate Python bindings for any C++
47classes library.
48
49
50%prep
51%setup -q
52%patch0
53
54%build
55%ifarch x86_64 ppc
56OPT_FLAGS="%{optflags} -fPIC"
57%else
58OPT_FLAGS="%{optflags}"
59%endif
60
61%{__python} configure.py -k -d %{python_sitearch} \
62        -b %{_bindir} CXXFLAGS="$OPT_FLAGS" CFLAGS="$OPT_FLAGS"
63make %{?_smp_mflags}
64
65%{__python} configure.py -d %{python_sitearch} \
66        -b %{_bindir} CXXFLAGS="$OPT_FLAGS" CFLAGS="$OPT_FLAGS"
67make %{?_smp_mflags}
68
69
70%install
71rm -rf $RPM_BUILD_ROOT
72make install DESTDIR=$RPM_BUILD_ROOT
73
74install sipconfig.pyc $RPM_BUILD_ROOT%{python_sitearch}
75install -m644 siplib/libsip.a -D $RPM_BUILD_ROOT%{_libdir}/libsip.a
76mkdir -p $RPM_BUILD_ROOT%{_datadir}/sip
77
78
79%clean
80rm -rf $RPM_BUILD_ROOT
81
82%files
83%defattr(-, root, root, 755)
84%doc LICENSE LICENSE-GPL2 LICENSE-GPL3 NEWS README
85%doc doc/html
86%{_bindir}/sip
87%{python_sitearch}/*
88
89%files devel
90%defattr(-, root, root, 755)
91%{python_inc}/*
92%{_libdir}/libsip.a
93%dir %{_datadir}/sip
94
95%changelog
96* Wed Jun 05 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.14.6-1
97- new upstream release
98
99* Sun Jul 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.13.3-1
100- new upstream release
101
102* Sat Feb 18 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.13.1-2
103- rebuild with python-2.7.2
104
105* Sat Jan  7 2012 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.13.1-1
106- new upstream release
107
108* Sun Jul 31 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.12.3-1
109- new upstream release
110
111* Sun Jan 30 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.12.1-1
112- new upstream release
113
114* Mon Oct  4 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 4.10.5-2
115- add gcc option "-fPIC" also on ppc
116
117* Sat Jul 24 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.10.5-1
118- new upstream release
119
120* Sun May 09 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.10.2-1
121- new upstream release
122
123* Wed Feb 03 2010 Shu KONNO <owa@bg.wakwak.com> 4.10-1
124- new upstream release
125
126* Wed Feb 03 2010 Shu KONNO <owa@bg.wakwak.com> 4.9.3-2
127- rebuilt with python-2.6.4
128
129* Wed Nov 25 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.9.3-1
130- new upstream release
131
132* Thu Oct 22 2009 Shu KONNO <owa@bg.wakwak.com> 4.9-1
133- new upstream release
134- added japanese summary
135- changed source url
136
137* Sat Aug 29 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.8.2-1
138- new upstream release
139- remove qt-devel dependency
140
141* Sun Jul 20 2008 Shu KONNO <owa@bg.wakwak.com> 4.7.1-1vl1
142- rebuilt with python-2.5.2
143- applied new versioning policy and spec in utf-8
144
145* Fri Nov 30 2007 Shu KONNO <owa@bg.wakwak.com> 4.7.1-0vl1
146- new upstream release
147- added gcc option "-fPIC" (if x86_64)
148
149* Wed Sep  5 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.7-0vl1
150- new upstream release
151- use qt qmake files
152
153* Sun May 27 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.5-0vl2
154- rebuilt with new toolchain
155
156* Sun Jun 11 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.5-0vl1
157- new upstream release
158- rebuilt with python 2.4.3
159- changed Group to Development/Languages
160
161* Sun Apr 03 2005 Shu KONNO <owa@bg.wakwak.com> 3.11.1-0vl2
162- Rebuild for python 2.4.1
163
164* Sat Jan 15 2005 Satoshi MACHINO <machino@vinelinux.org> 3.11.1-0vl1
165- built for VineLinux
166- new upstream version
167
168* Sat Dec 04 2004 Michael Scherer <misc@mandrake.org> 3.10.2-5mdk
169- Rebuild for new python
170
171* Wed Jun  9 2004 Götz Waschk <waschk@linux-mandrake.com> 3.10.2-4mdk
172- obsolete libsip10 too
173
174* Mon Jun  7 2004 Götz Waschk <waschk@linux-mandrake.com> 3.10.2-3mdk
175- drop library packages
176
177* Mon Jun 07 2004 Per Øyvind Karlsen <peroyvind@linux-mandrake.com> 3.10.2-2mdk
178- fix build and install problems
179- drop .so.*, they no longer exist
180- use %%{py_ver} macro
181
182* Sat Jun 05 2004 Per Øyvind Karlsen <peroyvind@linux-mandrake.com> 3.10.2-1mdk
183- 3.10.2
184
185* Fri Apr 23 2004 Götz Waschk <waschk@linux-mandrake.com> 3.10.1-1mdk
186- add sipconfig
187- major 11
188- add source URL
189- new version
190
191* Mon Sep  8 2003 Götz Waschk <waschk@linux-mandrake.com> 3.8-3mdk
192- fix buildrequires
193
194* Sun Sep  7 2003 Götz Waschk <waschk@linux-mandrake.com> 3.8-2mdk
195- fix buildrequires
196- move libsip.so to the lib package, as it's required by generated bindings
197- move sip to the devel package
198
199* Wed Aug 20 2003 Austin Acton <aacton@yorku.ca> 3.8-1mdk
200- 3.8
201
202* Sat Aug 9 2003 Austin Acton <aacton@yorku.ca> 3.6-8mdk
203- the one true fix (eat your heart out per oyvind :-) )
204
205* Fri Aug 08 2003 Per Øyvind Karlsen <peroyvind@linux-mandrake.com> 3.6-7mdk
206- really rebuild for new python (austin was the sucky one this time;)
207
208* Thu Aug 7 2003 Austin Acton <aacton@yorku.ca> 3.6-6mdk
209- python 2.3
210
211* Sat Jul 19 2003 Till Kamppeter <till@mandrakesoft.com> 3.6-5mdk
212- Rebuild
213
214* Fri Jun 20 2003 Per Øyvind Karlsen <peroyvind@sintrax.net> 3.6-4mdk
215- fix path to qt3 (lib64 issues)
216- use %%mklibname macro for -devel package
217
218* Tue May 27 2003 Austin Acton <aacton@yorku.ca> 3.6-3mdk
219- rebuild for rpm 4.2
220
221* Tue Apr 29 2003 Per Øyvind Karlsen <peroyvind@sintrax.net> 3.6-2mdk
222- added QPL to license
223
224* Tue Apr 29 2003 Per Øyvind Karlsen <peroyvind@sintrax.net> 3.6-1mdk
225- 3.6 (lib major 9)
226- cleanups
227- fix license
228- make --short-circuitable
229- use %%mklibname macro
230
231* Fri Jan 03 2003 Lenny Cartier <lenny@mandrakesoft.com> 3.5-1mdk
232- 3.5
233
234* Sat Aug 17 2002 Christian Belisle <cbelisle@mandrakesoft.com> 3.3.2-2mdk
235- fix Provides for libsip9.
236
237* Wed Jul 17 2002 Christian Belisle <cbelisle@mandrakesoft.com> 3.3.2-1mdk
238- 3.3.2
239- use the new sip's build script
240
241* Sat Jun 29 2002 Olivier Thauvin <thauvin@aerov.jussieu.fr> 3.2.4-1mdk
242- 3.2.4
243
244* Tue May 28 2002 Lenny Cartier <lenny@mandrakesoft.com> 3.2.2-2mdk
245- rebuild against new libstdc++
246
247* Mon May 13 2002 Lenny Cartier <lenny@mandrakesoft.com> 3.2.2-1mdk
248- 3.2.2
249
250* Tue May 07 2002 Lenny Cartier <lenny@mandrakesoft.com> 3.2.1-1mdk
251- 3.2.1
252
253* Mon Apr 08 2002 Christian Belisle <cbelisle@mandrakesoft.com> 3.1-1mdk
254- version 3.1 (lib major 8).
255- update URL.
256
257* Fri Jan 11 2002 Lenny Cartier <lenny@mandrakesoft.com> 3.0-3mdk
258- merge with  RA <ralf_ahlbrink@web.de> mods :
259        - added BuildRequires: libpython2.2-devel
260
261* Fri Nov 30 2001 Yves Duret <yduret@mandrakesoft.com> 3.0-1mdk
262- version 3.0 (lib major 7)
263
264* Fri Nov 30 2001 Yves Duret <yduret@mandrakesoft.com> 2.5-2mdk
265- rebuild against libpng3
266- %%makeinstall_std
267- std %%build step (macros..)
268- added %%dir %%{_includedir}/sip in -devel package
269
270* Mon Sep 03 2001 Lenny Cartier <lenny@mandrakesoft.com> 2.5-1mdk
271- 2.5
272
273* Mon May 14 2001 Yves BAILLY <ybailly@mandrakesoft.com> 2.4-3mdk
274- fixed some errors in spec file (sorry, my first package)
275
276* Mon May 14 2001 Yves BAILLY <ybailly@mandrakesoft.com> 2.4-2mdk
277- fixed the Python dependency (>= 2.0 instead of = 2.0)
278
279* Mon May 14 2001 Yves BAILLY <ybailly@mandrakesoft.com> 2.4-1mdk
280- upgrade to version 2.4
281
282* Tue Mar 20 2001 David BAUDENS <baudens@mandrakesoft.com> 2.3-2mdk
283- Rebuild against Qt 2.3.0
284
285* Wed Feb 21 2001 Lenny Cartier <lenny@mandrakesoft.com> 2.3-1mdk
286- updated to 2.3
287
288* Mon Feb 12 2001 Lenny Cartier <lenny@mandrakesoft.com> 2.2-1mdk
289- used srpm from Gerard Vermeulen <gvermeul@labs.polycnrs-gre.fr>
290        - built on Mandrake-7.2 following Mandrake RPM guidelines
291
292
Note: See TracBrowser for help on using the repository browser.