source: projects/specs/trunk/s/sip/sip-vl.spec @ 12469

Revision 12469, 15.7 KB checked in by tomop, 4 years ago (diff)

python-3.8.5 and related packages.

Line 
1%{!?python_sitearch:%global python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
2%{!?python_inc:%global python_inc %(%{__python} -c "from distutils.sysconfig import get_python_inc; print get_python_inc(1)")}
3%define py_ver %(python -c 'import sys;print(sys.version[0:3])')
4
5%{!?python3:%global __python3 /usr/bin/python3}
6%{!?python3_inc:%global python3_inc %(%{__python3} -c "from distutils.sysconfig import get_python_inc; print(get_python_inc(1))")}
7%{!?python3_sitearch: %global python3_sitearch %(python3 -c "from distutils.sysconfig import get_python_lib; import sys; sys.stdout.write(get_python_lib(1))")}
8%{!?python3_sitelib: %global python3_sitelib %(python3 -c "from distutils.sysconfig import get_python_lib; print(get_python_lib())")}
9%{!?python3_version: %global python3_version %(python3 -c "import sys; sys.stdout.write(sys.version[:3])")}
10
11%global rpm_macros_dir %(d=%{_rpmconfigdir}/macros.d; [ -d $d ] || d=%{_sysconfdir}/rpm; echo $d)
12
13# trim changelog included in binary rpms
14%global _changelog_trimtime %(date +%s -d "1 year ago")
15
16Name:           sip
17Summary:        Python/C++ Bindings Generator
18Summary(ja):    Python/C++ インターフェイス生成ツール
19Version:        4.19.24
20Release:        1%{?_dist_release}
21Group:          programming
22Vendor:         Project Vine
23Distribution:   Vine Linux
24
25# sipgen/parser.{c.h} is GPLv3+ with exceptions (bison)
26License:        GPLv2 or GPLv3 and (GPLv3+ with exceptions)
27URL:            https://www.riverbankcomputing.co.uk/software/sip/intro
28Source0:        https://www.riverbankcomputing.com/static/Downloads/sip/%{version}/sip-%{version}%{?snap:.%{snap}}.tar.gz
29
30# extracted from sip.h, SIP_API_MAJOR_NR SIP_API_MINOR_NR defines
31Source1: macros.sip
32%global _sip_api_major 12
33%global _sip_api_minor 7
34%global _sip_api %{_sip_api_major}.%{_sip_api_minor}
35
36Source10: sip-wrapper.sh
37
38## upstreamable patches
39# make install should not strip (by default), kills -debuginfo
40Patch50: sip-4.18-no_strip.patch
41# try not to rpath the world
42Patch51: sip-4.18-no_rpath.patch
43
44BuildRoot:      %{_tmppath}/%{name}-%{version}-root
45
46Provides: sip-api(%{_sip_api_major}) = %{_sip_api}
47Provides: sip-api(%{_sip_api_major})%{?_isa} = %{_sip_api}
48
49BuildRequires:  python-rpm-macros
50BuildRequires:  python3-devel
51BuildRequires:  python3-rpm-macros
52BuildRequires:  python-devel
53BuildRequires:  python2-rpm-macros
54BuildRequires:  sed
55
56%description
57SIP is a tool for generating bindings for C++ classes so that they can be
58accessed as normal Python classes. SIP takes many of its ideas from SWIG but,
59because it is specifically designed for C++ and Python, is able to generate
60tighter bindings. SIP is so called because it is a small SWIG.
61
62SIP was originally designed to generate Python bindings for KDE and so has
63explicit support for the signal slot mechanism used by the Qt/KDE class
64libraries. However, SIP can be used to generate Python bindings for any C++
65class library.
66
67
68%package devel
69Summary:        Files needed to generate Python bindings for any C++ class library
70Summary(ja):    Python/C++ インタフェース作成に必要なライブラリやヘッダファイル
71Group:          programming
72Requires:       %{name} = %{version}-%{release}
73Requires:       %{name}-macros = %{version}-%{release}
74Requires:       python-devel
75Provides:       libsip-devel = %{version}-%{release}
76
77%description devel
78This package contains files needed to generate Python bindings for any C++
79classes library.
80
81
82%package pyqt5-sip
83Summary: %summary
84Group:          programming
85Provides: python-pyqt5-sip-api(%{_sip_api_major}) = %{_sip_api}
86Provides: python-pyqt5-sip-api(%{_sip_api_major})%{?_isa} = %{_sip_api}
87%{?python_provide:%python_provide python-pyqt5-sip}
88%description pyqt5-sip
89%{summary}
90
91
92%package macros
93Summary: RPM macros for use when working with SIP
94Group:   programming
95Requires: rpm
96# when arch->noarch happened
97Obsoletes: sip-macros < 4.15.5
98BuildArch: noarch
99
100%description macros
101This package contains RPM macros for use when working with SIP.
102It is used by both the sip-devel (python 2) and python3-sip-devel subpackages.
103
104
105%package -n python3-sip
106Summary: SIP - Python 3/C++ Bindings Generator
107Group: programming
108BuildRequires: python3-devel
109Provides: python3-sip-api(%{_sip_api_major}) = %{_sip_api}
110Provides: python3-sip-api(%{_sip_api_major})%{?_isa} = %{_sip_api}
111
112%description -n python3-sip
113This is the Python 3 build of SIP.
114
115SIP is a tool for generating bindings for C++ classes so that they can be
116accessed as normal Python 3 classes. SIP takes many of its ideas from SWIG but,
117because it is specifically designed for C++ and Python, is able to generate
118tighter bindings. SIP is so called because it is a small SWIG.
119
120SIP was originally designed to generate Python bindings for KDE and so has
121explicit support for the signal slot mechanism used by the Qt/KDE class
122libraries. However, SIP can be used to generate Python 3 bindings for any C++
123class library.
124
125
126%package -n python3-sip-devel
127Summary: Files needed to generate Python 3 bindings for any C++ class library
128Group: programming
129Requires: %{name}-macros = %{version}-%{release}
130Requires: python3-sip%{?_isa} = %{version}-%{release}
131Requires: python3-devel
132
133%description -n python3-sip-devel
134This package contains files needed to generate Python 3 bindings for any C++
135classes library.
136
137
138%package -n python3-pyqt5-sip
139Summary: SIP - Python 3/C++ Bindings Generator for pyqt5
140Group: programming
141BuildRequires: python3-devel
142Provides: python3-pyqt5-sip-api(%{_sip_api_major}) = %{_sip_api}
143Provides: python3-pyqt5-sip-api(%{_sip_api_major})%{?_isa} = %{_sip_api}
144%description -n python3-pyqt5-sip
145This is the Python 3 build of pyqt5-SIP.
146
147
148%debug_package
149
150
151%prep
152%setup -q
153
154%patch50 -p1 -b .no_strip
155%patch51 -p1 -b .no_rpath
156
157
158%build
159%ifarch x86_64 ppc
160OPT_FLAGS="%{optflags} -fPIC"
161%else
162OPT_FLAGS="%{optflags}"
163%endif
164
165mkdir %{_target_platform}-python3
166pushd %{_target_platform}-python3
167%{__python3} ../configure.py \
168  -d %{python3_sitearch} \
169  CXXFLAGS="${OPT_FLAGS}" CFLAGS="${OPT_FLAGS}" LFLAGS="%{?__global_ldflags}"
170
171make %{?_smp_mflags}
172popd
173
174mkdir %{_target_platform}
175pushd %{_target_platform}
176%{__python} ../configure.py \
177  -d %{python_sitearch} \
178  CFLAGS="${OPT_FLAGS}" CXXFLAGS="${OPT_FLAGS}" LFLAGS="%{?__global_ldflags}"
179
180make %{?_smp_mflags}
181popd
182
183mkdir %{_target_platform}-python2-pyqt5
184pushd %{_target_platform}-python2-pyqt5
185%{__python} ../configure.py \
186  --sip-module=PyQt5.sip \
187  -b %{_bindir} -d %{python_sitearch} -e %{_includedir}/python%{python_version} \
188  CFLAGS+="%{optflags}" CXXFLAGS+="%{optflags}" LFLAGS+="%{?__global_ldflags}"
189
190make %{?_smp_mflags}
191popd
192
193mkdir %{_target_platform}-python3-pyqt5
194pushd %{_target_platform}-python3-pyqt5
195%{__python3} ../configure.py \
196  --sip-module=PyQt5.sip \
197  -b %{_bindir} -d %{python3_sitearch} -e %{_includedir}/python%{python3_version} \
198  CXXFLAGS+="%{optflags}" CFLAGS+="%{optflags}" LFLAGS+="%{?__global_ldflags}"
199
200make %{?_smp_mflags}
201popd
202
203
204%install
205rm -rf %{buildroot}
206
207# Perform the Python 3 installation first, to avoid stomping over the Python 2
208# /usr/bin/sip:
209make install DESTDIR=%{buildroot} -C %{_target_platform}-python3
210make install DESTDIR=%{buildroot} -C %{_target_platform}-python3-pyqt5
211
212mkdir -p %{buildroot}%{_datadir}/python3-sip
213mv %{buildroot}%{_bindir}/sip %{buildroot}%{_bindir}/python3-sip
214
215## toplevel __pycache__ creation is ... inconsistent
216## rawhide makes one, f23 local builds do not, so let's *make* it consistent
217mkdir -p %{buildroot}%{python3_sitearch}/__pycache__/exclude_rpm_hack
218
219# Python 2 installation:
220make install DESTDIR=%{buildroot} -C %{_target_platform}
221make install DESTDIR=%{buildroot} -C %{_target_platform}-python2-pyqt5
222
223# sip-wrapper
224install %{SOURCE10} %{buildroot}%{_bindir}/sip-pyqt5
225sed -i -e 's|@SIP_MODULE@|PyQt5.sip|g' %{buildroot}%{_bindir}/sip-pyqt5
226
227mkdir -p %{buildroot}%{_datadir}/sip
228
229# Macros used by -devel subpackages:
230install -D -p -m644 %{SOURCE1} %{buildroot}%{rpm_macros_dir}/macros.sip
231
232
233%clean
234rm -rf $RPM_BUILD_ROOT
235
236%files
237%defattr(-, root, root, 755)
238%doc NEWS README
239%license LICENSE LICENSE-GPL2 LICENSE-GPL3
240%{python_sitearch}/sip.so
241%{_datadir}/sip/
242%{python_sitearch}/*.dist-info
243
244%files devel
245%{_bindir}/sip
246%{_bindir}/sip-pyqt5
247%{_bindir}/python3-sip
248%defattr(-, root, root, 755)
249%{python_inc}/sip.h
250%{python_sitearch}/sip*.py*
251
252%files pyqt5-sip
253%doc NEWS README
254%license LICENSE LICENSE-GPL2 LICENSE-GPL3
255%dir %{python_sitearch}/PyQt5/
256%{python_sitearch}/PyQt5/sip.*
257%{python_sitearch}/PyQt5_sip-%{version}.dist-info/
258
259%files macros
260%{rpm_macros_dir}/macros.sip
261
262%files -n python3-sip
263%doc NEWS README
264%license LICENSE LICENSE-GPL2 LICENSE-GPL3
265%{python3_sitearch}/sip.*
266%{python3_sitearch}/*.dist-info
267
268%files -n python3-sip-devel
269# Note that the "sip" binary is invoked by name in a few places higher up
270# in the KDE-Python stack; these will need changing to "python3-sip":
271%{python3_inc}/sip.h
272%{python3_sitearch}/sip*.py*
273%{python3_sitearch}/__pycache__/*
274%exclude %{python3_sitearch}/__pycache__/exclude_rpm_hack
275
276%files -n python3-pyqt5-sip
277%doc NEWS README
278%license LICENSE LICENSE-GPL2 LICENSE-GPL3
279%dir %{python3_sitearch}/PyQt5/
280%{python3_sitearch}/PyQt5/sip.*
281%{python3_sitearch}/PyQt5_sip-%{version}.dist-info/
282
283
284%changelog
285* Sat Aug 15 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.19.24-1
286- new upstream release.
287
288* Tue Oct 22 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.19.19-1
289- new upstream release.
290
291* Tue Jul 12 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.18-1
292- new upstream release.
293
294* Thu Jun 30 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.16.4-2
295- rebuild with gcc-5.4.0
296
297* Sat Nov  8 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 4.16.4-1
298- new upstream release
299
300* Mon May 05 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.15.5-1
301- new upstream release
302
303* Sun Dec 08 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.15.3-1
304- new upstream release
305
306* Sun Sep 08 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.14.7-1
307- new upstream release
308
309* Wed Jun 05 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.14.6-1
310- new upstream release
311
312* Sun Jul 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.13.3-1
313- new upstream release
314
315* Sat Feb 18 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.13.1-2
316- rebuild with python-2.7.2
317
318* Sat Jan  7 2012 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.13.1-1
319- new upstream release
320
321* Sun Jul 31 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.12.3-1
322- new upstream release
323
324* Sun Jan 30 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.12.1-1
325- new upstream release
326
327* Mon Oct  4 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 4.10.5-2
328- add gcc option "-fPIC" also on ppc
329
330* Sat Jul 24 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.10.5-1
331- new upstream release
332
333* Sun May 09 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.10.2-1
334- new upstream release
335
336* Wed Feb 03 2010 Shu KONNO <owa@bg.wakwak.com> 4.10-1
337- new upstream release
338
339* Wed Feb 03 2010 Shu KONNO <owa@bg.wakwak.com> 4.9.3-2
340- rebuilt with python-2.6.4
341
342* Wed Nov 25 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.9.3-1
343- new upstream release
344
345* Thu Oct 22 2009 Shu KONNO <owa@bg.wakwak.com> 4.9-1
346- new upstream release
347- added japanese summary
348- changed source url
349
350* Sat Aug 29 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.8.2-1
351- new upstream release
352- remove qt-devel dependency
353
354* Sun Jul 20 2008 Shu KONNO <owa@bg.wakwak.com> 4.7.1-1vl1
355- rebuilt with python-2.5.2
356- applied new versioning policy and spec in utf-8
357
358* Fri Nov 30 2007 Shu KONNO <owa@bg.wakwak.com> 4.7.1-0vl1
359- new upstream release
360- added gcc option "-fPIC" (if x86_64)
361
362* Wed Sep  5 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.7-0vl1
363- new upstream release
364- use qt qmake files
365
366* Sun May 27 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.5-0vl2
367- rebuilt with new toolchain
368
369* Sun Jun 11 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.5-0vl1
370- new upstream release
371- rebuilt with python 2.4.3
372- changed Group to Development/Languages
373
374* Sun Apr 03 2005 Shu KONNO <owa@bg.wakwak.com> 3.11.1-0vl2
375- Rebuild for python 2.4.1
376
377* Sat Jan 15 2005 Satoshi MACHINO <machino@vinelinux.org> 3.11.1-0vl1
378- built for VineLinux
379- new upstream version
380
381* Sat Dec 04 2004 Michael Scherer <misc@mandrake.org> 3.10.2-5mdk
382- Rebuild for new python
383
384* Wed Jun  9 2004 Götz Waschk <waschk@linux-mandrake.com> 3.10.2-4mdk
385- obsolete libsip10 too
386
387* Mon Jun  7 2004 Götz Waschk <waschk@linux-mandrake.com> 3.10.2-3mdk
388- drop library packages
389
390* Mon Jun 07 2004 Per Øyvind Karlsen <peroyvind@linux-mandrake.com> 3.10.2-2mdk
391- fix build and install problems
392- drop .so.*, they no longer exist
393- use %%{py_ver} macro
394
395* Sat Jun 05 2004 Per Øyvind Karlsen <peroyvind@linux-mandrake.com> 3.10.2-1mdk
396- 3.10.2
397
398* Fri Apr 23 2004 Götz Waschk <waschk@linux-mandrake.com> 3.10.1-1mdk
399- add sipconfig
400- major 11
401- add source URL
402- new version
403
404* Mon Sep  8 2003 Götz Waschk <waschk@linux-mandrake.com> 3.8-3mdk
405- fix buildrequires
406
407* Sun Sep  7 2003 Götz Waschk <waschk@linux-mandrake.com> 3.8-2mdk
408- fix buildrequires
409- move libsip.so to the lib package, as it's required by generated bindings
410- move sip to the devel package
411
412* Wed Aug 20 2003 Austin Acton <aacton@yorku.ca> 3.8-1mdk
413- 3.8
414
415* Sat Aug 9 2003 Austin Acton <aacton@yorku.ca> 3.6-8mdk
416- the one true fix (eat your heart out per oyvind :-) )
417
418* Fri Aug 08 2003 Per Øyvind Karlsen <peroyvind@linux-mandrake.com> 3.6-7mdk
419- really rebuild for new python (austin was the sucky one this time;)
420
421* Thu Aug 7 2003 Austin Acton <aacton@yorku.ca> 3.6-6mdk
422- python 2.3
423
424* Sat Jul 19 2003 Till Kamppeter <till@mandrakesoft.com> 3.6-5mdk
425- Rebuild
426
427* Fri Jun 20 2003 Per Øyvind Karlsen <peroyvind@sintrax.net> 3.6-4mdk
428- fix path to qt3 (lib64 issues)
429- use %%mklibname macro for -devel package
430
431* Tue May 27 2003 Austin Acton <aacton@yorku.ca> 3.6-3mdk
432- rebuild for rpm 4.2
433
434* Tue Apr 29 2003 Per Øyvind Karlsen <peroyvind@sintrax.net> 3.6-2mdk
435- added QPL to license
436
437* Tue Apr 29 2003 Per Øyvind Karlsen <peroyvind@sintrax.net> 3.6-1mdk
438- 3.6 (lib major 9)
439- cleanups
440- fix license
441- make --short-circuitable
442- use %%mklibname macro
443
444* Fri Jan 03 2003 Lenny Cartier <lenny@mandrakesoft.com> 3.5-1mdk
445- 3.5
446
447* Sat Aug 17 2002 Christian Belisle <cbelisle@mandrakesoft.com> 3.3.2-2mdk
448- fix Provides for libsip9.
449
450* Wed Jul 17 2002 Christian Belisle <cbelisle@mandrakesoft.com> 3.3.2-1mdk
451- 3.3.2
452- use the new sip's build script
453
454* Sat Jun 29 2002 Olivier Thauvin <thauvin@aerov.jussieu.fr> 3.2.4-1mdk
455- 3.2.4
456
457* Tue May 28 2002 Lenny Cartier <lenny@mandrakesoft.com> 3.2.2-2mdk
458- rebuild against new libstdc++
459
460* Mon May 13 2002 Lenny Cartier <lenny@mandrakesoft.com> 3.2.2-1mdk
461- 3.2.2
462
463* Tue May 07 2002 Lenny Cartier <lenny@mandrakesoft.com> 3.2.1-1mdk
464- 3.2.1
465
466* Mon Apr 08 2002 Christian Belisle <cbelisle@mandrakesoft.com> 3.1-1mdk
467- version 3.1 (lib major 8).
468- update URL.
469
470* Fri Jan 11 2002 Lenny Cartier <lenny@mandrakesoft.com> 3.0-3mdk
471- merge with  RA <ralf_ahlbrink@web.de> mods :
472        - added BuildRequires: libpython2.2-devel
473
474* Fri Nov 30 2001 Yves Duret <yduret@mandrakesoft.com> 3.0-1mdk
475- version 3.0 (lib major 7)
476
477* Fri Nov 30 2001 Yves Duret <yduret@mandrakesoft.com> 2.5-2mdk
478- rebuild against libpng3
479- %%makeinstall_std
480- std %%build step (macros..)
481- added %%dir %%{_includedir}/sip in -devel package
482
483* Mon Sep 03 2001 Lenny Cartier <lenny@mandrakesoft.com> 2.5-1mdk
484- 2.5
485
486* Mon May 14 2001 Yves BAILLY <ybailly@mandrakesoft.com> 2.4-3mdk
487- fixed some errors in spec file (sorry, my first package)
488
489* Mon May 14 2001 Yves BAILLY <ybailly@mandrakesoft.com> 2.4-2mdk
490- fixed the Python dependency (>= 2.0 instead of = 2.0)
491
492* Mon May 14 2001 Yves BAILLY <ybailly@mandrakesoft.com> 2.4-1mdk
493- upgrade to version 2.4
494
495* Tue Mar 20 2001 David BAUDENS <baudens@mandrakesoft.com> 2.3-2mdk
496- Rebuild against Qt 2.3.0
497
498* Wed Feb 21 2001 Lenny Cartier <lenny@mandrakesoft.com> 2.3-1mdk
499- updated to 2.3
500
501* Mon Feb 12 2001 Lenny Cartier <lenny@mandrakesoft.com> 2.2-1mdk
502- used srpm from Gerard Vermeulen <gvermeul@labs.polycnrs-gre.fr>
503        - built on Mandrake-7.2 following Mandrake RPM guidelines
504
505
Note: See TracBrowser for help on using the repository browser.