source: projects/specs/trunk/s/sip/sip-vl.spec @ 12287

Revision 12287, 15.4 KB checked in by tomop, 5 years ago (diff)

updated 26 packages

python-qt5-5.12.3-1

qt5-qt3d-5.12.5-1

qt5-qtbase-5.12.5-1

qt5-qtcanvas3d-5.12.5-1

qt5-qtconnectivity-5.12.5-1

qt5-qtdeclarative-5.12.5-1

qt5-qtdoc-5.12.5-1

qt5-qtgraphicaleffects-5.12.5-1

qt5-qtimageformats-5.12.5-1

qt5-qtlocation-5.12.5-1

qt5-qtmultimedia-5.12.5-1

qt5-qtquickcontrols-5.12.5-1

qt5-qtquickcontrols2-5.12.5-1

qt5-qtscript-5.12.5-1

qt5-qtsensors-5.12.5-1

qt5-qtserialport-5.12.5-1

qt5-qtsvg-5.12.5-1

qt5-qttools-5.12.5-1

qt5-qttranslations-5.12.5-1

qt5-qtwebchannel-5.12.5-1

qt5-qtwebengine-5.12.5-1

qt5-qtwebsockets-5.12.5-1

qt5-qtx11extras-5.12.5-1

qt5-qtxmlpatterns-5.12.5-1

qt5-5.12.5-2

sip-4.19.19-1

Line 
1%{!?python_sitearch:%global python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
2%{!?python_inc:%global python_inc %(%{__python} -c "from distutils.sysconfig import get_python_inc; print get_python_inc(1)")}
3%define py_ver %(python -c 'import sys;print(sys.version[0:3])')
4
5%{!?python3:%global __python3 /usr/bin/python3}
6%{!?python3_inc:%global python3_inc %(%{__python3} -c "from distutils.sysconfig import get_python_inc; print(get_python_inc(1))")}
7%{!?python3_sitearch: %global python3_sitearch %(python3 -c "from distutils.sysconfig import get_python_lib; import sys; sys.stdout.write(get_python_lib(1))")}
8%{!?python3_sitelib: %global python3_sitelib %(python3 -c "from distutils.sysconfig import get_python_lib; print(get_python_lib())")}
9%{!?python3_version: %global python3_version %(python3 -c "import sys; sys.stdout.write(sys.version[:3])")}
10
11%global rpm_macros_dir %(d=%{_rpmconfigdir}/macros.d; [ -d $d ] || d=%{_sysconfdir}/rpm; echo $d)
12
13# trim changelog included in binary rpms
14%global _changelog_trimtime %(date +%s -d "1 year ago")
15
16Name:           sip
17Summary:        Python/C++ Bindings Generator
18Summary(ja):    Python/C++ インターフェイス生成ツール
19Version:        4.19.19
20Release:        1%{?_dist_release}
21Group:          Development/Tools
22
23# sipgen/parser.{c.h} is GPLv3+ with exceptions (bison)
24License:        GPLv2 or GPLv3 and (GPLv3+ with exceptions)
25URL:            https://www.riverbankcomputing.co.uk/software/sip/intro
26Source0:        https://www.riverbankcomputing.com/static/Downloads/sip/%{version}/sip-%{version}%{?snap:.%{snap}}.tar.gz
27
28# extracted from sip.h, SIP_API_MAJOR_NR SIP_API_MINOR_NR defines
29Source1: macros.sip
30%global _sip_api_major 12
31%global _sip_api_minor 7
32%global _sip_api %{_sip_api_major}.%{_sip_api_minor}
33
34Source10: sip-wrapper.sh
35
36
37## upstreamable patches
38# make install should not strip (by default), kills -debuginfo
39Patch50: sip-4.18-no_strip.patch
40# try not to rpath the world
41Patch51: sip-4.18-no_rpath.patch
42
43BuildRoot:      %{_tmppath}/%{name}-%{version}-root
44
45Provides: sip-api(%{_sip_api_major}) = %{_sip_api}
46Provides: sip-api(%{_sip_api_major})%{?_isa} = %{_sip_api}
47
48BuildRequires:  python3-devel
49BuildRequires:  python3-rpm-macros
50BuildRequires:  python-devel
51BuildRequires:  python-rpm-macros
52BuildRequires:  sed
53
54Vendor:         Project Vine
55Distribution:   Vine Linux
56
57%description
58SIP is a tool for generating bindings for C++ classes so that they can be
59accessed as normal Python classes. SIP takes many of its ideas from SWIG but,
60because it is specifically designed for C++ and Python, is able to generate
61tighter bindings. SIP is so called because it is a small SWIG.
62
63SIP was originally designed to generate Python bindings for KDE and so has
64explicit support for the signal slot mechanism used by the Qt/KDE class
65libraries. However, SIP can be used to generate Python bindings for any C++
66class library.
67
68
69%package devel
70Summary:        Files needed to generate Python bindings for any C++ class library
71Summary(ja):    Python/C++ インタフェース作成に必要なライブラリやヘッダファイル
72Group:          Development/Libraries
73Requires:       %{name} = %{version}-%{release}
74Requires:       %{name}-macros = %{version}-%{release}
75Requires:       python-devel
76Provides:       libsip-devel = %{version}-%{release}
77
78%description devel
79This package contains files needed to generate Python bindings for any C++
80classes library.
81
82
83%package pyqt5-sip
84Summary: %summary
85Provides: python-pyqt5-sip-api(%{_sip_api_major}) = %{_sip_api}
86Provides: python-pyqt5-sip-api(%{_sip_api_major})%{?_isa} = %{_sip_api}
87%{?python_provide:%python_provide python-pyqt5-sip}
88%description pyqt5-sip
89%{summary}
90
91
92%package macros
93Summary: RPM macros for use when working with SIP
94Requires: rpm
95# when arch->noarch happened
96Obsoletes: sip-macros < 4.15.5
97BuildArch: noarch
98
99%description macros
100This package contains RPM macros for use when working with SIP.
101It is used by both the sip-devel (python 2) and python3-sip-devel subpackages.
102
103
104%package -n python3-sip
105Summary: SIP - Python 3/C++ Bindings Generator
106BuildRequires: python3-devel
107Provides: python3-sip-api(%{_sip_api_major}) = %{_sip_api}
108Provides: python3-sip-api(%{_sip_api_major})%{?_isa} = %{_sip_api}
109
110%description -n python3-sip
111This is the Python 3 build of SIP.
112
113SIP is a tool for generating bindings for C++ classes so that they can be
114accessed as normal Python 3 classes. SIP takes many of its ideas from SWIG but,
115because it is specifically designed for C++ and Python, is able to generate
116tighter bindings. SIP is so called because it is a small SWIG.
117
118SIP was originally designed to generate Python bindings for KDE and so has
119explicit support for the signal slot mechanism used by the Qt/KDE class
120libraries. However, SIP can be used to generate Python 3 bindings for any C++
121class library.
122
123
124%package -n python3-sip-devel
125Summary: Files needed to generate Python 3 bindings for any C++ class library
126Requires: %{name}-macros = %{version}-%{release}
127Requires: python3-sip%{?_isa} = %{version}-%{release}
128Requires: python3-devel
129
130%description -n python3-sip-devel
131This package contains files needed to generate Python 3 bindings for any C++
132classes library.
133
134
135%package -n python3-pyqt5-sip
136Summary: SIP - Python 3/C++ Bindings Generator for pyqt5
137BuildRequires: python3-devel
138Provides: python3-pyqt5-sip-api(%{_sip_api_major}) = %{_sip_api}
139Provides: python3-pyqt5-sip-api(%{_sip_api_major})%{?_isa} = %{_sip_api}
140%description -n python3-pyqt5-sip
141This is the Python 3 build of pyqt5-SIP.
142
143
144%prep
145%setup -q
146
147%patch50 -p1 -b .no_strip
148%patch51 -p1 -b .no_rpath
149
150
151%build
152%ifarch x86_64 ppc
153OPT_FLAGS="%{optflags} -fPIC"
154%else
155OPT_FLAGS="%{optflags}"
156%endif
157
158mkdir %{_target_platform}-python3
159pushd %{_target_platform}-python3
160%{__python3} ../configure.py \
161  -d %{python3_sitearch} \
162  CXXFLAGS="${OPT_FLAGS}" CFLAGS="${OPT_FLAGS}" LFLAGS="%{?__global_ldflags}"
163
164make %{?_smp_mflags}
165popd
166
167mkdir %{_target_platform}
168pushd %{_target_platform}
169%{__python} ../configure.py \
170  -d %{python_sitearch} \
171  CFLAGS="${OPT_FLAGS}" CXXFLAGS="${OPT_FLAGS}" LFLAGS="%{?__global_ldflags}"
172
173make %{?_smp_mflags}
174popd
175
176mkdir %{_target_platform}-python2-pyqt5
177pushd %{_target_platform}-python2-pyqt5
178%{__python} ../configure.py \
179  --sip-module=PyQt5.sip \
180  -b %{_bindir} -d %{python_sitearch} -e %{_includedir}/python%{python_version} \
181  CFLAGS+="%{optflags}" CXXFLAGS+="%{optflags}" LFLAGS+="%{?__global_ldflags}"
182
183make %{?_smp_mflags}
184popd
185
186mkdir %{_target_platform}-python3-pyqt5
187pushd %{_target_platform}-python3-pyqt5
188%{__python3} ../configure.py \
189  --sip-module=PyQt5.sip \
190  -b %{_bindir} -d %{python3_sitearch} -e %{_includedir}/python%{python3_version}m \
191  CXXFLAGS+="%{optflags}" CFLAGS+="%{optflags}" LFLAGS+="%{?__global_ldflags}"
192
193make %{?_smp_mflags}
194popd
195
196
197%install
198rm -rf %{buildroot}
199
200# Perform the Python 3 installation first, to avoid stomping over the Python 2
201# /usr/bin/sip:
202make install DESTDIR=%{buildroot} -C %{_target_platform}-python3
203make install DESTDIR=%{buildroot} -C %{_target_platform}-python3-pyqt5
204
205mkdir -p %{buildroot}%{_datadir}/python3-sip
206mv %{buildroot}%{_bindir}/sip %{buildroot}%{_bindir}/python3-sip
207
208## toplevel __pycache__ creation is ... inconsistent
209## rawhide makes one, f23 local builds do not, so let's *make* it consistent
210mkdir -p %{buildroot}%{python3_sitearch}/__pycache__/exclude_rpm_hack
211
212# Python 2 installation:
213make install DESTDIR=%{buildroot} -C %{_target_platform}
214make install DESTDIR=%{buildroot} -C %{_target_platform}-python2-pyqt5
215
216# sip-wrapper
217install %{SOURCE10} %{buildroot}%{_bindir}/sip-pyqt5
218sed -i -e 's|@SIP_MODULE@|PyQt5.sip|g' %{buildroot}%{_bindir}/sip-pyqt5
219
220mkdir -p %{buildroot}%{_datadir}/sip
221
222# Macros used by -devel subpackages:
223install -D -p -m644 %{SOURCE1} %{buildroot}%{rpm_macros_dir}/macros.sip
224
225
226%clean
227rm -rf $RPM_BUILD_ROOT
228
229%files
230%defattr(-, root, root, 755)
231%doc NEWS README
232%license LICENSE LICENSE-GPL2 LICENSE-GPL3
233%{python_sitearch}/sip.so
234%{_datadir}/sip/
235%{python_sitearch}/*.dist-info
236
237%files devel
238%{_bindir}/sip
239%{_bindir}/sip-pyqt5
240%{_bindir}/python3-sip
241%defattr(-, root, root, 755)
242%{python_inc}/sip.h
243%{python_sitearch}/sip*.py*
244
245%files pyqt5-sip
246%doc NEWS README
247%license LICENSE LICENSE-GPL2 LICENSE-GPL3
248%dir %{python_sitearch}/PyQt5/
249%{python_sitearch}/PyQt5/sip.*
250%{python_sitearch}/PyQt5_sip-%{version}.dist-info/
251
252%files macros
253%{rpm_macros_dir}/macros.sip
254
255%files -n python3-sip
256%doc NEWS README
257%license LICENSE LICENSE-GPL2 LICENSE-GPL3
258%{python3_sitearch}/sip.*
259%{python3_sitearch}/*.dist-info
260
261%files -n python3-sip-devel
262# Note that the "sip" binary is invoked by name in a few places higher up
263# in the KDE-Python stack; these will need changing to "python3-sip":
264%{python3_inc}/sip.h
265%{python3_sitearch}/sip*.py*
266%{python3_sitearch}/__pycache__/*
267%exclude %{python3_sitearch}/__pycache__/exclude_rpm_hack
268
269%files -n python3-pyqt5-sip
270%doc NEWS README
271%license LICENSE LICENSE-GPL2 LICENSE-GPL3
272%dir %{python3_sitearch}/PyQt5/
273%{python3_sitearch}/PyQt5/sip.*
274%{python3_sitearch}/PyQt5_sip-%{version}.dist-info/
275
276
277%changelog
278* Tue Oct 22 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.19.19-1
279- new upstream release.
280
281* Tue Jul 12 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.18-1
282- new upstream release.
283
284* Thu Jun 30 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.16.4-2
285- rebuild with gcc-5.4.0
286
287* Sat Nov  8 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 4.16.4-1
288- new upstream release
289
290* Mon May 05 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.15.5-1
291- new upstream release
292
293* Sun Dec 08 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.15.3-1
294- new upstream release
295
296* Sun Sep 08 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.14.7-1
297- new upstream release
298
299* Wed Jun 05 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.14.6-1
300- new upstream release
301
302* Sun Jul 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.13.3-1
303- new upstream release
304
305* Sat Feb 18 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.13.1-2
306- rebuild with python-2.7.2
307
308* Sat Jan  7 2012 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.13.1-1
309- new upstream release
310
311* Sun Jul 31 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.12.3-1
312- new upstream release
313
314* Sun Jan 30 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.12.1-1
315- new upstream release
316
317* Mon Oct  4 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 4.10.5-2
318- add gcc option "-fPIC" also on ppc
319
320* Sat Jul 24 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.10.5-1
321- new upstream release
322
323* Sun May 09 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.10.2-1
324- new upstream release
325
326* Wed Feb 03 2010 Shu KONNO <owa@bg.wakwak.com> 4.10-1
327- new upstream release
328
329* Wed Feb 03 2010 Shu KONNO <owa@bg.wakwak.com> 4.9.3-2
330- rebuilt with python-2.6.4
331
332* Wed Nov 25 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.9.3-1
333- new upstream release
334
335* Thu Oct 22 2009 Shu KONNO <owa@bg.wakwak.com> 4.9-1
336- new upstream release
337- added japanese summary
338- changed source url
339
340* Sat Aug 29 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.8.2-1
341- new upstream release
342- remove qt-devel dependency
343
344* Sun Jul 20 2008 Shu KONNO <owa@bg.wakwak.com> 4.7.1-1vl1
345- rebuilt with python-2.5.2
346- applied new versioning policy and spec in utf-8
347
348* Fri Nov 30 2007 Shu KONNO <owa@bg.wakwak.com> 4.7.1-0vl1
349- new upstream release
350- added gcc option "-fPIC" (if x86_64)
351
352* Wed Sep  5 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.7-0vl1
353- new upstream release
354- use qt qmake files
355
356* Sun May 27 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.5-0vl2
357- rebuilt with new toolchain
358
359* Sun Jun 11 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.5-0vl1
360- new upstream release
361- rebuilt with python 2.4.3
362- changed Group to Development/Languages
363
364* Sun Apr 03 2005 Shu KONNO <owa@bg.wakwak.com> 3.11.1-0vl2
365- Rebuild for python 2.4.1
366
367* Sat Jan 15 2005 Satoshi MACHINO <machino@vinelinux.org> 3.11.1-0vl1
368- built for VineLinux
369- new upstream version
370
371* Sat Dec 04 2004 Michael Scherer <misc@mandrake.org> 3.10.2-5mdk
372- Rebuild for new python
373
374* Wed Jun  9 2004 Götz Waschk <waschk@linux-mandrake.com> 3.10.2-4mdk
375- obsolete libsip10 too
376
377* Mon Jun  7 2004 Götz Waschk <waschk@linux-mandrake.com> 3.10.2-3mdk
378- drop library packages
379
380* Mon Jun 07 2004 Per Øyvind Karlsen <peroyvind@linux-mandrake.com> 3.10.2-2mdk
381- fix build and install problems
382- drop .so.*, they no longer exist
383- use %%{py_ver} macro
384
385* Sat Jun 05 2004 Per Øyvind Karlsen <peroyvind@linux-mandrake.com> 3.10.2-1mdk
386- 3.10.2
387
388* Fri Apr 23 2004 Götz Waschk <waschk@linux-mandrake.com> 3.10.1-1mdk
389- add sipconfig
390- major 11
391- add source URL
392- new version
393
394* Mon Sep  8 2003 Götz Waschk <waschk@linux-mandrake.com> 3.8-3mdk
395- fix buildrequires
396
397* Sun Sep  7 2003 Götz Waschk <waschk@linux-mandrake.com> 3.8-2mdk
398- fix buildrequires
399- move libsip.so to the lib package, as it's required by generated bindings
400- move sip to the devel package
401
402* Wed Aug 20 2003 Austin Acton <aacton@yorku.ca> 3.8-1mdk
403- 3.8
404
405* Sat Aug 9 2003 Austin Acton <aacton@yorku.ca> 3.6-8mdk
406- the one true fix (eat your heart out per oyvind :-) )
407
408* Fri Aug 08 2003 Per Øyvind Karlsen <peroyvind@linux-mandrake.com> 3.6-7mdk
409- really rebuild for new python (austin was the sucky one this time;)
410
411* Thu Aug 7 2003 Austin Acton <aacton@yorku.ca> 3.6-6mdk
412- python 2.3
413
414* Sat Jul 19 2003 Till Kamppeter <till@mandrakesoft.com> 3.6-5mdk
415- Rebuild
416
417* Fri Jun 20 2003 Per Øyvind Karlsen <peroyvind@sintrax.net> 3.6-4mdk
418- fix path to qt3 (lib64 issues)
419- use %%mklibname macro for -devel package
420
421* Tue May 27 2003 Austin Acton <aacton@yorku.ca> 3.6-3mdk
422- rebuild for rpm 4.2
423
424* Tue Apr 29 2003 Per Øyvind Karlsen <peroyvind@sintrax.net> 3.6-2mdk
425- added QPL to license
426
427* Tue Apr 29 2003 Per Øyvind Karlsen <peroyvind@sintrax.net> 3.6-1mdk
428- 3.6 (lib major 9)
429- cleanups
430- fix license
431- make --short-circuitable
432- use %%mklibname macro
433
434* Fri Jan 03 2003 Lenny Cartier <lenny@mandrakesoft.com> 3.5-1mdk
435- 3.5
436
437* Sat Aug 17 2002 Christian Belisle <cbelisle@mandrakesoft.com> 3.3.2-2mdk
438- fix Provides for libsip9.
439
440* Wed Jul 17 2002 Christian Belisle <cbelisle@mandrakesoft.com> 3.3.2-1mdk
441- 3.3.2
442- use the new sip's build script
443
444* Sat Jun 29 2002 Olivier Thauvin <thauvin@aerov.jussieu.fr> 3.2.4-1mdk
445- 3.2.4
446
447* Tue May 28 2002 Lenny Cartier <lenny@mandrakesoft.com> 3.2.2-2mdk
448- rebuild against new libstdc++
449
450* Mon May 13 2002 Lenny Cartier <lenny@mandrakesoft.com> 3.2.2-1mdk
451- 3.2.2
452
453* Tue May 07 2002 Lenny Cartier <lenny@mandrakesoft.com> 3.2.1-1mdk
454- 3.2.1
455
456* Mon Apr 08 2002 Christian Belisle <cbelisle@mandrakesoft.com> 3.1-1mdk
457- version 3.1 (lib major 8).
458- update URL.
459
460* Fri Jan 11 2002 Lenny Cartier <lenny@mandrakesoft.com> 3.0-3mdk
461- merge with  RA <ralf_ahlbrink@web.de> mods :
462        - added BuildRequires: libpython2.2-devel
463
464* Fri Nov 30 2001 Yves Duret <yduret@mandrakesoft.com> 3.0-1mdk
465- version 3.0 (lib major 7)
466
467* Fri Nov 30 2001 Yves Duret <yduret@mandrakesoft.com> 2.5-2mdk
468- rebuild against libpng3
469- %%makeinstall_std
470- std %%build step (macros..)
471- added %%dir %%{_includedir}/sip in -devel package
472
473* Mon Sep 03 2001 Lenny Cartier <lenny@mandrakesoft.com> 2.5-1mdk
474- 2.5
475
476* Mon May 14 2001 Yves BAILLY <ybailly@mandrakesoft.com> 2.4-3mdk
477- fixed some errors in spec file (sorry, my first package)
478
479* Mon May 14 2001 Yves BAILLY <ybailly@mandrakesoft.com> 2.4-2mdk
480- fixed the Python dependency (>= 2.0 instead of = 2.0)
481
482* Mon May 14 2001 Yves BAILLY <ybailly@mandrakesoft.com> 2.4-1mdk
483- upgrade to version 2.4
484
485* Tue Mar 20 2001 David BAUDENS <baudens@mandrakesoft.com> 2.3-2mdk
486- Rebuild against Qt 2.3.0
487
488* Wed Feb 21 2001 Lenny Cartier <lenny@mandrakesoft.com> 2.3-1mdk
489- updated to 2.3
490
491* Mon Feb 12 2001 Lenny Cartier <lenny@mandrakesoft.com> 2.2-1mdk
492- used srpm from Gerard Vermeulen <gvermeul@labs.polycnrs-gre.fr>
493        - built on Mandrake-7.2 following Mandrake RPM guidelines
494
495
Note: See TracBrowser for help on using the repository browser.