source: projects/specs/trunk/s/sip/sip-vl.spec @ 10600

Revision 10600, 13.3 KB checked in by tomop, 8 years ago (diff)

sip-4.18-1

Line 
1%{!?python_sitearch:%global python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
2%{!?python_inc:%global python_inc %(%{__python} -c "from distutils.sysconfig import get_python_inc; print get_python_inc(1)")}
3%define py_ver %(python -c 'import sys;print(sys.version[0:3])')
4
5%{!?python3:%global __python3 /usr/bin/python3}
6%{!?python3_inc:%global python3_inc %(%{__python3} -c "from distutils.sysconfig import get_python_inc; print(get_python_inc(1))")}
7%{!?python3_sitearch: %global python3_sitearch %(python3 -c "from distutils.sysconfig import get_python_lib; import sys; sys.stdout.write(get_python_lib(1))")}
8%{!?python3_sitelib: %global python3_sitelib %(python3 -c "from distutils.sysconfig import get_python_lib; print(get_python_lib())")}
9%{!?python3_version: %global python3_version %(python3 -c "import sys; sys.stdout.write(sys.version[:3])")}
10
11%global rpm_macros_dir %(d=%{_rpmconfigdir}/macros.d; [ -d $d ] || d=%{_sysconfdir}/rpm; echo $d)
12
13# trim changelog included in binary rpms
14%global _changelog_trimtime %(date +%s -d "1 year ago")
15
16Name:           sip
17Summary:        Python/C++ Bindings Generator
18Summary(ja):    Python/C++ インターフェイス生成ツール
19Version:        4.18
20Release:        1%{?_dist_release}
21
22License:        GPLv2 or GPLv3
23Group:          Development/Tools
24URL:            http://www.riverbankcomputing.co.uk/software/sip/intro
25
26Source0:  http://downloads.sourceforge.net/pyqt/sip-%{version}%{?snap:-snapshot-%{snap}}.tar.gz
27
28## upstream patches
29Patch1: sip-4.18-diamond_inheritance.patch
30Patch2: sip-4.18-shadow_build.patch
31
32## upstreamable patches
33# make install should not strip (by default), kills -debuginfo
34Patch50: sip-4.18-no_strip.patch
35# try not to rpath the world
36Patch51: sip-4.18-no_rpath.patch
37
38# extracted from sip.h, SIP_API_MAJOR_NR SIP_API_MINOR_NR defines
39Source1: macros.sip
40%global _sip_api_major 11
41%global _sip_api_minor 3
42%global _sip_api %{_sip_api_major}.%{_sip_api_minor}
43
44BuildRoot:      %{_tmppath}/%{name}-%{version}-root
45
46Provides: sip-api(%{_sip_api_major}) = %{_sip_api}
47Provides: sip-api(%{_sip_api_major})%{?_isa} = %{_sip_api}
48
49BuildRequires:  python3-devel
50BuildRequires:  python-devel
51BuildRequires:  sed
52
53Vendor:         Project Vine
54Distribution:   Vine Linux
55
56%description
57SIP is a tool for generating bindings for C++ classes so that they can be
58accessed as normal Python classes. SIP takes many of its ideas from SWIG but,
59because it is specifically designed for C++ and Python, is able to generate
60tighter bindings. SIP is so called because it is a small SWIG.
61
62SIP was originally designed to generate Python bindings for KDE and so has
63explicit support for the signal slot mechanism used by the Qt/KDE class
64libraries. However, SIP can be used to generate Python bindings for any C++
65class library.
66
67
68%package devel
69Summary:        Files needed to generate Python bindings for any C++ class library
70Summary(ja):    Python/C++ インタフェース作成に必要なライブラリやヘッダファイル
71Group:          Development/Libraries
72Requires:       %{name} = %{version}-%{release}
73Requires:       %{name}-macros = %{version}-%{release}
74Requires:       python-devel
75Provides:       libsip-devel = %{version}-%{release}
76
77%description devel
78This package contains files needed to generate Python bindings for any C++
79classes library.
80
81
82%package macros
83Summary: RPM macros for use when working with SIP
84Requires: rpm
85# when arch->noarch happened
86Obsoletes: sip-macros < 4.15.5
87BuildArch: noarch
88
89%description macros
90This package contains RPM macros for use when working with SIP.
91It is used by both the sip-devel (python 2) and python3-sip-devel subpackages.
92
93
94%package -n python3-sip
95Summary: SIP - Python 3/C++ Bindings Generator
96BuildRequires: python3-devel
97Provides: python3-sip-api(%{_sip_api_major}) = %{_sip_api}
98Provides: python3-sip-api(%{_sip_api_major})%{?_isa} = %{_sip_api}
99
100%description -n python3-sip
101This is the Python 3 build of SIP.
102
103SIP is a tool for generating bindings for C++ classes so that they can be
104accessed as normal Python 3 classes. SIP takes many of its ideas from SWIG but,
105because it is specifically designed for C++ and Python, is able to generate
106tighter bindings. SIP is so called because it is a small SWIG.
107
108SIP was originally designed to generate Python bindings for KDE and so has
109explicit support for the signal slot mechanism used by the Qt/KDE class
110libraries. However, SIP can be used to generate Python 3 bindings for any C++
111class library.
112
113
114%package -n python3-sip-devel
115Summary: Files needed to generate Python 3 bindings for any C++ class library
116Requires: %{name}-macros = %{version}-%{release}
117Requires: python3-sip%{?_isa} = %{version}-%{release}
118Requires: python3-devel
119
120%description -n python3-sip-devel
121This package contains files needed to generate Python 3 bindings for any C++
122classes library.
123
124
125%prep
126%setup -q
127
128%patch1 -p1 -b .diamond_inheritance
129%patch2 -p1 -b .shadow_build
130
131%patch50 -p1 -b .no_strip
132%patch51 -p1 -b .no_rpath
133
134
135%build
136%ifarch x86_64 ppc
137OPT_FLAGS="%{optflags} -fPIC"
138%else
139OPT_FLAGS="%{optflags}"
140%endif
141
142mkdir %{_target_platform}-python3
143pushd %{_target_platform}-python3
144%{__python3} ../configure.py \
145  -d %{python3_sitearch} \
146  --sipdir=%{_datadir}/python3-sip \
147  CXXFLAGS="${OPT_FLAGS}" CFLAGS="${OPT_FLAGS}" LFLAGS="%{?__global_ldflags}"
148
149make %{?_smp_mflags}
150popd
151
152mkdir %{_target_platform}
153pushd %{_target_platform}
154%{__python} ../configure.py \
155  -d %{python_sitearch} \
156  CFLAGS="${OPT_FLAGS}" CXXFLAGS="${OPT_FLAGS}" LFLAGS="%{?__global_ldflags}"
157
158make %{?_smp_mflags}
159popd
160
161
162%install
163rm -rf %{buildroot}
164
165# Perform the Python 3 installation first, to avoid stomping over the Python 2
166# /usr/bin/sip:
167make install DESTDIR=%{buildroot} -C %{_target_platform}-python3
168mkdir -p %{buildroot}%{_datadir}/python3-sip
169mv %{buildroot}%{_bindir}/sip %{buildroot}%{_bindir}/python3-sip
170
171## toplevel __pycache__ creation is ... inconsistent
172## rawhide makes one, f23 local builds do not, so let's *make* it consistent
173mkdir -p %{buildroot}%{python3_sitearch}/__pycache__/exclude_rpm_hack
174
175# Python 2 installation:
176make install DESTDIR=%{buildroot} -C %{_target_platform}
177mkdir -p %{buildroot}%{_datadir}/sip
178
179# Macros used by -devel subpackages:
180install -D -p -m644 %{SOURCE1} %{buildroot}%{rpm_macros_dir}/macros.sip
181
182
183%clean
184rm -rf $RPM_BUILD_ROOT
185
186%files
187%defattr(-, root, root, 755)
188%doc NEWS README
189%license LICENSE LICENSE-GPL2 LICENSE-GPL3
190%{python_sitearch}/sip.so
191%{python_sitearch}/sip*.py*
192
193%files devel
194%defattr(-, root, root, 755)
195%{_bindir}/sip
196%{_datadir}/sip/
197%{python_inc}/sip.h
198
199%files macros
200%{rpm_macros_dir}/macros.sip
201
202%files -n python3-sip
203%doc NEWS README
204%license LICENSE LICENSE-GPL2 LICENSE-GPL3
205%{python3_sitearch}/sip.so
206%{python3_sitearch}/sip*.py*
207%{python3_sitearch}/__pycache__/*
208%exclude %{python3_sitearch}/__pycache__/exclude_rpm_hack
209
210%files -n python3-sip-devel
211# Note that the "sip" binary is invoked by name in a few places higher up
212# in the KDE-Python stack; these will need changing to "python3-sip":
213%{_bindir}/python3-sip
214%{_datadir}/python3-sip/
215%{python3_inc}/sip.h
216
217
218%changelog
219* Tue Jul 12 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.18-1
220- new upstream release.
221
222* Thu Jun 30 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.16.4-2
223- rebuild with gcc-5.4.0
224
225* Sat Nov  8 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 4.16.4-1
226- new upstream release
227
228* Mon May 05 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.15.5-1
229- new upstream release
230
231* Sun Dec 08 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.15.3-1
232- new upstream release
233
234* Sun Sep 08 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.14.7-1
235- new upstream release
236
237* Wed Jun 05 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.14.6-1
238- new upstream release
239
240* Sun Jul 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.13.3-1
241- new upstream release
242
243* Sat Feb 18 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.13.1-2
244- rebuild with python-2.7.2
245
246* Sat Jan  7 2012 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.13.1-1
247- new upstream release
248
249* Sun Jul 31 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.12.3-1
250- new upstream release
251
252* Sun Jan 30 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.12.1-1
253- new upstream release
254
255* Mon Oct  4 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 4.10.5-2
256- add gcc option "-fPIC" also on ppc
257
258* Sat Jul 24 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.10.5-1
259- new upstream release
260
261* Sun May 09 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.10.2-1
262- new upstream release
263
264* Wed Feb 03 2010 Shu KONNO <owa@bg.wakwak.com> 4.10-1
265- new upstream release
266
267* Wed Feb 03 2010 Shu KONNO <owa@bg.wakwak.com> 4.9.3-2
268- rebuilt with python-2.6.4
269
270* Wed Nov 25 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.9.3-1
271- new upstream release
272
273* Thu Oct 22 2009 Shu KONNO <owa@bg.wakwak.com> 4.9-1
274- new upstream release
275- added japanese summary
276- changed source url
277
278* Sat Aug 29 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.8.2-1
279- new upstream release
280- remove qt-devel dependency
281
282* Sun Jul 20 2008 Shu KONNO <owa@bg.wakwak.com> 4.7.1-1vl1
283- rebuilt with python-2.5.2
284- applied new versioning policy and spec in utf-8
285
286* Fri Nov 30 2007 Shu KONNO <owa@bg.wakwak.com> 4.7.1-0vl1
287- new upstream release
288- added gcc option "-fPIC" (if x86_64)
289
290* Wed Sep  5 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.7-0vl1
291- new upstream release
292- use qt qmake files
293
294* Sun May 27 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.5-0vl2
295- rebuilt with new toolchain
296
297* Sun Jun 11 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.5-0vl1
298- new upstream release
299- rebuilt with python 2.4.3
300- changed Group to Development/Languages
301
302* Sun Apr 03 2005 Shu KONNO <owa@bg.wakwak.com> 3.11.1-0vl2
303- Rebuild for python 2.4.1
304
305* Sat Jan 15 2005 Satoshi MACHINO <machino@vinelinux.org> 3.11.1-0vl1
306- built for VineLinux
307- new upstream version
308
309* Sat Dec 04 2004 Michael Scherer <misc@mandrake.org> 3.10.2-5mdk
310- Rebuild for new python
311
312* Wed Jun  9 2004 Götz Waschk <waschk@linux-mandrake.com> 3.10.2-4mdk
313- obsolete libsip10 too
314
315* Mon Jun  7 2004 Götz Waschk <waschk@linux-mandrake.com> 3.10.2-3mdk
316- drop library packages
317
318* Mon Jun 07 2004 Per Øyvind Karlsen <peroyvind@linux-mandrake.com> 3.10.2-2mdk
319- fix build and install problems
320- drop .so.*, they no longer exist
321- use %%{py_ver} macro
322
323* Sat Jun 05 2004 Per Øyvind Karlsen <peroyvind@linux-mandrake.com> 3.10.2-1mdk
324- 3.10.2
325
326* Fri Apr 23 2004 Götz Waschk <waschk@linux-mandrake.com> 3.10.1-1mdk
327- add sipconfig
328- major 11
329- add source URL
330- new version
331
332* Mon Sep  8 2003 Götz Waschk <waschk@linux-mandrake.com> 3.8-3mdk
333- fix buildrequires
334
335* Sun Sep  7 2003 Götz Waschk <waschk@linux-mandrake.com> 3.8-2mdk
336- fix buildrequires
337- move libsip.so to the lib package, as it's required by generated bindings
338- move sip to the devel package
339
340* Wed Aug 20 2003 Austin Acton <aacton@yorku.ca> 3.8-1mdk
341- 3.8
342
343* Sat Aug 9 2003 Austin Acton <aacton@yorku.ca> 3.6-8mdk
344- the one true fix (eat your heart out per oyvind :-) )
345
346* Fri Aug 08 2003 Per Øyvind Karlsen <peroyvind@linux-mandrake.com> 3.6-7mdk
347- really rebuild for new python (austin was the sucky one this time;)
348
349* Thu Aug 7 2003 Austin Acton <aacton@yorku.ca> 3.6-6mdk
350- python 2.3
351
352* Sat Jul 19 2003 Till Kamppeter <till@mandrakesoft.com> 3.6-5mdk
353- Rebuild
354
355* Fri Jun 20 2003 Per Øyvind Karlsen <peroyvind@sintrax.net> 3.6-4mdk
356- fix path to qt3 (lib64 issues)
357- use %%mklibname macro for -devel package
358
359* Tue May 27 2003 Austin Acton <aacton@yorku.ca> 3.6-3mdk
360- rebuild for rpm 4.2
361
362* Tue Apr 29 2003 Per Øyvind Karlsen <peroyvind@sintrax.net> 3.6-2mdk
363- added QPL to license
364
365* Tue Apr 29 2003 Per Øyvind Karlsen <peroyvind@sintrax.net> 3.6-1mdk
366- 3.6 (lib major 9)
367- cleanups
368- fix license
369- make --short-circuitable
370- use %%mklibname macro
371
372* Fri Jan 03 2003 Lenny Cartier <lenny@mandrakesoft.com> 3.5-1mdk
373- 3.5
374
375* Sat Aug 17 2002 Christian Belisle <cbelisle@mandrakesoft.com> 3.3.2-2mdk
376- fix Provides for libsip9.
377
378* Wed Jul 17 2002 Christian Belisle <cbelisle@mandrakesoft.com> 3.3.2-1mdk
379- 3.3.2
380- use the new sip's build script
381
382* Sat Jun 29 2002 Olivier Thauvin <thauvin@aerov.jussieu.fr> 3.2.4-1mdk
383- 3.2.4
384
385* Tue May 28 2002 Lenny Cartier <lenny@mandrakesoft.com> 3.2.2-2mdk
386- rebuild against new libstdc++
387
388* Mon May 13 2002 Lenny Cartier <lenny@mandrakesoft.com> 3.2.2-1mdk
389- 3.2.2
390
391* Tue May 07 2002 Lenny Cartier <lenny@mandrakesoft.com> 3.2.1-1mdk
392- 3.2.1
393
394* Mon Apr 08 2002 Christian Belisle <cbelisle@mandrakesoft.com> 3.1-1mdk
395- version 3.1 (lib major 8).
396- update URL.
397
398* Fri Jan 11 2002 Lenny Cartier <lenny@mandrakesoft.com> 3.0-3mdk
399- merge with  RA <ralf_ahlbrink@web.de> mods :
400        - added BuildRequires: libpython2.2-devel
401
402* Fri Nov 30 2001 Yves Duret <yduret@mandrakesoft.com> 3.0-1mdk
403- version 3.0 (lib major 7)
404
405* Fri Nov 30 2001 Yves Duret <yduret@mandrakesoft.com> 2.5-2mdk
406- rebuild against libpng3
407- %%makeinstall_std
408- std %%build step (macros..)
409- added %%dir %%{_includedir}/sip in -devel package
410
411* Mon Sep 03 2001 Lenny Cartier <lenny@mandrakesoft.com> 2.5-1mdk
412- 2.5
413
414* Mon May 14 2001 Yves BAILLY <ybailly@mandrakesoft.com> 2.4-3mdk
415- fixed some errors in spec file (sorry, my first package)
416
417* Mon May 14 2001 Yves BAILLY <ybailly@mandrakesoft.com> 2.4-2mdk
418- fixed the Python dependency (>= 2.0 instead of = 2.0)
419
420* Mon May 14 2001 Yves BAILLY <ybailly@mandrakesoft.com> 2.4-1mdk
421- upgrade to version 2.4
422
423* Tue Mar 20 2001 David BAUDENS <baudens@mandrakesoft.com> 2.3-2mdk
424- Rebuild against Qt 2.3.0
425
426* Wed Feb 21 2001 Lenny Cartier <lenny@mandrakesoft.com> 2.3-1mdk
427- updated to 2.3
428
429* Mon Feb 12 2001 Lenny Cartier <lenny@mandrakesoft.com> 2.2-1mdk
430- used srpm from Gerard Vermeulen <gvermeul@labs.polycnrs-gre.fr>
431        - built on Mandrake-7.2 following Mandrake RPM guidelines
432
433
Note: See TracBrowser for help on using the repository browser.