source: projects/specs/trunk/s/shotwell/shotwell-vl.spec @ 8056

Revision 8056, 9.0 KB checked in by Takemikaduchi, 10 years ago (diff)

KDE-4.11.4
exiv2-0.24
wireshark-1.10.5, etc...

Line 
1Name:           shotwell
2Version:        0.15.1
3Release:        2%{?_dist_release}
4Summary:        A photo manager for the GNOME desktop
5Summary(ja):    GNOME デスクトップ向けの写真管理ツール
6
7Group:          Applications/Graphics
8# LGPLv2+ for the code
9# CC-BY-SA for some of the icons
10License:        LGPLv2+ and CC-BY-SA
11URL:            http://www.yorba.org/shotwell/
12
13Source0:        http://www.yorba.org/download/shotwell/stable/shotwell-%{version}.tar.xz
14# http://trac.yorba.org/ticket/3379
15Source1:        shotwell-icons.tar.bz2
16
17# http://redmine.yorba.org/issues/5181
18Patch0:         shotwell-usrmove.patch
19
20BuildRoot:      %{_tmppath}/%{name}-%{version}-root
21
22BuildRequires:  GConf2-devel
23BuildRequires:  LibRaw-devel
24BuildRequires:  LibRaw-static
25BuildRequires:  WebKit3-gtk-devel
26BuildRequires:  dbus-glib-devel
27BuildRequires:  desktop-file-utils
28BuildRequires:  gettext
29BuildRequires:  gtk3-devel
30#BuildRequires:  gstreamer-devel
31#BuildRequires:  gstreamer-plugins-base-devel
32BuildRequires:  gstreamer1-devel
33BuildRequires:  gstreamer1-plugins-base-devel
34BuildRequires:  json-glib-devel
35BuildRequires:  libexif-devel
36BuildRequires:  libgee-devel
37BuildRequires:  libgee-vala
38BuildRequires:  libgphoto2-devel
39BuildRequires:  libgudev1-devel
40BuildRequires:  libgexiv2-devel >= 0.2.0
41BuildRequires:  libsoup-devel
42BuildRequires:  libxml2-devel
43BuildRequires:  lcms2-devel
44BuildRequires:  sqlite3-devel
45BuildRequires:  unique3-devel
46BuildRequires:  vala-devel >= 0.9.5
47BuildRequires:  rest-devel
48
49# used by shotwell-settings-migrator
50Requires: dconf
51
52Vendor: Project Vine
53Distribution: Vine Linux
54Packager: kudoh
55
56%description
57Shotwell is a new open source photo manager designed for the GNOME desktop
58environment. It allows you to import photos from your camera, view and edit
59them, and share them with others.
60
61%description -l ja
62Shotwell は GNOME デスクトップ環境用に設計された新しいオープンソースの
63画像管理ツールです。
64あなたのカメラから写真を取り込んだり、それらを表示・編集したり、
65他の人々と共有するなどができます。
66
67%prep
68%setup -q -n %{name}-%{version}
69%patch0 -p1 -b .usrmove
70
71%build
72# We can't use the configure macro: it's not a standard autotools configure script
73export CFLAGS="%{optflags}"
74export LIB=%{_lib}
75
76# HACK: Remove fatal-warnings to succeed build with vala 0.13.
77#sed -i "s:--fatal-warnings ::g" Makefile plugins/Makefile.plugin.mk
78./configure --prefix=%{_prefix} --lib=%{_lib} --disable-schemas-install
79#sed -i -e 's/\\n/\n/g' configure.mk
80make %{?_smp_mflags}
81
82
83%install
84rm -rf $RPM_BUILD_ROOT
85export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
86export XDG_DISABLE_MAKEFILE_UPDATES=1
87# otherwise gettext always returns English text regardless of LANGUAGE asked
88export LANG=en_US.utf8
89make install DESTDIR=$RPM_BUILD_ROOT
90
91desktop-file-validate $RPM_BUILD_ROOT%{_datadir}/applications/shotwell.desktop
92desktop-file-validate $RPM_BUILD_ROOT%{_datadir}/applications/shotwell-viewer.desktop
93
94# put hi-res icons in place
95(
96  cd $RPM_BUILD_ROOT%{_datadir}/icons/hicolor
97  rm -rf 16x16 24x24 scalable
98  tar xf %{SOURCE1}
99)
100
101%find_lang %{name} --all-name
102
103%clean
104rm -rf $RPM_BUILD_ROOT
105
106%post
107touch --no-create %{_datadir}/icons/hicolor &>/dev/null || :
108update-desktop-database &> /dev/null || :
109
110%postun
111if [ $1 -eq 0 ] ; then
112  touch --no-create %{_datadir}/icons/hicolor &>/dev/null
113  gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor &>/dev/null || :
114  glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
115fi
116update-desktop-database &> /dev/null || :
117
118%posttrans
119gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor &>/dev/null || :
120glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
121
122%files -f %{name}.lang
123%defattr(-,root,root,-)
124%doc README COPYING MAINTAINERS NEWS THANKS AUTHORS
125%{_bindir}/shotwell
126%{_libexecdir}/shotwell/shotwell-settings-migrator
127%{_libexecdir}/shotwell/shotwell-video-thumbnailer
128%{_libdir}/shotwell/plugins/builtin
129%{_datadir}/GConf/gsettings/shotwell.convert
130%{_datadir}/glib-2.0/schemas/org.yorba.shotwell-extras.gschema.xml
131%{_datadir}/glib-2.0/schemas/org.yorba.shotwell.gschema.xml
132%{_datadir}/gnome/help/
133%{_datadir}/shotwell
134%{_datadir}/appdata/shotwell.appdata.xml
135%{_datadir}/applications/shotwell.desktop
136%{_datadir}/applications/shotwell-viewer.desktop
137%{_datadir}/icons/hicolor/*
138%exclude %{_datadir}/icons/hicolor/icon-theme.cache
139%exclude %{_datadir}/glib-2.0/schemas/gschemas.compiled
140
141
142%changelog
143* Wed Dec 11 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 0.15.1-2
144- rebuild with exiv2-0.24
145
146* Sat Nov 30 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 0.15.1-1
147- new upstream release
148- remove Patch1 (0001-Port-to-GStreamer-1.0.patch)
149- change BuildRequires: libgee-devel instead of libgee06-devel
150- add BuildRequires: libgee-vala
151
152* Fri Jan 11 2013 IWAI, Masaharu <iwai@alib.jp> - 0.13.1-2
153- build with libgphoto2 2.5.0-1
154
155* Sat Oct 20 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.13.1-1
156- new upstream release
157- changed archive typr to xz
158- changed BuildRequires: libgee-devel to libgee06-devel
159- changed BuildRequires: gstreamer-devel and gstreamer-plugins-base-devel to
160  gstreamer1-devel and gstreamer1-plugins-base-devel
161- added Requires: dconf
162- added Patch0,1 from Fedora
163
164* Sun Jul 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 0.12.3-2
165- rebuild with exiv2-0.23
166
167* Thu May 10 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.12.3-1
168- new upstream release
169- dropt Source2
170
171* Sun Apr 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 0.12.2-1
172- new upstream release
173- remove Patch0
174- change BuildRequires: gtk3-devel instead of gtk2-devel
175- change BuildRequires: WebKit3-gtk-devel instead of WebKit-gtk-devel
176- change BuildRequires: unique3-devel instead of unique-devel
177- remove BuildRequires: hal-devel
178- add BuildRequires: rest-devel, lcms2-devel
179
180* Sun Nov 13 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.11.6-1
181- new upstream release
182
183* Thu Oct 20 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.11.5-1
184- new upstream release
185
186* Fri Oct 14 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.11.4-1
187- new upstream release
188
189* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.11.2-1
190- new upstream release
191- add Patch0 (shotwell-0.11.1-vala-0.14.patch)
192- add BuildRequires: gstreamer-plugins-base-devel
193
194* Sat Aug 27 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.1-2
195- rebuilt with libgexiv2-0.2.2-2
196
197* Wed Aug 17 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.10.1-1
198- new upstream release
199
200* Sat Jun 18 2011 IWAI, Masaharu <iwai@alib.jp> 0.8.1-5
201- add ja.po (Source2): fix <BTS:VineLinux:1142>
202- update Summary and description
203
204* Fri Jun 10 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.1-4
205- add hi-res icons (SOURCE1)
206- add LANG=en_US.utf8 to get gettext to actually generate translated strings
207
208* Sat Jun 04 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.8.1-3
209- dropt Patch0
210- added BuildRequires: LibRaw-static
211
212* Sun Apr 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 0.8.1-2
213- add Patch1 (shotwell-0.8.1-vala.patch)
214
215* Wed Jan 12 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.8.1-1
216- new upstream release
217- added BuildRequires: gstreamer-devel, json-glib-devel, libsoup-devel, libxml2-devel
218
219* Tue Sep 28 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.7.2-2
220- rebuilt with rpm-4.8.1 for pkg-config
221- fixed %%changelog in Tue Sep 14 2010
222
223* Tue Sep 14 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.7.2-1
224- new upstream release
225- changed source URL
226- added Patch0 to work around desktop file incorrect comment
227- changed BuildRequires: vala-devel >= 0.9.5
228
229* Fri Aug 27 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.7.1-1
230- new upstream release
231
232* Sat Aug 21 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.7.0-1
233- new upstream release
234- changed BuildRequires: libgexiv2-devel >= 0.2.0
235
236* Thu Jul 22 2010 Shu KONNO <owa@bg.wakwak.com> - 0.6.1-2
237- fixed LIB_DIRS in libraw-config (for lib64)
238
239* Wed Jul 14 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.6.1-1
240- new upstream release
241- added BuildRequires: LibRaw-devel, libgexiv2-devel
242
243* Wed May 12 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.5.2-1
244- new upstream release
245
246* Sat Mar 13 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.5.0-1
247- new upstream release
248- added BuildRequires:  libgudev1-devel
249- applied new naming policy to spec
250
251* Wed Jan 20 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.4.3-1
252- new upstream release
253- proved Japanese description
254
255* Thu Jan 7 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.4.2-1
256- new upstrema release
257
258* Wed Dec 30 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.4.1-1
259- intial build for VineSeed
260
261* Fri Dec 18 2009 Matthias Clasen <mclasen@redhat.com> - 0.4.0-0.1.20091218svn
262* Thu Nov 12 2009 Matthias Clasen <mclasen@redhat.com> - 0.3.2-1
263- Update to 0.3.2
264
265* Tue Nov  3 2009 Matthias Clasen <mclasen@redhat.com> - 0.3.0-1
266- Version 0.3.0
267
268* Thu Aug 20 2009 Michel Salim <salimma@fedoraproject.org> - 0.2.0-3
269- Rebuild against new libgee
270
271* Wed Aug 12 2009  Matthias Clasen <mclasen@redhat.com> - 0.2.0-2.fc12
272- Bring icon cache handling in sync with current guidelines
273
274* Sun Aug  9 2009  Matthias Clasen <mclasen@redhat.com> - 0.2.0-1.fc12
275- Initial packaging
Note: See TracBrowser for help on using the repository browser.