source: projects/specs/trunk/s/shotwell/shotwell-vl.spec @ 8011

Revision 8011, 8.9 KB checked in by Takemikaduchi, 11 years ago (diff)

new upstream release

Line 
1Name:           shotwell
2Version:        0.15.1
3Release:        1%{?_dist_release}
4Summary:        A photo manager for the GNOME desktop
5Summary(ja):    GNOME デスクトップ向けの写真管理ツール
6
7Group:          Applications/Graphics
8# LGPLv2+ for the code
9# CC-BY-SA for some of the icons
10License:        LGPLv2+ and CC-BY-SA
11URL:            http://www.yorba.org/shotwell/
12
13Source0:        http://www.yorba.org/download/shotwell/stable/shotwell-%{version}.tar.xz
14# http://trac.yorba.org/ticket/3379
15Source1:        shotwell-icons.tar.bz2
16
17# http://redmine.yorba.org/issues/5181
18Patch0:         shotwell-usrmove.patch
19
20BuildRoot:      %{_tmppath}/%{name}-%{version}-root
21
22BuildRequires:  GConf2-devel
23BuildRequires:  LibRaw-devel
24BuildRequires:  LibRaw-static
25BuildRequires:  WebKit3-gtk-devel
26BuildRequires:  dbus-glib-devel
27BuildRequires:  desktop-file-utils
28BuildRequires:  gettext
29BuildRequires:  gtk3-devel
30#BuildRequires:  gstreamer-devel
31#BuildRequires:  gstreamer-plugins-base-devel
32BuildRequires:  gstreamer1-devel
33BuildRequires:  gstreamer1-plugins-base-devel
34BuildRequires:  json-glib-devel
35BuildRequires:  libexif-devel
36BuildRequires:  libgee-devel
37BuildRequires:  libgee-vala
38BuildRequires:  libgphoto2-devel
39BuildRequires:  libgudev1-devel
40BuildRequires:  libgexiv2-devel >= 0.2.0
41BuildRequires:  libsoup-devel
42BuildRequires:  libxml2-devel
43BuildRequires:  lcms2-devel
44BuildRequires:  sqlite3-devel
45BuildRequires:  unique3-devel
46BuildRequires:  vala-devel >= 0.9.5
47BuildRequires:  rest-devel
48
49# used by shotwell-settings-migrator
50Requires: dconf
51
52Vendor: Project Vine
53Distribution: Vine Linux
54Packager: kudoh
55
56%description
57Shotwell is a new open source photo manager designed for the GNOME desktop
58environment. It allows you to import photos from your camera, view and edit
59them, and share them with others.
60
61%description -l ja
62Shotwell は GNOME デスクトップ環境用に設計された新しいオープンソースの
63画像管理ツールです。
64あなたのカメラから写真を取り込んだり、それらを表示・編集したり、
65他の人々と共有するなどができます。
66
67%prep
68%setup -q -n %{name}-%{version}
69%patch0 -p1 -b .usrmove
70
71%build
72# We can't use the configure macro: it's not a standard autotools configure script
73export CFLAGS="%{optflags}"
74export LIB=%{_lib}
75
76# HACK: Remove fatal-warnings to succeed build with vala 0.13.
77#sed -i "s:--fatal-warnings ::g" Makefile plugins/Makefile.plugin.mk
78./configure --prefix=%{_prefix} --lib=%{_lib} --disable-schemas-install
79#sed -i -e 's/\\n/\n/g' configure.mk
80make %{?_smp_mflags}
81
82
83%install
84rm -rf $RPM_BUILD_ROOT
85export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
86export XDG_DISABLE_MAKEFILE_UPDATES=1
87# otherwise gettext always returns English text regardless of LANGUAGE asked
88export LANG=en_US.utf8
89make install DESTDIR=$RPM_BUILD_ROOT
90
91desktop-file-validate $RPM_BUILD_ROOT%{_datadir}/applications/shotwell.desktop
92desktop-file-validate $RPM_BUILD_ROOT%{_datadir}/applications/shotwell-viewer.desktop
93
94# put hi-res icons in place
95(
96  cd $RPM_BUILD_ROOT%{_datadir}/icons/hicolor
97  rm -rf 16x16 24x24 scalable
98  tar xf %{SOURCE1}
99)
100
101%find_lang %{name} --all-name
102
103%clean
104rm -rf $RPM_BUILD_ROOT
105
106%post
107touch --no-create %{_datadir}/icons/hicolor &>/dev/null || :
108update-desktop-database &> /dev/null || :
109
110%postun
111if [ $1 -eq 0 ] ; then
112  touch --no-create %{_datadir}/icons/hicolor &>/dev/null
113  gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor &>/dev/null || :
114  glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
115fi
116update-desktop-database &> /dev/null || :
117
118%posttrans
119gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor &>/dev/null || :
120glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
121
122%files -f %{name}.lang
123%defattr(-,root,root,-)
124%doc README COPYING MAINTAINERS NEWS THANKS AUTHORS
125%{_bindir}/shotwell
126%{_libexecdir}/shotwell/shotwell-settings-migrator
127%{_libexecdir}/shotwell/shotwell-video-thumbnailer
128%{_libdir}/shotwell/plugins/builtin
129%{_datadir}/GConf/gsettings/shotwell.convert
130%{_datadir}/glib-2.0/schemas/org.yorba.shotwell-extras.gschema.xml
131%{_datadir}/glib-2.0/schemas/org.yorba.shotwell.gschema.xml
132%{_datadir}/gnome/help/
133%{_datadir}/shotwell
134%{_datadir}/appdata/shotwell.appdata.xml
135%{_datadir}/applications/shotwell.desktop
136%{_datadir}/applications/shotwell-viewer.desktop
137%{_datadir}/icons/hicolor/*
138%exclude %{_datadir}/icons/hicolor/icon-theme.cache
139%exclude %{_datadir}/glib-2.0/schemas/gschemas.compiled
140
141
142%changelog
143* Sat Nov 30 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 0.15.1-1
144- new upstream release
145- remove Patch1 (0001-Port-to-GStreamer-1.0.patch)
146- change BuildRequires: libgee-devel instead of libgee06-devel
147- add BuildRequires: libgee-vala
148
149* Fri Jan 11 2013 IWAI, Masaharu <iwai@alib.jp> - 0.13.1-2
150- build with libgphoto2 2.5.0-1
151
152* Sat Oct 20 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.13.1-1
153- new upstream release
154- changed archive typr to xz
155- changed BuildRequires: libgee-devel to libgee06-devel
156- changed BuildRequires: gstreamer-devel and gstreamer-plugins-base-devel to
157  gstreamer1-devel and gstreamer1-plugins-base-devel
158- added Requires: dconf
159- added Patch0,1 from Fedora
160
161* Sun Jul 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 0.12.3-2
162- rebuild with exiv2-0.23
163
164* Thu May 10 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.12.3-1
165- new upstream release
166- dropt Source2
167
168* Sun Apr 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 0.12.2-1
169- new upstream release
170- remove Patch0
171- change BuildRequires: gtk3-devel instead of gtk2-devel
172- change BuildRequires: WebKit3-gtk-devel instead of WebKit-gtk-devel
173- change BuildRequires: unique3-devel instead of unique-devel
174- remove BuildRequires: hal-devel
175- add BuildRequires: rest-devel, lcms2-devel
176
177* Sun Nov 13 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.11.6-1
178- new upstream release
179
180* Thu Oct 20 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.11.5-1
181- new upstream release
182
183* Fri Oct 14 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.11.4-1
184- new upstream release
185
186* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.11.2-1
187- new upstream release
188- add Patch0 (shotwell-0.11.1-vala-0.14.patch)
189- add BuildRequires: gstreamer-plugins-base-devel
190
191* Sat Aug 27 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.1-2
192- rebuilt with libgexiv2-0.2.2-2
193
194* Wed Aug 17 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.10.1-1
195- new upstream release
196
197* Sat Jun 18 2011 IWAI, Masaharu <iwai@alib.jp> 0.8.1-5
198- add ja.po (Source2): fix <BTS:VineLinux:1142>
199- update Summary and description
200
201* Fri Jun 10 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.1-4
202- add hi-res icons (SOURCE1)
203- add LANG=en_US.utf8 to get gettext to actually generate translated strings
204
205* Sat Jun 04 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.8.1-3
206- dropt Patch0
207- added BuildRequires: LibRaw-static
208
209* Sun Apr 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 0.8.1-2
210- add Patch1 (shotwell-0.8.1-vala.patch)
211
212* Wed Jan 12 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.8.1-1
213- new upstream release
214- added BuildRequires: gstreamer-devel, json-glib-devel, libsoup-devel, libxml2-devel
215
216* Tue Sep 28 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.7.2-2
217- rebuilt with rpm-4.8.1 for pkg-config
218- fixed %%changelog in Tue Sep 14 2010
219
220* Tue Sep 14 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.7.2-1
221- new upstream release
222- changed source URL
223- added Patch0 to work around desktop file incorrect comment
224- changed BuildRequires: vala-devel >= 0.9.5
225
226* Fri Aug 27 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.7.1-1
227- new upstream release
228
229* Sat Aug 21 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.7.0-1
230- new upstream release
231- changed BuildRequires: libgexiv2-devel >= 0.2.0
232
233* Thu Jul 22 2010 Shu KONNO <owa@bg.wakwak.com> - 0.6.1-2
234- fixed LIB_DIRS in libraw-config (for lib64)
235
236* Wed Jul 14 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.6.1-1
237- new upstream release
238- added BuildRequires: LibRaw-devel, libgexiv2-devel
239
240* Wed May 12 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.5.2-1
241- new upstream release
242
243* Sat Mar 13 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.5.0-1
244- new upstream release
245- added BuildRequires:  libgudev1-devel
246- applied new naming policy to spec
247
248* Wed Jan 20 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.4.3-1
249- new upstream release
250- proved Japanese description
251
252* Thu Jan 7 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.4.2-1
253- new upstrema release
254
255* Wed Dec 30 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.4.1-1
256- intial build for VineSeed
257
258* Fri Dec 18 2009 Matthias Clasen <mclasen@redhat.com> - 0.4.0-0.1.20091218svn
259* Thu Nov 12 2009 Matthias Clasen <mclasen@redhat.com> - 0.3.2-1
260- Update to 0.3.2
261
262* Tue Nov  3 2009 Matthias Clasen <mclasen@redhat.com> - 0.3.0-1
263- Version 0.3.0
264
265* Thu Aug 20 2009 Michel Salim <salimma@fedoraproject.org> - 0.2.0-3
266- Rebuild against new libgee
267
268* Wed Aug 12 2009  Matthias Clasen <mclasen@redhat.com> - 0.2.0-2.fc12
269- Bring icon cache handling in sync with current guidelines
270
271* Sun Aug  9 2009  Matthias Clasen <mclasen@redhat.com> - 0.2.0-1.fc12
272- Initial packaging
Note: See TracBrowser for help on using the repository browser.