source: projects/specs/trunk/s/shotwell/shotwell-vl.spec @ 7336

Revision 7336, 8.7 KB checked in by iwaim, 11 years ago (diff)

shotwell 0.13.1-2

Line 
1Name:           shotwell
2Version:        0.13.1
3Release:        2%{?_dist_release}
4Summary:        A photo manager for the GNOME desktop
5Summary(ja):    GNOME デスクトップ向けの写真管理ツール
6
7Group:          Applications/Graphics
8# LGPLv2+ for the code
9# CC-BY-SA for some of the icons
10License:        LGPLv2+ and CC-BY-SA
11URL:            http://www.yorba.org/shotwell/
12
13Source0:        http://www.yorba.org/download/shotwell/stable/shotwell-%{version}.tar.xz
14# http://trac.yorba.org/ticket/3379
15Source1:        shotwell-icons.tar.bz2
16
17# http://redmine.yorba.org/issues/5181
18Patch0:         shotwell-usrmove.patch
19# http://redmine.yorba.org/issues/5548
20Patch1:         0001-Port-to-GStreamer-1.0.patch
21
22BuildRoot:      %{_tmppath}/%{name}-%{version}-root
23
24BuildRequires:  GConf2-devel
25BuildRequires:  LibRaw-devel
26BuildRequires:  LibRaw-static
27BuildRequires:  WebKit3-gtk-devel
28BuildRequires:  dbus-glib-devel
29BuildRequires:  desktop-file-utils
30BuildRequires:  gettext
31BuildRequires:  gtk3-devel
32#BuildRequires:  gstreamer-devel
33#BuildRequires:  gstreamer-plugins-base-devel
34BuildRequires:  gstreamer1-devel
35BuildRequires:  gstreamer1-plugins-base-devel
36BuildRequires:  json-glib-devel
37BuildRequires:  libexif-devel
38BuildRequires:  libgee06-devel
39BuildRequires:  libgphoto2-devel
40BuildRequires:  libgudev1-devel
41BuildRequires:  libgexiv2-devel >= 0.2.0
42BuildRequires:  libsoup-devel
43BuildRequires:  libxml2-devel
44BuildRequires:  lcms2-devel
45BuildRequires:  sqlite3-devel
46BuildRequires:  unique3-devel
47BuildRequires:  vala-devel >= 0.9.5
48BuildRequires:  rest-devel
49
50# used by shotwell-settings-migrator
51Requires: dconf
52
53Vendor: Project Vine
54Distribution: Vine Linux
55Packager: kudoh
56
57%description
58Shotwell is a new open source photo manager designed for the GNOME desktop
59environment. It allows you to import photos from your camera, view and edit
60them, and share them with others.
61
62%description -l ja
63Shotwell は GNOME デスクトップ環境用に設計された新しいオープンソースの
64画像管理ツールです。
65あなたのカメラから写真を取り込んだり、それらを表示・編集したり、
66他の人々と共有するなどができます。
67
68%prep
69%setup -q -n %{name}-%{version}
70%patch0 -p1 -b .usrmove
71%patch1 -p1
72
73%build
74# We can't use the configure macro: it's not a standard autotools configure script
75export CFLAGS="%{optflags}"
76export LIB=%{_lib}
77
78# HACK: Remove fatal-warnings to succeed build with vala 0.13.
79#sed -i "s:--fatal-warnings ::g" Makefile plugins/Makefile.plugin.mk
80./configure --prefix=%{_prefix} --lib=%{_lib} --disable-schemas-install
81#sed -i -e 's/\\n/\n/g' configure.mk
82make %{?_smp_mflags}
83
84
85%install
86rm -rf $RPM_BUILD_ROOT
87export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
88export XDG_DISABLE_MAKEFILE_UPDATES=1
89# otherwise gettext always returns English text regardless of LANGUAGE asked
90export LANG=en_US.utf8
91make install DESTDIR=$RPM_BUILD_ROOT
92
93desktop-file-validate $RPM_BUILD_ROOT%{_datadir}/applications/shotwell.desktop
94desktop-file-validate $RPM_BUILD_ROOT%{_datadir}/applications/shotwell-viewer.desktop
95
96# put hi-res icons in place
97(
98  cd $RPM_BUILD_ROOT%{_datadir}/icons/hicolor
99  rm -rf 16x16 24x24 scalable
100  tar xf %{SOURCE1}
101)
102
103%find_lang %{name} --all-name
104
105%clean
106rm -rf $RPM_BUILD_ROOT
107
108%post
109touch --no-create %{_datadir}/icons/hicolor &>/dev/null || :
110update-desktop-database &> /dev/null || :
111
112%postun
113if [ $1 -eq 0 ] ; then
114  touch --no-create %{_datadir}/icons/hicolor &>/dev/null
115  gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor &>/dev/null || :
116  glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
117fi
118update-desktop-database &> /dev/null || :
119
120%posttrans
121gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor &>/dev/null || :
122glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
123
124%files -f %{name}.lang
125%defattr(-,root,root,-)
126%doc README COPYING MAINTAINERS NEWS THANKS AUTHORS
127%{_bindir}/shotwell
128%{_bindir}/shotwell-video-thumbnailer
129%{_libexecdir}/shotwell/shotwell-settings-migrator
130%{_libdir}/shotwell/plugins/builtin
131%{_datadir}/GConf/gsettings/shotwell.convert
132%{_datadir}/glib-2.0/schemas/org.yorba.shotwell-extras.gschema.xml
133%{_datadir}/glib-2.0/schemas/org.yorba.shotwell.gschema.xml
134%{_datadir}/gnome/help/
135%{_datadir}/shotwell
136%{_datadir}/applications/shotwell.desktop
137%{_datadir}/applications/shotwell-viewer.desktop
138%{_datadir}/icons/hicolor/*
139%exclude %{_datadir}/icons/hicolor/icon-theme.cache
140%exclude %{_datadir}/glib-2.0/schemas/gschemas.compiled
141
142
143%changelog
144* Fri Jan 11 2013 IWAI, Masaharu <iwai@alib.jp> - 0.13.1-2
145- build with libgphoto2 2.5.0-1
146
147* Sat Oct 20 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.13.1-1
148- new upstream release
149- changed archive typr to xz
150- changed BuildRequires: libgee-devel to libgee06-devel
151- changed BuildRequires: gstreamer-devel and gstreamer-plugins-base-devel to
152  gstreamer1-devel and gstreamer1-plugins-base-devel
153- added Requires: dconf
154- added Patch0,1 from Fedora
155
156* Sun Jul 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 0.12.3-2
157- rebuild with exiv2-0.23
158
159* Thu May 10 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.12.3-1
160- new upstream release
161- dropt Source2
162
163* Sun Apr 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 0.12.2-1
164- new upstream release
165- remove Patch0
166- change BuildRequires: gtk3-devel instead of gtk2-devel
167- change BuildRequires: WebKit3-gtk-devel instead of WebKit-gtk-devel
168- change BuildRequires: unique3-devel instead of unique-devel
169- remove BuildRequires: hal-devel
170- add BuildRequires: rest-devel, lcms2-devel
171
172* Sun Nov 13 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.11.6-1
173- new upstream release
174
175* Thu Oct 20 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.11.5-1
176- new upstream release
177
178* Fri Oct 14 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.11.4-1
179- new upstream release
180
181* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.11.2-1
182- new upstream release
183- add Patch0 (shotwell-0.11.1-vala-0.14.patch)
184- add BuildRequires: gstreamer-plugins-base-devel
185
186* Sat Aug 27 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.1-2
187- rebuilt with libgexiv2-0.2.2-2
188
189* Wed Aug 17 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.10.1-1
190- new upstream release
191
192* Sat Jun 18 2011 IWAI, Masaharu <iwai@alib.jp> 0.8.1-5
193- add ja.po (Source2): fix <BTS:VineLinux:1142>
194- update Summary and description
195
196* Fri Jun 10 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.1-4
197- add hi-res icons (SOURCE1)
198- add LANG=en_US.utf8 to get gettext to actually generate translated strings
199
200* Sat Jun 04 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.8.1-3
201- dropt Patch0
202- added BuildRequires: LibRaw-static
203
204* Sun Apr 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 0.8.1-2
205- add Patch1 (shotwell-0.8.1-vala.patch)
206
207* Wed Jan 12 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.8.1-1
208- new upstream release
209- added BuildRequires: gstreamer-devel, json-glib-devel, libsoup-devel, libxml2-devel
210
211* Tue Sep 28 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.7.2-2
212- rebuilt with rpm-4.8.1 for pkg-config
213- fixed %%changelog in Tue Sep 14 2010
214
215* Tue Sep 14 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.7.2-1
216- new upstream release
217- changed source URL
218- added Patch0 to work around desktop file incorrect comment
219- changed BuildRequires: vala-devel >= 0.9.5
220
221* Fri Aug 27 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.7.1-1
222- new upstream release
223
224* Sat Aug 21 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.7.0-1
225- new upstream release
226- changed BuildRequires: libgexiv2-devel >= 0.2.0
227
228* Thu Jul 22 2010 Shu KONNO <owa@bg.wakwak.com> - 0.6.1-2
229- fixed LIB_DIRS in libraw-config (for lib64)
230
231* Wed Jul 14 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.6.1-1
232- new upstream release
233- added BuildRequires: LibRaw-devel, libgexiv2-devel
234
235* Wed May 12 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.5.2-1
236- new upstream release
237
238* Sat Mar 13 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.5.0-1
239- new upstream release
240- added BuildRequires:  libgudev1-devel
241- applied new naming policy to spec
242
243* Wed Jan 20 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.4.3-1
244- new upstream release
245- proved Japanese description
246
247* Thu Jan 7 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.4.2-1
248- new upstrema release
249
250* Wed Dec 30 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.4.1-1
251- intial build for VineSeed
252
253* Fri Dec 18 2009 Matthias Clasen <mclasen@redhat.com> - 0.4.0-0.1.20091218svn
254* Thu Nov 12 2009 Matthias Clasen <mclasen@redhat.com> - 0.3.2-1
255- Update to 0.3.2
256
257* Tue Nov  3 2009 Matthias Clasen <mclasen@redhat.com> - 0.3.0-1
258- Version 0.3.0
259
260* Thu Aug 20 2009 Michel Salim <salimma@fedoraproject.org> - 0.2.0-3
261- Rebuild against new libgee
262
263* Sun Aug 12 2009  Matthias Clasen <mclasen@redhat.com> - 0.2.0-2.fc12
264- Bring icon cache handling in sync with current guidelines
265
266* Sun Aug  9 2009  Matthias Clasen <mclasen@redhat.com> - 0.2.0-1.fc12
267- Initial packaging
Note: See TracBrowser for help on using the repository browser.