source: projects/specs/trunk/s/shotwell/shotwell-vl.spec @ 1939

Revision 1939, 5.5 KB checked in by kudoh, 14 years ago (diff)
Line 
1Name:           shotwell
2Version:        0.7.2
3Release:        2%{?_dist_release}
4Summary:        A photo organizer for the GNOME desktop
5Summary(ja):    GNOME デスクトップ向けの画像整理ソフト
6
7Group:          Applications/Graphics
8# LGPLv2+ for the code
9# CC-BY-SA for some of the icons
10License:        LGPLv2+ and CC-BY-SA
11URL:            http://www.yorba.org/shotwell/
12Source0:        http://www.yorba.org/download/shotwell/0.7/shotwell-%{version}.tar.bz2
13# svn co svn://svn.yorba.org/shotwell/branches/shotwell-0.4, make dist
14Patch0:         workaround_desktop.patch
15
16BuildRoot:      %{_tmppath}/%{name}-%{version}-root
17
18BuildRequires:  GConf2-devel
19BuildRequires:  LibRaw-devel
20BuildRequires:  WebKit-gtk-devel
21BuildRequires:  dbus-glib-devel
22BuildRequires:  desktop-file-utils
23BuildRequires:  gettext
24BuildRequires:  gtk2-devel
25BuildRequires:  hal-devel
26BuildRequires:  libexif-devel
27BuildRequires:  libgee-devel
28BuildRequires:  libgphoto2-devel
29BuildRequires:  libgudev1-devel
30BuildRequires:  libgexiv2-devel >= 0.2.0
31BuildRequires:  sqlite3-devel
32BuildRequires:  unique-devel
33BuildRequires:  vala-devel >= 0.9.5
34
35%description
36Shotwell is a new open source photo organizer designed for the GNOME desktop
37environment. It allows you to import photos from your camera, view and edit
38them, and share them with others.
39
40%description -l ja
41Shotwell は GNOME デスクトップ環境用に設計された新しいオープンソースの
42画像整理ソフトです。
43あなたのカメラから写真を取り込んだり、それらを表示・編集したり、
44他の人々と共有するなどができます。
45
46%prep
47%setup -q -n %{name}-%{version}
48%patch0 -p1
49
50%build
51./configure --prefix=/usr --disable-schemas-install --assume-pkgs
52sed -i -e 's/\\n/\n/g' configure.mk
53sed -i -e 's/^CFLAGS=.*$/CFLAGS=%{optflags}/' Makefile
54sed -i -e 's|LIB_DIRS=.*$|LIB_DIRS=%{_libdir}|' libraw-config
55make %{?_smp_mflags}
56
57
58%install
59rm -rf $RPM_BUILD_ROOT
60export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
61export XDG_DISABLE_MAKEFILE_UPDATES=1
62make install DESTDIR=$RPM_BUILD_ROOT
63
64desktop-file-validate $RPM_BUILD_ROOT%{_datadir}/applications/shotwell.desktop
65desktop-file-validate $RPM_BUILD_ROOT%{_datadir}/applications/shotwell-viewer.desktop
66
67%find_lang %{name}
68
69%clean
70rm -rf $RPM_BUILD_ROOT
71
72%post
73touch --no-create %{_datadir}/icons/hicolor &>/dev/null || :
74update-desktop-database &> /dev/null || :
75export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
76gconftool-2 --makefile-install-rule %{_sysconfdir}/gconf/schemas/shotwell.schemas > /dev/null || :
77
78%pre
79if [ "$1" -gt 1 ]; then
80  export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
81  gconftool-2 --makefile-uninstall-rule %{_sysconfdir}/gconf/schemas/shotwell.schemas > /dev/null || :
82fi
83
84%preun
85if [ "$1" -eq 0 ]; then
86  export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
87  gconftool-2 --makefile-uninstall-rule %{_sysconfdir}/gconf/schemas/shotwell.schemas > /dev/null || :
88fi
89
90%postun
91if [ $1 -eq 0 ] ; then
92  touch --no-create %{_datadir}/icons/hicolor &>/dev/null
93  gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor &>/dev/null || :
94fi
95update-desktop-database &> /dev/null || :
96
97%posttrans
98gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor &>/dev/null || :
99
100%files -f %{name}.lang
101%defattr(-,root,root,-)
102%doc README COPYING MAINTAINERS NEWS THANKS AUTHORS
103%{_sysconfdir}/gconf/schemas/shotwell.schemas
104%{_bindir}/shotwell
105%{_datadir}/gnome/help/
106%{_datadir}/shotwell
107%{_datadir}/applications/shotwell.desktop
108%{_datadir}/applications/shotwell-viewer.desktop
109%{_datadir}/icons/hicolor/*
110
111
112%changelog
113* Tue Sep 28 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.7.2-2
114- rebuilt with rpm-4.8.1 for pkg-config
115- fixed %%changelog in Tue Sep 14 2010
116
117* Tue Sep 14 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.7.2-1
118- new upstream release
119- changed source URL
120- added Patch0 to work around desktop file incorrect comment
121- changed BuildRequires: vala-devel >= 0.9.5
122
123* Fri Aug 27 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.7.1-1
124- new upstream release
125
126* Sat Aug 21 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.7.0-1
127- new upstream release
128- changed BuildRequires: libgexiv2-devel >= 0.2.0
129
130* Thu Jul 22 2010 Shu KONNO <owa@bg.wakwak.com> - 0.6.1-2
131- fixed LIB_DIRS in libraw-config (for lib64)
132
133* Wed Jul 14 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.6.1-1
134- new upstream release
135- added BuildRequires: LibRaw-devel, libgexiv2-devel
136
137* Wed May 12 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.5.2-1
138- new upstream release
139
140* Sat Mar 13 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.5.0-1
141- new upstream release
142- added BuildRequires:  libgudev1-devel
143- applied new naming policy to spec
144
145* Wed Jan 20 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.4.3-1
146- new upstream release
147- proved Japanese description
148
149* Thu Jan 7 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.4.2-1
150- new upstrema release
151
152* Wed Dec 30 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.4.1-1
153- intial build for VineSeed
154
155* Fri Dec 18 2009 Matthias Clasen <mclasen@redhat.com> - 0.4.0-0.1.20091218svn
156* Thu Nov 12 2009 Matthias Clasen <mclasen@redhat.com> - 0.3.2-1
157- Update to 0.3.2
158
159* Tue Nov  3 2009 Matthias Clasen <mclasen@redhat.com> - 0.3.0-1
160- Version 0.3.0
161
162* Thu Aug 20 2009 Michel Salim <salimma@fedoraproject.org> - 0.2.0-3
163- Rebuild against new libgee
164
165* Sun Aug 12 2009  Matthias Clasen <mclasen@redhat.com> - 0.2.0-2.fc12
166- Bring icon cache handling in sync with current guidelines
167
168* Sun Aug  9 2009  Matthias Clasen <mclasen@redhat.com> - 0.2.0-1.fc12
169- Initial packaging
Note: See TracBrowser for help on using the repository browser.