source: projects/specs/trunk/s/shotwell/shotwell-vl.spec @ 4663

Revision 4663, 7.0 KB checked in by inagaki, 13 years ago (diff)

update: exiv2, libgexiv2. fotoxx, printoxx, gthumb, gnome-commander, strigi, shotwell, ufraw

RevLine 
[521]1Name:           shotwell
[4616]2Version:        0.10.1
[4663]3Release:        2%{?_dist_release}
[4172]4Summary:        A photo manager for the GNOME desktop
5Summary(ja):    GNOME デスクトップ向けの写真管理ツール
[521]6
7Group:          Applications/Graphics
8# LGPLv2+ for the code
9# CC-BY-SA for some of the icons
10License:        LGPLv2+ and CC-BY-SA
11URL:            http://www.yorba.org/shotwell/
[4104]12
[4616]13Source0:        http://www.yorba.org/download/shotwell/0.10/shotwell-%{version}.tar.bz2
[4104]14# http://trac.yorba.org/ticket/3379
15Source1:        shotwell-icons.tar.bz2
[4172]16Source2:        shotwell-0.8.1-vine2-ja.po
[3330]17Patch1:         shotwell-0.8.1-vala.patch
[521]18
19BuildRoot:      %{_tmppath}/%{name}-%{version}-root
20
[1343]21BuildRequires:  GConf2-devel
22BuildRequires:  LibRaw-devel
[4055]23BuildRequires:  LibRaw-static
[1343]24BuildRequires:  WebKit-gtk-devel
25BuildRequires:  dbus-glib-devel
26BuildRequires:  desktop-file-utils
27BuildRequires:  gettext
[521]28BuildRequires:  gtk2-devel
[2491]29BuildRequires:  gstreamer-devel
[1343]30BuildRequires:  hal-devel
[2491]31BuildRequires:  json-glib-devel
[1343]32BuildRequires:  libexif-devel
33BuildRequires:  libgee-devel
34BuildRequires:  libgphoto2-devel
[564]35BuildRequires:  libgudev1-devel
[1628]36BuildRequires:  libgexiv2-devel >= 0.2.0
[2491]37BuildRequires:  libsoup-devel
38BuildRequires:  libxml2-devel
[521]39BuildRequires:  sqlite3-devel
[1343]40BuildRequires:  unique-devel
[1803]41BuildRequires:  vala-devel >= 0.9.5
[521]42
[4104]43Vendor: Project Vine
44Distribution: Vine Linux
45Packager: kudoh
46
[521]47%description
[4172]48Shotwell is a new open source photo manager designed for the GNOME desktop
[521]49environment. It allows you to import photos from your camera, view and edit
50them, and share them with others.
51
52%description -l ja
53Shotwell は GNOME デスクトップ環境用に設計された新しいオープンソースの
[4172]54画像管理ツールです。
[521]55あなたのカメラから写真を取り込んだり、それらを表示・編集したり、
56他の人々と共有するなどができます。
57
58%prep
59%setup -q -n %{name}-%{version}
[2491]60#%patch0 -p1
[4616]61#%patch1 -p1
[4172]62pushd po
63%__rm -f ja.po
64%__cp %{SOURCE2} ja.po
65popd
[521]66
67%build
[4616]68./configure --prefix=%{_prefix} --lib=%{_lib} --disable-schemas-install --assume-pkgs
[521]69sed -i -e 's/\\n/\n/g' configure.mk
70sed -i -e 's/^CFLAGS=.*$/CFLAGS=%{optflags}/' Makefile
[1417]71sed -i -e 's|LIB_DIRS=.*$|LIB_DIRS=%{_libdir}|' libraw-config
[521]72make %{?_smp_mflags}
73
74
75%install
76rm -rf $RPM_BUILD_ROOT
77export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
78export XDG_DISABLE_MAKEFILE_UPDATES=1
[4104]79# otherwise gettext always returns English text regardless of LANGUAGE asked
80export LANG=en_US.utf8
[521]81make install DESTDIR=$RPM_BUILD_ROOT
82
83desktop-file-validate $RPM_BUILD_ROOT%{_datadir}/applications/shotwell.desktop
84desktop-file-validate $RPM_BUILD_ROOT%{_datadir}/applications/shotwell-viewer.desktop
85
[4104]86# put hi-res icons in place
87(
88  cd $RPM_BUILD_ROOT%{_datadir}/icons/hicolor
89  rm -rf 16x16 24x24 scalable
90  tar xf %{SOURCE1}
91)
92     
[4616]93%find_lang %{name} --all-name
[521]94
95%clean
96rm -rf $RPM_BUILD_ROOT
97
98%post
99touch --no-create %{_datadir}/icons/hicolor &>/dev/null || :
100update-desktop-database &> /dev/null || :
101export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
102gconftool-2 --makefile-install-rule %{_sysconfdir}/gconf/schemas/shotwell.schemas > /dev/null || :
103
104%pre
105if [ "$1" -gt 1 ]; then
106  export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
107  gconftool-2 --makefile-uninstall-rule %{_sysconfdir}/gconf/schemas/shotwell.schemas > /dev/null || :
108fi
109
110%preun
111if [ "$1" -eq 0 ]; then
112  export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
113  gconftool-2 --makefile-uninstall-rule %{_sysconfdir}/gconf/schemas/shotwell.schemas > /dev/null || :
114fi
115
116%postun
117if [ $1 -eq 0 ] ; then
118  touch --no-create %{_datadir}/icons/hicolor &>/dev/null
119  gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor &>/dev/null || :
120fi
121update-desktop-database &> /dev/null || :
122
123%posttrans
124gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor &>/dev/null || :
125
126%files -f %{name}.lang
127%defattr(-,root,root,-)
128%doc README COPYING MAINTAINERS NEWS THANKS AUTHORS
129%{_sysconfdir}/gconf/schemas/shotwell.schemas
130%{_bindir}/shotwell
[4616]131%{_bindir}/shotwell-video-thumbnailer
132%{_libdir}/shotwell/plugins/builtin
[1628]133%{_datadir}/gnome/help/
[521]134%{_datadir}/shotwell
135%{_datadir}/applications/shotwell.desktop
136%{_datadir}/applications/shotwell-viewer.desktop
[564]137%{_datadir}/icons/hicolor/*
[3330]138%exclude %{_datadir}/icons/hicolor/icon-theme.cache
[521]139
140
141%changelog
[4663]142* Sat Aug 27 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.1-2
143- rebuilt with libgexiv2-0.2.2-2
144
[4616]145* Wed Aug 17 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.10.1-1
146- new upstream release
147
[4172]148* Sat Jun 18 2011 IWAI, Masaharu <iwai@alib.jp> 0.8.1-5
149- add ja.po (Source2): fix <BTS:VineLinux:1142>
150- update Summary and description
151
[4104]152* Fri Jun 10 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.1-4
153- add hi-res icons (SOURCE1)
154- add LANG=en_US.utf8 to get gettext to actually generate translated strings
155
[4055]156* Sat Jun 04 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.8.1-3
157- dropt Patch0
158- added BuildRequires: LibRaw-static
159
[3330]160* Sun Apr 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 0.8.1-2
161- add Patch1 (shotwell-0.8.1-vala.patch)
162
[2491]163* Wed Jan 12 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.8.1-1
164- new upstream release
165- added BuildRequires: gstreamer-devel, json-glib-devel, libsoup-devel, libxml2-devel
166
[1939]167* Tue Sep 28 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.7.2-2
168- rebuilt with rpm-4.8.1 for pkg-config
169- fixed %%changelog in Tue Sep 14 2010
170
[1803]171* Tue Sep 14 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.7.2-1
172- new upstream release
173- changed source URL
[1939]174- added Patch0 to work around desktop file incorrect comment
[1803]175- changed BuildRequires: vala-devel >= 0.9.5
176
[1677]177* Fri Aug 27 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.7.1-1
178- new upstream release
179
[1628]180* Sat Aug 21 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.7.0-1
181- new upstream release
182- changed BuildRequires: libgexiv2-devel >= 0.2.0
183
[1417]184* Thu Jul 22 2010 Shu KONNO <owa@bg.wakwak.com> - 0.6.1-2
185- fixed LIB_DIRS in libraw-config (for lib64)
186
[1343]187* Wed Jul 14 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.6.1-1
188- new upstream release
189- added BuildRequires: LibRaw-devel, libgexiv2-devel
190
[1007]191* Wed May 12 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.5.2-1
192- new upstream release
193
[564]194* Sat Mar 13 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.5.0-1
195- new upstream release
196- added BuildRequires:  libgudev1-devel
197- applied new naming policy to spec
198
[521]199* Wed Jan 20 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.4.3-1
[564]200- new upstream release
[521]201- proved Japanese description
202
203* Thu Jan 7 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.4.2-1
204- new upstrema release
205
206* Wed Dec 30 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.4.1-1
207- intial build for VineSeed
208
209* Fri Dec 18 2009 Matthias Clasen <mclasen@redhat.com> - 0.4.0-0.1.20091218svn
210* Thu Nov 12 2009 Matthias Clasen <mclasen@redhat.com> - 0.3.2-1
211- Update to 0.3.2
212
213* Tue Nov  3 2009 Matthias Clasen <mclasen@redhat.com> - 0.3.0-1
214- Version 0.3.0
215
216* Thu Aug 20 2009 Michel Salim <salimma@fedoraproject.org> - 0.2.0-3
217- Rebuild against new libgee
218
219* Sun Aug 12 2009  Matthias Clasen <mclasen@redhat.com> - 0.2.0-2.fc12
220- Bring icon cache handling in sync with current guidelines
221
222* Sun Aug  9 2009  Matthias Clasen <mclasen@redhat.com> - 0.2.0-1.fc12
223- Initial packaging
Note: See TracBrowser for help on using the repository browser.