source: projects/specs/trunk/s/shotwell/shotwell-vl.spec @ 4616

Revision 4616, 6.9 KB checked in by Takemikaduchi, 13 years ago (diff)

X.Org, compiz, GNOME3, etc...

Line 
1Name:           shotwell
2Version:        0.10.1
3Release:        1%{?_dist_release}
4Summary:        A photo manager for the GNOME desktop
5Summary(ja):    GNOME デスクトップ向けの写真管理ツール
6
7Group:          Applications/Graphics
8# LGPLv2+ for the code
9# CC-BY-SA for some of the icons
10License:        LGPLv2+ and CC-BY-SA
11URL:            http://www.yorba.org/shotwell/
12
13Source0:        http://www.yorba.org/download/shotwell/0.10/shotwell-%{version}.tar.bz2
14# http://trac.yorba.org/ticket/3379
15Source1:        shotwell-icons.tar.bz2
16Source2:        shotwell-0.8.1-vine2-ja.po
17Patch1:         shotwell-0.8.1-vala.patch
18
19BuildRoot:      %{_tmppath}/%{name}-%{version}-root
20
21BuildRequires:  GConf2-devel
22BuildRequires:  LibRaw-devel
23BuildRequires:  LibRaw-static
24BuildRequires:  WebKit-gtk-devel
25BuildRequires:  dbus-glib-devel
26BuildRequires:  desktop-file-utils
27BuildRequires:  gettext
28BuildRequires:  gtk2-devel
29BuildRequires:  gstreamer-devel
30BuildRequires:  hal-devel
31BuildRequires:  json-glib-devel
32BuildRequires:  libexif-devel
33BuildRequires:  libgee-devel
34BuildRequires:  libgphoto2-devel
35BuildRequires:  libgudev1-devel
36BuildRequires:  libgexiv2-devel >= 0.2.0
37BuildRequires:  libsoup-devel
38BuildRequires:  libxml2-devel
39BuildRequires:  sqlite3-devel
40BuildRequires:  unique-devel
41BuildRequires:  vala-devel >= 0.9.5
42
43Vendor: Project Vine
44Distribution: Vine Linux
45Packager: kudoh
46
47%description
48Shotwell is a new open source photo manager designed for the GNOME desktop
49environment. It allows you to import photos from your camera, view and edit
50them, and share them with others.
51
52%description -l ja
53Shotwell は GNOME デスクトップ環境用に設計された新しいオープンソースの
54画像管理ツールです。
55あなたのカメラから写真を取り込んだり、それらを表示・編集したり、
56他の人々と共有するなどができます。
57
58%prep
59%setup -q -n %{name}-%{version}
60#%patch0 -p1
61#%patch1 -p1
62pushd po
63%__rm -f ja.po
64%__cp %{SOURCE2} ja.po
65popd
66
67%build
68./configure --prefix=%{_prefix} --lib=%{_lib} --disable-schemas-install --assume-pkgs
69sed -i -e 's/\\n/\n/g' configure.mk
70sed -i -e 's/^CFLAGS=.*$/CFLAGS=%{optflags}/' Makefile
71sed -i -e 's|LIB_DIRS=.*$|LIB_DIRS=%{_libdir}|' libraw-config
72make %{?_smp_mflags}
73
74
75%install
76rm -rf $RPM_BUILD_ROOT
77export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
78export XDG_DISABLE_MAKEFILE_UPDATES=1
79# otherwise gettext always returns English text regardless of LANGUAGE asked
80export LANG=en_US.utf8
81make install DESTDIR=$RPM_BUILD_ROOT
82
83desktop-file-validate $RPM_BUILD_ROOT%{_datadir}/applications/shotwell.desktop
84desktop-file-validate $RPM_BUILD_ROOT%{_datadir}/applications/shotwell-viewer.desktop
85
86# put hi-res icons in place
87(
88  cd $RPM_BUILD_ROOT%{_datadir}/icons/hicolor
89  rm -rf 16x16 24x24 scalable
90  tar xf %{SOURCE1}
91)
92     
93%find_lang %{name} --all-name
94
95%clean
96rm -rf $RPM_BUILD_ROOT
97
98%post
99touch --no-create %{_datadir}/icons/hicolor &>/dev/null || :
100update-desktop-database &> /dev/null || :
101export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
102gconftool-2 --makefile-install-rule %{_sysconfdir}/gconf/schemas/shotwell.schemas > /dev/null || :
103
104%pre
105if [ "$1" -gt 1 ]; then
106  export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
107  gconftool-2 --makefile-uninstall-rule %{_sysconfdir}/gconf/schemas/shotwell.schemas > /dev/null || :
108fi
109
110%preun
111if [ "$1" -eq 0 ]; then
112  export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
113  gconftool-2 --makefile-uninstall-rule %{_sysconfdir}/gconf/schemas/shotwell.schemas > /dev/null || :
114fi
115
116%postun
117if [ $1 -eq 0 ] ; then
118  touch --no-create %{_datadir}/icons/hicolor &>/dev/null
119  gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor &>/dev/null || :
120fi
121update-desktop-database &> /dev/null || :
122
123%posttrans
124gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor &>/dev/null || :
125
126%files -f %{name}.lang
127%defattr(-,root,root,-)
128%doc README COPYING MAINTAINERS NEWS THANKS AUTHORS
129%{_sysconfdir}/gconf/schemas/shotwell.schemas
130%{_bindir}/shotwell
131%{_bindir}/shotwell-video-thumbnailer
132%{_libdir}/shotwell/plugins/builtin
133%{_datadir}/gnome/help/
134%{_datadir}/shotwell
135%{_datadir}/applications/shotwell.desktop
136%{_datadir}/applications/shotwell-viewer.desktop
137%{_datadir}/icons/hicolor/*
138%exclude %{_datadir}/icons/hicolor/icon-theme.cache
139
140
141%changelog
142* Wed Aug 17 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.10.1-1
143- new upstream release
144
145* Sat Jun 18 2011 IWAI, Masaharu <iwai@alib.jp> 0.8.1-5
146- add ja.po (Source2): fix <BTS:VineLinux:1142>
147- update Summary and description
148
149* Fri Jun 10 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.1-4
150- add hi-res icons (SOURCE1)
151- add LANG=en_US.utf8 to get gettext to actually generate translated strings
152
153* Sat Jun 04 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.8.1-3
154- dropt Patch0
155- added BuildRequires: LibRaw-static
156
157* Sun Apr 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 0.8.1-2
158- add Patch1 (shotwell-0.8.1-vala.patch)
159
160* Wed Jan 12 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.8.1-1
161- new upstream release
162- added BuildRequires: gstreamer-devel, json-glib-devel, libsoup-devel, libxml2-devel
163
164* Tue Sep 28 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.7.2-2
165- rebuilt with rpm-4.8.1 for pkg-config
166- fixed %%changelog in Tue Sep 14 2010
167
168* Tue Sep 14 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.7.2-1
169- new upstream release
170- changed source URL
171- added Patch0 to work around desktop file incorrect comment
172- changed BuildRequires: vala-devel >= 0.9.5
173
174* Fri Aug 27 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.7.1-1
175- new upstream release
176
177* Sat Aug 21 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.7.0-1
178- new upstream release
179- changed BuildRequires: libgexiv2-devel >= 0.2.0
180
181* Thu Jul 22 2010 Shu KONNO <owa@bg.wakwak.com> - 0.6.1-2
182- fixed LIB_DIRS in libraw-config (for lib64)
183
184* Wed Jul 14 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.6.1-1
185- new upstream release
186- added BuildRequires: LibRaw-devel, libgexiv2-devel
187
188* Wed May 12 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.5.2-1
189- new upstream release
190
191* Sat Mar 13 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.5.0-1
192- new upstream release
193- added BuildRequires:  libgudev1-devel
194- applied new naming policy to spec
195
196* Wed Jan 20 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.4.3-1
197- new upstream release
198- proved Japanese description
199
200* Thu Jan 7 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.4.2-1
201- new upstrema release
202
203* Wed Dec 30 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.4.1-1
204- intial build for VineSeed
205
206* Fri Dec 18 2009 Matthias Clasen <mclasen@redhat.com> - 0.4.0-0.1.20091218svn
207* Thu Nov 12 2009 Matthias Clasen <mclasen@redhat.com> - 0.3.2-1
208- Update to 0.3.2
209
210* Tue Nov  3 2009 Matthias Clasen <mclasen@redhat.com> - 0.3.0-1
211- Version 0.3.0
212
213* Thu Aug 20 2009 Michel Salim <salimma@fedoraproject.org> - 0.2.0-3
214- Rebuild against new libgee
215
216* Sun Aug 12 2009  Matthias Clasen <mclasen@redhat.com> - 0.2.0-2.fc12
217- Bring icon cache handling in sync with current guidelines
218
219* Sun Aug  9 2009  Matthias Clasen <mclasen@redhat.com> - 0.2.0-1.fc12
220- Initial packaging
Note: See TracBrowser for help on using the repository browser.