source: projects/specs/trunk/s/shotwell/shotwell-vl.spec @ 4104

Revision 4104, 6.5 KB checked in by daisuke, 13 years ago (diff)

shotwell:

  • add new hi-res icons
  • add LANG=en_US.utf8 to get gettext to actually generate translated strings (for .desktop translation)
RevLine 
[521]1Name:           shotwell
[2491]2Version:        0.8.1
[4104]3Release:        4%{?_dist_release}
[521]4Summary:        A photo organizer for the GNOME desktop
5Summary(ja):    GNOME デスクトップ向けの画像整理ソフト
6
7Group:          Applications/Graphics
8# LGPLv2+ for the code
9# CC-BY-SA for some of the icons
10License:        LGPLv2+ and CC-BY-SA
11URL:            http://www.yorba.org/shotwell/
[4104]12
[2491]13Source0:        http://www.yorba.org/download/shotwell/0.8/shotwell-%{version}.tar.bz2
[4104]14# http://trac.yorba.org/ticket/3379
15Source1:        shotwell-icons.tar.bz2
[3330]16Patch1:         shotwell-0.8.1-vala.patch
[521]17
18BuildRoot:      %{_tmppath}/%{name}-%{version}-root
19
[1343]20BuildRequires:  GConf2-devel
21BuildRequires:  LibRaw-devel
[4055]22BuildRequires:  LibRaw-static
[1343]23BuildRequires:  WebKit-gtk-devel
24BuildRequires:  dbus-glib-devel
25BuildRequires:  desktop-file-utils
26BuildRequires:  gettext
[521]27BuildRequires:  gtk2-devel
[2491]28BuildRequires:  gstreamer-devel
[1343]29BuildRequires:  hal-devel
[2491]30BuildRequires:  json-glib-devel
[1343]31BuildRequires:  libexif-devel
32BuildRequires:  libgee-devel
33BuildRequires:  libgphoto2-devel
[564]34BuildRequires:  libgudev1-devel
[1628]35BuildRequires:  libgexiv2-devel >= 0.2.0
[2491]36BuildRequires:  libsoup-devel
37BuildRequires:  libxml2-devel
[521]38BuildRequires:  sqlite3-devel
[1343]39BuildRequires:  unique-devel
[1803]40BuildRequires:  vala-devel >= 0.9.5
[521]41
[4104]42Vendor: Project Vine
43Distribution: Vine Linux
44Packager: kudoh
45
[521]46%description
47Shotwell is a new open source photo organizer designed for the GNOME desktop
48environment. It allows you to import photos from your camera, view and edit
49them, and share them with others.
50
51%description -l ja
52Shotwell は GNOME デスクトップ環境用に設計された新しいオープンソースの
53画像整理ソフトです。
54あなたのカメラから写真を取り込んだり、それらを表示・編集したり、
55他の人々と共有するなどができます。
56
57%prep
58%setup -q -n %{name}-%{version}
[2491]59#%patch0 -p1
[3330]60%patch1 -p1
[521]61
62%build
[1803]63./configure --prefix=/usr --disable-schemas-install --assume-pkgs
[521]64sed -i -e 's/\\n/\n/g' configure.mk
65sed -i -e 's/^CFLAGS=.*$/CFLAGS=%{optflags}/' Makefile
[1417]66sed -i -e 's|LIB_DIRS=.*$|LIB_DIRS=%{_libdir}|' libraw-config
[521]67make %{?_smp_mflags}
68
69
70%install
71rm -rf $RPM_BUILD_ROOT
72export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
73export XDG_DISABLE_MAKEFILE_UPDATES=1
[4104]74# otherwise gettext always returns English text regardless of LANGUAGE asked
75export LANG=en_US.utf8
[521]76make install DESTDIR=$RPM_BUILD_ROOT
77
78desktop-file-validate $RPM_BUILD_ROOT%{_datadir}/applications/shotwell.desktop
79desktop-file-validate $RPM_BUILD_ROOT%{_datadir}/applications/shotwell-viewer.desktop
80
[4104]81# put hi-res icons in place
82(
83  cd $RPM_BUILD_ROOT%{_datadir}/icons/hicolor
84  rm -rf 16x16 24x24 scalable
85  tar xf %{SOURCE1}
86)
87     
[521]88%find_lang %{name}
89
90%clean
91rm -rf $RPM_BUILD_ROOT
92
93%post
94touch --no-create %{_datadir}/icons/hicolor &>/dev/null || :
95update-desktop-database &> /dev/null || :
96export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
97gconftool-2 --makefile-install-rule %{_sysconfdir}/gconf/schemas/shotwell.schemas > /dev/null || :
98
99%pre
100if [ "$1" -gt 1 ]; then
101  export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
102  gconftool-2 --makefile-uninstall-rule %{_sysconfdir}/gconf/schemas/shotwell.schemas > /dev/null || :
103fi
104
105%preun
106if [ "$1" -eq 0 ]; then
107  export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
108  gconftool-2 --makefile-uninstall-rule %{_sysconfdir}/gconf/schemas/shotwell.schemas > /dev/null || :
109fi
110
111%postun
112if [ $1 -eq 0 ] ; then
113  touch --no-create %{_datadir}/icons/hicolor &>/dev/null
114  gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor &>/dev/null || :
115fi
116update-desktop-database &> /dev/null || :
117
118%posttrans
119gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor &>/dev/null || :
120
121%files -f %{name}.lang
122%defattr(-,root,root,-)
123%doc README COPYING MAINTAINERS NEWS THANKS AUTHORS
124%{_sysconfdir}/gconf/schemas/shotwell.schemas
125%{_bindir}/shotwell
[1628]126%{_datadir}/gnome/help/
[521]127%{_datadir}/shotwell
128%{_datadir}/applications/shotwell.desktop
129%{_datadir}/applications/shotwell-viewer.desktop
[564]130%{_datadir}/icons/hicolor/*
[3330]131%exclude %{_datadir}/icons/hicolor/icon-theme.cache
[521]132
133
134%changelog
[4104]135* Fri Jun 10 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.1-4
136- add hi-res icons (SOURCE1)
137- add LANG=en_US.utf8 to get gettext to actually generate translated strings
138
[4055]139* Sat Jun 04 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.8.1-3
140- dropt Patch0
141- added BuildRequires: LibRaw-static
142
[3330]143* Sun Apr 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 0.8.1-2
144- add Patch1 (shotwell-0.8.1-vala.patch)
145
[2491]146* Wed Jan 12 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.8.1-1
147- new upstream release
148- added BuildRequires: gstreamer-devel, json-glib-devel, libsoup-devel, libxml2-devel
149
[1939]150* Tue Sep 28 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.7.2-2
151- rebuilt with rpm-4.8.1 for pkg-config
152- fixed %%changelog in Tue Sep 14 2010
153
[1803]154* Tue Sep 14 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.7.2-1
155- new upstream release
156- changed source URL
[1939]157- added Patch0 to work around desktop file incorrect comment
[1803]158- changed BuildRequires: vala-devel >= 0.9.5
159
[1677]160* Fri Aug 27 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.7.1-1
161- new upstream release
162
[1628]163* Sat Aug 21 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.7.0-1
164- new upstream release
165- changed BuildRequires: libgexiv2-devel >= 0.2.0
166
[1417]167* Thu Jul 22 2010 Shu KONNO <owa@bg.wakwak.com> - 0.6.1-2
168- fixed LIB_DIRS in libraw-config (for lib64)
169
[1343]170* Wed Jul 14 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.6.1-1
171- new upstream release
172- added BuildRequires: LibRaw-devel, libgexiv2-devel
173
[1007]174* Wed May 12 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.5.2-1
175- new upstream release
176
[564]177* Sat Mar 13 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.5.0-1
178- new upstream release
179- added BuildRequires:  libgudev1-devel
180- applied new naming policy to spec
181
[521]182* Wed Jan 20 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.4.3-1
[564]183- new upstream release
[521]184- proved Japanese description
185
186* Thu Jan 7 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.4.2-1
187- new upstrema release
188
189* Wed Dec 30 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.4.1-1
190- intial build for VineSeed
191
192* Fri Dec 18 2009 Matthias Clasen <mclasen@redhat.com> - 0.4.0-0.1.20091218svn
193* Thu Nov 12 2009 Matthias Clasen <mclasen@redhat.com> - 0.3.2-1
194- Update to 0.3.2
195
196* Tue Nov  3 2009 Matthias Clasen <mclasen@redhat.com> - 0.3.0-1
197- Version 0.3.0
198
199* Thu Aug 20 2009 Michel Salim <salimma@fedoraproject.org> - 0.2.0-3
200- Rebuild against new libgee
201
202* Sun Aug 12 2009  Matthias Clasen <mclasen@redhat.com> - 0.2.0-2.fc12
203- Bring icon cache handling in sync with current guidelines
204
205* Sun Aug  9 2009  Matthias Clasen <mclasen@redhat.com> - 0.2.0-1.fc12
206- Initial packaging
Note: See TracBrowser for help on using the repository browser.