source: projects/specs/trunk/s/setup/setup-vl.spec @ 521

Revision 521, 12.7 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Summary: A set of system configuration and setup files.
2Summary(ja): システム設定およびセットアップファイル一式
3Name: setup
4Version: 2.8.1
5Release: 1%{?_dist_release}
6License: public domain
7Group: System Environment/Base
8Source: setup-%{version}.tar.bz2
9Patch: setup-2.8.1-vine.patch
10
11Buildroot: %{_tmppath}/%{name}-%{version}-root
12BuildArchitectures: noarch
13Conflicts: initscripts < 4.26, bash <= 2.0.4-21
14
15%description
16The setup package contains a set of important system configuration and
17setup files, such as passwd, group, and profile.
18
19%description -l ja
20このsetupパッケージには、passwd, group, profile などの、
21重要なシステム設定ファイルが含まれてます。
22
23%prep
24%setup -q
25%patch -p1
26
27%install
28rm -rf %{buildroot}
29mkdir -p %{buildroot}/etc/profile.d
30cp -ar * %{buildroot}/etc
31rm -f %{buildroot}/etc/uidgid
32mkdir -p %{buildroot}/var/log
33touch %{buildroot}/etc/{shadow,gshadow}
34touch %{buildroot}/var/log/lastlog
35touch %{buildroot}/etc/environment
36chmod 0644 %{buildroot}/etc/environment
37chmod 0400 %{buildroot}/etc/{shadow,gshadow}
38chmod 0644 %{buildroot}/var/log/lastlog
39touch %{buildroot}/etc/fstab
40touch %{buildroot}/etc/mtab
41
42# remove unpackaged files
43rm -f %{buildroot}/etc/Makefile
44rm -f %{buildroot}/etc/serviceslint
45rm -f %{buildroot}/etc/uidgidlint
46rm -f %{buildroot}/etc/shadowconvert.sh
47rm -f %{buildroot}/etc/setup.spec
48rm -f $RPM_BUILD_ROOT/etc/{bashrc,aliases}
49
50%clean
51rm -rf %{buildroot}
52
53%postun
54#throw away useless and dangerous update stuff until rpm will be able to
55#handle it ( http://rpm.org/ticket/6 )
56rm -f /etc/passwd.rpmnew
57rm -f /etc/shadow.rpmnew
58rm -f /etc/group.rpmnew
59rm -f /etc/gshadow.rpmnew
60
61%files
62%defattr(-,root,root)
63%doc uidgid
64%verify(not md5 size mtime) %config(noreplace) /etc/passwd
65%verify(not md5 size mtime) %config(noreplace) /etc/group
66%verify(not md5 size mtime) %config(noreplace,missingok) /etc/shadow
67%verify(not md5 size mtime) %config(noreplace,missingok) /etc/gshadow
68%verify(not md5 size mtime) %config(noreplace) /etc/services
69%verify(not md5 size mtime) %config(noreplace) /etc/exports
70%config(noreplace) /etc/environment
71%config(noreplace) /etc/filesystems
72%config(noreplace) /etc/host.conf
73%verify(not md5 size mtime) %config(noreplace) /etc/hosts
74%verify(not md5 size mtime) %config(noreplace) /etc/hosts.allow
75%verify(not md5 size mtime) %config(noreplace) /etc/hosts.deny
76%verify(not md5 size mtime) %config(noreplace) /etc/motd
77%config(noreplace) /etc/printcap
78%verify(not md5 size mtime) %config(noreplace) /etc/inputrc
79# config(noreplace) /etc/bashrc
80%config(noreplace) /etc/profile
81%verify(not md5 size mtime) %config(noreplace) /etc/protocols
82%attr(0600,root,root) %config(noreplace,missingok) /etc/securetty
83%config(noreplace) /etc/csh.login
84%config(noreplace) /etc/csh.cshrc
85%dir /etc/profile.d
86%config(noreplace) %verify(not md5 size mtime) /etc/shells
87%ghost %attr(0644,root,root) %verify(not md5 size mtime) /var/log/lastlog
88%ghost %verify(not md5 size mtime) %config(noreplace,missingok) /etc/fstab
89%ghost %verify(not md5 size mtime) %config(noreplace,missingok) /etc/mtab
90
91%changelog
92* Sat Mar 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.1-1
93- update to 2.8.1
94- spec in utf-8
95- new versioning policy
96- add %%postun to remove dangerous .rpmnew files
97
98* Sat May 20 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.7-2vl5
99- add /etc/environment
100- add /etc/{fstab,mtab} as %%ghost
101- add console to /etc/securetty
102- import /etc/services from FC
103- set mark-symlinked-directories in /etc/inputrc
104- add /sbin/nologin to /etc/shells
105
106* Fri Mar 04 2005 Satoshi MACHINO <machino@vinelinux.org> 2.5.7-2vl4
107- updated setup-2.5.7-vine.patch
108        -- changed /etc/printcap for using cups
109
110* Mon Jun 28 2004 NISHIMURA Daisuke <nishi@graco.c.u-tokyo.ac.jp> 2.5.7-2vl3
111- source /etc/profile.d/*.sh in /etc/profile
112
113* Sun Feb 24 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.7-2vl1
114- merge with new upstream version
115
116* Wed Jan 09 2002 Tim Powers <timp@redhat.com>
117- automated rebuild
118
119* Mon Aug 27 2001 Preston Brown <pbrown@redhat.com>
120- add ext3 to /etc/filesystems
121
122* Mon Aug 20 2001 Bill Nottingham <notting@redhat.com>
123- change FTP user's home dir to /var/ftp (#52091)
124- %%ghost /etc/shadow, /etc/gshadow
125
126* Fri Aug 17 2001 Bill Nottingham <notting@redhat.com>
127- add /etc/shells to filelist (#51813)
128
129* Mon Aug 13 2001 Bill Nottingham <notting@redhat.com>
130- put lock in /etc/group (#51654)
131
132* Wed Aug  8 2001 Bill Nottingham <notting@redhat.com>
133- lock only needs to be a gid
134- don't set dspmbyte=euc here; do it in lang.csh, and only if necessary (#50318)
135
136* Mon Aug  6 2001 Jeff Johnson <jbj@redhat.com>
137- add lock.lock uid/gid 54 to own /var/lock directory.
138
139* Thu Jul 19 2001 Bill Nottingham <notting@redhat.com>
140- add forward/backward-word mappings (#48783)
141- add pgpkeyserver port to /etc/services (#49407)
142
143* Thu Jul 19 2001 Preston Brown <pbrown@redhat.com>
144- core files disabled by default.  Developers can enable them.
145
146* Fri Jul 13 2001 Bill Nottingham <notting@redhat.com> 2.5.1-1
147- revert news user back to no shell (#48701)
148
149* Tue Jul 10 2001 Bill Nottingham <notting@redhat.com> 2.5.0-1
150- move profile.d parsing from csh.cshrc to csh.login (#47417)
151
152* Sat Jul  7 2001 Nalin Dahyabhai <nalin@redhat.com> 2.4.15-1
153- reorder /etc/services to match comments again
154- protocol 118 is stp, not st
155- update URLs in /etc/protocols and /etc/services
156
157* Thu Jul  5 2001 Preston Brown <pbrown@redhat.com> 2.4.14-1
158- put */sbin in path if user ID is 0.
159
160* Mon Jun 25 2001 Bill Nottingham <notting@redhat.com>
161- add an entry to /etc/services for ssh X11 forwarding (#44944)
162
163* Wed Jun 13 2001 Bill Nottingham <notting@redhat.com>
164- take ttyS0 out of securetty on main tree
165
166* Tue Jun 12 2001 Philip Copeland <bryce@redhat.com>
167- added ttyS0 to securetty for serial console usage
168
169* Tue Jun 12 2001 Bill Nottingham <notting@redhat.com>
170- add rndc to /etc/services (#40265)
171- test for read bit, not execute bit, for profile.d (#35714)
172
173* Sun Jun 03 2001 Florian La Roche <Florian.LaRoche@redhat.de>
174- add "canna" entry to /etc/services
175
176* Mon May 21 2001 Bernhard Rosenkraenzer <bero@redhat.com> 2.4.10-1
177- Fix bugs #24159 and #30634 again; whoever moved bashrc from bash
178  to setup used an old version. :((
179
180* Wed May  2 2001 Preston Brown <pbrown@redhat.com> 2.4.9-1
181- bashrc moved here from bash package
182- set umask in bashrc, so it applies for ALL shells.
183
184* Fri Apr 27 2001 Preston Brown <pbrown@redhat.com> 2.4.8-1
185- /sbin/nologin for accounts that aren't "real."
186
187* Sat Apr  7 2001 Preston Brown <pbrown@redhat.com>
188- revert control-arrow forward/backward word (broken)
189
190* Tue Mar 27 2001 Preston Brown <pbrown@redhat.com>
191- fix japanese input with tcsh (#33211)
192
193* Tue Mar  6 2001 Bill Nottingham <notting@redhat.com>
194- fix some weirdness with rxvt (#30799)
195
196* Wed Feb 28 2001 Bill Nottingham <notting@redhat.com>
197- add SKK input method (#29759)
198
199* Fri Feb 23 2001 Preston Brown <pbrown@redhat.com>
200
201* Wed Feb 21 2001 Bill Nottingham <notting@redhat.com>
202- fix inputrc, Yet Again. (#28617)
203
204* Thu Feb 15 2001 Bill Nottingham <notting@redhat.com>
205- add in uidgid file, put it in %doc
206
207* Wed Feb  7 2001 Adrian Havill <havill@redhat.com>
208- bindkey for delete in the case of tcsh
209
210* Wed Feb  7 2001 Bill Nottingham <notting@redhat.com>
211- add some more stuff to /etc/services (#25396, patch from
212  <pekkas@netcore.fi>)
213
214* Tue Feb  6 2001 Nalin Dahyabhai <nalin@redhat.com>
215- add gii/tcp = 616 for gated
216
217* Tue Jan 30 2001 Bill Nottingham <notting@redhat.com>
218- wrap some inputrc settings with tests for mode, term (#24117)
219
220* Mon Jan 29 2001 Bill Nottingham <notting@redhat.com>
221- overhaul /etc/protocols (#18530)
222- add port 587 to /etc/services (#25001)
223- add corbaloc (#19581)
224- don't set /usr/X11R6/bin in $PATH if it's already set (#19968)
225
226* Fri Dec  1 2000 Nalin Dahyabhai <nalin@redhat.com>
227- Clean up /etc/services, separating registered numbers from unregistered
228  ("squatted") numbers, and adding some.
229
230* Mon Nov 20 2000 Bernhard Rosenkraenzer <bero@redhat.com>
231- Add smtps (465/tcp) and submission (587/tcp) to /etc/services for TLS
232  support (postfix >= 20001030-2)
233
234* Mon Nov  6 2000 Kazuhisa TAKEI <takei@vinelinux.org>
235- rebuild in  rpm 3.0.6
236
237* Wed Oct 11 2000 Jun Nishii <jun@vinelinux.org>
238- remove reading profile.d process from /etc/profile
239  the process moved to /etc/bashrc...
240
241* Thu Sep 07 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
242- 2.2.1-1vl2
243- removed /etc/filesystems in %files section
244
245* Sun Aug  6 2000 Bill Nottingham <notting@redhat.com>
246- /var/log/lastlog is %config(noreplace) (#15412)
247- some of the various %verify changes (#14819)
248
249* Thu Aug  3 2000 Nalin Dahyabhai <nalin@redhat.com>
250- linuxconf should be 98, not 99
251
252* Tue Jul 25 2000 Bill Nottingham <notting@redhat.com>
253- fix some of the csh stuff (#14622)
254
255* Sun Jul 23 2000 Nalin Dahyabhai <nalin@redhat.com>
256- stop setting "multi on" in /etc/host.conf
257
258* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
259- automatic rebuild
260
261* Tue Jun 27 2000 Bill Nottingham <notting@redhat.com>
262- add hfs filesystem
263
264* Wed Jun 21 2000 Preston Brown <pbrown@redhat.com>
265- printcap is a noreplace file now
266
267* Sun Jun 18 2000 Bill Nottingham <notting@redhat.com>
268- fix typo
269
270* Tue Jun 13 2000 Lisa Sagami <czs14350@nifty.ne.jp>
271- merged RH 2.2.1-1 and Vine 2.0.5-1vl3
272
273* Tue Jun 13 2000 Nalin Dahyabhai <nalin@redhat.com>
274- add linuxconf/tcp = 99 to /etc/services
275
276* Sat Jun 10 2000 Bill Nottingham <notting@redhat.com>
277- add some stuff to /etc/services
278- tweak ulimit call again
279
280* Tue Jun  6 2000 Bernhard Rosenkraenzer <bero@redhat.com>
281- homedir of ftp is now /var/ftp
282
283* Sun May 14 2000 Nalin Dahyabhai <nalin@redhat.com>
284- move profile.d logic in csh.login to csh.cshrc
285
286* Tue Apr 18 2000 Nalin Dahyabhai <nalin@redhat.com>
287- redirect ulimit -S -c to /dev/null to avoid clutter
288
289* Thu Apr 13 2000 Bernhard Rosenkraenzer <bero@redhat.com>
290- s/ulimit -c/ulimit -S -c/ - bash 2.x adaption
291
292* Mon Apr 03 2000 Nalin Dahyabhai <nalin@redhat.com>
293- Add more of the kerberos-related services from IANA's registry and krb5
294
295* Wed Mar 29 2000 Bernhard Rosenkraenzer <bero@redhat.com>
296- Add 2.4'ish vc/* devices to securetty
297
298* Thu Feb 17 2000 Preston Brown <pbrown@redhat.com>
299- add /etc/filesystems with sane defaults
300
301* Wed Feb 16 2000 Bill Nottingham <notting@redhat.com>
302- don't set prompt in /etc/profile (it's done in /etc/bashrc)
303
304* Fri Feb  5 2000 Bill Nottingham <notting@redhat.com>
305- yet more inputrc tweaks from Hans de Goede (hans@highrise.nl)
306
307* Sun Jan 30 2000 Bill Nottingham <notting@redhat.com>
308- yet more inputrc tweaks from Hans de Goede (hans@highrise.nl)
309
310* Sun Jan 23 2000 Bill Nottingham <notting@redhat.com>
311- fix mailq line. (#7140)
312
313* Fri Jan 21 2000 Bill Nottingham <notting@redhat.com>
314- add ldap to /etc/services
315
316* Tue Jan 18 2000 Bill Nottingham <notting@redhat.com>
317- kill HISTFILESIZE, it's broken
318
319* Tue Jan 18 2000 Preston Brown <pbrown@redhat.com>
320- some inputrc tweaks
321
322* Wed Jan 12 2000 Bill Nottingham <notting@redhat.com>
323- make some more stuff noreplace
324
325* Fri Nov 19 1999 Bill Nottingham <notting@redhat.com>
326- fix mailq line. (#7140)
327
328* Fri Oct 29 1999 Bill Nottingham <notting@redhat.com>
329- split csh.login into csh.login and csh.cshrc (#various)
330- fix pop service names (#6206)
331- fix ipv6 protocols entries (#6219)
332
333* Thu Sep  2 1999 Jeff Johnson <jbj@redhat.com>
334- rename /etc/csh.cshrc to /etc/csh.login (#2931).
335- (note: modified /etc/csh.cshrc should end up in /etc/csh.cshrc.rpmsave)
336
337* Fri Aug 20 1999 Jeff Johnson <jbj@redhat.com>
338- add defattr.
339- fix limit command in /etc/csh.cshrc (#4582).
340
341* Thu Jul  8 1999 Bill Nottingham <notting@redhat.com>
342- move /etc/inputrc here.
343
344* Mon Apr 19 1999 Bill Nottingham <notting@redhat.com>
345- always use /etc/inputrc
346
347* Wed Mar 31 1999 Preston Brown <pbrown@redhat.com>
348- added alias pointing to imap from imap2
349
350* Tue Mar 23 1999 Preston Brown <pbrown@redhat.com>
351- updated protocols/services from debian to comply with more modern
352- IETF/RFC standards
353
354* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
355- auto rebuild in the new build environment (release 4)
356
357* Thu Feb 18 1999 Jeff Johnson <jbj@redhat.com>
358- unset variables used in /etc/csh.cshrc (#1212)
359
360* Mon Jan 18 1999 Jeff Johnson <jbj@redhat.com>
361- compile for Raw Hide.
362
363* Tue Oct 13 1998 Cristian Gafton <gafton@redhat.com>
364- fix the csh.cshrc re: ${PATH} undefined
365
366* Mon Apr 27 1998 Prospector System <bugs@redhat.com>
367- translations modified for de, fr, tr
368
369* Fri Dec 05 1997 Erik Troan <ewt@redhat.com>
370- /etc/profile uses $i, which needs to be unset
371
372* Mon Nov 03 1997 Donnie Barnes <djb@redhat.com>
373- made /etc/passwd and /etc/group %config(noreplace)
374
375* Mon Oct 20 1997 Erik Troan <ewt@redhat.com>
376- removed /etc/inetd.conf, /etc/rpc
377- flagged /etc/securetty as missingok
378- fixed buildroot stuff in spec file
379
380* Thu Jul 31 1997 Erik Troan <ewt@redhat.com>
381- made a noarch package
382
383* Wed Apr 16 1997 Erik Troan <ewt@redhat.com>
384- Don't verify md5sum, size, or timestamp of /var/log/lastlog, /etc/passwd,
385  or /etc/group.
Note: See TracBrowser for help on using the repository browser.