source: projects/specs/trunk/s/setup/setup-vl.spec @ 8720

Revision 8720, 12.9 KB checked in by daisuke, 10 years ago (diff)

setup: rebase to 2.9.0

Line 
1Summary: A set of system configuration and setup files.
2Summary(ja): システム設定およびセットアップファイル一式
3Name: setup
4Version: 2.9.0
5Release: 1%{?_dist_release}
6License: Public Domain
7Group: System Environment/Base
8URL: https://fedorahosted.org/setup/
9
10# use our forked version
11Source: setup-vine-%{version}.tar.bz2
12
13Buildroot: %{_tmppath}/%{name}-%{version}-root
14BuildArch: noarch
15Conflicts: initscripts < 4.26, bash <= 2.0.4-21
16
17%description
18The setup package contains a set of important system configuration and
19setup files, such as passwd, group, and profile.
20
21%description -l ja
22このsetupパッケージには、passwd, group, profile などの、
23重要なシステム設定ファイルが含まれてます。
24
25%prep
26%setup -q -n %{name}-vine-%{version}
27./shadowconvert.sh
28
29%install
30rm -rf %{buildroot}
31mkdir -p %{buildroot}/etc/profile.d
32cp -ar * %{buildroot}/etc
33rm -f %{buildroot}/etc/uidgid
34rm -f %{buildroot}/etc/COPYING
35mkdir -p %{buildroot}/var/log
36touch %{buildroot}/etc/{shadow,gshadow}
37touch %{buildroot}/var/log/lastlog
38touch %{buildroot}/etc/environment
39chmod 0644 %{buildroot}/etc/environment
40chmod 0400 %{buildroot}/etc/{shadow,gshadow}
41chmod 0644 %{buildroot}/var/log/lastlog
42touch %{buildroot}/etc/fstab
43
44# remove unpackaged files
45rm -f %{buildroot}/etc/Makefile
46rm -f %{buildroot}/etc/services.orig
47rm -f %{buildroot}/etc/serviceslint
48rm -f %{buildroot}/etc/uidgidlint
49rm -f %{buildroot}/etc/shadowconvert.sh
50rm -f %{buildroot}/etc/setup.spec
51rm -f $RPM_BUILD_ROOT/etc/{bashrc,aliases}
52
53%clean
54rm -rf %{buildroot}
55
56#throw away useless and dangerous update stuff until rpm will be able to
57#handle it ( http://rpm.org/ticket/6 )
58%post -p <lua>
59for i, name in ipairs({"passwd", "shadow", "group", "gshadow"}) do
60     os.remove("/etc/"..name..".rpmnew")
61end
62
63%files
64%defattr(-,root,root)
65%doc uidgid COPYING
66%verify(not md5 size mtime) %config(noreplace) /etc/passwd
67%verify(not md5 size mtime) %config(noreplace) /etc/group
68%verify(not md5 size mtime) %config(noreplace,missingok) /etc/shadow
69%verify(not md5 size mtime) %config(noreplace,missingok) /etc/gshadow
70%verify(not md5 size mtime) %config(noreplace) /etc/services
71%verify(not md5 size mtime) %config(noreplace) /etc/exports
72%config(noreplace) /etc/environment
73%config(noreplace) /etc/filesystems
74%config(noreplace) /etc/host.conf
75%verify(not md5 size mtime) %config(noreplace) /etc/hosts
76%verify(not md5 size mtime) %config(noreplace) /etc/hosts.allow
77%verify(not md5 size mtime) %config(noreplace) /etc/hosts.deny
78%verify(not md5 size mtime) %config(noreplace) /etc/motd
79%config(noreplace) /etc/printcap
80%verify(not md5 size mtime) %config(noreplace) /etc/inputrc
81# config(noreplace) /etc/bashrc
82%config(noreplace) /etc/profile
83%verify(not md5 size mtime) %config(noreplace) /etc/protocols
84%attr(0600,root,root) %config(noreplace,missingok) /etc/securetty
85%config(noreplace) /etc/csh.login
86%config(noreplace) /etc/csh.cshrc
87%dir /etc/profile.d
88%config(noreplace) %verify(not md5 size mtime) /etc/shells
89%ghost %attr(0644,root,root) %verify(not md5 size mtime) /var/log/lastlog
90%ghost %verify(not md5 size mtime) %config(noreplace,missingok) /etc/fstab
91
92%changelog
93* Wed Jul 02 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 2.9.0-1
94- rebase to 2.9.0
95
96* Thu Apr 14 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.31-1
97- update to 2.8.31
98- use <lua> for post scriptlet
99
100* Sat Mar 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.1-1
101- update to 2.8.1
102- spec in utf-8
103- new versioning policy
104- add %%postun to remove dangerous .rpmnew files
105
106* Sat May 20 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.7-2vl5
107- add /etc/environment
108- add /etc/{fstab,mtab} as %%ghost
109- add console to /etc/securetty
110- import /etc/services from FC
111- set mark-symlinked-directories in /etc/inputrc
112- add /sbin/nologin to /etc/shells
113
114* Fri Mar 04 2005 Satoshi MACHINO <machino@vinelinux.org> 2.5.7-2vl4
115- updated setup-2.5.7-vine.patch
116        -- changed /etc/printcap for using cups
117
118* Mon Jun 28 2004 NISHIMURA Daisuke <nishi@graco.c.u-tokyo.ac.jp> 2.5.7-2vl3
119- source /etc/profile.d/*.sh in /etc/profile
120
121* Sun Feb 24 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.7-2vl1
122- merge with new upstream version
123
124* Wed Jan 09 2002 Tim Powers <timp@redhat.com>
125- automated rebuild
126
127* Mon Aug 27 2001 Preston Brown <pbrown@redhat.com>
128- add ext3 to /etc/filesystems
129
130* Mon Aug 20 2001 Bill Nottingham <notting@redhat.com>
131- change FTP user's home dir to /var/ftp (#52091)
132- %%ghost /etc/shadow, /etc/gshadow
133
134* Fri Aug 17 2001 Bill Nottingham <notting@redhat.com>
135- add /etc/shells to filelist (#51813)
136
137* Mon Aug 13 2001 Bill Nottingham <notting@redhat.com>
138- put lock in /etc/group (#51654)
139
140* Wed Aug  8 2001 Bill Nottingham <notting@redhat.com>
141- lock only needs to be a gid
142- don't set dspmbyte=euc here; do it in lang.csh, and only if necessary (#50318)
143
144* Mon Aug  6 2001 Jeff Johnson <jbj@redhat.com>
145- add lock.lock uid/gid 54 to own /var/lock directory.
146
147* Thu Jul 19 2001 Bill Nottingham <notting@redhat.com>
148- add forward/backward-word mappings (#48783)
149- add pgpkeyserver port to /etc/services (#49407)
150
151* Thu Jul 19 2001 Preston Brown <pbrown@redhat.com>
152- core files disabled by default.  Developers can enable them.
153
154* Fri Jul 13 2001 Bill Nottingham <notting@redhat.com> 2.5.1-1
155- revert news user back to no shell (#48701)
156
157* Tue Jul 10 2001 Bill Nottingham <notting@redhat.com> 2.5.0-1
158- move profile.d parsing from csh.cshrc to csh.login (#47417)
159
160* Sat Jul  7 2001 Nalin Dahyabhai <nalin@redhat.com> 2.4.15-1
161- reorder /etc/services to match comments again
162- protocol 118 is stp, not st
163- update URLs in /etc/protocols and /etc/services
164
165* Thu Jul  5 2001 Preston Brown <pbrown@redhat.com> 2.4.14-1
166- put */sbin in path if user ID is 0.
167
168* Mon Jun 25 2001 Bill Nottingham <notting@redhat.com>
169- add an entry to /etc/services for ssh X11 forwarding (#44944)
170
171* Wed Jun 13 2001 Bill Nottingham <notting@redhat.com>
172- take ttyS0 out of securetty on main tree
173
174* Tue Jun 12 2001 Philip Copeland <bryce@redhat.com>
175- added ttyS0 to securetty for serial console usage
176
177* Tue Jun 12 2001 Bill Nottingham <notting@redhat.com>
178- add rndc to /etc/services (#40265)
179- test for read bit, not execute bit, for profile.d (#35714)
180
181* Sun Jun 03 2001 Florian La Roche <Florian.LaRoche@redhat.de>
182- add "canna" entry to /etc/services
183
184* Mon May 21 2001 Bernhard Rosenkraenzer <bero@redhat.com> 2.4.10-1
185- Fix bugs #24159 and #30634 again; whoever moved bashrc from bash
186  to setup used an old version. :((
187
188* Wed May  2 2001 Preston Brown <pbrown@redhat.com> 2.4.9-1
189- bashrc moved here from bash package
190- set umask in bashrc, so it applies for ALL shells.
191
192* Fri Apr 27 2001 Preston Brown <pbrown@redhat.com> 2.4.8-1
193- /sbin/nologin for accounts that aren't "real."
194
195* Sat Apr  7 2001 Preston Brown <pbrown@redhat.com>
196- revert control-arrow forward/backward word (broken)
197
198* Tue Mar 27 2001 Preston Brown <pbrown@redhat.com>
199- fix japanese input with tcsh (#33211)
200
201* Tue Mar  6 2001 Bill Nottingham <notting@redhat.com>
202- fix some weirdness with rxvt (#30799)
203
204* Wed Feb 28 2001 Bill Nottingham <notting@redhat.com>
205- add SKK input method (#29759)
206
207* Fri Feb 23 2001 Preston Brown <pbrown@redhat.com>
208
209* Wed Feb 21 2001 Bill Nottingham <notting@redhat.com>
210- fix inputrc, Yet Again. (#28617)
211
212* Thu Feb 15 2001 Bill Nottingham <notting@redhat.com>
213- add in uidgid file, put it in %doc
214
215* Wed Feb  7 2001 Adrian Havill <havill@redhat.com>
216- bindkey for delete in the case of tcsh
217
218* Wed Feb  7 2001 Bill Nottingham <notting@redhat.com>
219- add some more stuff to /etc/services (#25396, patch from
220  <pekkas@netcore.fi>)
221
222* Tue Feb  6 2001 Nalin Dahyabhai <nalin@redhat.com>
223- add gii/tcp = 616 for gated
224
225* Tue Jan 30 2001 Bill Nottingham <notting@redhat.com>
226- wrap some inputrc settings with tests for mode, term (#24117)
227
228* Mon Jan 29 2001 Bill Nottingham <notting@redhat.com>
229- overhaul /etc/protocols (#18530)
230- add port 587 to /etc/services (#25001)
231- add corbaloc (#19581)
232- don't set /usr/X11R6/bin in $PATH if it's already set (#19968)
233
234* Fri Dec  1 2000 Nalin Dahyabhai <nalin@redhat.com>
235- Clean up /etc/services, separating registered numbers from unregistered
236  ("squatted") numbers, and adding some.
237
238* Mon Nov 20 2000 Bernhard Rosenkraenzer <bero@redhat.com>
239- Add smtps (465/tcp) and submission (587/tcp) to /etc/services for TLS
240  support (postfix >= 20001030-2)
241
242* Mon Nov  6 2000 Kazuhisa TAKEI <takei@vinelinux.org>
243- rebuild in  rpm 3.0.6
244
245* Wed Oct 11 2000 Jun Nishii <jun@vinelinux.org>
246- remove reading profile.d process from /etc/profile
247  the process moved to /etc/bashrc...
248
249* Thu Sep 07 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
250- 2.2.1-1vl2
251- removed /etc/filesystems in %files section
252
253* Sun Aug  6 2000 Bill Nottingham <notting@redhat.com>
254- /var/log/lastlog is %config(noreplace) (#15412)
255- some of the various %verify changes (#14819)
256
257* Thu Aug  3 2000 Nalin Dahyabhai <nalin@redhat.com>
258- linuxconf should be 98, not 99
259
260* Tue Jul 25 2000 Bill Nottingham <notting@redhat.com>
261- fix some of the csh stuff (#14622)
262
263* Sun Jul 23 2000 Nalin Dahyabhai <nalin@redhat.com>
264- stop setting "multi on" in /etc/host.conf
265
266* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
267- automatic rebuild
268
269* Tue Jun 27 2000 Bill Nottingham <notting@redhat.com>
270- add hfs filesystem
271
272* Wed Jun 21 2000 Preston Brown <pbrown@redhat.com>
273- printcap is a noreplace file now
274
275* Sun Jun 18 2000 Bill Nottingham <notting@redhat.com>
276- fix typo
277
278* Tue Jun 13 2000 Lisa Sagami <czs14350@nifty.ne.jp>
279- merged RH 2.2.1-1 and Vine 2.0.5-1vl3
280
281* Tue Jun 13 2000 Nalin Dahyabhai <nalin@redhat.com>
282- add linuxconf/tcp = 99 to /etc/services
283
284* Sat Jun 10 2000 Bill Nottingham <notting@redhat.com>
285- add some stuff to /etc/services
286- tweak ulimit call again
287
288* Tue Jun  6 2000 Bernhard Rosenkraenzer <bero@redhat.com>
289- homedir of ftp is now /var/ftp
290
291* Sun May 14 2000 Nalin Dahyabhai <nalin@redhat.com>
292- move profile.d logic in csh.login to csh.cshrc
293
294* Tue Apr 18 2000 Nalin Dahyabhai <nalin@redhat.com>
295- redirect ulimit -S -c to /dev/null to avoid clutter
296
297* Thu Apr 13 2000 Bernhard Rosenkraenzer <bero@redhat.com>
298- s/ulimit -c/ulimit -S -c/ - bash 2.x adaption
299
300* Mon Apr 03 2000 Nalin Dahyabhai <nalin@redhat.com>
301- Add more of the kerberos-related services from IANA's registry and krb5
302
303* Wed Mar 29 2000 Bernhard Rosenkraenzer <bero@redhat.com>
304- Add 2.4'ish vc/* devices to securetty
305
306* Thu Feb 17 2000 Preston Brown <pbrown@redhat.com>
307- add /etc/filesystems with sane defaults
308
309* Wed Feb 16 2000 Bill Nottingham <notting@redhat.com>
310- don't set prompt in /etc/profile (it's done in /etc/bashrc)
311
312* Sat Feb  5 2000 Bill Nottingham <notting@redhat.com>
313- yet more inputrc tweaks from Hans de Goede (hans@highrise.nl)
314
315* Sun Jan 30 2000 Bill Nottingham <notting@redhat.com>
316- yet more inputrc tweaks from Hans de Goede (hans@highrise.nl)
317
318* Sun Jan 23 2000 Bill Nottingham <notting@redhat.com>
319- fix mailq line. (#7140)
320
321* Fri Jan 21 2000 Bill Nottingham <notting@redhat.com>
322- add ldap to /etc/services
323
324* Tue Jan 18 2000 Bill Nottingham <notting@redhat.com>
325- kill HISTFILESIZE, it's broken
326
327* Tue Jan 18 2000 Preston Brown <pbrown@redhat.com>
328- some inputrc tweaks
329
330* Wed Jan 12 2000 Bill Nottingham <notting@redhat.com>
331- make some more stuff noreplace
332
333* Fri Nov 19 1999 Bill Nottingham <notting@redhat.com>
334- fix mailq line. (#7140)
335
336* Fri Oct 29 1999 Bill Nottingham <notting@redhat.com>
337- split csh.login into csh.login and csh.cshrc (#various)
338- fix pop service names (#6206)
339- fix ipv6 protocols entries (#6219)
340
341* Thu Sep  2 1999 Jeff Johnson <jbj@redhat.com>
342- rename /etc/csh.cshrc to /etc/csh.login (#2931).
343- (note: modified /etc/csh.cshrc should end up in /etc/csh.cshrc.rpmsave)
344
345* Fri Aug 20 1999 Jeff Johnson <jbj@redhat.com>
346- add defattr.
347- fix limit command in /etc/csh.cshrc (#4582).
348
349* Thu Jul  8 1999 Bill Nottingham <notting@redhat.com>
350- move /etc/inputrc here.
351
352* Mon Apr 19 1999 Bill Nottingham <notting@redhat.com>
353- always use /etc/inputrc
354
355* Wed Mar 31 1999 Preston Brown <pbrown@redhat.com>
356- added alias pointing to imap from imap2
357
358* Tue Mar 23 1999 Preston Brown <pbrown@redhat.com>
359- updated protocols/services from debian to comply with more modern
360- IETF/RFC standards
361
362* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
363- auto rebuild in the new build environment (release 4)
364
365* Thu Feb 18 1999 Jeff Johnson <jbj@redhat.com>
366- unset variables used in /etc/csh.cshrc (#1212)
367
368* Mon Jan 18 1999 Jeff Johnson <jbj@redhat.com>
369- compile for Raw Hide.
370
371* Tue Oct 13 1998 Cristian Gafton <gafton@redhat.com>
372- fix the csh.cshrc re: ${PATH} undefined
373
374* Mon Apr 27 1998 Prospector System <bugs@redhat.com>
375- translations modified for de, fr, tr
376
377* Fri Dec 05 1997 Erik Troan <ewt@redhat.com>
378- /etc/profile uses $i, which needs to be unset
379
380* Mon Nov 03 1997 Donnie Barnes <djb@redhat.com>
381- made /etc/passwd and /etc/group %config(noreplace)
382
383* Mon Oct 20 1997 Erik Troan <ewt@redhat.com>
384- removed /etc/inetd.conf, /etc/rpc
385- flagged /etc/securetty as missingok
386- fixed buildroot stuff in spec file
387
388* Thu Jul 31 1997 Erik Troan <ewt@redhat.com>
389- made a noarch package
390
391* Wed Apr 16 1997 Erik Troan <ewt@redhat.com>
392- Don't verify md5sum, size, or timestamp of /var/log/lastlog, /etc/passwd,
393  or /etc/group.
Note: See TracBrowser for help on using the repository browser.