source: projects/specs/trunk/s/sed/sed-vl.spec @ 8851

Revision 8851, 6.6 KB checked in by Takemikaduchi, 10 years ago (diff)

alsa, mc: new upstream release
others: rebuild

Line 
1%ifos linux
2%define _bindir /bin
3%endif
4
5Summary: A GNU stream text editor.
6Summary(ja): GNU ストリームテキストエディタ
7Name: sed
8Version: 4.2.2
9Release: 2%{?_dist_release}
10
11License: GPLv2+
12Group: Applications/Text
13URL: http://www.gnu.org/software/sed/
14
15Source0: ftp://ftp.gnu.org/pub/gnu/sed/sed-%{version}.tar.bz2
16#Patch0: sed-4.2.1-dummyparam.diff
17#Patch1: sed-4.2.1-multibyte.patch
18
19BuildRoot: %{_tmppath}/%{name}-%{version}-root
20BuildRequires: glibc-devel
21BuildRequires: libacl-devel
22Requires(post): /sbin/install-info
23Requires(preun): /sbin/install-info
24
25%description
26The sed (Stream EDitor) editor is a stream or batch (non-interactive)
27editor.  Sed takes text as input, performs an operation or set of
28operations on the text and outputs the modified text.  The operations
29that sed performs (substitutions, deletions, insertions, etc.) can be
30specified in a script file or from the command line.
31
32%description -l ja
33sed (Stream Editor) エディタはストリームまたはバッチ(非インタラクティブ)
34エディタです。sed は入力としてテキストを用い、テキストの操作または
35操作のセットをテキストとに対して行い、修正されたテキストを出力します。
36sed が行う操作 (置換、削除、挿入、その他) はスクリプトファイルか、
37コマンドラインから指定されます。
38
39%prep
40%setup -q
41#%patch0 -p1
42#%patch1 -p1 -b .mb
43
44%build
45export LANG=C
46%configure --without-included-regex
47make %{_smp_mflags}
48
49echo ====================TESTING=========================
50make check
51echo ====================TESTING END=====================
52
53%install
54rm -rf $RPM_BUILD_ROOT
55
56%makeinstall
57rm -f $RPM_BUILD_ROOT/%{_infodir}/dir
58
59%find_lang %{name}
60
61%post
62/sbin/install-info %{_infodir}/sed.info.gz %{_infodir}/dir
63
64%preun
65if [ $1 = 0 ]; then
66   /sbin/install-info --delete %{_infodir}/sed.info.gz %{_infodir}/dir
67fi
68
69%clean
70rm -rf ${RPM_BUILD_ROOT}
71
72%files -f %{name}.lang
73%defattr(-,root,root)
74%doc BUGS NEWS THANKS README AUTHORS
75%{_bindir}/sed
76%{_infodir}/*.info*
77%{_mandir}/man*/*
78
79%changelog
80* Sun Jul 20 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 4.2.2-2
81- rebuild with VineSeed environment
82
83* Sat Jul 20 2013 Toshiharu Kudoh <toshi.kd2@gmail.com> - 4.2.2-1
84- new upstream release
85- deleted all patches
86
87* Sat Apr 16 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.2.1-3
88- rebuilt with current VineSeed
89
90* Mon Dec 14 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.2.1-2
91- added Patch1 from Debian (#551075)
92  Apply patch from WANG Yunfeng to treat incomplete multibyte
93  sequences as a single-byte character.
94
95* Mon Nov 30 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.2.1-1
96- new upstream release, dropped Patch1 and 2
97- added Patch0 from Fedora
98  * Mon Jun 29 2009  Jiri Moskovcak <jmoskovc@redhat.com>
99  - added patch to maintain backwards compatibility for scripts using -c/--copy
100  - Resolves: #502934
101
102* Mon Sep 29 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 4.1.5-3
103- rebuilt against current toolchain
104- spec in UTF-8
105
106* Sun Apr 20 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.1.5-2vl5
107- dropped Patch0
108
109* Sat Apr 19 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.1.5-1vl5
110- added Patch0-2 from Fedora
111  * Mon Sep  4 2006 Petr Machata <pmachata@redhat.com> - 4.1.5-5
112  - Fix handling of relative symlinks (#205122)
113  * Wed Aug  3 2006 Petr Machata <pmachata@redhat.com> - 4.1.5-4
114  - remove superfluous multibyte processing in str_append for UTF-8
115    encoding (thanks Paolo Bonzini, #177246)
116  * Thu Jun 29 2006 Petr Machata <pmachata@redhat.com> - 4.1.5-2
117  - #185374:
118    - Follow symlinks before rename (avoid symlink overwrite)
119    - Add -c flag for copy instead of rename (avoid ownership change)
120
121* Sat Aug 25 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.1.5-0vl1
122- new upstream release
123- run 'make check' on non-English locale
124
125* Thu Mar 09 2006 Shu KONNO <owa@bg.wakwak.com> 4.1.2-0vl2
126- s/Copyright/License/
127- rebuilt for x86_64 architecture support
128
129* Wed Oct 13 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 4.1.2-0vl1
130- new upstream release
131
132* Thu Jun 17 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 4.1-0vl1
133- new upstream release
134- remove obsolete patch
135
136* Mon Apr 12 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 4.0.8-4vl2
137- rebuilt for Vine
138  * Wed Jan  7 2004 Jakub Jelinek <jakub@redhat.com> 4.0.8-3
139  - if not -n, print current buffer after N command on the last line
140    unless POSIXLY_CORRECT (#112952)
141  - adjust XFAIL_TESTS for the improved glibc regex implementation
142    (#112642)
143
144  * Fri Nov 14 2003 Jakub Jelinek <jakub@redhat.com> 4.0.8-2
145  - enable --without-included-regex again
146  - use fastmap for regex searching
147
148  * Sat Oct 25 2003 Florian La Roche <Florian.LaRoche@redhat.de>
149  - update to 4.0.8
150  - simplify specfile
151  - disable --without-included-regex to pass the testsuite
152
153  * Sat Apr 12 2003 Florian La Roche <Florian.LaRoche@redhat.de>
154  - update to 4.0.7
155  - use "--without-included-regex"
156  - do not gzip info pages in spec file, "TODO" is not present anymore
157
158  * Thu Jan 23 2003 Jakub Jelinek <jakub@redhat.com> 4.0.5-1
159  - update to 4.0.5
160
161  * Tue Oct 22 2002 Jakub Jelinek <jakub@redhat.com>
162  - rebuilt to fix x86-64 miscompilation
163  - run make check in %%build
164
165  * Fri Apr  5 2002 Jakub Jelinek <jakub@redhat.com>
166  - Remove stale URLs from documentation (#62519)
167
168  * Sun Jun 24 2001 Elliot Lee <sopwith@redhat.com>
169  - Bump release + rebuild.
170
171  * Mon Dec 18 2000 Yukihiro Nakai <ynakai@redhat.com>
172  - Update to 2000.11.28 patch
173  - Rebuild for 7.1 tree
174
175  * Mon Jun  5 2000 Jeff Johnson <jbj@redhat.com>
176  - FHS packaging.
177
178  * Mon Feb  7 2000 Jeff Johnson <jbj@redhat.com>
179  - compress man pages.
180
181  * Tue Jan 18 2000 Jakub Jelinek <jakub@redhat.com>
182  - rebuild with glibc 2.1.3 to fix an mmap64 bug in sys/mman.h
183
184* Sat Oct 06 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 3.02_mb1.09-0vl1
185- mb patch updated to 1.09
186
187* Tue May 29 2001 <sagami@vinelinux.org>
188- 3.02_mb1.08-1vl2: use better macros
189
190* Fri Sep 08 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
191- 3.02_mb1.08-1vl1
192- modified %files section to handle compressed man page(s)
193
194* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
195- auto rebuild in the new build environment (release 4)
196
197* Tue Aug 18 1998 Jeff Johnson <jbj@redhat.com>
198- update to 3.02
199
200* Sun Jul 26 1998 Jeff Johnson <jbj@redhat.com>
201- update to 3.01
202
203* Mon Apr 27 1998 Prospector System <bugs@redhat.com>
204- translations modified for de, fr, tr
205
206* Thu Oct 23 1997 Donnie Barnes <djb@redhat.com>
207- removed references to the -g option from the man page that we add
208
209* Fri Oct 17 1997 Donnie Barnes <djb@redhat.com>
210- spec file cleanups
211- added BuildRoot
212
213* Mon Jun 02 1997 Erik Troan <ewt@redhat.com>
214- built against glibc
Note: See TracBrowser for help on using the repository browser.