source: projects/specs/trunk/s/sed/sed-vl.spec @ 7732

Revision 7732, 6.5 KB checked in by kudoh, 11 years ago (diff)

--force-log

Line 
1%ifos linux
2%define _bindir /bin
3%endif
4
5Summary: A GNU stream text editor.
6Summary(ja): GNU ストリームテキストエディタ
7Name: sed
8Version: 4.2.2
9Release: 1%{?_dist_release}
10
11License: GPLv2+
12Group: Applications/Text
13URL: http://www.gnu.org/software/sed/
14
15Source0: ftp://ftp.gnu.org/pub/gnu/sed/sed-%{version}.tar.bz2
16#Patch0: sed-4.2.1-dummyparam.diff
17#Patch1: sed-4.2.1-multibyte.patch
18
19BuildRoot: %{_tmppath}/%{name}-%{version}-root
20BuildRequires: glibc-devel
21BuildRequires: libacl-devel
22Requires(post): /sbin/install-info
23Requires(preun): /sbin/install-info
24
25%description
26The sed (Stream EDitor) editor is a stream or batch (non-interactive)
27editor.  Sed takes text as input, performs an operation or set of
28operations on the text and outputs the modified text.  The operations
29that sed performs (substitutions, deletions, insertions, etc.) can be
30specified in a script file or from the command line.
31
32%description -l ja
33sed (Stream Editor) エディタはストリームまたはバッチ(非インタラクティブ)
34エディタです。sed は入力としてテキストを用い、テキストの操作または
35操作のセットをテキストとに対して行い、修正されたテキストを出力します。
36sed が行う操作 (置換、削除、挿入、その他) はスクリプトファイルか、
37コマンドラインから指定されます。
38
39%prep
40%setup -q
41#%patch0 -p1
42#%patch1 -p1 -b .mb
43
44%build
45export LANG=C
46%configure --without-included-regex
47make %{_smp_mflags}
48
49echo ====================TESTING=========================
50make check
51echo ====================TESTING END=====================
52
53%install
54rm -rf $RPM_BUILD_ROOT
55
56%makeinstall
57rm -f $RPM_BUILD_ROOT/%{_infodir}/dir
58
59%find_lang %{name}
60
61%post
62/sbin/install-info %{_infodir}/sed.info.gz %{_infodir}/dir
63
64%preun
65if [ $1 = 0 ]; then
66   /sbin/install-info --delete %{_infodir}/sed.info.gz %{_infodir}/dir
67fi
68
69%clean
70rm -rf ${RPM_BUILD_ROOT}
71
72%files -f %{name}.lang
73%defattr(-,root,root)
74%doc BUGS NEWS THANKS README AUTHORS
75%{_bindir}/sed
76%{_infodir}/*.info*
77%{_mandir}/man*/*
78
79%changelog
80* Sat Jul 20 2013 Toshiharu Kudoh <toshi.kd2@gmail.com> - 4.2.2-1
81- new upstream release
82- deleted all patches
83
84* Sat Apr 16 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.2.1-3
85- rebuilt with current VineSeed
86
87* Mon Dec 14 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.2.1-2
88- added Patch1 from Debian (#551075)
89  Apply patch from WANG Yunfeng to treat incomplete multibyte
90  sequences as a single-byte character.
91
92* Mon Nov 30 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.2.1-1
93- new upstream release, dropped Patch1 and 2
94- added Patch0 from Fedora
95  * Mon Jun 29 2009  Jiri Moskovcak <jmoskovc@redhat.com>
96  - added patch to maintain backwards compatibility for scripts using -c/--copy
97  - Resolves: #502934
98
99* Mon Sep 29 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 4.1.5-3
100- rebuilt against current toolchain
101- spec in UTF-8
102
103* Sun Apr 20 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.1.5-2vl5
104- dropped Patch0
105
106* Sat Apr 19 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.1.5-1vl5
107- added Patch0-2 from Fedora
108  * Mon Sep  4 2006 Petr Machata <pmachata@redhat.com> - 4.1.5-5
109  - Fix handling of relative symlinks (#205122)
110  * Wed Aug  3 2006 Petr Machata <pmachata@redhat.com> - 4.1.5-4
111  - remove superfluous multibyte processing in str_append for UTF-8
112    encoding (thanks Paolo Bonzini, #177246)
113  * Thu Jun 29 2006 Petr Machata <pmachata@redhat.com> - 4.1.5-2
114  - #185374:
115    - Follow symlinks before rename (avoid symlink overwrite)
116    - Add -c flag for copy instead of rename (avoid ownership change)
117
118* Sat Aug 25 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.1.5-0vl1
119- new upstream release
120- run 'make check' on non-English locale
121
122* Thu Mar 09 2006 Shu KONNO <owa@bg.wakwak.com> 4.1.2-0vl2
123- s/Copyright/License/
124- rebuilt for x86_64 architecture support
125
126* Wed Oct 13 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 4.1.2-0vl1
127- new upstream release
128
129* Thu Jun 17 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 4.1-0vl1
130- new upstream release
131- remove obsolete patch
132
133* Sat Apr 12 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 4.0.8-4vl2
134- rebuilt for Vine
135  * Wed Jan  7 2004 Jakub Jelinek <jakub@redhat.com> 4.0.8-3
136  - if not -n, print current buffer after N command on the last line
137    unless POSIXLY_CORRECT (#112952)
138  - adjust XFAIL_TESTS for the improved glibc regex implementation
139    (#112642)
140
141  * Fri Nov 14 2003 Jakub Jelinek <jakub@redhat.com> 4.0.8-2
142  - enable --without-included-regex again
143  - use fastmap for regex searching
144
145  * Sat Oct 25 2003 Florian La Roche <Florian.LaRoche@redhat.de>
146  - update to 4.0.8
147  - simplify specfile
148  - disable --without-included-regex to pass the testsuite
149
150  * Sat Apr 12 2003 Florian La Roche <Florian.LaRoche@redhat.de>
151  - update to 4.0.7
152  - use "--without-included-regex"
153  - do not gzip info pages in spec file, "TODO" is not present anymore
154
155  * Thu Jan 23 2003 Jakub Jelinek <jakub@redhat.com> 4.0.5-1
156  - update to 4.0.5
157
158  * Tue Oct 22 2002 Jakub Jelinek <jakub@redhat.com>
159  - rebuilt to fix x86-64 miscompilation
160  - run make check in %%build
161
162  * Fri Apr  5 2002 Jakub Jelinek <jakub@redhat.com>
163  - Remove stale URLs from documentation (#62519)
164
165  * Sun Jun 24 2001 Elliot Lee <sopwith@redhat.com>
166  - Bump release + rebuild.
167
168  * Mon Dec 18 2000 Yukihiro Nakai <ynakai@redhat.com>
169  - Update to 2000.11.28 patch
170  - Rebuild for 7.1 tree
171
172  * Mon Jun  5 2000 Jeff Johnson <jbj@redhat.com>
173  - FHS packaging.
174
175  * Mon Feb  7 2000 Jeff Johnson <jbj@redhat.com>
176  - compress man pages.
177
178  * Tue Jan 18 2000 Jakub Jelinek <jakub@redhat.com>
179  - rebuild with glibc 2.1.3 to fix an mmap64 bug in sys/mman.h
180
181* Sat Oct 06 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 3.02_mb1.09-0vl1
182- mb patch updated to 1.09
183
184* Tue May 29 2001 <sagami@vinelinux.org>
185- 3.02_mb1.08-1vl2: use better macros
186
187* Fri Sep 08 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
188- 3.02_mb1.08-1vl1
189- modified %files section to handle compressed man page(s)
190
191* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
192- auto rebuild in the new build environment (release 4)
193
194* Tue Aug 18 1998 Jeff Johnson <jbj@redhat.com>
195- update to 3.02
196
197* Sun Jul 26 1998 Jeff Johnson <jbj@redhat.com>
198- update to 3.01
199
200* Mon Apr 27 1998 Prospector System <bugs@redhat.com>
201- translations modified for de, fr, tr
202
203* Thu Oct 23 1997 Donnie Barnes <djb@redhat.com>
204- removed references to the -g option from the man page that we add
205
206* Fri Oct 17 1997 Donnie Barnes <djb@redhat.com>
207- spec file cleanups
208- added BuildRoot
209
210* Mon Jun 02 1997 Erik Troan <ewt@redhat.com>
211- built against glibc
Note: See TracBrowser for help on using the repository browser.