source: projects/specs/trunk/s/scim-bridge/scim-bridge-vl.spec @ 5389

Revision 5389, 11.8 KB checked in by inagaki, 12 years ago (diff)

update: scim-bridge

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3%define name scim-bridge
4%define version 0.4.16
5%define release 16%{?_dist_release}
6
7%define qt3_ver 3.3.8
8%define qt4_ver 4.8.0
9
10# build qt3 immodule ("--without qt3" to disable qt3)
11%bcond_without qt3
12%define _qt3_version 3.3.8
13%define _qt3_prefix  %{_libdir}/qt-%{_qt3_version}
14%define _qt3_plugindir %{_qt3_prefix}/plugins
15
16# build qt4 immodule ("--without qt4" to disable qt4)
17%bcond_without qt4
18# Qt4 version auto-detection -- inagaki
19%define _qt4_version %(pkg-config --modversion --silence-errors Qt 2>/dev/null || echo %{qt4_ver})
20%define _qt4_prefix %(pkg-config --variable prefix --silence-errors Qt 2>/dev/null || echo %{_libdir}/qt4)
21%define _qt4_plugindir %(pkg-config --variable plugindir --silence-errors Qt 2>/dev/null || echo %{_qt4_prefix}/plugins)
22
23
24Summary: yet another IM client of SCIM
25Summary(ja): もう一つ別の SCIM IM クライアント
26Name: %{name}
27Version: %{version}
28Release: %{release}
29
30Group: System Environment/Libraries
31License: GPL/LGPL
32URL: http://www.scim-im.org/projects/scim_bridge
33
34Source0: http://1jaist.dl.sourceforge.net/sourceforge/scim/%{name}-%{version}.tar.gz
35
36# Patch from Fedora 10
37Patch0: scim-bridge-0.4.15-fix-gdm.patch
38Patch1: scim-bridge-0.4.15-bz461373.patch
39
40# Patch from Mandriva 2009
41Patch2: bug-351920-should-return-retval.patch
42Patch3: scim-bridge-0.4.15.2-linkage.patch
43
44# Patch from Fedora development
45Patch4: scim-bridge-0.4.15-EOF.patch
46Patch5: scim-bridge-0.4.15-hotkey-help.patch
47Patch6: scim-bridge-0.4.16-fix-gtk-key-snooper.patch
48Patch7: scim-bridge-0.4.16-fixes-null-imengine.patch
49
50BuildRoot: %{_tmppath}/%{name}-%{version}-root
51BuildRequires: scim-devel >= 1.4
52BuildRequires: pkgconfig >= 0.9.0
53BuildRequires: gtk2-devel >= 2.14.0
54
55Requires: scim >= 1.4
56
57%description
58Scim-bridge is yet another IM client of SCIM.
59The im-module of scim-bridge communicates with scim via socket.
60
61%description -l ja
62scim-bridge は、もう一つ別の SCIM IM クライアントです。
63scim-bridge の im-module はソケット経由で SCIM と通信します。
64
65%package gtk
66Summary:        SCIM Bridge GTK IM Module
67Summary(ja):    SCIM Bridge GTK IM モジュール
68Group:          System Environment/Libraries
69Requires:       %{name} = %{version}-%{release}
70Requires:       gtk2 >= 2.14.0
71Requires(post): gtk2 >= 2.14.0
72Requires(postun): gtk2 >= 2.14.0
73Obsoletes:      %{name} <= 0.1.7
74
75%description gtk
76This package provides the SCIM Bridge GTK IM module.
77
78%description -l ja gtk
79このパッケージには SCIM Bridge の GTK IM モジュールが含まれています。
80
81%if !%{without qt3}
82%package qt
83Summary:        SCIM Bridge Qt IM Module
84Summary(ja):    SCIM Bridge Qt IM モジュール
85Group:          System Environment/Libraries
86Requires:       %{name} = %{version}-%{release}
87Requires:       qt = %{_qt3_version}
88BuildRequires:  qt-devel
89BuildRequires:  libXmu-devel
90
91%description qt
92This package provides the SCIM Bridge Qt IM module.
93
94%description -l ja qt
95このパッケージには SCIM Bridge の Qt IM モジュールが含まれています。
96%endif
97
98%if !%{without qt4}
99%package qt4
100Summary:        SCIM Bridge Qt4 IM Module
101Summary(ja):    SCIM Bridge Qt4 IM モジュール
102Group:          System Environment/Libraries
103Requires:       %{name} = %{version}-%{release}
104Requires:       qt4 >= %{_qt4_version}
105BuildRequires:  qt4-devel
106
107%description qt4
108This package provides the SCIM Bridge Qt4 IM module.
109
110%description -l ja qt4
111このパッケージには SCIM Bridge の Qt4 IM モジュールが含まれています。
112%endif
113
114## to build compat32 for x86_64 architecture support
115%package -n compat32-%{name}-gtk
116Summary:        SCIM Bridge GTK IM Module
117Summary(ja):    SCIM Bridge GTK IM モジュール
118Group:          System Environment/Libraries
119Requires:       %{name} = %{version}-%{release}
120Requires:       gtk2 >= 2.14.0
121Requires(post): gtk2 >= 2.14.0
122Requires(postun): gtk2 >= 2.14.0
123
124%description -n compat32-%{name}-gtk
125This package provides the SCIM Bridge GTK IM module.
126
127%description -l ja -n compat32-%{name}-gtk
128このパッケージには SCIM Bridge の GTK IM モジュールが含まれています。
129
130%if !%{without qt3}
131%package -n compat32-%{name}-qt
132Summary:        SCIM Bridge Qt IM Module
133Summary(ja):    SCIM Bridge Qt IM モジュール
134Group:          System Environment/Libraries
135Requires:       %{name} = %{version}-%{release}
136Requires:       qt = %{_qt3_version}
137BuildRequires:  qt-devel
138
139%description -n compat32-%{name}-qt
140This package provides the SCIM Bridge Qt IM module.
141
142%description -l ja -n compat32-%{name}-qt
143このパッケージには SCIM Bridge の Qt IM モジュールが含まれています。
144%endif
145
146%if !%{without qt4}
147%package -n compat32-%{name}-qt4
148Summary:        SCIM Bridge Qt4 IM Module
149Summary(ja):    SCIM Bridge Qt4 IM モジュール
150Group:          System Environment/Libraries
151Requires:       %{name} = %{version}-%{release}
152Requires:       qt4 = %{_qt4_version}
153BuildRequires:  qt4-devel
154
155%description -n compat32-%{name}-qt4
156This package provides the SCIM Bridge Qt4 IM module.
157
158%description -l ja -n compat32-%{name}-qt4
159このパッケージには SCIM Bridge の Qt4 IM モジュールが含まれています。
160%endif
161
162
163
164%prep
165%setup -q
166%patch0 -p1 -b .0-fix-gdm
167%patch1 -p1
168%patch2 -p1
169%patch3
170%patch4 -p1
171%patch5 -p1
172pushd client-gtk
173%patch6 -p0
174popd
175%patch7 -p1
176
177%build
178%if !%{without qt3}
179export QT3_PREFIX=%{_qt3_prefix}
180%endif
181%if !%{without qt4}
182export QT4_PREFIX=%{_qt4_prefix}
183%endif
184
185%configure --disable-static \
186%if %{without qt3}
187        --disable-qt3-immodule \
188%else
189        --enable-qt3-immodule \
190%endif
191%if %{without qt4}
192        --disable-qt4-immodule \
193%else
194        --enable-qt4-immodule \
195%endif
196        --enable-gtk2-immodule
197
198%__make %{?_smp_mflags}
199
200%install
201%__rm -rf %{buildroot}
202#%%makeinstall moduledir=%{buildroot}%{_libdir}/gtk-2.0/immodules
203%__make DESTDIR=%{buildroot} install
204
205# remove unneeded files
206%__rm -f %{buildroot}%{_libdir}/gtk-2.0/immodules/*.{a,la}
207%__rm -f %{buildroot}%{_qt3_plugindir}/inputmethods/*.{a,la}
208%__rm -f %{buildroot}%{_qt4_plugindir}/inputmethods/*.{a,la}
209
210%clean
211%__rm -rf %{buildroot}
212
213%post gtk
214%{_bindir}/gtk-query-immodules-2.0 > %{_sysconfdir}/gtk-2.0/%{_arch}/gtk.immodules
215
216%postun gtk
217%{_bindir}/gtk-query-immodules-2.0 > %{_sysconfdir}/gtk-2.0/%{_arch}/gtk.immodules
218
219%post -n compat32-%{name}-gtk
220%{_bindir}/gtk-query-immodules-2.0-32 > %{_sysconfdir}/gtk-2.0/i386/gtk.immodules
221
222%postun -n compat32-%{name}-gtk
223%{_bindir}/gtk-query-immodules-2.0-32 > %{_sysconfdir}/gtk-2.0/i386/gtk.immodules
224
225%files
226%defattr(-,root,root)
227%doc AUTHORS COPYING ChangeLog NEWS README doc/LICENSE*
228%{_bindir}/scim-bridge
229
230%files gtk
231%defattr(-,root,root)
232%{_libdir}/gtk-2.0/immodules/im-scim-bridge.so
233
234%if !%{without qt3}
235%files qt
236%defattr(-,root,root)
237%{_qt3_plugindir}/inputmethods/*.so
238%endif
239
240%if !%{without qt4}
241%files qt4
242%defattr(-,root,root)
243%{_qt4_plugindir}/inputmethods/*.so
244%endif
245
246## to build compat32 for x86_64 architecture support
247%if %{build_compat32}
248%files -n compat32-%{name}-gtk
249%defattr(-,root,root)
250%{_libdir}/gtk-2.0/immodules/im-scim-bridge.so
251
252%if !%{without qt3}
253%files -n compat32-%{name}-qt
254%defattr(-,root,root)
255%{_qt3_plugindir}/inputmethods/*.so
256%endif
257
258%if !%{without qt4}
259%files -n compat32-%{name}-qt4
260%defattr(-,root,root)
261%{_qt4_plugindir}/inputmethods/*.so
262%endif
263%endif
264
265
266%changelog
267* Tue Jan 10 2012 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.4.16-16
268- rebuilt with qt4-4.8.0
269
270* Tue Mar  8 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.4.16-15
271- rebuilt with qt4-4.7.2
272
273* Sat Feb  5 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.4.16-14
274- added BR: libXmu-devel to qt package
275
276* Sun Jan 30 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.4.16-13
277- rebuilt with qt4-4.7.1
278
279* Sat Oct 09 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.4.16-12
280- added compat32-* packages for x86_64 architecture support
281
282* Thu Jul 29 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.4.16-11
283- rebuilt with qt4-4.6.3
284
285* Tue Jun 22 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.4.16-10
286- used %{?_smp_mflags} macro on build
287- deleted in unused log in changelog
288  - Patch8 was none, forgot to delete...
289
290* Fri May 14 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.4.16-9
291- added Patch6,7 from Fedora development
292  - to fix Text input in firefox becomes increasingly sluggish (Patch6)
293  - to fix Process /usr/bin/scim-bridge was killed by signal 11 (Patch7)
294- added configure --disable-static option
295
296* Sun Jan 31 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.4.16-8
297- updated Qt version detection macros to build properly
298
299* Fri Jan 22 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.4.16-7
300- rebuilt with qt4-4.6.1
301
302* Sun Nov 22 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.4.16-6
303- rebuilt with qt4-4.5.3
304
305* Tue Oct 13 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.4.16-5
306- cleaned up spec
307- renumbered patch
308- added Patch5 from Fedora
309
310* Wed Sep 02 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.4.16-4
311- rebuild with qt4-4.5.2
312
313* Mon Apr 27 2009 Shu KONNO <owa@bg.wakwak.com> 0.4.16-3
314- dropt qt3rel/qt4rel part of Requires in subpackages qt, qt4
315
316* Sun Apr 26 2009 Shu KONNO <owa@bg.wakwak.com> 0.4.16-2
317- rebuild with qt-3.3.8-3vl5, because scim-bridge-qt requires "Rq: qt = %{qt3ver}-%{qt3rel}"
318
319* Sun Apr 19 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.4.16-1
320- new upstream release
321- dropt Pacth3,4,5 (these patches are merged)
322
323* Fri Apr 17 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.4.15.2-2
324- spec in UTF-8
325- fixed description in scim-bridge-qt4
326- added patch6,7 (import Fedora, Mandriva patches)
327
328* Mon Feb 2 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.4.15.2-1
329- new upstream release
330- added patch0,1,2,3,4,5 (import Fedora, Mandriva, scim-devel patches)
331
332* Wed Oct 08 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.4.15-4
333- rebuild with qt4-4.4.2
334
335* Fri Oct 03 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.4.15-3
336- add qt4 immodule
337  - build gtk,qt3,qt4 immodule by default
338
339* Sat Sep 27 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.4.15-2
340- rebuild with gtk+-2.14
341
342* Sat Apr 05 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.4.15-1
343- new upstream release
344- apply new versioning policy
345
346* Fri Jan 18 2008 IWAI, Masaharu <iwai@alib.jp> 0.4.14-0vl2
347- drop unnecessary BuildRequires for qt3-immodule package
348- fix typo: 0.4.14-0vl1 changelog <BTS:VineLinux:#592>
349
350* Wed Jan  9 2008 IWAI, Masaharu <iwai@alib.jp> 0.4.14-0vl1
351- new upstream release
352- drop unnecessary Qt fix patch ( Patch0 ): upstream merged
353- update BuildRequires
354  - drop doxygen
355  - add XOrg-gl-devel for building qt3-immodule
356  - move libmng-devel for building qt3-immodule
357
358* Tue Oct 09 2007 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.4.13-0vl2
359- rebuild for Vine Linux 4.2.
360
361* Tue Oct 09 2007 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.4.13-0vl3
362- add patch0 to fix symbol lookup error with qt3.
363
364* Wed Sep 26 2007 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.4.13-0vl0
365- rebuild for Vine Linux 4.2.
366
367* Sat Sep 15 2007 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.4.13-0vl1
368- new upstrm release
369- detect qt version at build time.
370- add --disable-qt4-immodule configure option.
371- add BuildRequires libmng-devel.
372
373* Thu May 10 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.4.12-0vl2
374- rebuild with libstdc++34
375
376* Thu May 03 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.4.12-0vl1
377- new upstream release
378
379* Tue Dec 19 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.4.8-0vl2
380- change License to GPL/LGPL
381- add doc/LICENSE.* as documents
382
383* Mon Dec 18 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.4.8-0vl1
384- new upstream release
385- add BuildRequires: doxygen, qt-devel
386- add new sub-packages:
387  - gtk: GTK IM module (obsoletes: %%{name} <= 0.1.7)
388  - qt:  Qt IM module
389
390* Wed May 10 2006 IWAI, Masaharu <iwai@alib.jp> 0.1.7-0vl1
391- new upstream release
392- add documents
393- running gtk-query-immodules-2.0 in post and postun scripts
394- add PreReq: gtk2 > 2.2
395
396* Fri Apr 21 2006 IWAI, Masaharu <iwai@alib.jp> 0.1.6-0vl1
397- new upstream release
398
399* Thu Apr  6 2006 IWAI, Masaharu <iwai@alib.jp> 0.1.4-0vl1
400- initial release
401
Note: See TracBrowser for help on using the repository browser.