source: projects/specs/trunk/s/scim-bridge/scim-bridge-vl.spec @ 8084

Revision 8084, 12.0 KB checked in by Takemikaduchi, 10 years ago (diff)

new upstream release or rebuild

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3%define name scim-bridge
4%define version 0.4.16
5%define release 17%{?_dist_release}
6
7%define qt3_ver 3.3.8
8%define qt4_ver 4.8.5
9
10# build qt3 immodule ("--without qt3" to disable qt3)
11%bcond_without qt3
12%define _qt3_version 3.3.8
13%define _qt3_prefix  %{_libdir}/qt-%{_qt3_version}
14%define _qt3_plugindir %{_qt3_prefix}/plugins
15
16# build qt4 immodule ("--without qt4" to disable qt4)
17%bcond_without qt4
18# Qt4 version auto-detection -- inagaki
19%define _qt4_version %(pkg-config --modversion --silence-errors Qt 2>/dev/null || echo %{qt4_ver})
20%define _qt4_prefix %(pkg-config --variable prefix --silence-errors Qt 2>/dev/null || echo %{_libdir}/qt4)
21%define _qt4_plugindir %(pkg-config --variable plugindir --silence-errors Qt 2>/dev/null || echo %{_qt4_prefix}/plugins)
22
23
24Summary: yet another IM client of SCIM
25Summary(ja): もう一つ別の SCIM IM クライアント
26Name: %{name}
27Version: %{version}
28Release: %{release}
29
30Group: System Environment/Libraries
31License: GPL/LGPL
32URL: http://www.scim-im.org/projects/scim_bridge
33
34Source0: http://1jaist.dl.sourceforge.net/sourceforge/scim/%{name}-%{version}.tar.gz
35
36# Patch from Fedora 10
37Patch0: scim-bridge-0.4.15-fix-gdm.patch
38Patch1: scim-bridge-0.4.15-bz461373.patch
39
40# Patch from Mandriva 2009
41Patch2: bug-351920-should-return-retval.patch
42Patch3: scim-bridge-0.4.15.2-linkage.patch
43
44# Patch from Fedora development
45Patch4: scim-bridge-0.4.15-EOF.patch
46Patch5: scim-bridge-0.4.15-hotkey-help.patch
47Patch6: scim-bridge-0.4.16-fix-gtk-key-snooper.patch
48Patch7: scim-bridge-0.4.16-fixes-null-imengine.patch
49
50Patch100: scim-bridge-0.4.16-header.patch
51
52BuildRoot: %{_tmppath}/%{name}-%{version}-root
53BuildRequires: scim-devel >= 1.4
54BuildRequires: pkgconfig >= 0.9.0
55BuildRequires: gtk2-devel >= 2.14.0
56
57Requires: scim >= 1.4
58
59%description
60Scim-bridge is yet another IM client of SCIM.
61The im-module of scim-bridge communicates with scim via socket.
62
63%description -l ja
64scim-bridge は、もう一つ別の SCIM IM クライアントです。
65scim-bridge の im-module はソケット経由で SCIM と通信します。
66
67%package gtk
68Summary:        SCIM Bridge GTK IM Module
69Summary(ja):    SCIM Bridge GTK IM モジュール
70Group:          System Environment/Libraries
71Requires:       %{name} = %{version}-%{release}
72Requires:       gtk2 >= 2.14.0
73Requires(post): gtk2 >= 2.14.0
74Requires(postun): gtk2 >= 2.14.0
75Obsoletes:      %{name} <= 0.1.7
76
77%description gtk
78This package provides the SCIM Bridge GTK IM module.
79
80%description -l ja gtk
81このパッケージには SCIM Bridge の GTK IM モジュールが含まれています。
82
83%if !%{without qt3}
84%package qt
85Summary:        SCIM Bridge Qt IM Module
86Summary(ja):    SCIM Bridge Qt IM モジュール
87Group:          System Environment/Libraries
88Requires:       %{name} = %{version}-%{release}
89Requires:       qt = %{_qt3_version}
90BuildRequires:  qt-devel
91BuildRequires:  libXmu-devel
92
93%description qt
94This package provides the SCIM Bridge Qt IM module.
95
96%description -l ja qt
97このパッケージには SCIM Bridge の Qt IM モジュールが含まれています。
98%endif
99
100%if !%{without qt4}
101%package qt4
102Summary:        SCIM Bridge Qt4 IM Module
103Summary(ja):    SCIM Bridge Qt4 IM モジュール
104Group:          System Environment/Libraries
105Requires:       %{name} = %{version}-%{release}
106Requires:       qt4 >= %{_qt4_version}
107BuildRequires:  qt4-devel
108
109%description qt4
110This package provides the SCIM Bridge Qt4 IM module.
111
112%description -l ja qt4
113このパッケージには SCIM Bridge の Qt4 IM モジュールが含まれています。
114%endif
115
116## to build compat32 for x86_64 architecture support
117%package -n compat32-%{name}-gtk
118Summary:        SCIM Bridge GTK IM Module
119Summary(ja):    SCIM Bridge GTK IM モジュール
120Group:          System Environment/Libraries
121Requires:       %{name} = %{version}-%{release}
122Requires:       gtk2 >= 2.14.0
123Requires(post): gtk2 >= 2.14.0
124Requires(postun): gtk2 >= 2.14.0
125
126%description -n compat32-%{name}-gtk
127This package provides the SCIM Bridge GTK IM module.
128
129%description -l ja -n compat32-%{name}-gtk
130このパッケージには SCIM Bridge の GTK IM モジュールが含まれています。
131
132%if !%{without qt3}
133%package -n compat32-%{name}-qt
134Summary:        SCIM Bridge Qt IM Module
135Summary(ja):    SCIM Bridge Qt IM モジュール
136Group:          System Environment/Libraries
137Requires:       %{name} = %{version}-%{release}
138Requires:       qt = %{_qt3_version}
139BuildRequires:  qt-devel
140
141%description -n compat32-%{name}-qt
142This package provides the SCIM Bridge Qt IM module.
143
144%description -l ja -n compat32-%{name}-qt
145このパッケージには SCIM Bridge の Qt IM モジュールが含まれています。
146%endif
147
148%if !%{without qt4}
149%package -n compat32-%{name}-qt4
150Summary:        SCIM Bridge Qt4 IM Module
151Summary(ja):    SCIM Bridge Qt4 IM モジュール
152Group:          System Environment/Libraries
153Requires:       %{name} = %{version}-%{release}
154Requires:       qt4 = %{_qt4_version}
155BuildRequires:  qt4-devel
156
157%description -n compat32-%{name}-qt4
158This package provides the SCIM Bridge Qt4 IM module.
159
160%description -l ja -n compat32-%{name}-qt4
161このパッケージには SCIM Bridge の Qt4 IM モジュールが含まれています。
162%endif
163
164
165
166%prep
167%setup -q
168%patch0 -p1 -b .0-fix-gdm
169%patch1 -p1
170%patch2 -p1
171%patch3
172%patch4 -p1
173%patch5 -p1
174pushd client-gtk
175%patch6 -p0
176popd
177%patch7 -p1
178
179%patch100 -p1
180
181%build
182%if !%{without qt3}
183export QT3_PREFIX=%{_qt3_prefix}
184%endif
185%if !%{without qt4}
186export QT4_PREFIX=%{_qt4_prefix}
187%endif
188
189%configure --disable-static \
190%if %{without qt3}
191        --disable-qt3-immodule \
192%else
193        --enable-qt3-immodule \
194%endif
195%if %{without qt4}
196        --disable-qt4-immodule \
197%else
198        --enable-qt4-immodule \
199%endif
200        --enable-gtk2-immodule
201
202%__make %{?_smp_mflags}
203
204%install
205%__rm -rf %{buildroot}
206#%%makeinstall moduledir=%{buildroot}%{_libdir}/gtk-2.0/immodules
207%__make DESTDIR=%{buildroot} install
208
209# remove unneeded files
210%__rm -f %{buildroot}%{_libdir}/gtk-2.0/immodules/*.{a,la}
211%__rm -f %{buildroot}%{_qt3_plugindir}/inputmethods/*.{a,la}
212%__rm -f %{buildroot}%{_qt4_plugindir}/inputmethods/*.{a,la}
213
214%clean
215%__rm -rf %{buildroot}
216
217%post gtk
218%{_bindir}/gtk-query-immodules-2.0 > %{_sysconfdir}/gtk-2.0/%{_arch}/gtk.immodules
219
220%postun gtk
221%{_bindir}/gtk-query-immodules-2.0 > %{_sysconfdir}/gtk-2.0/%{_arch}/gtk.immodules
222
223%post -n compat32-%{name}-gtk
224%{_bindir}/gtk-query-immodules-2.0-32 > %{_sysconfdir}/gtk-2.0/i386/gtk.immodules
225
226%postun -n compat32-%{name}-gtk
227%{_bindir}/gtk-query-immodules-2.0-32 > %{_sysconfdir}/gtk-2.0/i386/gtk.immodules
228
229%files
230%defattr(-,root,root)
231%doc AUTHORS COPYING ChangeLog NEWS README doc/LICENSE*
232%{_bindir}/scim-bridge
233
234%files gtk
235%defattr(-,root,root)
236%{_libdir}/gtk-2.0/immodules/im-scim-bridge.so
237
238%if !%{without qt3}
239%files qt
240%defattr(-,root,root)
241%{_qt3_plugindir}/inputmethods/*.so
242%endif
243
244%if !%{without qt4}
245%files qt4
246%defattr(-,root,root)
247%{_qt4_plugindir}/inputmethods/*.so
248%endif
249
250## to build compat32 for x86_64 architecture support
251%if %{build_compat32}
252%files -n compat32-%{name}-gtk
253%defattr(-,root,root)
254%{_libdir}/gtk-2.0/immodules/im-scim-bridge.so
255
256%if !%{without qt3}
257%files -n compat32-%{name}-qt
258%defattr(-,root,root)
259%{_qt3_plugindir}/inputmethods/*.so
260%endif
261
262%if !%{without qt4}
263%files -n compat32-%{name}-qt4
264%defattr(-,root,root)
265%{_qt4_plugindir}/inputmethods/*.so
266%endif
267%endif
268
269
270%changelog
271* Mon Dec 30 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4.16-17
272- rebuild with VineSeed environment
273- add Patch100 (scim-bridge-0.4.16-header.patch)
274
275* Tue Jan 10 2012 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.4.16-16
276- rebuilt with qt4-4.8.0
277
278* Tue Mar  8 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.4.16-15
279- rebuilt with qt4-4.7.2
280
281* Sat Feb  5 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.4.16-14
282- added BR: libXmu-devel to qt package
283
284* Sun Jan 30 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.4.16-13
285- rebuilt with qt4-4.7.1
286
287* Sat Oct 09 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.4.16-12
288- added compat32-* packages for x86_64 architecture support
289
290* Thu Jul 29 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.4.16-11
291- rebuilt with qt4-4.6.3
292
293* Tue Jun 22 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.4.16-10
294- used %{?_smp_mflags} macro on build
295- deleted in unused log in changelog
296  - Patch8 was none, forgot to delete...
297
298* Fri May 14 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.4.16-9
299- added Patch6,7 from Fedora development
300  - to fix Text input in firefox becomes increasingly sluggish (Patch6)
301  - to fix Process /usr/bin/scim-bridge was killed by signal 11 (Patch7)
302- added configure --disable-static option
303
304* Sun Jan 31 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.4.16-8
305- updated Qt version detection macros to build properly
306
307* Fri Jan 22 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.4.16-7
308- rebuilt with qt4-4.6.1
309
310* Sun Nov 22 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.4.16-6
311- rebuilt with qt4-4.5.3
312
313* Tue Oct 13 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.4.16-5
314- cleaned up spec
315- renumbered patch
316- added Patch5 from Fedora
317
318* Wed Sep 02 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.4.16-4
319- rebuild with qt4-4.5.2
320
321* Mon Apr 27 2009 Shu KONNO <owa@bg.wakwak.com> 0.4.16-3
322- dropt qt3rel/qt4rel part of Requires in subpackages qt, qt4
323
324* Sun Apr 26 2009 Shu KONNO <owa@bg.wakwak.com> 0.4.16-2
325- rebuild with qt-3.3.8-3vl5, because scim-bridge-qt requires "Rq: qt = %{qt3ver}-%{qt3rel}"
326
327* Sun Apr 19 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.4.16-1
328- new upstream release
329- dropt Pacth3,4,5 (these patches are merged)
330
331* Fri Apr 17 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.4.15.2-2
332- spec in UTF-8
333- fixed description in scim-bridge-qt4
334- added patch6,7 (import Fedora, Mandriva patches)
335
336* Mon Feb 2 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.4.15.2-1
337- new upstream release
338- added patch0,1,2,3,4,5 (import Fedora, Mandriva, scim-devel patches)
339
340* Wed Oct 08 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.4.15-4
341- rebuild with qt4-4.4.2
342
343* Fri Oct 03 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.4.15-3
344- add qt4 immodule
345  - build gtk,qt3,qt4 immodule by default
346
347* Sat Sep 27 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.4.15-2
348- rebuild with gtk+-2.14
349
350* Sat Apr 05 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.4.15-1
351- new upstream release
352- apply new versioning policy
353
354* Fri Jan 18 2008 IWAI, Masaharu <iwai@alib.jp> 0.4.14-0vl2
355- drop unnecessary BuildRequires for qt3-immodule package
356- fix typo: 0.4.14-0vl1 changelog <BTS:VineLinux:#592>
357
358* Wed Jan  9 2008 IWAI, Masaharu <iwai@alib.jp> 0.4.14-0vl1
359- new upstream release
360- drop unnecessary Qt fix patch ( Patch0 ): upstream merged
361- update BuildRequires
362  - drop doxygen
363  - add XOrg-gl-devel for building qt3-immodule
364  - move libmng-devel for building qt3-immodule
365
366* Tue Oct 09 2007 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.4.13-0vl2
367- rebuild for Vine Linux 4.2.
368
369* Tue Oct 09 2007 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.4.13-0vl3
370- add patch0 to fix symbol lookup error with qt3.
371
372* Wed Sep 26 2007 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.4.13-0vl0
373- rebuild for Vine Linux 4.2.
374
375* Sat Sep 15 2007 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.4.13-0vl1
376- new upstrm release
377- detect qt version at build time.
378- add --disable-qt4-immodule configure option.
379- add BuildRequires libmng-devel.
380
381* Thu May 10 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.4.12-0vl2
382- rebuild with libstdc++34
383
384* Thu May 03 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.4.12-0vl1
385- new upstream release
386
387* Tue Dec 19 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.4.8-0vl2
388- change License to GPL/LGPL
389- add doc/LICENSE.* as documents
390
391* Mon Dec 18 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.4.8-0vl1
392- new upstream release
393- add BuildRequires: doxygen, qt-devel
394- add new sub-packages:
395  - gtk: GTK IM module (obsoletes: %%{name} <= 0.1.7)
396  - qt:  Qt IM module
397
398* Wed May 10 2006 IWAI, Masaharu <iwai@alib.jp> 0.1.7-0vl1
399- new upstream release
400- add documents
401- running gtk-query-immodules-2.0 in post and postun scripts
402- add PreReq: gtk2 > 2.2
403
404* Fri Apr 21 2006 IWAI, Masaharu <iwai@alib.jp> 0.1.6-0vl1
405- new upstream release
406
407* Thu Apr  6 2006 IWAI, Masaharu <iwai@alib.jp> 0.1.4-0vl1
408- initial release
409
Note: See TracBrowser for help on using the repository browser.