source: projects/specs/trunk/s/scim-bridge/scim-bridge-vl.spec @ 9292

Revision 9292, 12.1 KB checked in by inagaki, 9 years ago (diff)

2015-01-25 Ryoichi INAGAKI <ryo1@…>

  • gnutls, scim-bridge: rebuilt
  • rusers, rwho: added patches


Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3%define name scim-bridge
4%define version 0.4.16
5%define release 18%{?_dist_release}
6
7%define qt3_ver 3.3.8
8%define qt4_ver 4.8.6
9
10# build qt3 immodule ("--without qt3" to disable qt3)
11%bcond_without qt3
12%define _qt3_version 3.3.8
13%define _qt3_prefix  %{_libdir}/qt-%{_qt3_version}
14%define _qt3_plugindir %{_qt3_prefix}/plugins
15
16# build qt4 immodule ("--without qt4" to disable qt4)
17%bcond_without qt4
18# Qt4 version auto-detection -- inagaki
19%define _qt4_version %(pkg-config --modversion --silence-errors Qt 2>/dev/null || echo %{qt4_ver})
20%define _qt4_prefix %(pkg-config --variable prefix --silence-errors Qt 2>/dev/null || echo %{_libdir}/qt4)
21%define _qt4_plugindir %(pkg-config --variable plugindir --silence-errors Qt 2>/dev/null || echo %{_qt4_prefix}/plugins)
22
23
24Summary: yet another IM client of SCIM
25Summary(ja): もう一つ別の SCIM IM クライアント
26Name: %{name}
27Version: %{version}
28Release: %{release}
29
30Group: System Environment/Libraries
31License: GPL/LGPL
32URL: http://www.scim-im.org/projects/scim_bridge
33
34Source0: http://jaist.dl.sourceforge.net/sourceforge/scim/%{name}-%{version}.tar.gz
35
36# Patch from Fedora 10
37Patch0: scim-bridge-0.4.15-fix-gdm.patch
38Patch1: scim-bridge-0.4.15-bz461373.patch
39
40# Patch from Mandriva 2009
41Patch2: bug-351920-should-return-retval.patch
42Patch3: scim-bridge-0.4.15.2-linkage.patch
43
44# Patch from Fedora development
45Patch4: scim-bridge-0.4.15-EOF.patch
46Patch5: scim-bridge-0.4.15-hotkey-help.patch
47Patch6: scim-bridge-0.4.16-fix-gtk-key-snooper.patch
48Patch7: scim-bridge-0.4.16-fixes-null-imengine.patch
49
50Patch100: scim-bridge-0.4.16-header.patch
51
52BuildRoot: %{_tmppath}/%{name}-%{version}-root
53BuildRequires: scim-devel >= 1.4
54BuildRequires: pkgconfig >= 0.9.0
55BuildRequires: gtk2-devel >= 2.14.0
56
57Requires: scim >= 1.4
58
59%description
60Scim-bridge is yet another IM client of SCIM.
61The im-module of scim-bridge communicates with scim via socket.
62
63%description -l ja
64scim-bridge は、もう一つ別の SCIM IM クライアントです。
65scim-bridge の im-module はソケット経由で SCIM と通信します。
66
67%package gtk
68Summary:        SCIM Bridge GTK IM Module
69Summary(ja):    SCIM Bridge GTK IM モジュール
70Group:          System Environment/Libraries
71Requires:       %{name} = %{version}-%{release}
72Requires:       gtk2 >= 2.14.0
73Requires(post): gtk2 >= 2.14.0
74Requires(postun): gtk2 >= 2.14.0
75Obsoletes:      %{name} <= 0.1.7
76
77%description gtk
78This package provides the SCIM Bridge GTK IM module.
79
80%description -l ja gtk
81このパッケージには SCIM Bridge の GTK IM モジュールが含まれています。
82
83%if !%{without qt3}
84%package qt
85Summary:        SCIM Bridge Qt IM Module
86Summary(ja):    SCIM Bridge Qt IM モジュール
87Group:          System Environment/Libraries
88Requires:       %{name} = %{version}-%{release}
89Requires:       qt = %{_qt3_version}
90BuildRequires:  qt-devel
91BuildRequires:  libXmu-devel
92
93%description qt
94This package provides the SCIM Bridge Qt IM module.
95
96%description -l ja qt
97このパッケージには SCIM Bridge の Qt IM モジュールが含まれています。
98%endif
99
100%if !%{without qt4}
101%package qt4
102Summary:        SCIM Bridge Qt4 IM Module
103Summary(ja):    SCIM Bridge Qt4 IM モジュール
104Group:          System Environment/Libraries
105Requires:       %{name} = %{version}-%{release}
106Requires:       qt4 >= %{_qt4_version}
107BuildRequires:  qt4-devel
108
109%description qt4
110This package provides the SCIM Bridge Qt4 IM module.
111
112%description -l ja qt4
113このパッケージには SCIM Bridge の Qt4 IM モジュールが含まれています。
114%endif
115
116## to build compat32 for x86_64 architecture support
117%package -n compat32-%{name}-gtk
118Summary:        SCIM Bridge GTK IM Module
119Summary(ja):    SCIM Bridge GTK IM モジュール
120Group:          System Environment/Libraries
121Requires:       %{name} = %{version}-%{release}
122Requires:       compat32-gtk2 >= 2.14.0
123Requires(post): gtk2 >= 2.14.0
124Requires(postun): gtk2 >= 2.14.0
125
126%description -n compat32-%{name}-gtk
127This package provides the SCIM Bridge GTK IM module.
128
129%description -l ja -n compat32-%{name}-gtk
130このパッケージには SCIM Bridge の GTK IM モジュールが含まれています。
131
132%if !%{without qt3}
133%package -n compat32-%{name}-qt
134Summary:        SCIM Bridge Qt IM Module
135Summary(ja):    SCIM Bridge Qt IM モジュール
136Group:          System Environment/Libraries
137Requires:       %{name} = %{version}-%{release}
138Requires:       compat32-qt >= %{_qt3_version}
139BuildRequires:  qt-devel
140
141%description -n compat32-%{name}-qt
142This package provides the SCIM Bridge Qt IM module.
143
144%description -l ja -n compat32-%{name}-qt
145このパッケージには SCIM Bridge の Qt IM モジュールが含まれています。
146%endif
147
148%if !%{without qt4}
149%package -n compat32-%{name}-qt4
150Summary:        SCIM Bridge Qt4 IM Module
151Summary(ja):    SCIM Bridge Qt4 IM モジュール
152Group:          System Environment/Libraries
153Requires:       %{name} = %{version}-%{release}
154Requires:       compat32-qt4 >= %{_qt4_version}
155BuildRequires:  qt4-devel
156
157%description -n compat32-%{name}-qt4
158This package provides the SCIM Bridge Qt4 IM module.
159
160%description -l ja -n compat32-%{name}-qt4
161このパッケージには SCIM Bridge の Qt4 IM モジュールが含まれています。
162%endif
163
164
165%prep
166%setup -q
167%patch0 -p1 -b .0-fix-gdm
168%patch1 -p1
169%patch2 -p1
170%patch3
171%patch4 -p1
172%patch5 -p1
173pushd client-gtk
174%patch6 -p0
175popd
176%patch7 -p1
177
178%patch100 -p1
179
180%build
181%if !%{without qt3}
182export QT3_PREFIX=%{_qt3_prefix}
183%endif
184%if !%{without qt4}
185export QT4_PREFIX=%{_qt4_prefix}
186%endif
187
188%configure --disable-static \
189%if %{without qt3}
190        --disable-qt3-immodule \
191%else
192        --enable-qt3-immodule \
193%endif
194%if %{without qt4}
195        --disable-qt4-immodule \
196%else
197        --enable-qt4-immodule \
198%endif
199        --enable-gtk2-immodule
200
201%__make %{?_smp_mflags}
202
203%install
204%__rm -rf %{buildroot}
205#%%makeinstall moduledir=%{buildroot}%{_libdir}/gtk-2.0/immodules
206%__make DESTDIR=%{buildroot} install
207
208# remove unneeded files
209%__rm -f %{buildroot}%{_libdir}/gtk-2.0/immodules/*.{a,la}
210%__rm -f %{buildroot}%{_qt3_plugindir}/inputmethods/*.{a,la}
211%__rm -f %{buildroot}%{_qt4_plugindir}/inputmethods/*.{a,la}
212
213%clean
214%__rm -rf %{buildroot}
215
216%post gtk
217%{_bindir}/gtk-query-immodules-2.0 > %{_sysconfdir}/gtk-2.0/%{_arch}/gtk.immodules
218
219%postun gtk
220%{_bindir}/gtk-query-immodules-2.0 > %{_sysconfdir}/gtk-2.0/%{_arch}/gtk.immodules
221
222%post -n compat32-%{name}-gtk
223%{_bindir}/gtk-query-immodules-2.0-32 > %{_sysconfdir}/gtk-2.0/i386/gtk.immodules
224
225%postun -n compat32-%{name}-gtk
226%{_bindir}/gtk-query-immodules-2.0-32 > %{_sysconfdir}/gtk-2.0/i386/gtk.immodules
227
228%files
229%defattr(-,root,root)
230%doc AUTHORS COPYING ChangeLog NEWS README doc/LICENSE*
231%{_bindir}/scim-bridge
232
233%files gtk
234%defattr(-,root,root)
235%{_libdir}/gtk-2.0/immodules/im-scim-bridge.so
236
237%if !%{without qt3}
238%files qt
239%defattr(-,root,root)
240%{_qt3_plugindir}/inputmethods/*.so
241%endif
242
243%if !%{without qt4}
244%files qt4
245%defattr(-,root,root)
246%{_qt4_plugindir}/inputmethods/*.so
247%endif
248
249## to build compat32 for x86_64 architecture support
250%if %{build_compat32}
251%files -n compat32-%{name}-gtk
252%defattr(-,root,root)
253%{_libdir}/gtk-2.0/immodules/im-scim-bridge.so
254
255%if !%{without qt3}
256%files -n compat32-%{name}-qt
257%defattr(-,root,root)
258%{_qt3_plugindir}/inputmethods/*.so
259%endif
260
261%if !%{without qt4}
262%files -n compat32-%{name}-qt4
263%defattr(-,root,root)
264%{_qt4_plugindir}/inputmethods/*.so
265%endif
266%endif
267
268
269%changelog
270* Sun Jan 25 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 0.4.16-18
271- fixed compat32 Requires
272
273* Mon Dec 30 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4.16-17
274- rebuild with VineSeed environment
275- add Patch100 (scim-bridge-0.4.16-header.patch)
276
277* Tue Jan 10 2012 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.4.16-16
278- rebuilt with qt4-4.8.0
279
280* Tue Mar  8 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.4.16-15
281- rebuilt with qt4-4.7.2
282
283* Sat Feb  5 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.4.16-14
284- added BR: libXmu-devel to qt package
285
286* Sun Jan 30 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.4.16-13
287- rebuilt with qt4-4.7.1
288
289* Sat Oct 09 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.4.16-12
290- added compat32-* packages for x86_64 architecture support
291
292* Thu Jul 29 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.4.16-11
293- rebuilt with qt4-4.6.3
294
295* Tue Jun 22 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.4.16-10
296- used %{?_smp_mflags} macro on build
297- deleted in unused log in changelog
298  - Patch8 was none, forgot to delete...
299
300* Fri May 14 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.4.16-9
301- added Patch6,7 from Fedora development
302  - to fix Text input in firefox becomes increasingly sluggish (Patch6)
303  - to fix Process /usr/bin/scim-bridge was killed by signal 11 (Patch7)
304- added configure --disable-static option
305
306* Sun Jan 31 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.4.16-8
307- updated Qt version detection macros to build properly
308
309* Fri Jan 22 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.4.16-7
310- rebuilt with qt4-4.6.1
311
312* Sun Nov 22 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.4.16-6
313- rebuilt with qt4-4.5.3
314
315* Tue Oct 13 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.4.16-5
316- cleaned up spec
317- renumbered patch
318- added Patch5 from Fedora
319
320* Wed Sep 02 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.4.16-4
321- rebuild with qt4-4.5.2
322
323* Mon Apr 27 2009 Shu KONNO <owa@bg.wakwak.com> 0.4.16-3
324- dropt qt3rel/qt4rel part of Requires in subpackages qt, qt4
325
326* Sun Apr 26 2009 Shu KONNO <owa@bg.wakwak.com> 0.4.16-2
327- rebuild with qt-3.3.8-3vl5, because scim-bridge-qt requires "Rq: qt = %{qt3ver}-%{qt3rel}"
328
329* Sun Apr 19 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.4.16-1
330- new upstream release
331- dropt Pacth3,4,5 (these patches are merged)
332
333* Fri Apr 17 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.4.15.2-2
334- spec in UTF-8
335- fixed description in scim-bridge-qt4
336- added patch6,7 (import Fedora, Mandriva patches)
337
338* Mon Feb 2 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.4.15.2-1
339- new upstream release
340- added patch0,1,2,3,4,5 (import Fedora, Mandriva, scim-devel patches)
341
342* Wed Oct 08 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.4.15-4
343- rebuild with qt4-4.4.2
344
345* Fri Oct 03 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.4.15-3
346- add qt4 immodule
347  - build gtk,qt3,qt4 immodule by default
348
349* Sat Sep 27 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.4.15-2
350- rebuild with gtk+-2.14
351
352* Sat Apr 05 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.4.15-1
353- new upstream release
354- apply new versioning policy
355
356* Fri Jan 18 2008 IWAI, Masaharu <iwai@alib.jp> 0.4.14-0vl2
357- drop unnecessary BuildRequires for qt3-immodule package
358- fix typo: 0.4.14-0vl1 changelog <BTS:VineLinux:#592>
359
360* Wed Jan  9 2008 IWAI, Masaharu <iwai@alib.jp> 0.4.14-0vl1
361- new upstream release
362- drop unnecessary Qt fix patch ( Patch0 ): upstream merged
363- update BuildRequires
364  - drop doxygen
365  - add XOrg-gl-devel for building qt3-immodule
366  - move libmng-devel for building qt3-immodule
367
368* Tue Oct 09 2007 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.4.13-0vl2
369- rebuild for Vine Linux 4.2.
370
371* Tue Oct 09 2007 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.4.13-0vl3
372- add patch0 to fix symbol lookup error with qt3.
373
374* Wed Sep 26 2007 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.4.13-0vl0
375- rebuild for Vine Linux 4.2.
376
377* Sat Sep 15 2007 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.4.13-0vl1
378- new upstrm release
379- detect qt version at build time.
380- add --disable-qt4-immodule configure option.
381- add BuildRequires libmng-devel.
382
383* Thu May 10 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.4.12-0vl2
384- rebuild with libstdc++34
385
386* Thu May 03 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.4.12-0vl1
387- new upstream release
388
389* Tue Dec 19 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.4.8-0vl2
390- change License to GPL/LGPL
391- add doc/LICENSE.* as documents
392
393* Mon Dec 18 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.4.8-0vl1
394- new upstream release
395- add BuildRequires: doxygen, qt-devel
396- add new sub-packages:
397  - gtk: GTK IM module (obsoletes: %%{name} <= 0.1.7)
398  - qt:  Qt IM module
399
400* Wed May 10 2006 IWAI, Masaharu <iwai@alib.jp> 0.1.7-0vl1
401- new upstream release
402- add documents
403- running gtk-query-immodules-2.0 in post and postun scripts
404- add PreReq: gtk2 > 2.2
405
406* Fri Apr 21 2006 IWAI, Masaharu <iwai@alib.jp> 0.1.6-0vl1
407- new upstream release
408
409* Thu Apr  6 2006 IWAI, Masaharu <iwai@alib.jp> 0.1.4-0vl1
410- initial release
411
Note: See TracBrowser for help on using the repository browser.