source: projects/specs/trunk/r/rrdtool/rrdtool-vl.spec @ 9748

Revision 9748, 6.4 KB checked in by Takemikaduchi, 9 years ago (diff)

rebuild with ruby-2.2.3

RevLine 
[5728]1
2# Basic Information
3Name:           rrdtool
[9229]4Version:        1.4.9
[9748]5Release:        3%{?_dist_release}
[9229]6License:        GPLv2+ with exceptions
7Group:          Applications/Databases
[5728]8URL:            http://oss.oetiker.ch/rrdtool/
[9229]9
[5728]10Source0:        http://oss.oetiker.ch/%{name}/pub/%{name}-%{version}.tar.gz
[9229]11Patch3:         rrdtool-1.4.7-ruby-2-fix.patch
[5728]12
13Summary:        RRDtool - Round Robin Database tool
14Summary(ja):    RRDtool - ラウンドロビンデータベースツール
15
[9229]16BuildRoot:      %{_tmppath}/%{name}-%{version}-root
[5728]17# Dependency
18BuildRequires:  glib2-devel
19BuildRequires:  glibc-devel
[9229]20BuildRequires:  libdbi-devel
[5728]21BuildRequires:  libxml2-devel
22BuildRequires:  lua-devel
23BuildRequires:  pango-devel
[9229]24BuildRequires:  perl(ExtUtils::MakeMaker)
25BuildRequires:  python-devel
26BuildRequires:  ruby-devel
[9748]27BuildRequires:  tcl-devel
[5728]28
[9229]29Vendor:         Project Vine
30Distribution:   Vine Linux
31Packager:       yasumichi
32
33
[5728]34%description
35It is pretty easy to gather status information from all sorts of things,
36ranging from the temperature in your office to the number of octets which
37have passed through the FDDI interface of your router. But it is not so
38trivial to store this data in a efficient and systematic manner. This is
39where RRDtool kicks in. It lets you log and analyze the data you gather from
40all kinds of data-sources (DS). The data analysis part of RRDtool is based
41on the ability to quickly generate graphical representations of the data
42values collected over a definable time period.
43
44#%%description -l ja
45
46%package devel
47Summary:        Libraries and include files of RRDtool
[9229]48Group:          Development/Libraries
49Requires:       %{name} = %{version}-%{release}
[5728]50
51%description devel
52Libraries and include files of RRDtool
53
[9229]54
55%package doc
56Summary: RRDtool documentation
57Summary(ja): RRDtool のドキュメント
58Group: Applications/Documentation
59BuildArch: noarch
60
61%description doc
62RRD is the Acronym for Round Robin Database. RRD is a system to store and
63display time-series data (i.e. network bandwidth, machine-room temperature,
64server load average). This package contains documentation on using RRD.
65
66
[5728]67%package tcl
68Summary:        RRDTool modules for tcl
[9229]69Group:          Development/Libraries
70Requires:       %{name} = %{version}-%{release}
[5728]71
72%description tcl
[9229]73RRDTool bindings for Tcl.
[5728]74
[9229]75
[5728]76%package -n perl-rrdtool
[9229]77Summary:        Perl RRDtool bindings
78Summary(ja):    RRDTool の perl バインディング
79Group:          Development/Libraries
80Requires:       %{name} = %{version}-%{release}
81Requires:       perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
[5728]82
83%description -n perl-rrdtool
[9229]84The Perl RRDTool bindings.
[5728]85
[9229]86
[5728]87%package -n python-rrdtool
[9229]88Summary:        Python RRDTool bindings
89Summary(ja):    RRDTool の Python バインディング
90Group:          Development/Libraries
91Requires:       %{name} = %{version}-%{release}
[5728]92
93%description -n python-rrdtool
[9229]94RDTool bindings for python.
[5728]95
[9229]96
97%package -n ruby-rrdtool
98Summary:        Ruby RRDTool bindings
99Summary(ja):    RRDTool の ruby バインディング
100Group:          Development/Libraries
101Requires:       %{name} = %{version}-%{release}
102
103%description -n ruby-rrdtool
104RRDtool bindings for Ruby.
105
106
[5728]107%prep
108%setup -q
[9229]109%patch3 -p1 -b .ruby-2-fix
[5728]110
111%build
[8710]112%configure \
[9229]113    --disable-rpath \
114    --disable-static \
115    --enable-perl-site-install \
116    --with-perl-options="INSTALLDIRS=vendor" \
117    --enable-ruby \
118    --with-pic
[8710]119
[9229]120# Fix another rpath issue
121%{__perl} -pi.orig -e 's|-Wl,--rpath -Wl,\$rp||g' \
122    bindings/perl-shared/Makefile.PL
123
124# Remove Rpath from Ruby
125%{__perl} -pi.orig -e 's|-Wl,--rpath -Wl,\$\(EPREFIX\)/lib||g' \
126    bindings/ruby/extconf.rb
127sed -i 's| extconf.rb| extconf.rb --vendor |' bindings/Makefile
128
[8710]129perl -pi -e 's/(rrdcached_LDADD =)/$1 \$(ALL_LIBS) /' src/Makefile
[5728]130%{__make} %{?_smp_mflags}
131
[9229]132
[5728]133%install
134%{__rm} -rf ${RPM_BUILD_ROOT}
135%{__make} install DESTDIR=${RPM_BUILD_ROOT}
136
[9229]137# Install ruby module by force
138mkdir -p $RPM_BUILD_ROOT/%{ruby_vendorarchdir}
139make -C bindings/ruby install DESTDIR=$RPM_BUILD_ROOT
140
141# We only want .txt and .html files for the main documentation
142rm -rf docs_to_be_included
143mkdir -p docs_to_be_included/html docs_to_be_included/txt
144mv $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}/html/* docs_to_be_included/html/
145mv $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}/txt/* docs_to_be_included/txt/
146
147# Put perl docs in perl package
148rm -rf docs_perl
149mkdir -p docs_perl/html
150mv docs_to_be_included/html/RRD*.html docs_perl/html/
151
152# Clean up
153%{__rm} -rf $RPM_BUILD_ROOT%{_docdir}/%{name}-*
[5728]154%{__rm} -f ${RPM_BUILD_ROOT}%{_prefix}/lib/lua/*/rrd.la
155%{__rm} -f ${RPM_BUILD_ROOT}%{_libdir}/librrd*.la
156%{__rm} -f ${RPM_BUILD_ROOT}%{perl_archlib}/perllocal.pod
[9229]157%{__rm} -f ${RPM_BUILD_ROOT}%{perl_vendorarch}/auto/*/.packlist
[5728]158
159
160%clean
161%{__rm} -rf ${RPM_BUILD_ROOT}
162
[9229]163%post -p /sbin/ldconfig
[5728]164
[9229]165%postun -p /sbin/ldconfig
166
[5728]167%files
168%defattr(-,root,root)
[9229]169#doc COPYING NEWS README TODO
[5728]170%{_bindir}/rrd*
171%{_prefix}/lib/lua/*/rrd.so.*
172%{_libdir}/librrd*.so.*
173%{_mandir}/man1/*.1*
174%{_datadir}/rrdtool/examples/cgi-demo.cgi
175
176%files devel
177%defattr(-,root,root)
178%{_includedir}/rrd*.h
179%{_prefix}/lib/lua/*/rrd.so
180%{_libdir}/librrd.so
181%{_libdir}/librrd_th.so
182%{_libdir}/pkgconfig/librrd.pc
[9229]183%{_mandir}/man3/librrd.3*
[5728]184
[9229]185%files doc
186%defattr(-,root,root,-)
187%doc CONTRIBUTORS COPYING COPYRIGHT README TODO NEWS THREADS
188%doc docs_to_be_included/html docs_to_be_included/txt
189
[5728]190%files tcl
191%defattr(-,root,root)
[9229]192%doc bindings/tcl/README
[8710]193%{_datadir}/rrdtool/ifOctets.tcl
194%{_datadir}/rrdtool/pkgIndex.tcl
[5728]195%{_libdir}/tclrrd*.so
196
197%files -n perl-rrdtool
198%defattr(-,root,root)
[8710]199%{perl_vendorlib}/RRDp.pm
200%{perl_vendorarch}/RRDs.pm
201%{perl_vendorarch}/auto/RRDs/RRDs.bs
202%{perl_vendorarch}/auto/RRDs/RRDs.so
[5728]203%{_datadir}/rrdtool/examples/*.pl
204%{_datadir}/rrdtool/examples/rrdcached/RRDCached.pm
205%{_datadir}/rrdtool/examples/rrdcached/rrdcached-size.pl
[9229]206%{_mandir}/man3/RRD?.3pm*
[5728]207
208%files -n python-rrdtool
209%defattr(-,root,root)
[9229]210%doc bindings/python/AUTHORS bindings/python/COPYING bindings/python/README
[5728]211%{python_sitearch}/py_rrdtool-*-py*.egg-info
212%{python_sitearch}/rrdtoolmodule.so
213
[9229]214%files -n ruby-rrdtool
215%defattr(-,root,root,-)
216%doc bindings/ruby/README
217%{ruby_vendorarchdir}/RRD.so
218
[5728]219%changelog
[9748]220* Sun Sep 13 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.9-3
221- rebuild with ruby-2.2.3
222
[9291]223* Sun Jan 25 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.9-2
224- rebuild with libdbi-0.9.0
225
[9229]226* Mon Jan  5 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 1.4.9-1
227- new upstream release.
228- added Group tag to subpackages
229- added ruby subpackages
230- split documents into subpackages
231- added %%post and %%postun section
232
[8710]233* Tue Jul  1 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.4.8-1
234- new upstream release.
235
[5728]236* Fri Feb 17 2012 Yasumichi Akahoshi <yasumichi@vinelinux.org> 1.4.7-1
237- initial build for Vine Linux
Note: See TracBrowser for help on using the repository browser.