source: projects/specs/trunk/r/rpmdevtools/rpmdevtools-vl.spec @ 12545

Revision 12545, 22.3 KB checked in by tomop, 3 years ago (diff)

rpm-4.16.1.2-1 and requirements

Line 
1%global spectool_version 1.1.0
2%global _emacs_sitestartdir /usr/share/emacs/site-lisp
3
4Name:           rpmdevtools
5Summary:        RPM Development Tools
6Version:        9.3
7Release:        1%{?_dist_release}
8Group:          programming
9Vendor:         Project Vine
10Distribution:   Vine Linux
11
12# rpmdev-setuptree is GPLv2, everything else GPLv2+
13License:        GPLv2+ and GPLv2
14URL:            https://pagure.io/rpmdevtools
15Source0:        https://releases.pagure.org/rpmdevtools/%{name}-%{version}.tar.xz
16
17# Use Accept-Encoding: identity together with decode_content=False
18# This is to avoid text files downloaded gzipped
19Patch1:         https://pagure.io/rpmdevtools/pull-request/77.patch
20# Fedora-specific downstream patches
21## Force legacy datestamp by default until rhbz#1715412 is resolved
22Patch1001:      0001-Force-legacy-datestamp-while-RHBZ-1715412-is-still-a.patch
23# Vine patch(es)
24Patch2000:      rpmdevtools-vine.patch
25
26BuildArch:      noarch
27# help2man, pod2man, *python for creating man pages
28BuildRequires:  help2man
29BuildRequires:  %{_bindir}/pod2man
30BuildRequires:  perl
31BuildRequires:  python3
32BuildRequires:  python3-rpm
33BuildRequires:  python3-requests
34BuildRequires:  python3-progressbar2
35# emacs-common >= 1:22.3-3 for macros.emacs
36BuildRequires:  emacsen-common
37BuildRequires:  bash-completion
38Provides:       spectool = %{spectool_version}
39Requires:       curl
40Requires:       diffutils
41Requires:       fakeroot
42Requires:       file
43Requires:       findutils
44Requires:       gawk
45Requires:       grep
46Requires:       rpm-build >= 4.16.0.0
47Requires:       python3-rpm
48Requires:       python3-requests
49Requires:       python3-progressbar2
50Requires:       sed
51
52%description
53This package contains scripts and (X)Emacs support files to aid in
54development of RPM packages.
55rpmdev-setuptree    Create RPM build tree within user's home directory
56rpmdev-diff         Diff contents of two archives
57rpmdev-newspec      Creates new .spec from template
58rpmdev-rmdevelrpms  Find (and optionally remove) "development" RPMs
59rpmdev-checksig     Check package signatures using alternate RPM keyring
60rpminfo             Print information about executables and libraries
61rpmdev-md5/sha*     Display checksums of all files in an archive file
62rpmdev-vercmp       RPM version comparison checker
63spectool            Expand and download sources and patches in specfiles
64rpmdev-wipetree     Erase all files within dirs created by rpmdev-setuptree
65rpmdev-extract      Extract various archives, "tar xvf" style
66rpmdev-bumpspec     Bump revision in specfile
67...and many more.
68
69
70%prep
71%autosetup -p1
72grep -lF "%{_bindir}/python " * \
73| xargs sed -i -e "s|%{_bindir}/python |%{_bindir}/python3 |"
74
75
76%build
77%configure --libdir=%{_prefix}/lib
78%make_build
79
80
81%install
82rm -rf $RPM_BUILD_ROOT
83%make_install
84
85echo %%{_datadir}/bash-completion > %{name}.files
86[ -d $RPM_BUILD_ROOT%{_sysconfdir}/bash_completion.d ] && \
87echo %%{_sysconfdir}/bash_completion.d > %{name}.files
88
89%if 0%{?fedora}
90for dir in %{_emacs_sitestartdir} %{_xemacs_sitestartdir} ; do
91%else
92for dir in %{_emacs_sitestartdir} ; do
93%endif
94  install -dm 755 $RPM_BUILD_ROOT$dir
95  ln -s %{_datadir}/rpmdevtools/rpmdev-init.el $RPM_BUILD_ROOT$dir
96  touch $RPM_BUILD_ROOT$dir/rpmdev-init.elc
97done
98
99# For backwards compatibility
100ln -sr %{buildroot}%{_bindir}/rpmdev-spectool %{buildroot}%{_bindir}/spectool
101echo ".so man1/rpmdev-spectool.1" > %{buildroot}%{_mandir}/man1/spectool.1
102
103
104%files -f %{name}.files
105%license COPYING
106%doc NEWS
107%config(noreplace) %{_sysconfdir}/rpmdevtools/
108%{_datadir}/rpmdevtools/
109%{_bindir}/*
110%{_emacs_sitestartdir}/rpmdev-init.el
111%ghost %{_emacs_sitestartdir}/rpmdev-init.elc
112%if 0%{?fedora}
113%{_xemacs_sitestartdir}/rpmdev-init.el
114%ghost %{_xemacs_sitestartdir}/rpmdev-init.elc
115%endif
116%{_mandir}/man[18]/*.[18]*
117
118
119%changelog
120* Tue Feb 23 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 9.3-1
121- new upstream release.
122- updated patches.
123
124* Tue Sep 03 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 8.10-11
125- rpmdev-bumpspec: made to set %%_dist_release to %%nil.
126
127* Mon Aug 12 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 8.10-10
128- initial build for Vine Linux.
129
130* Fri Jul 26 2019 Fedora Release Engineering <releng@fedoraproject.org> - 8.10-9
131- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
132
133* Sat Feb 02 2019 Fedora Release Engineering <releng@fedoraproject.org> - 8.10-8
134- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
135
136* Wed Nov 28 2018 Neal Gompa <ngompa13@gmail.com> - 8.10-7
137- Fix regex substitution issues with Python 3.7 (rhbz#1651954)
138
139* Sun Sep 16 2018 Neal Gompa <ngompa13@gmail.com> - 8.10-6
140- Fix regex related deprecation warnings (rhbz#1598089)
141
142* Sat Jul 14 2018 Fedora Release Engineering <releng@fedoraproject.org> - 8.10-5
143- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
144
145* Fri Feb 09 2018 Fedora Release Engineering <releng@fedoraproject.org> - 8.10-4
146- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
147
148* Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 8.10-3
149- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
150
151* Sat Feb 11 2017 Fedora Release Engineering <releng@fedoraproject.org> - 8.10-2
152- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
153
154* Sat Jan 14 2017 Ville Skyttä <ville.skytta@iki.fi> - 8.10-1
155- Update to 8.10
156
157* Mon Dec 19 2016 Miro Hrončok <mhroncok@redhat.com> - 8.9-2
158- Rebuild for Python 3.6
159
160* Sat Jun 25 2016 Ville Skyttä <ville.skytta@iki.fi> - 8.9-1
161- Update to 8.9
162
163* Sat Jun 25 2016 Ville Skyttä <ville.skytta@iki.fi> - 8.8-1
164- Update to 8.8
165
166* Fri Jun 24 2016 Petr Písař <ppisar@redhat.com>
167- Add new mandatory perl build deps
168
169* Thu Jun 23 2016 Ville Skyttä <ville.skytta@iki.fi> - 8.7-1
170- Update to 8.7
171- Specfile cleanups
172
173* Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 8.6-3
174- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
175
176* Fri Jun  5 2015 Ville Skyttä <ville.skytta@iki.fi> - 8.6-2
177- Use python3 on > F-22
178
179* Sun May 10 2015 Ville Skyttä <ville.skytta@iki.fi> - 8.6-1
180- Update to 8.6
181
182* Mon Oct 20 2014 Ville Skyttä <ville.skytta@iki.fi> - 8.5-1
183- Update to 8.5
184- Mark COPYING as %%license where applicable
185
186* Sun Jun 08 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 8.4-3
187- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
188
189* Thu Oct 17 2013 Ville Skyttä <ville.skytta@iki.fi> - 8.4-2
190- Do not require devscripts in any scenario.
191
192* Mon Oct  7 2013 Ville Skyttä <ville.skytta@iki.fi> - 8.4-1
193- Update to 8.4.
194
195* Sun Aug 04 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 8.3-5
196- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
197
198* Wed Jul 17 2013 Petr Pisar <ppisar@redhat.com> - 8.3-4
199- Perl 5.18 rebuild
200
201* Thu Feb 14 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 8.3-3
202- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
203
204* Tue Oct 16 2012 Thomas Woerner <twoerner@redhat.com> - 8.3-2
205- xemacs is not available on RHEL (RHBZ#866841)
206
207* Sun Sep  2 2012 Ville Skyttä <ville.skytta@iki.fi> - 8.3-1
208- Update to 8.3.
209- Drop specfile constructs no longer needed with Fedora's rpm.
210
211* Sat Jul 21 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 8.2-3
212- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
213
214* Sat Jan 14 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 8.2-2
215- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
216
217* Sat Nov 12 2011 Ville Skyttä <ville.skytta@iki.fi> - 8.2-1
218- Update to 8.2.
219
220* Tue Apr 26 2011 Ville Skyttä <ville.skytta@iki.fi> - 8.1-1
221- Update to 8.1.
222
223* Tue Mar  1 2011 Ville Skyttä <ville.skytta@iki.fi> - 8.0-3
224- Require xemacs-filesystem on F-15+ (#672093).
225
226* Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 8.0-2
227- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
228
229* Sun Feb  6 2011 Ville Skyttä <ville.skytta@iki.fi> - 8.0-1
230- Update to 8.0, fixes #519061 and #657594.
231
232* Mon Sep 27 2010 Ville Skyttä <ville.skytta@iki.fi> - 7.10-1
233- Update to 7.10, fixes #595135 and #619867.
234- Patch spectool to work with specfiles containing Icon or BuildArchitectures
235  (#637000).
236
237* Thu May 20 2010 Ville Skyttä <ville.skytta@iki.fi> - 7.9-1
238- Update to 7.9, fixes #588313 and #589705.
239
240* Fri Apr 16 2010 Ville Skyttä <ville.skytta@iki.fi> - 7.8-2
241- Require %%{_bindir}/man instead of man (#582932).
242
243* Tue Feb 16 2010 Ville Skyttä <ville.skytta@iki.fi> - 7.8-1
244- Update to 7.8, fixes #562316.
245
246* Tue Feb  2 2010 Ville Skyttä <ville.skytta@iki.fi> - 7.7-1
247- Update to 7.7, fixes #558263.
248
249* Mon Dec  7 2009 Ville Skyttä <ville.skytta@iki.fi> - 7.6-1
250- Update to 7.6, fixes #528907.
251
252* Thu Sep 17 2009 Ville Skyttä <ville.skytta@iki.fi> - 7.5-1
253- Update to 7.5, fixes #502403.
254
255* Fri Aug 21 2009 Ville Skyttä <ville.skytta@iki.fi> - 7.4-1
256- Update to 7.4, fixes #215927 and #466353.
257- Patch spectool to make -s and -p to work as documented (Todd Zullinger).
258
259* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 7.3-2
260- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
261
262* Mon May 25 2009 Ville Skyttä <ville.skytta@iki.fi> - 7.3-1
263- Release 7.3.
264
265* Sat May 23 2009 Ville Skyttä <ville.skytta@iki.fi>
266- Add rpmdev-packager - script for getting rpm packager info.
267- Use rpmdev-packager in rpmdev-bumpspec and rpmdev-init.el.
268- Fix rpmdev-extract MIME type comparisons with file(1) output containing
269  parameters.
270
271* Wed May 20 2009 Ville Skyttä <ville.skytta@iki.fi> - 7.2-1
272- Release 7.2.
273
274* Sun May  3 2009 Ville Skyttä <ville.skytta@iki.fi>
275- Add dummy spec template for ad-hoc testing.
276
277* Sat May  2 2009 Ville Skyttä <ville.skytta@iki.fi>
278- Improve newspec/newinit when only "-o foo" argument is given (#498588,
279  thanks to Edwin ten Brink).
280- Try to get packager mail address for *Emacs rpm-spec-mode from ~/.fedora.cert
281  if rpm-spec-user-mail-address is not set.
282- Add xz support to rpmdev-extract.
283
284* Sat Apr 18 2009 Ville Skyttä <ville.skytta@iki.fi>
285- Make bumpspec's use of "head" POSIX compliant.
286
287* Thu Apr 16 2009 Ville Skyttä <ville.skytta@iki.fi>
288- Add rpmdev-newinit for easier access to the init script template, move the
289  template to %%{_sysconfdir}/rpmdevtools, improve reload action example.
290
291* Tue Apr  7 2009 Ville Skyttä <ville.skytta@iki.fi>
292- Speed up rpmls bash completion.
293
294* Sat Apr  4 2009 Ville Skyttä <ville.skytta@iki.fi> - 7.1-1
295- 7.1.
296- Make rpmdev-md5 and friends work on non-srpm package files too.
297
298* Sun Mar 15 2009 Ville Skyttä <ville.skytta@iki.fi>
299- Add bash completion.
300
301* Mon Mar  9 2009 Ville Skyttä <ville.skytta@iki.fi>
302- Add query format option to rmdevelrpms, sort output by NEVRA.
303
304* Sun Feb 22 2009 Ville Skyttä <ville.skytta@iki.fi>
305- Use %%global instead of %%define in spec templates.
306- Handle %%global in addition to %%define in rpmdev-bumpspec.
307
308* Mon Jan 26 2009 Ville Skyttä <ville.skytta@iki.fi>
309- Add result dependent exit statuses to rpmdev-vercmp.
310
311* Fri Dec 26 2008 Ville Skyttä <ville.skytta@iki.fi>
312- Add minimum version to rpm-python dependency (for rpmdev-bumpspec).
313
314* Fri Dec 26 2008 Ville Skyttä <ville.skytta@iki.fi> - 7.0-1
315- 7.0.
316- Drop fonts spec template, adapt to new ones from Fedora fonts SIG (#477055).
317- Add man page for rpmdev-newspec.
318
319* Tue Dec 16 2008 Ville Skyttä <ville.skytta@iki.fi>
320- Add imake and intltool to internal list of devel packages in rmdevelrpms.
321
322* Sat Dec 13 2008 Ville Skyttä <ville.skytta@iki.fi>
323- Add rpmdev-sha*/*sum companions to rpmdev-md5 (ticket #7).
324
325* Wed Nov 26 2008 Ville Skyttä <ville.skytta@iki.fi>
326- Add vamp-plugin-sdk to internal list of non-devel packages in rmdevelrpms
327  (#472641, Michael Schwendt).
328
329* Thu Nov 20 2008 Ville Skyttä <ville.skytta@iki.fi>
330- Drop "minimal buildroot" dependencies.
331- Drop fedora-rpmdevtools Obsoletes.
332
333* Mon Oct 13 2008 Ville Skyttä <ville.skytta@iki.fi>
334- Show available types in rpmdev-newspec --help (ticket #6, Todd Zullinger).
335
336* Fri Sep 26 2008 Ville Skyttä <ville.skytta@iki.fi>
337- Add -r/--rightmost option to rpmdev-bumpspec (ticket #1, Thorsten Leemhuis).
338- Add %%packager from rpm config to the set of defaults for rpmdev-bumpspec's
339  user string.
340
341* Thu Sep 25 2008 Ville Skyttä <ville.skytta@iki.fi>
342- Bring rpmdev-bumpspec copyright holder closer to truth (Michael Schwendt).
343
344* Mon Sep 22 2008 Ville Skyttä <ville.skytta@iki.fi>
345- Switch to lzma compressed tarball.
346
347* Sun Sep  7 2008 Ville Skyttä <ville.skytta@iki.fi>
348- Improve arch specific %%files in perl spec template (#461177, Chris Weyl).
349
350* Sun Aug  3 2008 Ville Skyttä <ville.skytta@iki.fi> - 6.7-1
351- 6.7.
352- Make rpmdev-diff, rpmdev-md5 and rpminfo honor TMPDIR.
353
354* Sat Apr 26 2008 Ville Skyttä <ville.skytta@iki.fi>
355- Make rpmls work with URLs.
356
357* Sun Apr 20 2008 Ville Skyttä <ville.skytta@iki.fi>
358- Include rpm arch in dir names created by rpmdev-extract (#443266).
359
360* Fri Apr 18 2008 Ville Skyttä <ville.skytta@iki.fi>
361- Remove duplicate "reload" from case block in init script template.
362- Fix exit status of "reload" in case service is not running in init
363  script template (#442993).
364
365* Thu Mar 27 2008 Ville Skyttä <ville.skytta@iki.fi> - 6.6-1
366- Fix man page generation.
367
368* Wed Mar 26 2008 Ville Skyttä <ville.skytta@iki.fi> - 6.5-1
369- 6.5.
370
371* Sun Mar 23 2008 Ville Skyttä <ville.skytta@iki.fi>
372- Generate man pages at build time.
373
374* Sat Mar 22 2008 Ville Skyttä <ville.skytta@iki.fi>
375- Remove libgcj-devel and zlib-devel from rmdevelrpms' internal exclusion
376  list, they're not essential on non-devel systems any more.
377
378* Mon Mar 17 2008 Ville Skyttä <ville.skytta@iki.fi>
379- Include ocaml spec template.
380
381* Tue Mar 11 2008 Ville Skyttä <ville.skytta@iki.fi>
382- Include Michael Schwendt's bumpspecfile.py (as rpmdev-bumpspec).
383
384* Tue Feb 12 2008 Ville Skyttä <ville.skytta@iki.fi>
385- Sync with qa-robot upstream.
386- Update spectool to 1.0.10.
387
388* Sun Feb  3 2008 Ville Skyttä <ville.skytta@iki.fi>
389- Add support for 7-zip, lzma and lzo in rpmdev-extract.
390
391* Fri Feb  1 2008 Ville Skyttä <ville.skytta@iki.fi>
392- Add ';;' to the init script template's reload action.
393
394* Sat Dec  8 2007 Ville Skyttä <ville.skytta@iki.fi>
395- Add fonts spec template from the Fedora Fonts SIG (#407781).
396- Add option to use macro style instead of shell style variables to newspec.
397- Prefer ~/.config/rpmdevtools/rmdevelrpms.conf over ~/.rmdevelrpmsrc in
398  rmdevelrpms.
399
400* Fri Oct 12 2007 Lubomir Kundrak <lkundrak@redhat.com> - 6.4-1
401- Import the previous fix into CVS to resync, bump version
402
403* Fri Oct 12 2007 Lubomir Kundrak <lkundrak@redhat.com> - 6.3-1
404- Fix paths in qa-robot tools
405
406* Sat Sep  8 2007 Ville Skyttä <ville.skytta@iki.fi> - 6.2-1
407- Sync deps with Fedora's new "assumed present in buildroots" packages list.
408
409* Thu Sep  6 2007 Ville Skyttä <ville.skytta@iki.fi>
410- Init script template cleanups.
411
412* Tue Aug 28 2007 Ville Skyttä <ville.skytta@iki.fi>
413- Update rpminfo to version 2004-07-07-02.
414
415* Fri Aug 10 2007 Ville Skyttä <ville.skytta@iki.fi> - 6.1-1
416- Sync COPYING with http://www.gnu.org/licenses/old-licenses/gpl-2.0.txt
417
418* Mon Aug  6 2007 Ville Skyttä <ville.skytta@iki.fi>
419- Work around #250990 in rpmls and rpmdev-extract.
420- Clarify copyright info of rpmdev-* and rpmls.
421
422* Sat Jul  7 2007 Ville Skyttä <ville.skytta@iki.fi>
423- Fix Epoch handling in the 2-arg form of rpmdev-vercmp with yum < 3.1.2.
424- The long form of the list option in rmdevelrpms is --list-only, not --list.
425
426* Thu Jul  5 2007 Ville Skyttä <ville.skytta@iki.fi> - 6.0-1
427- Remove check-{buildroot,rpaths*}, now included in rpm-build >= 4.4.2.1.
428- Drop explicit dependency on patch, pulled in by recent rpm-build.
429- Add cmake and scons to default devel package list in rpmdev-rmdevelrpms.
430- Add LSB comment block to init script template.
431
432* Wed Jun 27 2007 Ville Skyttä <ville.skytta@iki.fi>
433- Add 2-argument form for comparing EVR strings to rpmdev-vercmp
434  (available only if rpmUtils.miscutils is available).
435
436* Sat Jun 16 2007 Ville Skyttä <ville.skytta@iki.fi>
437- Include rpmsodiff and dependencies (rpmargs, rpmelfsym, rpmfile, rpmpeek,
438  rpmsoname) from ALT Linux's qa-robot package.
439- Include rpmls (#213778).
440
441* Fri Jun 15 2007 Ville Skyttä <ville.skytta@iki.fi>
442- Update spectool to 1.0.9 (#243731).
443
444* Wed Apr 11 2007 Ville Skyttä <ville.skytta@iki.fi>
445- Add --list-only option to rmdevelrpms (Thorsten Leemhuis).
446
447* Tue Mar 13 2007 Ville Skyttä <ville.skytta@iki.fi>
448- BR perl(ExtUtils::MakeMaker) by default in perl spec template.
449- Drop deprecated backwards compatibility with fedora-rpmdevtools.
450- Update URL.
451
452* Wed Nov  8 2006 Ville Skyttä <ville.skytta@iki.fi>
453- Arch-qualify output of matched packages in rmdevelrpms and allow
454  arch-qualified packages in the config file.
455
456* Wed Oct 25 2006 Ville Skyttä <ville.skytta@iki.fi> - 5.3-1
457- Update spectool to 1.0.8, fixes #212108.
458
459* Mon Oct  2 2006 Ville Skyttä <ville.skytta@iki.fi> - 5.2-1
460- Skip *.jar.so.debug in check-buildroot (#208903).
461- Treat yasm and *-static as devel packages in rmdevelrpms.
462
463* Sat Sep  9 2006 Ville Skyttä <ville.skytta@iki.fi> - 5.1-1
464- Re-add PHP PEAR spec template, more improvements to it (#198706,
465  Christopher Stone, Remi Collet).
466
467* Tue Aug 22 2006 Ville Skyttä <ville.skytta@iki.fi> - 5.0-2
468- Migrate rmdevelrpms config when upgrading from fedora-rpmdevtools.
469
470* Sun Aug 20 2006 Ville Skyttä <ville.skytta@iki.fi> - 5.0-1
471- Re-rename almost everything to rpmdev-*, with backwards compat symlinks.
472- Don't encourage %%ghost'ing *.pyo in Python spec template, add some comments.
473- Drop PHP PEAR spec template, it's not ready yet.
474
475* Wed Aug  2 2006 Ville Skyttä <ville.skytta@iki.fi>
476- Treat *-sdk as devel packages in rmdevelrpms (#199909).
477- Don't assume compface is a devel package in rmdevelrpms.
478
479* Thu Jul 20 2006 Ville Skyttä <ville.skytta@iki.fi>
480- Mark things that are not needed for noarch module packages in the Perl
481  spec template.
482
483* Wed Jul 19 2006 Ville Skyttä <ville.skytta@iki.fi>
484- Move option arguments to "find" before non-option ones in Perl spec template.
485- Drop python-abi dependency from Python spec template (#189947).
486
487* Tue Jul 18 2006 Ville Skyttä <ville.skytta@iki.fi>
488- Add PHP PEAR spec template (#198706, Christopher Stone).
489
490* Mon Jul 17 2006 Ville Skyttä <ville.skytta@iki.fi>
491- Drop fedora- prefix everywhere, add backcompat symlinks for execubtables.
492- Move %%{_sysconfdir}/fedora to %%{_sysconfdir}/rpmdevtools and
493  %%{_datadir}/fedora to %%{_datadir}/rpmdevtools.
494- Move spec templates to %%{_sysconfdir}/rpmdevtools, mark as config.
495- Bump version to 5.0.
496
497* Sun Jul 16 2006 Ville Skyttä <ville.skytta@iki.fi>
498- Drop fedora-kmodhelper.
499- Drop fedora-installdevkeys and GPG keys, modify rpmchecksig to use
500  the system rpmdb.
501
502* Sat Jul 15 2006 Ville Skyttä <ville.skytta@iki.fi>
503- Sort rmdevelrpms' output.
504
505* Fri Jul  7 2006 Ville Skyttä <ville.skytta@iki.fi>
506- Improve ruby spec template (#180066, David Lutterkort).
507
508* Mon Jun  5 2006 Ville Skyttä <ville.skytta@iki.fi>
509- Add manual pages for rmdevelrpms, diffarchive and extract.
510- Trim pre-2005 changelog entries.
511- Autotoolize source tree.
512
513* Tue May 16 2006 Ville Skyttä <ville.skytta@iki.fi> - 1.6-1
514- Add spec template for library packages (#185606, Ignacio Vazquez-Abrams).
515
516* Sun Feb 26 2006 Ville Skyttä <ville.skytta@iki.fi> - 1.5-1
517- Improve diffarchive and extract error messages.
518
519* Fri Feb 24 2006 Ville Skyttä <ville.skytta@iki.fi>
520- Update spectool to 1.0.7 (#162253).
521
522* Thu Feb  9 2006 Ville Skyttä <ville.skytta@iki.fi>
523- Add file(1) based archive type detection to fedora-extract.
524
525* Wed Feb  8 2006 Ville Skyttä <ville.skytta@iki.fi>
526- Add "diff file lists only" option to diffarchive.
527
528* Sun Feb  5 2006 Ville Skyttä <ville.skytta@iki.fi>
529- Add Ruby spec template (#180066, Oliver Andrich) and make newrpmspec
530  use it for ruby-*.
531
532* Sat Feb  4 2006 Ville Skyttä <ville.skytta@iki.fi> - 1.4-2
533- Fix rpath checker tests with bash 3.1 (#178636, Enrico Scholz).
534
535* Fri Dec 30 2005 Ville Skyttä <ville.skytta@iki.fi> - 1.4-1
536- Update spectool to 1.0.6 (#176521).
537
538* Wed Dec 28 2005 Ville Skyttä <ville.skytta@iki.fi>
539- Update spectool to 1.0.5 (#162253), require wget for it.
540- Add disttags to spec templates.
541
542* Thu Oct 27 2005 Ville Skyttä <ville.skytta@iki.fi> - 1.3-1
543- check-rpaths-worker: detect when RPATH references the parent directory
544  of an absolute path (#169298, Enrico Scholz).
545- Add regression test for check-rpaths* (#169298, Enrico Scholz).
546- Honor user's indent-tabs-mode setting in fedora-init.el (#170902).
547
548* Fri Oct  7 2005 Ville Skyttä <ville.skytta@iki.fi> - 1.2-1
549- check-buildroot: grep for buildroot as a fixed string, not a regexp.
550- Update FSF's address in copyright notices.
551- check-rpaths-worker: allow multiple $ORIGIN paths in an RPATH and allow
552  RPATHs which are relative to $ORIGIN (#169298, Enrico Scholz).
553- check-rpaths-worker: give out an hint about usage and the detected issues
554  at the first detected error (Enrico Scholz).
555- Remove some redundancy from the Perl spec template.
556- Teach fedora-newrpmspec to detect and use different specfile variants.
557- Use fedora-newrpmspec in fedora-init.el.
558
559* Fri Jul  8 2005 Ville Skyttä <ville.skytta@iki.fi> - 1.1-1
560- Drop more pre-FC2 compat stuff from Perl spec template.
561- Treat gcc-gfortran as a devel package in rmdevelrpms.
562- Drop fedora.us GPG key.
563
564* Thu Mar 24 2005 Ville Skyttä <ville.skytta@iki.fi> - 1.0-1
565- Make fedora-diffarchive work better with archives containing dirs without
566  read/execute permissions.
567- Sync "Epoch: 0" drops with Fedora Extras CVS.
568- Include Nils Philippsen's spectool.
569- Own (%%ghost'd) more dirs from the site-lisp dir hierarchies.
570- Drop trigger support pre-FC2 Emacs and XEmacs packages.
571- Drop rpm-spec-mode.el patch, no longer needed for FC2 Emacs and later.
572- Update URLs.
573- Drop developer GPG keys from the package, add Fedora Extras key.
574- Drop fedora-pkgannfmt, it's no longer relevant.
575- Remove pre-FC2 compatibility stuff from Perl spec template.
576- Don't try to remove gcc-java and related packages by default in rmdevelrpms.
577- Remove "full featured" spec template, convert newrpmspec to use -minimal.
578
579* Sun Feb  6 2005 Ville Skyttä <ville.skytta@iki.fi> - 0:0.3.1-1
580- Make buildrpmtree and wipebuildtree less dependent on a specific
581  configuration (#147014, Ignacio Vazquez-Abrams).
582
583* Tue Jan 18 2005 Ville Skyttä <ville.skytta@iki.fi> - 0:0.3.0-1
584- Remove 0.fdr. prefixes and epoch 0's from all spec templates.
585- Add try-restart action to init script template.
586- Remove deprecated fedora-diffrpm and fedora-unrpm.
587- Install check-* to %%{_prefix}/lib/rpm instead of %%{_libdir}/rpm (bug 2351).
588- Check both %%{_prefix}/lib and %%{_prefix}/lib64 in the xemacs trigger.
589- Update rpminfo to 2004-07-07-01 and include it in the tarball.
Note: See TracBrowser for help on using the repository browser.