source: projects/specs/trunk/r/rpmdevtools/rpmdevtools-vl.spec @ 12544

Revision 12544, 21.9 KB checked in by tomop, 3 years ago (diff)

rpmdevtools-8.10-11

Line 
1%bcond_with python3
2
3%global spectool_version 1.0.10
4%global _emacs_sitestartdir /usr/share/emacs/site-lisp
5
6Name:           rpmdevtools
7Version:        8.10
8Release:        11%{?_dist_release}
9Summary:        RPM Development Tools
10
11# rpmdev-setuptree is GPLv2, everything else GPLv2+
12License:        GPLv2+ and GPLv2
13URL:            https://pagure.io/rpmdevtools
14Source0:        https://releases.pagure.org/rpmdevtools/%{name}-%{version}.tar.xz
15
16Vendor:         Project Vine
17Distribution:   Vine Linux
18
19# Backports from upstream
20Patch0001:      0001-bumpspec-checksig-Avoid-python-3.6-regex-related-dep.patch
21Patch0002:      0001-Limit-newVersion-s-re.sub-to-a-single-replacement.patch
22
23# Vine patch(es)
24Patch1000:      rpmdevtools-vine.patch
25
26BuildArch:      noarch
27# help2man, pod2man, *python for creating man pages
28BuildRequires:  help2man
29BuildRequires:  %{_bindir}/pod2man
30BuildRequires:  perl
31%if %{with python3}
32BuildRequires:  python3
33BuildRequires:  rpm-python3
34%else
35BuildRequires:  python >= 2.7
36BuildRequires:  rpm-python
37%endif
38# emacs-common >= 1:22.3-3 for macros.emacs
39BuildRequires:  emacsen-common
40BuildRequires:  bash-completion
41Provides:       spectool = %{spectool_version}
42Requires:       curl
43Requires:       diffutils
44Requires:       fakeroot
45Requires:       file
46Requires:       findutils
47Requires:       gawk
48Requires:       grep
49Requires:       rpm-build >= 4.4.2.3
50%if %{with python3}
51Requires:       rpm-python3
52%else
53Requires:       python >= 2.4
54Requires:       rpm-python
55%endif
56Requires:       sed
57
58%description
59This package contains scripts and (X)Emacs support files to aid in
60development of RPM packages.
61rpmdev-setuptree    Create RPM build tree within user's home directory
62rpmdev-diff         Diff contents of two archives
63rpmdev-newspec      Creates new .spec from template
64rpmdev-rmdevelrpms  Find (and optionally remove) "development" RPMs
65rpmdev-checksig     Check package signatures using alternate RPM keyring
66rpminfo             Print information about executables and libraries
67rpmdev-md5/sha*     Display checksums of all files in an archive file
68rpmdev-vercmp       RPM version comparison checker
69spectool            Expand and download sources and patches in specfiles
70rpmdev-wipetree     Erase all files within dirs created by rpmdev-setuptree
71rpmdev-extract      Extract various archives, "tar xvf" style
72rpmdev-bumpspec     Bump revision in specfile
73...and many more.
74
75
76%prep
77%autosetup -p1
78%if %{with python3}
79grep -lF "%{_bindir}/python " * \
80| xargs sed -i -e "s|%{_bindir}/python |%{_bindir}/python3 |"
81%endif
82
83
84%build
85%configure --libdir=%{_prefix}/lib
86%make_build
87
88
89%install
90rm -rf $RPM_BUILD_ROOT
91
92%make_install
93
94echo %%{_datadir}/bash-completion > %{name}.files
95[ -d $RPM_BUILD_ROOT%{_sysconfdir}/bash_completion.d ] && \
96echo %%{_sysconfdir}/bash_completion.d > %{name}.files
97
98%if 0%{?fedora}
99for dir in %{_emacs_sitestartdir} %{_xemacs_sitestartdir} ; do
100%else
101for dir in %{_emacs_sitestartdir} ; do
102%endif
103  install -dm 755 $RPM_BUILD_ROOT$dir
104  ln -s %{_datadir}/rpmdevtools/rpmdev-init.el $RPM_BUILD_ROOT$dir
105  touch $RPM_BUILD_ROOT$dir/rpmdev-init.elc
106done
107
108
109%files -f %{name}.files
110%license COPYING
111%doc NEWS
112%config(noreplace) %{_sysconfdir}/rpmdevtools/
113%{_datadir}/rpmdevtools/
114%{_bindir}/*
115%{_emacs_sitestartdir}/rpmdev-init.el
116%ghost %{_emacs_sitestartdir}/rpmdev-init.elc
117%if 0%{?fedora}
118%{_xemacs_sitestartdir}/rpmdev-init.el
119%ghost %{_xemacs_sitestartdir}/rpmdev-init.elc
120%endif
121%{_mandir}/man[18]/*.[18]*
122
123
124%changelog
125* Tue Sep 03 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 8.10-11
126- rpmdev-bumpspec: made to set %%_dist_release to %%nil.
127
128* Mon Aug 12 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 8.10-10
129- initial build for Vine Linux.
130
131* Fri Jul 26 2019 Fedora Release Engineering <releng@fedoraproject.org> - 8.10-9
132- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
133
134* Sat Feb 02 2019 Fedora Release Engineering <releng@fedoraproject.org> - 8.10-8
135- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
136
137* Wed Nov 28 2018 Neal Gompa <ngompa13@gmail.com> - 8.10-7
138- Fix regex substitution issues with Python 3.7 (rhbz#1651954)
139
140* Sun Sep 16 2018 Neal Gompa <ngompa13@gmail.com> - 8.10-6
141- Fix regex related deprecation warnings (rhbz#1598089)
142
143* Sat Jul 14 2018 Fedora Release Engineering <releng@fedoraproject.org> - 8.10-5
144- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
145
146* Fri Feb 09 2018 Fedora Release Engineering <releng@fedoraproject.org> - 8.10-4
147- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
148
149* Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 8.10-3
150- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
151
152* Sat Feb 11 2017 Fedora Release Engineering <releng@fedoraproject.org> - 8.10-2
153- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
154
155* Sat Jan 14 2017 Ville Skyttä <ville.skytta@iki.fi> - 8.10-1
156- Update to 8.10
157
158* Mon Dec 19 2016 Miro Hrončok <mhroncok@redhat.com> - 8.9-2
159- Rebuild for Python 3.6
160
161* Sat Jun 25 2016 Ville Skyttä <ville.skytta@iki.fi> - 8.9-1
162- Update to 8.9
163
164* Sat Jun 25 2016 Ville Skyttä <ville.skytta@iki.fi> - 8.8-1
165- Update to 8.8
166
167* Fri Jun 24 2016 Petr Písař <ppisar@redhat.com>
168- Add new mandatory perl build deps
169
170* Thu Jun 23 2016 Ville Skyttä <ville.skytta@iki.fi> - 8.7-1
171- Update to 8.7
172- Specfile cleanups
173
174* Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 8.6-3
175- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
176
177* Fri Jun  5 2015 Ville Skyttä <ville.skytta@iki.fi> - 8.6-2
178- Use python3 on > F-22
179
180* Sun May 10 2015 Ville Skyttä <ville.skytta@iki.fi> - 8.6-1
181- Update to 8.6
182
183* Mon Oct 20 2014 Ville Skyttä <ville.skytta@iki.fi> - 8.5-1
184- Update to 8.5
185- Mark COPYING as %%license where applicable
186
187* Sun Jun 08 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 8.4-3
188- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
189
190* Thu Oct 17 2013 Ville Skyttä <ville.skytta@iki.fi> - 8.4-2
191- Do not require devscripts in any scenario.
192
193* Mon Oct  7 2013 Ville Skyttä <ville.skytta@iki.fi> - 8.4-1
194- Update to 8.4.
195
196* Sun Aug 04 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 8.3-5
197- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
198
199* Wed Jul 17 2013 Petr Pisar <ppisar@redhat.com> - 8.3-4
200- Perl 5.18 rebuild
201
202* Thu Feb 14 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 8.3-3
203- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
204
205* Tue Oct 16 2012 Thomas Woerner <twoerner@redhat.com> - 8.3-2
206- xemacs is not available on RHEL (RHBZ#866841)
207
208* Sun Sep  2 2012 Ville Skyttä <ville.skytta@iki.fi> - 8.3-1
209- Update to 8.3.
210- Drop specfile constructs no longer needed with Fedora's rpm.
211
212* Sat Jul 21 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 8.2-3
213- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
214
215* Sat Jan 14 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 8.2-2
216- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
217
218* Sat Nov 12 2011 Ville Skyttä <ville.skytta@iki.fi> - 8.2-1
219- Update to 8.2.
220
221* Tue Apr 26 2011 Ville Skyttä <ville.skytta@iki.fi> - 8.1-1
222- Update to 8.1.
223
224* Tue Mar  1 2011 Ville Skyttä <ville.skytta@iki.fi> - 8.0-3
225- Require xemacs-filesystem on F-15+ (#672093).
226
227* Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 8.0-2
228- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
229
230* Sun Feb  6 2011 Ville Skyttä <ville.skytta@iki.fi> - 8.0-1
231- Update to 8.0, fixes #519061 and #657594.
232
233* Mon Sep 27 2010 Ville Skyttä <ville.skytta@iki.fi> - 7.10-1
234- Update to 7.10, fixes #595135 and #619867.
235- Patch spectool to work with specfiles containing Icon or BuildArchitectures
236  (#637000).
237
238* Thu May 20 2010 Ville Skyttä <ville.skytta@iki.fi> - 7.9-1
239- Update to 7.9, fixes #588313 and #589705.
240
241* Fri Apr 16 2010 Ville Skyttä <ville.skytta@iki.fi> - 7.8-2
242- Require %%{_bindir}/man instead of man (#582932).
243
244* Tue Feb 16 2010 Ville Skyttä <ville.skytta@iki.fi> - 7.8-1
245- Update to 7.8, fixes #562316.
246
247* Tue Feb  2 2010 Ville Skyttä <ville.skytta@iki.fi> - 7.7-1
248- Update to 7.7, fixes #558263.
249
250* Mon Dec  7 2009 Ville Skyttä <ville.skytta@iki.fi> - 7.6-1
251- Update to 7.6, fixes #528907.
252
253* Thu Sep 17 2009 Ville Skyttä <ville.skytta@iki.fi> - 7.5-1
254- Update to 7.5, fixes #502403.
255
256* Fri Aug 21 2009 Ville Skyttä <ville.skytta@iki.fi> - 7.4-1
257- Update to 7.4, fixes #215927 and #466353.
258- Patch spectool to make -s and -p to work as documented (Todd Zullinger).
259
260* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 7.3-2
261- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
262
263* Mon May 25 2009 Ville Skyttä <ville.skytta@iki.fi> - 7.3-1
264- Release 7.3.
265
266* Sat May 23 2009 Ville Skyttä <ville.skytta@iki.fi>
267- Add rpmdev-packager - script for getting rpm packager info.
268- Use rpmdev-packager in rpmdev-bumpspec and rpmdev-init.el.
269- Fix rpmdev-extract MIME type comparisons with file(1) output containing
270  parameters.
271
272* Wed May 20 2009 Ville Skyttä <ville.skytta@iki.fi> - 7.2-1
273- Release 7.2.
274
275* Sun May  3 2009 Ville Skyttä <ville.skytta@iki.fi>
276- Add dummy spec template for ad-hoc testing.
277
278* Sat May  2 2009 Ville Skyttä <ville.skytta@iki.fi>
279- Improve newspec/newinit when only "-o foo" argument is given (#498588,
280  thanks to Edwin ten Brink).
281- Try to get packager mail address for *Emacs rpm-spec-mode from ~/.fedora.cert
282  if rpm-spec-user-mail-address is not set.
283- Add xz support to rpmdev-extract.
284
285* Sat Apr 18 2009 Ville Skyttä <ville.skytta@iki.fi>
286- Make bumpspec's use of "head" POSIX compliant.
287
288* Thu Apr 16 2009 Ville Skyttä <ville.skytta@iki.fi>
289- Add rpmdev-newinit for easier access to the init script template, move the
290  template to %%{_sysconfdir}/rpmdevtools, improve reload action example.
291
292* Tue Apr  7 2009 Ville Skyttä <ville.skytta@iki.fi>
293- Speed up rpmls bash completion.
294
295* Sat Apr  4 2009 Ville Skyttä <ville.skytta@iki.fi> - 7.1-1
296- 7.1.
297- Make rpmdev-md5 and friends work on non-srpm package files too.
298
299* Sun Mar 15 2009 Ville Skyttä <ville.skytta@iki.fi>
300- Add bash completion.
301
302* Mon Mar  9 2009 Ville Skyttä <ville.skytta@iki.fi>
303- Add query format option to rmdevelrpms, sort output by NEVRA.
304
305* Sun Feb 22 2009 Ville Skyttä <ville.skytta@iki.fi>
306- Use %%global instead of %%define in spec templates.
307- Handle %%global in addition to %%define in rpmdev-bumpspec.
308
309* Mon Jan 26 2009 Ville Skyttä <ville.skytta@iki.fi>
310- Add result dependent exit statuses to rpmdev-vercmp.
311
312* Fri Dec 26 2008 Ville Skyttä <ville.skytta@iki.fi>
313- Add minimum version to rpm-python dependency (for rpmdev-bumpspec).
314
315* Fri Dec 26 2008 Ville Skyttä <ville.skytta@iki.fi> - 7.0-1
316- 7.0.
317- Drop fonts spec template, adapt to new ones from Fedora fonts SIG (#477055).
318- Add man page for rpmdev-newspec.
319
320* Tue Dec 16 2008 Ville Skyttä <ville.skytta@iki.fi>
321- Add imake and intltool to internal list of devel packages in rmdevelrpms.
322
323* Sat Dec 13 2008 Ville Skyttä <ville.skytta@iki.fi>
324- Add rpmdev-sha*/*sum companions to rpmdev-md5 (ticket #7).
325
326* Wed Nov 26 2008 Ville Skyttä <ville.skytta@iki.fi>
327- Add vamp-plugin-sdk to internal list of non-devel packages in rmdevelrpms
328  (#472641, Michael Schwendt).
329
330* Thu Nov 20 2008 Ville Skyttä <ville.skytta@iki.fi>
331- Drop "minimal buildroot" dependencies.
332- Drop fedora-rpmdevtools Obsoletes.
333
334* Mon Oct 13 2008 Ville Skyttä <ville.skytta@iki.fi>
335- Show available types in rpmdev-newspec --help (ticket #6, Todd Zullinger).
336
337* Fri Sep 26 2008 Ville Skyttä <ville.skytta@iki.fi>
338- Add -r/--rightmost option to rpmdev-bumpspec (ticket #1, Thorsten Leemhuis).
339- Add %%packager from rpm config to the set of defaults for rpmdev-bumpspec's
340  user string.
341
342* Thu Sep 25 2008 Ville Skyttä <ville.skytta@iki.fi>
343- Bring rpmdev-bumpspec copyright holder closer to truth (Michael Schwendt).
344
345* Mon Sep 22 2008 Ville Skyttä <ville.skytta@iki.fi>
346- Switch to lzma compressed tarball.
347
348* Sun Sep  7 2008 Ville Skyttä <ville.skytta@iki.fi>
349- Improve arch specific %%files in perl spec template (#461177, Chris Weyl).
350
351* Sun Aug  3 2008 Ville Skyttä <ville.skytta@iki.fi> - 6.7-1
352- 6.7.
353- Make rpmdev-diff, rpmdev-md5 and rpminfo honor TMPDIR.
354
355* Sat Apr 26 2008 Ville Skyttä <ville.skytta@iki.fi>
356- Make rpmls work with URLs.
357
358* Sun Apr 20 2008 Ville Skyttä <ville.skytta@iki.fi>
359- Include rpm arch in dir names created by rpmdev-extract (#443266).
360
361* Fri Apr 18 2008 Ville Skyttä <ville.skytta@iki.fi>
362- Remove duplicate "reload" from case block in init script template.
363- Fix exit status of "reload" in case service is not running in init
364  script template (#442993).
365
366* Thu Mar 27 2008 Ville Skyttä <ville.skytta@iki.fi> - 6.6-1
367- Fix man page generation.
368
369* Wed Mar 26 2008 Ville Skyttä <ville.skytta@iki.fi> - 6.5-1
370- 6.5.
371
372* Sun Mar 23 2008 Ville Skyttä <ville.skytta@iki.fi>
373- Generate man pages at build time.
374
375* Sat Mar 22 2008 Ville Skyttä <ville.skytta@iki.fi>
376- Remove libgcj-devel and zlib-devel from rmdevelrpms' internal exclusion
377  list, they're not essential on non-devel systems any more.
378
379* Mon Mar 17 2008 Ville Skyttä <ville.skytta@iki.fi>
380- Include ocaml spec template.
381
382* Tue Mar 11 2008 Ville Skyttä <ville.skytta@iki.fi>
383- Include Michael Schwendt's bumpspecfile.py (as rpmdev-bumpspec).
384
385* Tue Feb 12 2008 Ville Skyttä <ville.skytta@iki.fi>
386- Sync with qa-robot upstream.
387- Update spectool to 1.0.10.
388
389* Sun Feb  3 2008 Ville Skyttä <ville.skytta@iki.fi>
390- Add support for 7-zip, lzma and lzo in rpmdev-extract.
391
392* Fri Feb  1 2008 Ville Skyttä <ville.skytta@iki.fi>
393- Add ';;' to the init script template's reload action.
394
395* Sat Dec  8 2007 Ville Skyttä <ville.skytta@iki.fi>
396- Add fonts spec template from the Fedora Fonts SIG (#407781).
397- Add option to use macro style instead of shell style variables to newspec.
398- Prefer ~/.config/rpmdevtools/rmdevelrpms.conf over ~/.rmdevelrpmsrc in
399  rmdevelrpms.
400
401* Fri Oct 12 2007 Lubomir Kundrak <lkundrak@redhat.com> - 6.4-1
402- Import the previous fix into CVS to resync, bump version
403
404* Fri Oct 12 2007 Lubomir Kundrak <lkundrak@redhat.com> - 6.3-1
405- Fix paths in qa-robot tools
406
407* Sat Sep  8 2007 Ville Skyttä <ville.skytta@iki.fi> - 6.2-1
408- Sync deps with Fedora's new "assumed present in buildroots" packages list.
409
410* Thu Sep  6 2007 Ville Skyttä <ville.skytta@iki.fi>
411- Init script template cleanups.
412
413* Tue Aug 28 2007 Ville Skyttä <ville.skytta@iki.fi>
414- Update rpminfo to version 2004-07-07-02.
415
416* Fri Aug 10 2007 Ville Skyttä <ville.skytta@iki.fi> - 6.1-1
417- Sync COPYING with http://www.gnu.org/licenses/old-licenses/gpl-2.0.txt
418
419* Mon Aug  6 2007 Ville Skyttä <ville.skytta@iki.fi>
420- Work around #250990 in rpmls and rpmdev-extract.
421- Clarify copyright info of rpmdev-* and rpmls.
422
423* Sat Jul  7 2007 Ville Skyttä <ville.skytta@iki.fi>
424- Fix Epoch handling in the 2-arg form of rpmdev-vercmp with yum < 3.1.2.
425- The long form of the list option in rmdevelrpms is --list-only, not --list.
426
427* Thu Jul  5 2007 Ville Skyttä <ville.skytta@iki.fi> - 6.0-1
428- Remove check-{buildroot,rpaths*}, now included in rpm-build >= 4.4.2.1.
429- Drop explicit dependency on patch, pulled in by recent rpm-build.
430- Add cmake and scons to default devel package list in rpmdev-rmdevelrpms.
431- Add LSB comment block to init script template.
432
433* Wed Jun 27 2007 Ville Skyttä <ville.skytta@iki.fi>
434- Add 2-argument form for comparing EVR strings to rpmdev-vercmp
435  (available only if rpmUtils.miscutils is available).
436
437* Sat Jun 16 2007 Ville Skyttä <ville.skytta@iki.fi>
438- Include rpmsodiff and dependencies (rpmargs, rpmelfsym, rpmfile, rpmpeek,
439  rpmsoname) from ALT Linux's qa-robot package.
440- Include rpmls (#213778).
441
442* Fri Jun 15 2007 Ville Skyttä <ville.skytta@iki.fi>
443- Update spectool to 1.0.9 (#243731).
444
445* Wed Apr 11 2007 Ville Skyttä <ville.skytta@iki.fi>
446- Add --list-only option to rmdevelrpms (Thorsten Leemhuis).
447
448* Tue Mar 13 2007 Ville Skyttä <ville.skytta@iki.fi>
449- BR perl(ExtUtils::MakeMaker) by default in perl spec template.
450- Drop deprecated backwards compatibility with fedora-rpmdevtools.
451- Update URL.
452
453* Wed Nov  8 2006 Ville Skyttä <ville.skytta@iki.fi>
454- Arch-qualify output of matched packages in rmdevelrpms and allow
455  arch-qualified packages in the config file.
456
457* Wed Oct 25 2006 Ville Skyttä <ville.skytta@iki.fi> - 5.3-1
458- Update spectool to 1.0.8, fixes #212108.
459
460* Mon Oct  2 2006 Ville Skyttä <ville.skytta@iki.fi> - 5.2-1
461- Skip *.jar.so.debug in check-buildroot (#208903).
462- Treat yasm and *-static as devel packages in rmdevelrpms.
463
464* Sat Sep  9 2006 Ville Skyttä <ville.skytta@iki.fi> - 5.1-1
465- Re-add PHP PEAR spec template, more improvements to it (#198706,
466  Christopher Stone, Remi Collet).
467
468* Tue Aug 22 2006 Ville Skyttä <ville.skytta@iki.fi> - 5.0-2
469- Migrate rmdevelrpms config when upgrading from fedora-rpmdevtools.
470
471* Sun Aug 20 2006 Ville Skyttä <ville.skytta@iki.fi> - 5.0-1
472- Re-rename almost everything to rpmdev-*, with backwards compat symlinks.
473- Don't encourage %%ghost'ing *.pyo in Python spec template, add some comments.
474- Drop PHP PEAR spec template, it's not ready yet.
475
476* Wed Aug  2 2006 Ville Skyttä <ville.skytta@iki.fi>
477- Treat *-sdk as devel packages in rmdevelrpms (#199909).
478- Don't assume compface is a devel package in rmdevelrpms.
479
480* Thu Jul 20 2006 Ville Skyttä <ville.skytta@iki.fi>
481- Mark things that are not needed for noarch module packages in the Perl
482  spec template.
483
484* Wed Jul 19 2006 Ville Skyttä <ville.skytta@iki.fi>
485- Move option arguments to "find" before non-option ones in Perl spec template.
486- Drop python-abi dependency from Python spec template (#189947).
487
488* Tue Jul 18 2006 Ville Skyttä <ville.skytta@iki.fi>
489- Add PHP PEAR spec template (#198706, Christopher Stone).
490
491* Mon Jul 17 2006 Ville Skyttä <ville.skytta@iki.fi>
492- Drop fedora- prefix everywhere, add backcompat symlinks for execubtables.
493- Move %%{_sysconfdir}/fedora to %%{_sysconfdir}/rpmdevtools and
494  %%{_datadir}/fedora to %%{_datadir}/rpmdevtools.
495- Move spec templates to %%{_sysconfdir}/rpmdevtools, mark as config.
496- Bump version to 5.0.
497
498* Sun Jul 16 2006 Ville Skyttä <ville.skytta@iki.fi>
499- Drop fedora-kmodhelper.
500- Drop fedora-installdevkeys and GPG keys, modify rpmchecksig to use
501  the system rpmdb.
502
503* Sat Jul 15 2006 Ville Skyttä <ville.skytta@iki.fi>
504- Sort rmdevelrpms' output.
505
506* Fri Jul  7 2006 Ville Skyttä <ville.skytta@iki.fi>
507- Improve ruby spec template (#180066, David Lutterkort).
508
509* Mon Jun  5 2006 Ville Skyttä <ville.skytta@iki.fi>
510- Add manual pages for rmdevelrpms, diffarchive and extract.
511- Trim pre-2005 changelog entries.
512- Autotoolize source tree.
513
514* Tue May 16 2006 Ville Skyttä <ville.skytta@iki.fi> - 1.6-1
515- Add spec template for library packages (#185606, Ignacio Vazquez-Abrams).
516
517* Sun Feb 26 2006 Ville Skyttä <ville.skytta@iki.fi> - 1.5-1
518- Improve diffarchive and extract error messages.
519
520* Fri Feb 24 2006 Ville Skyttä <ville.skytta@iki.fi>
521- Update spectool to 1.0.7 (#162253).
522
523* Thu Feb  9 2006 Ville Skyttä <ville.skytta@iki.fi>
524- Add file(1) based archive type detection to fedora-extract.
525
526* Wed Feb  8 2006 Ville Skyttä <ville.skytta@iki.fi>
527- Add "diff file lists only" option to diffarchive.
528
529* Sun Feb  5 2006 Ville Skyttä <ville.skytta@iki.fi>
530- Add Ruby spec template (#180066, Oliver Andrich) and make newrpmspec
531  use it for ruby-*.
532
533* Sat Feb  4 2006 Ville Skyttä <ville.skytta@iki.fi> - 1.4-2
534- Fix rpath checker tests with bash 3.1 (#178636, Enrico Scholz).
535
536* Fri Dec 30 2005 Ville Skyttä <ville.skytta@iki.fi> - 1.4-1
537- Update spectool to 1.0.6 (#176521).
538
539* Wed Dec 28 2005 Ville Skyttä <ville.skytta@iki.fi>
540- Update spectool to 1.0.5 (#162253), require wget for it.
541- Add disttags to spec templates.
542
543* Thu Oct 27 2005 Ville Skyttä <ville.skytta@iki.fi> - 1.3-1
544- check-rpaths-worker: detect when RPATH references the parent directory
545  of an absolute path (#169298, Enrico Scholz).
546- Add regression test for check-rpaths* (#169298, Enrico Scholz).
547- Honor user's indent-tabs-mode setting in fedora-init.el (#170902).
548
549* Fri Oct  7 2005 Ville Skyttä <ville.skytta@iki.fi> - 1.2-1
550- check-buildroot: grep for buildroot as a fixed string, not a regexp.
551- Update FSF's address in copyright notices.
552- check-rpaths-worker: allow multiple $ORIGIN paths in an RPATH and allow
553  RPATHs which are relative to $ORIGIN (#169298, Enrico Scholz).
554- check-rpaths-worker: give out an hint about usage and the detected issues
555  at the first detected error (Enrico Scholz).
556- Remove some redundancy from the Perl spec template.
557- Teach fedora-newrpmspec to detect and use different specfile variants.
558- Use fedora-newrpmspec in fedora-init.el.
559
560* Fri Jul  8 2005 Ville Skyttä <ville.skytta@iki.fi> - 1.1-1
561- Drop more pre-FC2 compat stuff from Perl spec template.
562- Treat gcc-gfortran as a devel package in rmdevelrpms.
563- Drop fedora.us GPG key.
564
565* Thu Mar 24 2005 Ville Skyttä <ville.skytta@iki.fi> - 1.0-1
566- Make fedora-diffarchive work better with archives containing dirs without
567  read/execute permissions.
568- Sync "Epoch: 0" drops with Fedora Extras CVS.
569- Include Nils Philippsen's spectool.
570- Own (%%ghost'd) more dirs from the site-lisp dir hierarchies.
571- Drop trigger support pre-FC2 Emacs and XEmacs packages.
572- Drop rpm-spec-mode.el patch, no longer needed for FC2 Emacs and later.
573- Update URLs.
574- Drop developer GPG keys from the package, add Fedora Extras key.
575- Drop fedora-pkgannfmt, it's no longer relevant.
576- Remove pre-FC2 compatibility stuff from Perl spec template.
577- Don't try to remove gcc-java and related packages by default in rmdevelrpms.
578- Remove "full featured" spec template, convert newrpmspec to use -minimal.
579
580* Sun Feb  6 2005 Ville Skyttä <ville.skytta@iki.fi> - 0:0.3.1-1
581- Make buildrpmtree and wipebuildtree less dependent on a specific
582  configuration (#147014, Ignacio Vazquez-Abrams).
583
584* Tue Jan 18 2005 Ville Skyttä <ville.skytta@iki.fi> - 0:0.3.0-1
585- Remove 0.fdr. prefixes and epoch 0's from all spec templates.
586- Add try-restart action to init script template.
587- Remove deprecated fedora-diffrpm and fedora-unrpm.
588- Install check-* to %%{_prefix}/lib/rpm instead of %%{_libdir}/rpm (bug 2351).
589- Check both %%{_prefix}/lib and %%{_prefix}/lib64 in the xemacs trigger.
590- Update rpminfo to 2004-07-07-01 and include it in the tarball.
Note: See TracBrowser for help on using the repository browser.