source: projects/specs/trunk/r/rply/rply-vl.spec @ 6011

Revision 6011, 2.7 KB checked in by Takemikaduchi, 12 years ago (diff)

new upstream release

Line 
1Name:           rply
2Version:        1.1.1
3Release:        1%{?_dist_release}
4Summary:        A library to read and write PLY files
5Group:          Development/Libraries
6License:        MIT
7URL:            http://www.tecgraf.puc-rio.br/~diego/professional/%{name}/
8Source0:        http://www.tecgraf.puc-rio.br/~diego/professional/%{name}/%{name}-%{version}.tar.gz
9Source1:        rply_CMakeLists.txt
10Source2:        RPLYConfig.cmake.in
11Source3:        rply_cmake_export_cmakelists.txt
12Buildroot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
13
14BuildRequires:  cmake >= 2.6.0
15
16
17%description
18RPly is a library that lets applications read and write PLY files.
19The PLY file format is widely used to store geometric information, such as 3D
20models, but is general enough to be useful for other purposes.
21
22RPly is easy to use, well documented, small, free, open-source, ANSI C,
23efficient, and well tested. The highlights are:
24
25* A callback mechanism that makes PLY file input straightforward;
26* Support for the full range of numeric formats;
27* Binary (big and little endian) and text modes are fully supported;
28* Input and output are buffered for efficiency;
29* Available under the MIT license for added freedom.
30
31
32%package        devel
33Summary:        Libraries and headers for rply
34Group:          Development/Libraries
35Requires:       %{name} = %{version}-%{release}
36
37%description devel
38Rply Library Header Files and Link Libraries
39
40
41%prep
42%setup -q
43
44# Add CMakeLists.txt file
45cp %{SOURCE1} CMakeLists.txt
46
47# Add CMake detection modules
48mkdir -p CMake/export
49mkdir -p CMake/Modules
50cp %{SOURCE2} CMake/Modules/
51cp %{SOURCE3} CMake/export/CMakeLists.txt
52
53%build
54%cmake -DCMAKE_BUILD_TYPE:STRING="Release"\
55       -DCMAKE_VERBOSE_MAKEFILE=ON .
56
57make %{?_smp_mflags}
58
59%install
60rm -rf $RPM_BUILD_ROOT
61make install DESTDIR=$RPM_BUILD_ROOT
62
63
64%clean
65rm -rf $RPM_BUILD_ROOT
66
67%post -p /sbin/ldconfig
68
69%postun -p /sbin/ldconfig
70
71
72%files
73%defattr(-,root,root,-)
74%doc LICENSE
75%doc manual/*
76%{_libdir}/*.so.*
77%{_bindir}/*
78
79%files devel
80%defattr(-,root,root)
81%dir %{_includedir}/%{name}/
82%{_includedir}/%{name}/*
83%{_libdir}/*.so
84%dir %{_datadir}/%{name}/
85%{_datadir}/%{name}/rplyConfig.cmake
86
87%changelog
88* Sat Apr 14 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.1.1-1
89- new upstream release
90
91* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.01-1
92- initial build for Vine Linux
93
94
95* Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org>
96- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
97
98* Sun Mar 21 2010 Mario Ceresa mrceresa@gmail.com
99- Added CMake modules to detect the package
100
101* Thu Mar 04 2010 Mario Ceresa mrceresa@gmail.com
102- Fixed problems detected in https://bugzilla.redhat.com/show_bug.cgi?id=570258#c2
103
104* Wed Mar 03 2010 Mario Ceresa mrceresa@gmail.com
105- Initial RPM Release
Note: See TracBrowser for help on using the repository browser.