source: projects/specs/trunk/r/rply/rply-vl.spec @ 8119

Revision 8119, 2.8 KB checked in by Takemikaduchi, 10 years ago (diff)

rebuild or new upstream release

Line 
1Name:           rply
2Version:        1.1.3
3Release:        1%{?_dist_release}
4Summary:        A library to read and write PLY files
5Group:          Development/Libraries
6License:        MIT
7URL:            http://www.tecgraf.puc-rio.br/~diego/professional/%{name}/
8Source0:        http://www.tecgraf.puc-rio.br/~diego/professional/%{name}/%{name}-%{version}.tar.gz
9Source1:        rply_CMakeLists.txt
10Source2:        RPLYConfig.cmake.in
11Source3:        rply_cmake_export_cmakelists.txt
12Buildroot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
13
14BuildRequires:  cmake >= 2.6.0
15
16Vendor: Project Vine
17Distribution: Vine Linux
18
19%description
20RPly is a library that lets applications read and write PLY files.
21The PLY file format is widely used to store geometric information, such as 3D
22models, but is general enough to be useful for other purposes.
23
24RPly is easy to use, well documented, small, free, open-source, ANSI C,
25efficient, and well tested. The highlights are:
26
27* A callback mechanism that makes PLY file input straightforward;
28* Support for the full range of numeric formats;
29* Binary (big and little endian) and text modes are fully supported;
30* Input and output are buffered for efficiency;
31* Available under the MIT license for added freedom.
32
33
34%package        devel
35Summary:        Libraries and headers for rply
36Group:          Development/Libraries
37Requires:       %{name} = %{version}-%{release}
38
39%description devel
40Rply Library Header Files and Link Libraries
41
42
43%prep
44%setup -q
45
46# Add CMakeLists.txt file
47cp %{SOURCE1} CMakeLists.txt
48
49# Add CMake detection modules
50mkdir -p CMake/export
51mkdir -p CMake/Modules
52cp %{SOURCE2} CMake/Modules/
53cp %{SOURCE3} CMake/export/CMakeLists.txt
54
55%build
56%cmake -DCMAKE_BUILD_TYPE:STRING="Release"\
57       -DCMAKE_VERBOSE_MAKEFILE=ON .
58
59make %{?_smp_mflags}
60
61%install
62rm -rf $RPM_BUILD_ROOT
63make install DESTDIR=$RPM_BUILD_ROOT
64
65
66%clean
67rm -rf $RPM_BUILD_ROOT
68
69%post -p /sbin/ldconfig
70
71%postun -p /sbin/ldconfig
72
73
74%files
75%defattr(-,root,root,-)
76%doc LICENSE
77%doc manual/*
78%{_libdir}/*.so.*
79%{_bindir}/*
80
81%files devel
82%defattr(-,root,root)
83%dir %{_includedir}/%{name}/
84%{_includedir}/%{name}/*
85%{_libdir}/*.so
86%dir %{_datadir}/%{name}/
87%{_datadir}/%{name}/rplyConfig.cmake
88
89%changelog
90* Sat Jan 04 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.1.3-1
91- new upstream release
92
93* Sat Apr 14 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.1.1-1
94- new upstream release
95
96* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.01-1
97- initial build for Vine Linux
98
99
100* Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org>
101- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
102
103* Sun Mar 21 2010 Mario Ceresa mrceresa@gmail.com
104- Added CMake modules to detect the package
105
106* Thu Mar 04 2010 Mario Ceresa mrceresa@gmail.com
107- Fixed problems detected in https://bugzilla.redhat.com/show_bug.cgi?id=570258#c2
108
109* Wed Mar 03 2010 Mario Ceresa mrceresa@gmail.com
110- Initial RPM Release
Note: See TracBrowser for help on using the repository browser.