source: projects/specs/trunk/r/robin-map/robin-map-vl.spec @ 12510

Revision 12510, 3.6 KB checked in by tomop, 3 years ago (diff)

updated 11 packages

Field3D-1.7.3-2

ImageMagick?-6.9.11.48-1

OpenEXR-2.5.3-1

OpenImageIO-2.2.9.0-1

babl-0.1.82-1

fmt-7.1.3-2

gegl04-0.4.26-2

gimp-2.10.22-1

hdf5-1.12.0-1

opencv-4.5.0-1

robin-map-0.6.3-4

Line 
1%global debug_package %{nil}
2
3Name:           robin-map
4Summary:        C++ implementation of a fast hash map and hash set using robin hood hashing
5Version:        0.6.3
6Release:        4%{?_dist_release}
7Group:          system
8Vendor:         Project Vine
9Distribution:   Vine Linux
10
11License:        MIT
12URL:            https://github.com/Tessil/robin-map
13Source0:        https://github.com/Tessil/%{name}/archive/v%{version}/%{name}-%{version}.tar.gz
14
15BuildArch:      noarch
16
17BuildRequires:  cmake gcc-c++
18BuildRequires:  libboost-devel
19BuildRequires:  libboost-test
20
21%description
22The robin-map library is a C++ implementation of a fast hash map and hash set
23using open-addressing and linear robin hood hashing with backward shift
24deletion to resolve collisions.
25
26*** This is a header only library. ***
27The package you want is %{name}-devel.
28
29
30%package devel
31Summary:        %{summary}
32Group:          programming
33
34%description devel
35The robin-map library is a C++ implementation of a fast hash map and hash set
36using open-addressing and linear robin hood hashing with backward shift
37deletion to resolve collisions.
38
39Four classes are provided: tsl::robin_map, tsl::robin_set, tsl::robin_pg_map
40and tsl::robin_pg_set. The first two are faster and use a power of two growth
41policy, the last two use a prime growth policy instead and are able to cope
42better with a poor hash function. Use the prime version if there is a chance of
43repeating patterns in the lower bits of your hash (e.g. you are storing
44pointers with an identity hash function). See GrowthPolicy for details.
45
46A benchmark of tsl::robin_map against other hash maps may be found here. This
47page also gives some advices on which hash table structure you should try for
48your use case (useful if you are a bit lost with the multiple hash tables
49implementations in the tsl namespace).
50
51
52%prep
53%autosetup -p1
54
55
56%build
57%cmake
58
59
60%install
61DESTDIR="%{buildroot}" %__cmake --install .
62
63
64%check
65pushd tests
66%cmake
67%__cmake --build .
68./tsl_robin_map_tests
69
70
71%files devel
72%license LICENSE
73%doc README.md
74%{_datadir}/cmake/tsl-%{name}/*.cmake
75%{_includedir}/tsl/
76
77
78%changelog
79* Sat Dec 12 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 0.6.3-4
80- initial build for Vine Linux.
81
82* Sat Aug 01 2020 Fedora Release Engineering <releng@fedoraproject.org> - 0.6.3-3
83- Second attempt - Rebuilt for
84  https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
85
86* Wed Jul 29 2020 Fedora Release Engineering <releng@fedoraproject.org> - 0.6.3-2
87- Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
88
89* Sun Jun 21 2020 Richard Shaw <hobbes1069@gmail.com> - 0.6.3-1
90- Update to 0.6.3.
91
92* Thu Jan 30 2020 Fedora Release Engineering <releng@fedoraproject.org> - 0.6.2-2
93- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
94
95* Tue Nov 12 2019 Richard Shaw <hobbes1069@gmail.com> - 0.6.2-1
96- Update to 0.6.2.
97
98* Fri Jul 26 2019 Fedora Release Engineering <releng@fedoraproject.org> - 0.6.1-2
99- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
100
101* Wed Feb 27 2019 Richard Shaw <hobbes1069@gmail.com> - 0.6.1-1
102- Update to 0.6.1.
103
104* Tue Feb 12 2019 Richard Shaw <hobbes1069@gmail.com> - 0.6.0-2
105- Add patch for GCC 9 warnings.
106
107* Mon Feb 11 2019 Richard Shaw <hobbes1069@gmail.com> - 0.6.0-1
108- Update to 0.6.0.
109
110* Sat Feb 02 2019 Fedora Release Engineering <releng@fedoraproject.org> - 0.2.0-3
111- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
112
113* Sat Jul 14 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.2.0-2
114- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
115
116* Mon Jun 11 2018 Richard Shaw <hobbes1069@gmail.com> - 0.2.0-1
117- Initial packaging.
Note: See TracBrowser for help on using the repository browser.