source: projects/specs/trunk/r/rhythmbox/rhythmbox-vl.spec @ 8769

Revision 8769, 20.2 KB checked in by daisuke, 10 years ago (diff)

rhythmbox: rebuild with new libimobiledevice

Line 
1# -*- coding: utf-8-unix -*-
2%define desktop_file_utils_version 0.9
3
4%define enable_DLNA_UPnP 0
5
6Summary: Music Management Application
7Summary(ja): 音楽管理アプリケーション
8Name: rhythmbox
9Version: 3.0.3
10Release: 2%{?_dist_release}
11License: GPL2+ with exceptions and GFDL
12Group: Applications/Multimedia
13URL: http://projects.gnome.org/rhythmbox/
14Source0: http://download.gnome.org/sources/${name}/3.0/%{name}-%{version}.tar.xz
15
16Source101:      rhythmbox-png.tar.bz2
17
18Patch0: rhythmbox-3.0-disable-python3.patch
19
20BuildRoot: %{_tmppath}/%{name}-%{version}-root
21BuildRequires: gtk3-devel
22BuildRequires: avahi-glib-devel >= 0.6
23BuildRequires: brasero-devel >= 2.32.0
24BuildRequires: dbus-glib-devel
25BuildRequires: gstreamer1-plugins-base-devel
26BuildRequires: json-glib-devel
27BuildRequires: libSM-devel
28BuildRequires: libgnome-keyring-devel >= 2.30.0
29BuildRequires: libgpod-devel
30BuildRequires: eudev-libgudev1-devel
31BuildRequires: libmusicbrainz3-devel >= 3.0.2
32BuildRequires: libnotify-devel
33BuildRequires: libsoup-devel
34BuildRequires: pygobject3-devel
35BuildRequires: totem-pl-parser-devel
36BuildRequires: WebKit3-gtk-devel
37BuildRequires: libpeas-devel
38BuildRequires: clutter-gtk-devel
39BuildRequires: clutter-gst-devel
40BuildRequires: libmx-devel
41BuildRequires: check-devel
42BuildRequires: libmtp-devel
43BuildRequires: libtdb-devel
44BuildRequires: grilo-devel
45BuildRequires: libdmapsharing-devel
46BuildRequires: lirc
47BuildRequires: gnome-doc-utils >= 0.3.2
48BuildRequires: yelp-tools
49
50Requires: brasero
51Requires: libgnome-keyring
52%if %{enable_DLNA_UPnP}
53Requires: python-Coherence
54%endif
55Requires: desktop-file-utils >= %{desktop_file_utils_version}
56
57# # gstreamer-plugins-ffmpeg and gstreamer-plugins-ugly package provided by
58# # self-build-gstreamer-plugins-ffmpeg and self-build-gstreamer-plugins-ugly,
59# # respectively.
60# Requires: self-build-gstreamer-plugins-ffmpeg
61# Requires: self-build-gstreamer-plugins-ugly
62
63Vendor: Project Vine
64Distribution: Vine Linux
65
66
67%description
68Rhythmbox is an integrated music management application based on the powerful
69GStreamer media framework. It has a number of features, including an easy to
70use music browser, searching and sorting, comprehensive audio format support
71through GStreamer, Internet Radio support, playlists and more.
72
73Rhythmbox is extensible through a plugin system.
74
75%description -l ja
76Rhythmbox は、強力な GStreamer メディアフレームワークに基づいている
77統合音楽管理アプリケーションです。
78見やすいユーザインターフェースを備え、検索や整列ができ、
79GStreamer により数多くの音声フォーマットをサポート、
80インターネットラジオをサポート、プレイリスト管理などの
81数多くの特徴を持ちます。
82
83%package devel
84Summary: Development tools for rhythmbox applications.
85Summary(ja): rhythmbox アプリケーションの開発用ファイル
86Group: Development/Libraries
87Requires: %{name} = %{version}-%{release}
88Requires: pkgconfig
89Requires: libxml2-devel
90Requires: glib2-devel
91Requires: gtk3-devel
92Requires: libsoup-devel
93Requires: totem-pl-parser-devel
94Requires: gstreamer1-devel
95
96%description devel
97Header files and libraries for building a extension library for the rhythmbox.
98
99%description devel -l ja
100
101%prep
102%setup -q
103%patch0 -p1
104tar xjf %{SOURCE101}
105
106%build
107autoreconf -if
108intltoolize --force --copy
109%configure --with-ipod \
110    --with-mtp \
111    --enable-lirc \
112    --disable-python \
113    --disable-vala \
114    --disable-browser-plugin \
115    --disable-static \
116    --enable-browser-plugin \
117    --without-hal
118%__make %{?_smp_mflags}
119
120%install
121%__rm -rf $RPM_BUILD_ROOT
122%__make install DESTDIR=$RPM_BUILD_ROOT
123
124%__rm -f $RPM_BUILD_ROOT%{_libdir}/bonobo/*.{a,la}
125%__rm -f $RPM_BUILD_ROOT%{_libdir}/bonobo/librb-nautilus-context-menu.so
126%__rm -f $RPM_BUILD_ROOT%{_libdir}/lib*.{a,la}
127%__rm -f $RPM_BUILD_ROOT%{_libdir}/rhythmbox/plugins/*.{a,la}
128%__rm -f $RPM_BUILD_ROOT%{_libdir}/rhythmbox/plugins/*/*.{a,la}
129%__rm -f $RPM_BUILD_ROOT%{_libdir}/librhythmbox-core.{a,la}
130%__rm -f $RPM_BUILD_ROOT%{_libdir}/mozilla/plugins/*.{a,la}
131
132## Don't package DLNA/UPnP plugin
133%if !%{enable_DLNA_UPnP}
134%__rm -rf $RPM_BUILD_ROOT%{_libdir}/rhythmbox/plugins/upnp_coherence
135%endif
136
137%find_lang %{name} --all-name --with-gnome
138
139
140# Don't package api docs
141%__rm -rf $RPM_BUILD_ROOT%{_datadir}/gtk-doc/
142
143# And don't package vala
144%__rm -f %{buildroot}%{_libdir}/rhythmbox/plugins/libsample-vala.so \
145        %{buildroot}%{_libdir}/rhythmbox/plugins/sample-vala.rb-plugin
146
147# remove sample plugins
148rm -rf $RPM_BUILD_ROOT/%{_libdir}/%{name}/sample-plugins
149
150%clean
151%__rm -rf $RPM_BUILD_ROOT
152
153%post
154/sbin/ldconfig
155update-desktop-database -q
156touch --no-create %{_datadir}/icons/hicolor
157if [ -x /usr/bin/gtk-update-icon-cache ]; then
158  gtk-update-icon-cache -q %{_datadir}/icons/hicolor
159fi
160
161%postun
162/sbin/ldconfig
163update-desktop-database -q
164touch --no-create %{_datadir}/icons/hicolor
165if [ -x /usr/bin/gtk-update-icon-cache ]; then
166  gtk-update-icon-cache -q %{_datadir}/icons/hicolor
167fi
168glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
169
170%posttrans
171glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
172
173
174%files -f %{name}.lang
175%defattr(-, root, root)
176%doc AUTHORS COPYING ChangeLog README NEWS
177%{_bindir}/*
178%{_libdir}/girepository-1.0/*.typelib
179%{_libdir}/lib*.so.*
180%{_libdir}/mozilla/plugins/librhythmbox-itms-detection-plugin.so
181%{_libdir}/rhythmbox/plugins
182%{_datadir}/applications/rhythmbox.desktop
183%{_datadir}/applications/rhythmbox-device.desktop
184%{_datadir}/dbus-1/services/org.gnome.Rhythmbox3.service
185%{_datadir}/glib-2.0/schemas/org.gnome.rhythmbox.gschema.xml
186%{_datadir}/icons/*
187%{_datadir}/rhythmbox
188%{_mandir}/man1/*
189%{_libexecdir}/rhythmbox-metadata
190
191%files devel
192%defattr(-, root, root)
193%{_includedir}/%{name}/*
194%{_libdir}/*.so
195%{_libdir}/pkgconfig/*.pc
196%{_datadir}/gir-1.0/*.gir
197
198
199%changelog
200* Wed Jul 09 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 3.0.3-2
201- rebuild with new libimobiledevice
202
203* Sat Jun 07 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0.3-1
204- new upstream release
205
206* Sun Mar 30 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0.2-1
207- new upstream release
208
209* Sat Jan 04 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0.1-2
210- rebuild with VineSeed environment
211
212* Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0.1-1
213- new upstream release
214
215* Fri Sep 06 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0-1
216- new upstream release
217- add Patch0 (rhythmbox-3.0-disable-python3.patch)
218
219* Sun Apr 21 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.99.1-1
220- new upstream release
221- add BuildRequies: yelp-tools
222- change BuildRequires: gstreamer1-plugins-base-devel instead of gstreamer-plugins-base-devel
223
224* Sun Mar 24 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.98-2
225- rebuild with libimobiledevice-1.1.5
226
227* Mon Oct 01 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.98-1
228- new upstream release
229- add BuildRequires: grilo-devel, libdmapsharing-devel
230
231* Tue Jun 05 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.97-1
232- new upstream release
233
234* Wed Apr 18 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.96-1
235- new upstream release
236
237* Sat Jan 21 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.95-1
238- new upstream release
239- add BuildRequires: gtk3-devel, libtdb-devel, pygobject3-devel
240- remove BuildRequires: gnome-vfs2-devel, gstreamer-python-devel, libffi-devel, libgnome-media-profiles-devel, libgnomeui-devel, libsexy-devel, popt-devel, python-devel, pygtk2-devel, sqlite3-devel
241
242* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.3-4
243- rebuild with cogl-0.8.0
244
245* Wed Aug 17 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.3-3
246- rebuild with libnotify-0.7
247- change BuildRequires: libmusicbrainz3-devel instead of libmusicbrainz-devel
248- change BuildRequires: libgnome-media-profiles-devel instead of gnome-media-devel
249- add BuildRequires: WebKit3-gtk-devel, libpeas-devel, clutter-gtk-devel, clutter-gst-devel, libmx-devel
250- add Patch0 (rhythmbox-0.13.3-git20110809.patch)
251- add Source101 (rhythmbox-png.tar.bz2)
252
253* Fri Aug 12 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.3-2
254- add BuildRequires: json-glib-devel
255- remove unrecognized configure option (--with-dbus, --with-cd-burning, --with-metadata-helper)
256
257* Sun Jan 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.3-1
258- new upstream release
259- change BuildRequires: gstreamer-python-devel instead of gstreamer-python
260
261* Sat Nov 06 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.2-1
262- new upstream release
263
264* Wed Oct 06 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.1-3
265- rebuild with brasero-2.32.0
266
267* Sun Sep 26 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.1-2
268- rebuild with rpm-4.8.1 for pkg-config file
269
270* Sun Sep 12 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.1-1
271- new upstream release
272- fix %files (add rhythmbox-device.desktop)
273
274* Sun Aug 29 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.0-1
275- new upstream release
276- change BuildRequires: gnome-media-devel instead of gnome-media
277- add devel package
278- drop Patch0
279
280* Sun Mar 14 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.12.8-1
281- new upstream release
282- drop Patch1, Patch2, Patch3
283- change BuildRequires: nautilus-cd-burner -> brasero-devel
284- change Requires: nautilus-cd-burner -> brasero
285- change BuildRequires: hal-devel -> libgudev1-devel
286- change BuildRequires: gnome-keyring-devel -> libgnome-keyring-devel
287- change Requires: gnome-keyring -> libgnome-keyring
288- add configure option (--without-hal)
289
290* Mon Feb 15 2010 Shu KONNO <owa@bg.wakwak.com> 0.12.6-2
291- rebuilt with new environment
292
293* Thu Jan 14 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.12.6-1
294- new upstream release
295  - dropped upstreamed/obsolete patches
296  - added patches applied Fedora development
297
298* Sun Oct 04 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.12.5-1
299- new upstream release
300- added configure options:
301  --disable-vala
302  --disable-browser-plugin
303
304* Thu Jul 30 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.12.2-2
305- added Japanese description
306
307* Thu Jul 02 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.12.2-1
308- new upstream release
309  - dropped rb-disable-power-plugin-by-default.patch
310- added BuildRequires:
311  - libSM-devel
312  - gnome-media
313
314* Wed Jun 10 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.12.1-2
315- rebuild with libgpod-0.7.2
316
317* Sun May 03 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.12.1-1
318- new upstream release
319- corrected License tag
320- dropped rhythmbox-0.11.6-libmtp.patch
321- added BuildRequires:
322  - sqlite3-devel
323  - libffi-devel
324
325* Sat Jan 10 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.11.6-2
326- defined enable_DLNA_UPnP = 0: unpacked DLNA/UPnP plugin
327- applied rhythmbox-0.11.6-libmtp.patch
328- added Requires:
329  - libgpod
330  - libnotify
331  - libsexy
332  - lirc
333  - libmtp
334  - libgnomeui
335  - nautilus-cd-burner
336  - gstreamer-python
337  - gnome-vfs2
338  - gnome-themes
339  - gnome-keyring
340  - python-Coherence, if enable_DLNA_UPnP = 1
341- added BuildRequires:
342  - libnotify-devel
343  - libsexy-devel
344  - lirc
345  - libmtp-devel
346  - gnome-vfs2-devel, instead of gnome-vfs2
347  - gnome-keyring-devel
348- dropped --with-internal-libsexy in configure options
349- added in configure options:
350  --with-mtp --with-libnautilus-burn --enable-lirc --disable-static
351- added %%preun to remove the schema
352
353* Sun Jan 04 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.11.6-1
354- new upstream release
355- changed to --with-metadata-helper in configure options
356- added BuildRequires:
357  - gstreamer-python
358  - intltool >= 0.35.0
359  - popt-devel
360
361* Sat Aug 09 2008 Shu KONNO <owa@bg.wakwak.com> 0.11.2-1vl5
362- added BuildRequires: totem-pl-parser-devel, instead of totem-devel
363- rebuilt with python-2.5.2
364- applied new versioning policy
365- spec in utf-8
366
367* Sun Jan 06 2008 Shu KONNO <owa@bg.wakwak.com> 0.11.2-0vl2
368- rebuilt with libgpod-0.6.0
369
370* Sun Aug 26 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.11.2-0vl1
371- new upstream release
372
373* Wed Jun 27 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.11.1-0vl1
374- new upstream release
375
376* Tue May 29 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.10.0-0vl2
377- rebuilt with new toolchain and libgpod-0.4.2
378- add BuildRequires: dbus-glib-devel
379
380* Sat Apr 28 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.10.0-0vl1
381- new upstream release
382
383* Wed Mar 21 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.8-0vl2
384- rebuilt for VineSeed
385
386* Wed Mar 21 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.8-0vl1
387- new upstream release
388- added --enable-python option to %%configure
389- added Requires: gnome-python
390
391* Sun Jan 21 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.7-0vl1
392- new upstream release
393- built with libsoup 2.2.99
394
395* Thu Nov 23 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.6-0vl4
396- added --with-cd-burner to configure
397- added BuildRequires: libsexy-devel hal-devel libsoup-devel
398
399* Wed Oct 25 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.9.6-0vl3
400- add BuildRequires:
401  - gnome-doc-utils >= 0.3.2
402  - python-devel
403  - pygtk2-devel
404  - check >= 0.8.2
405
406* Tue Oct 24 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.9.6-0vl2
407- rebuild with gnutls-1.4.1
408
409* Sun Oct  1 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.6-0vl1
410- new upstream release
411
412* Mon Jun 19 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.5-0vl1
413- new upstream release
414- run scrollkeeper-update at %post and %postun
415- added BuildRequires: libnotify-devel
416
417* Sun May 14 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.4.1-0vl1
418- new upstream release (dropped patch0)
419- added --without-metadata-helper at configure
420
421* Mon Mar 13 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.3.1-0vl1
422- Initial build for Vine Linux based on FC pacakge
423
424* Fri Mar 03 2006 Ray Strode <rstrode@redhat.com> - 0.9.3.1-2
425- add patch from James "Doc" Livingston to stop a hang
426  for new users (bug 183883)
427
428* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 0.9.3.1-1.2
429- bump again for double-long bug on ppc(64)
430
431* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 0.9.3.1-1.1
432- rebuilt for new gcc4.1 snapshot and glibc changes
433
434* Sat Feb  4 2006 Christopher Aillon <caillon@redhat.com> 0.9.3.1-1
435- Update to 0.9.3.1
436- Use gstreamer (0.10)
437
438* Wed Feb  1 2006 Christopher Aillon <caillon@redhat.com> 0.9.3-2
439- Remove hack for 173869, as its no longer needed.
440
441* Wed Feb  1 2006 Christopher Aillon <caillon@redhat.com> 0.9.3-1
442- 0.9.3
443
444* Wed Feb  1 2006 Christopher Aillon <caillon@redhat.com> 0.9.2.cvs20060201-1
445- Newer CVS snapshot
446
447* Sun Jan 22 2006 Christopher Aillon <caillon@redhat.com> 0.9.2.cvs20060123-1
448- Update to latest CVS
449- Add hack to workaround bug #173869
450
451* Thu Jan 19 2006 Christopher Aillon <caillon@redhat.com> 0.9.2-8
452- Rebuild, now that gstreamer08-plugins has been fixed
453
454* Thu Jan 19 2006 Ray Strode <rstrode@redhat.com> 0.9.2-7
455- bonobo multilib issue (bug 156982)
456
457* Wed Jan 04 2006 John (J5) Palmieri <johnp@redhat.com> 0.9.2-5
458- rebuild with ipod support
459
460* Tue Jan 03 2006 Jesse Keating <jkeating@redhat.com> 0.9.2-4
461- rebuilt again
462
463* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
464- rebuilt
465
466* Mon Dec  5 2005 Matthias Clasen <mclasen@redhat.com>
467- rebuild
468
469* Thu Dec 01 2005 John (J5) Palmieri <johnp@redhat.com>
470- rebuild for new dbus
471
472* Wed Nov 30 2005 Matthias Clasen <mclasen@redhat.com>
473- Update to 0.9.2
474
475* Tue Oct 25 2005 Matthias Clasen <mclasen@redhat.com>
476- Update to 0.9.1
477
478* Fri Sep 02 2005 Colin Walters <walters@redhat.com>
479- Add configure flags --with-bonobo --with-dbus
480- BR nautilus-cd-burner-devel
481- New upstream CVS snapshot for testing
482- Drop IDL file and ui .xml
483- Add dbus service file
484- Drop upstreamed rhythmbox-bluecurve.tar.gz
485- Drop upstreamed rhythmbox-0.8.8-cell-renderer.patch
486
487* Mon Jun 13 2005 Colin Walters <walters@redhat.com> - 0.8.8-3
488- Add Bluecurve-ized icons from Jeff Schroeder (157716)
489- Add rhythmbox-0.8.8-cell-renderer.patch to remove use of custom
490  cell renderer for playback icon (no longer necessary) and
491  changes the rating renderer to work with non-b&w icons
492
493* Mon Mar 14 2005 Colin Walters <walters@redhat.com> - 0.8.8-2
494- Rebuild for GCC4
495
496* Tue Oct 05 2004 Colin Walters <walters@redhat.com> - 0.8.8-1
497- New upstream version
498- Remove librb-nautilus-context-menu.so, killed upstream
499
500* Thu Sep 30 2004 Christopher Aillon <caillon@redhat.com> 0.8.7-2
501- PreReq desktop-file-utils >= 0.9
502
503* Wed Sep 29 2004 Colin Walters <walters@redhat.com> - 0.8.7-1
504- New upstream version
505
506* Sat Sep 18 2004 Colin Walters <walters@redhat.com> - 0.8.6-2
507- Fix postun to use correct syntax, thanks Nils Philippsen
508
509* Sat Sep 18 2004 Colin Walters <walters@redhat.com> - 0.8.6-1
510- New upstream version
511- Call update-desktop-database in post and postun
512
513* Thu Jun 24 2004 Colin Walters <walters@redhat.com> - 0.8.5-1
514- New upstream version
515
516* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
517- rebuilt
518
519* Tue May 18 2004 Colin Walters <walters@redhat.com> - 0.8.4-1
520- New upstream version
521- Remove backported patches
522- Gratuitiously bump various BuildRequires versions
523
524* Mon May 10 2004 Colin Walters <walters@redhat.com> - 0.8.3-4
525- Remove code to unregister GConf schema for now (Closes: #122532)
526
527* Fri May 07 2004 Colin Walters <walters@redhat.com> - 0.8.3-3
528- Apply tiny patch from 0.8 arch to fix GConf key used
529  for initial sorting
530
531* Fri May 07 2004 Colin Walters <walters@redhat.com> - 0.8.3-2
532- Apply patch from 0.8 arch tree to fix a number of memleaks
533
534* Sun May 02 2004 Colin Walters <walters@redhat.com> - 0.8.3-1
535- Update to 0.8.3: fixes showstopper bug with internet radio
536
537* Fri Apr 30 2004 Colin Walters <walters@redhat.com> - 0.8.2-1
538- Update to 0.8.2
539- Fix Source url
540- Add smp_mflags
541- Bump BuildRequires on gstreamer to 0.8.1
542
543* Fri Apr 23 2004 Colin Walters <walters@redhat.com> - 0.8.1-2
544- Uninstall GConf schemas on removal
545
546* Tue Apr 20 2004 Colin Walters <walters@redhat.com> - 0.8.1-1
547- Update to 0.8.1
548
549* Fri Apr 16 2004 Colin Walters <walters@redhat.com> - 0.8.0-1
550- Update to 0.8.0
551
552* Fri Apr 02 2004 Colin Walters <walters@redhat.com> - 0.7.2-1
553- Update to 0.7.2
554
555* Mon Mar 29 2004 Colin Walters <walters@redhat.com> - 0.7.1-2
556- Remove BuildRequires on autoconf and libvorbis-devel
557
558* Mon Mar 29 2004 Colin Walters <walters@redhat.com> - 0.7.1-1
559- New major version - I know we are past major version slush, but
560  this should have been done two weeks ago along with the GNOME 2.6
561  upload.  As upstream author as well, I believe this version is
562  good enough for FC2.
563- Remove --disable-mp3
564- Remove id3, flac variables
565- Remove GStreamer major version patch
566- Fix typo in description
567
568* Tue Mar 16 2004 Jeremy Katz <katzj@redhat.com> - 0.6.8-2
569- rebuild for new gstreamer
570
571* Thu Mar 11 2004 Alex Larsson <alexl@redhat.com> 0.6.8-1
572- update to 0.6.8
573
574* Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
575- rebuilt
576
577* Mon Mar  1 2004 Alexander Larsson <alexl@redhat.com> 0.6.7-1
578- update to 0.6.7
579
580* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
581- rebuilt
582
583* Mon Jan 12 2004 Colin Walters <walters@verbum.org> 0.6.4-1
584- New upstream version
585- Don't re-run the autotools; upstream incorporates newer versions.
586* Tue Oct 28 2003 Jonathan Blandford <jrb@redhat.com> 0.5.4-1
587- new version
588- remove smp_flags
589
590* Fri Oct 24 2003 Jonathan Blandford <jrb@redhat.com> 0.5.3-5
591- remove the initial iradio channels as they all are mp3 based.
592
593* Wed Oct  8 2003 Matthias Saou <matthias@rpmforge.net> 0.5.3-3
594- Fix category from Development/Libraries to Applications/Multimedia.
595- Use bz2 instead of gz as ftp.gnome.org has both, 300k saved in the src.rpm.
596- Fix SCHEMES vs. SCHEMAS in the post scriplet.
597- Added gstreamer-plugins-devel, libvorbis-devel, scrollkeeper and gettext deps.
598- Removed unnecessary date expansion define.
599- Updated description, including mp3 reference removal.
600- Added libid3tag and flac optional support for convenient rebuild.
601- Removed obsolete omf.make and xmldocs.make (included ones are the same now).
602
603* Mon Sep 22 2003 Jonathan Blandford <jrb@redhat.com> 0.5.3-1
604- new version
605- use %{_sysconfdir} instead of /etc
606
607* Wed Jan 22 2003 Tim Powers <timp@redhat.com>
608- rebuilt
609
610* Wed Dec 18 2002 Jonathan Blandford <jrb@redhat.com>
611- gave up on other archs for the Beta
612- new version
613- remove werror and add missing files
614
615* Thu Nov  7 2002 Jeremy Katz <katzj@redhat.com>
616- update to newer cvs snap
617
618* Mon Sep 23 2002 Jeremy Katz <katzj@redhat.com>
619- update to cvs snap
620
621* Sun Sep 22 2002 Jeremy Katz <katzj@redhat.com>
622- use %%(lang)
623
624* Sun Aug 11 2002 Jeremy Katz <katzj@redhat.com>
625- fix post to actually install the schema
626
627* Sat Jun 22 2002 Christian F.K. Schaller <Uraeus@linuxrising.org>
628- Added gconf file
629- Added i18n directory
630
631* Sat Jun 15 2002 Christian F.K. Schaller <Uraeus@linuxrising.org>
632- Updated for new rewrite of rhythmbox, thanks to Jeroen
633
634* Mon Mar 18 2002 Jorn Baayen <jorn@nl.linux.org>
635- removed bonobo dependency
636* Sat Mar 02 2002 Christian Schaller <Uraeus@linuxrising.org>
637- created new spec file
Note: See TracBrowser for help on using the repository browser.