source: projects/specs/trunk/r/rhythmbox/rhythmbox-vl.spec @ 7938

Revision 7938, 19.9 KB checked in by Takemikaduchi, 11 years ago (diff)

GNOME-3.10.1

Line 
1# -*- coding: utf-8-unix -*-
2%define desktop_file_utils_version 0.9
3
4%define enable_DLNA_UPnP 0
5
6Summary: Music Management Application
7Summary(ja): 音楽管理アプリケーション
8Name: rhythmbox
9Version: 3.0.1
10Release: 1%{?_dist_release}
11License: GPL2+ with exceptions and GFDL
12Group: Applications/Multimedia
13URL: http://projects.gnome.org/rhythmbox/
14Source0: http://download.gnome.org/sources/${name}/3.0/%{name}-%{version}.tar.xz
15
16Source101:      rhythmbox-png.tar.bz2
17
18Patch0: rhythmbox-3.0-disable-python3.patch
19
20BuildRoot: %{_tmppath}/%{name}-%{version}-root
21BuildRequires: gtk3-devel
22BuildRequires: avahi-glib-devel >= 0.6
23BuildRequires: brasero-devel >= 2.32.0
24BuildRequires: dbus-glib-devel
25BuildRequires: gstreamer1-plugins-base-devel
26BuildRequires: json-glib-devel
27BuildRequires: libSM-devel
28BuildRequires: libgnome-keyring-devel >= 2.30.0
29BuildRequires: libgpod-devel
30BuildRequires: libgudev1-devel
31BuildRequires: libmusicbrainz3-devel >= 3.0.2
32BuildRequires: libnotify-devel
33BuildRequires: libsoup-devel
34BuildRequires: pygobject3-devel
35BuildRequires: totem-pl-parser-devel
36BuildRequires: WebKit3-gtk-devel
37BuildRequires: libpeas-devel
38BuildRequires: clutter-gtk-devel
39BuildRequires: clutter-gst-devel
40BuildRequires: libmx-devel
41BuildRequires: check-devel
42BuildRequires: libmtp-devel
43BuildRequires: libtdb-devel
44BuildRequires: grilo-devel
45BuildRequires: libdmapsharing-devel
46BuildRequires: lirc
47BuildRequires: gnome-doc-utils >= 0.3.2
48BuildRequires: yelp-tools
49
50Requires: libgpod
51Requires: libnotify
52Requires: lirc
53Requires: libmtp
54Requires: brasero
55Requires: libgnome-keyring
56%if %{enable_DLNA_UPnP}
57Requires: python-Coherence
58%endif
59Requires: desktop-file-utils >= %{desktop_file_utils_version}
60
61# # gstreamer-plugins-ffmpeg and gstreamer-plugins-ugly package provided by
62# # self-build-gstreamer-plugins-ffmpeg and self-build-gstreamer-plugins-ugly,
63# # respectively.
64# Requires: self-build-gstreamer-plugins-ffmpeg
65# Requires: self-build-gstreamer-plugins-ugly
66
67Vendor: Project Vine
68Distribution: Vine Linux
69
70
71%description
72Rhythmbox is an integrated music management application based on the powerful
73GStreamer media framework. It has a number of features, including an easy to
74use music browser, searching and sorting, comprehensive audio format support
75through GStreamer, Internet Radio support, playlists and more.
76
77Rhythmbox is extensible through a plugin system.
78
79%description -l ja
80Rhythmbox は、強力な GStreamer メディアフレームワークに基づいている
81統合音楽管理アプリケーションです。
82見やすいユーザインターフェースを備え、検索や整列ができ、
83GStreamer により数多くの音声フォーマットをサポート、
84インターネットラジオをサポート、プレイリスト管理などの
85数多くの特徴を持ちます。
86
87%package devel
88Summary: Development tools for rhythmbox applications.
89Summary(ja): rhythmbox アプリケーションの開発用ファイル
90Group: Development/Libraries
91Requires: %{name} = %{version}-%{release}
92Requires: pkgconfig
93Requires: libxml2-devel
94Requires: glib2-devel
95Requires: gtk3-devel
96Requires: libsoup-devel
97Requires: totem-pl-parser-devel
98Requires: gstreamer1-devel
99
100%description devel
101Header files and libraries for building a extension library for the rhythmbox.
102
103%description devel -l ja
104
105%prep
106%setup -q
107%patch0 -p1
108tar xjf %{SOURCE101}
109
110%build
111autoreconf -if
112intltoolize --force --copy
113%configure --with-ipod \
114    --with-mtp \
115    --enable-lirc \
116    --disable-python \
117    --disable-vala \
118    --disable-browser-plugin \
119    --disable-static \
120    --enable-browser-plugin \
121    --without-hal
122%__make %{?_smp_mflags}
123
124%install
125%__rm -rf $RPM_BUILD_ROOT
126%__make install DESTDIR=$RPM_BUILD_ROOT
127
128%__rm -f $RPM_BUILD_ROOT%{_libdir}/bonobo/*.{a,la}
129%__rm -f $RPM_BUILD_ROOT%{_libdir}/bonobo/librb-nautilus-context-menu.so
130%__rm -f $RPM_BUILD_ROOT%{_libdir}/lib*.{a,la}
131%__rm -f $RPM_BUILD_ROOT%{_libdir}/rhythmbox/plugins/*.{a,la}
132%__rm -f $RPM_BUILD_ROOT%{_libdir}/rhythmbox/plugins/*/*.{a,la}
133%__rm -f $RPM_BUILD_ROOT%{_libdir}/librhythmbox-core.{a,la}
134%__rm -f $RPM_BUILD_ROOT%{_libdir}/mozilla/plugins/*.{a,la}
135
136## Don't package DLNA/UPnP plugin
137%if !%{enable_DLNA_UPnP}
138%__rm -rf $RPM_BUILD_ROOT%{_libdir}/rhythmbox/plugins/upnp_coherence
139%endif
140
141%find_lang %{name} --all-name --with-gnome
142
143
144# Don't package api docs
145%__rm -rf $RPM_BUILD_ROOT%{_datadir}/gtk-doc/
146
147# And don't package vala
148%__rm -f %{buildroot}%{_libdir}/rhythmbox/plugins/libsample-vala.so \
149        %{buildroot}%{_libdir}/rhythmbox/plugins/sample-vala.rb-plugin
150
151# remove sample plugins
152rm -rf $RPM_BUILD_ROOT/%{_libdir}/%{name}/sample-plugins
153
154%clean
155%__rm -rf $RPM_BUILD_ROOT
156
157%post
158/sbin/ldconfig
159update-desktop-database -q
160touch --no-create %{_datadir}/icons/hicolor
161if [ -x /usr/bin/gtk-update-icon-cache ]; then
162  gtk-update-icon-cache -q %{_datadir}/icons/hicolor
163fi
164
165%postun
166/sbin/ldconfig
167update-desktop-database -q
168touch --no-create %{_datadir}/icons/hicolor
169if [ -x /usr/bin/gtk-update-icon-cache ]; then
170  gtk-update-icon-cache -q %{_datadir}/icons/hicolor
171fi
172glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
173
174%posttrans
175glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
176
177
178%files -f %{name}.lang
179%defattr(-, root, root)
180%doc AUTHORS COPYING ChangeLog README NEWS
181%{_bindir}/*
182%{_libdir}/girepository-1.0/*.typelib
183%{_libdir}/lib*.so.*
184%{_libdir}/mozilla/plugins/librhythmbox-itms-detection-plugin.so
185%{_libdir}/rhythmbox/plugins
186%{_datadir}/applications/rhythmbox.desktop
187%{_datadir}/applications/rhythmbox-device.desktop
188%{_datadir}/dbus-1/services/org.gnome.Rhythmbox3.service
189%{_datadir}/glib-2.0/schemas/org.gnome.rhythmbox.gschema.xml
190%{_datadir}/icons/*
191%{_datadir}/rhythmbox
192%{_mandir}/man1/*
193%{_libexecdir}/rhythmbox-metadata
194
195%files devel
196%defattr(-, root, root)
197%{_includedir}/%{name}/*
198%{_libdir}/*.so
199%{_libdir}/pkgconfig/*.pc
200%{_datadir}/gir-1.0/*.gir
201
202
203%changelog
204* Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0.1-1
205- new upstream release
206
207* Fri Sep 06 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0-1
208- new upstream release
209- add Patch0 (rhythmbox-3.0-disable-python3.patch)
210
211* Sun Apr 21 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.99.1-1
212- new upstream release
213- add BuildRequies: yelp-tools
214- change BuildRequires: gstreamer1-plugins-base-devel instead of gstreamer-plugins-base-devel
215
216* Sun Mar 24 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.98-2
217- rebuild with libimobiledevice-1.1.5
218
219* Mon Oct 01 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.98-1
220- new upstream release
221- add BuildRequires: grilo-devel, libdmapsharing-devel
222
223* Tue Jun 05 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.97-1
224- new upstream release
225
226* Wed Apr 18 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.96-1
227- new upstream release
228
229* Sat Jan 21 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.95-1
230- new upstream release
231- add BuildRequires: gtk3-devel, libtdb-devel, pygobject3-devel
232- remove BuildRequires: gnome-vfs2-devel, gstreamer-python-devel, libffi-devel, libgnome-media-profiles-devel, libgnomeui-devel, libsexy-devel, popt-devel, python-devel, pygtk2-devel, sqlite3-devel
233
234* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.3-4
235- rebuild with cogl-0.8.0
236
237* Wed Aug 17 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.3-3
238- rebuild with libnotify-0.7
239- change BuildRequires: libmusicbrainz3-devel instead of libmusicbrainz-devel
240- change BuildRequires: libgnome-media-profiles-devel instead of gnome-media-devel
241- add BuildRequires: WebKit3-gtk-devel, libpeas-devel, clutter-gtk-devel, clutter-gst-devel, libmx-devel
242- add Patch0 (rhythmbox-0.13.3-git20110809.patch)
243- add Source101 (rhythmbox-png.tar.bz2)
244
245* Fri Aug 12 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.3-2
246- add BuildRequires: json-glib-devel
247- remove unrecognized configure option (--with-dbus, --with-cd-burning, --with-metadata-helper)
248
249* Sun Jan 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.3-1
250- new upstream release
251- change BuildRequires: gstreamer-python-devel instead of gstreamer-python
252
253* Sat Nov 06 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.2-1
254- new upstream release
255
256* Wed Oct 06 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.1-3
257- rebuild with brasero-2.32.0
258
259* Sun Sep 26 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.1-2
260- rebuild with rpm-4.8.1 for pkg-config file
261
262* Sun Sep 12 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.1-1
263- new upstream release
264- fix %files (add rhythmbox-device.desktop)
265
266* Sun Aug 29 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.0-1
267- new upstream release
268- change BuildRequires: gnome-media-devel instead of gnome-media
269- add devel package
270- drop Patch0
271
272* Sun Mar 14 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.12.8-1
273- new upstream release
274- drop Patch1, Patch2, Patch3
275- change BuildRequires: nautilus-cd-burner -> brasero-devel
276- change Requires: nautilus-cd-burner -> brasero
277- change BuildRequires: hal-devel -> libgudev1-devel
278- change BuildRequires: gnome-keyring-devel -> libgnome-keyring-devel
279- change Requires: gnome-keyring -> libgnome-keyring
280- add configure option (--without-hal)
281
282* Mon Feb 15 2010 Shu KONNO <owa@bg.wakwak.com> 0.12.6-2
283- rebuilt with new environment
284
285* Thu Jan 14 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.12.6-1
286- new upstream release
287  - dropped upstreamed/obsolete patches
288  - added patches applied Fedora development
289
290* Sun Oct 04 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.12.5-1
291- new upstream release
292- added configure options:
293  --disable-vala
294  --disable-browser-plugin
295
296* Thu Jul 30 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.12.2-2
297- added Japanese description
298
299* Thu Jul 02 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.12.2-1
300- new upstream release
301  - dropped rb-disable-power-plugin-by-default.patch
302- added BuildRequires:
303  - libSM-devel
304  - gnome-media
305
306* Wed Jun 10 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.12.1-2
307- rebuild with libgpod-0.7.2
308
309* Sun May 03 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.12.1-1
310- new upstream release
311- corrected License tag
312- dropped rhythmbox-0.11.6-libmtp.patch
313- added BuildRequires:
314  - sqlite3-devel
315  - libffi-devel
316
317* Sat Jan 10 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.11.6-2
318- defined enable_DLNA_UPnP = 0: unpacked DLNA/UPnP plugin
319- applied rhythmbox-0.11.6-libmtp.patch
320- added Requires:
321  - libgpod
322  - libnotify
323  - libsexy
324  - lirc
325  - libmtp
326  - libgnomeui
327  - nautilus-cd-burner
328  - gstreamer-python
329  - gnome-vfs2
330  - gnome-themes
331  - gnome-keyring
332  - python-Coherence, if enable_DLNA_UPnP = 1
333- added BuildRequires:
334  - libnotify-devel
335  - libsexy-devel
336  - lirc
337  - libmtp-devel
338  - gnome-vfs2-devel, instead of gnome-vfs2
339  - gnome-keyring-devel
340- dropped --with-internal-libsexy in configure options
341- added in configure options:
342  --with-mtp --with-libnautilus-burn --enable-lirc --disable-static
343- added %%preun to remove the schema
344
345* Sun Jan 04 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.11.6-1
346- new upstream release
347- changed to --with-metadata-helper in configure options
348- added BuildRequires:
349  - gstreamer-python
350  - intltool >= 0.35.0
351  - popt-devel
352
353* Sat Aug 09 2008 Shu KONNO <owa@bg.wakwak.com> 0.11.2-1vl5
354- added BuildRequires: totem-pl-parser-devel, instead of totem-devel
355- rebuilt with python-2.5.2
356- applied new versioning policy
357- spec in utf-8
358
359* Sun Jan 06 2008 Shu KONNO <owa@bg.wakwak.com> 0.11.2-0vl2
360- rebuilt with libgpod-0.6.0
361
362* Sun Aug 26 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.11.2-0vl1
363- new upstream release
364
365* Wed Jun 27 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.11.1-0vl1
366- new upstream release
367
368* Tue May 29 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.10.0-0vl2
369- rebuilt with new toolchain and libgpod-0.4.2
370- add BuildRequires: dbus-glib-devel
371
372* Sat Apr 28 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.10.0-0vl1
373- new upstream release
374
375* Wed Mar 21 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.8-0vl2
376- rebuilt for VineSeed
377
378* Wed Mar 21 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.8-0vl1
379- new upstream release
380- added --enable-python option to %%configure
381- added Requires: gnome-python
382
383* Sun Jan 21 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.7-0vl1
384- new upstream release
385- built with libsoup 2.2.99
386
387* Thu Nov 23 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.6-0vl4
388- added --with-cd-burner to configure
389- added BuildRequires: libsexy-devel hal-devel libsoup-devel
390
391* Wed Oct 25 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.9.6-0vl3
392- add BuildRequires:
393  - gnome-doc-utils >= 0.3.2
394  - python-devel
395  - pygtk2-devel
396  - check >= 0.8.2
397
398* Tue Oct 24 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.9.6-0vl2
399- rebuild with gnutls-1.4.1
400
401* Sun Oct  1 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.6-0vl1
402- new upstream release
403
404* Mon Jun 19 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.5-0vl1
405- new upstream release
406- run scrollkeeper-update at %post and %postun
407- added BuildRequires: libnotify-devel
408
409* Sun May 14 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.4.1-0vl1
410- new upstream release (dropped patch0)
411- added --without-metadata-helper at configure
412
413* Mon Mar 13 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.3.1-0vl1
414- Initial build for Vine Linux based on FC pacakge
415
416* Fri Mar 03 2006 Ray Strode <rstrode@redhat.com> - 0.9.3.1-2
417- add patch from James "Doc" Livingston to stop a hang
418  for new users (bug 183883)
419
420* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 0.9.3.1-1.2
421- bump again for double-long bug on ppc(64)
422
423* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 0.9.3.1-1.1
424- rebuilt for new gcc4.1 snapshot and glibc changes
425
426* Sat Feb  4 2006 Christopher Aillon <caillon@redhat.com> 0.9.3.1-1
427- Update to 0.9.3.1
428- Use gstreamer (0.10)
429
430* Wed Feb  1 2006 Christopher Aillon <caillon@redhat.com> 0.9.3-2
431- Remove hack for 173869, as its no longer needed.
432
433* Wed Feb  1 2006 Christopher Aillon <caillon@redhat.com> 0.9.3-1
434- 0.9.3
435
436* Wed Feb  1 2006 Christopher Aillon <caillon@redhat.com> 0.9.2.cvs20060201-1
437- Newer CVS snapshot
438
439* Sun Jan 22 2006 Christopher Aillon <caillon@redhat.com> 0.9.2.cvs20060123-1
440- Update to latest CVS
441- Add hack to workaround bug #173869
442
443* Thu Jan 19 2006 Christopher Aillon <caillon@redhat.com> 0.9.2-8
444- Rebuild, now that gstreamer08-plugins has been fixed
445
446* Thu Jan 19 2006 Ray Strode <rstrode@redhat.com> 0.9.2-7
447- bonobo multilib issue (bug 156982)
448
449* Wed Jan 04 2006 John (J5) Palmieri <johnp@redhat.com> 0.9.2-5
450- rebuild with ipod support
451
452* Tue Jan 03 2006 Jesse Keating <jkeating@redhat.com> 0.9.2-4
453- rebuilt again
454
455* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
456- rebuilt
457
458* Mon Dec  5 2005 Matthias Clasen <mclasen@redhat.com>
459- rebuild
460
461* Thu Dec 01 2005 John (J5) Palmieri <johnp@redhat.com>
462- rebuild for new dbus
463
464* Wed Nov 30 2005 Matthias Clasen <mclasen@redhat.com>
465- Update to 0.9.2
466
467* Tue Oct 25 2005 Matthias Clasen <mclasen@redhat.com>
468- Update to 0.9.1
469
470* Fri Sep 02 2005 Colin Walters <walters@redhat.com>
471- Add configure flags --with-bonobo --with-dbus
472- BR nautilus-cd-burner-devel
473- New upstream CVS snapshot for testing
474- Drop IDL file and ui .xml
475- Add dbus service file
476- Drop upstreamed rhythmbox-bluecurve.tar.gz
477- Drop upstreamed rhythmbox-0.8.8-cell-renderer.patch
478
479* Mon Jun 13 2005 Colin Walters <walters@redhat.com> - 0.8.8-3
480- Add Bluecurve-ized icons from Jeff Schroeder (157716)
481- Add rhythmbox-0.8.8-cell-renderer.patch to remove use of custom
482  cell renderer for playback icon (no longer necessary) and
483  changes the rating renderer to work with non-b&w icons
484
485* Mon Mar 14 2005 Colin Walters <walters@redhat.com> - 0.8.8-2
486- Rebuild for GCC4
487
488* Tue Oct 05 2004 Colin Walters <walters@redhat.com> - 0.8.8-1
489- New upstream version
490- Remove librb-nautilus-context-menu.so, killed upstream
491
492* Thu Sep 30 2004 Christopher Aillon <caillon@redhat.com> 0.8.7-2
493- PreReq desktop-file-utils >= 0.9
494
495* Wed Sep 29 2004 Colin Walters <walters@redhat.com> - 0.8.7-1
496- New upstream version
497
498* Sat Sep 18 2004 Colin Walters <walters@redhat.com> - 0.8.6-2
499- Fix postun to use correct syntax, thanks Nils Philippsen
500
501* Sat Sep 18 2004 Colin Walters <walters@redhat.com> - 0.8.6-1
502- New upstream version
503- Call update-desktop-database in post and postun
504
505* Thu Jun 24 2004 Colin Walters <walters@redhat.com> - 0.8.5-1
506- New upstream version
507
508* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
509- rebuilt
510
511* Tue May 18 2004 Colin Walters <walters@redhat.com> - 0.8.4-1
512- New upstream version
513- Remove backported patches
514- Gratuitiously bump various BuildRequires versions
515
516* Mon May 10 2004 Colin Walters <walters@redhat.com> - 0.8.3-4
517- Remove code to unregister GConf schema for now (Closes: #122532)
518
519* Fri May 07 2004 Colin Walters <walters@redhat.com> - 0.8.3-3
520- Apply tiny patch from 0.8 arch to fix GConf key used
521  for initial sorting
522
523* Fri May 07 2004 Colin Walters <walters@redhat.com> - 0.8.3-2
524- Apply patch from 0.8 arch tree to fix a number of memleaks
525
526* Sun May 02 2004 Colin Walters <walters@redhat.com> - 0.8.3-1
527- Update to 0.8.3: fixes showstopper bug with internet radio
528
529* Fri Apr 30 2004 Colin Walters <walters@redhat.com> - 0.8.2-1
530- Update to 0.8.2
531- Fix Source url
532- Add smp_mflags
533- Bump BuildRequires on gstreamer to 0.8.1
534
535* Fri Apr 23 2004 Colin Walters <walters@redhat.com> - 0.8.1-2
536- Uninstall GConf schemas on removal
537
538* Tue Apr 20 2004 Colin Walters <walters@redhat.com> - 0.8.1-1
539- Update to 0.8.1
540
541* Fri Apr 16 2004 Colin Walters <walters@redhat.com> - 0.8.0-1
542- Update to 0.8.0
543
544* Fri Apr 02 2004 Colin Walters <walters@redhat.com> - 0.7.2-1
545- Update to 0.7.2
546
547* Mon Mar 29 2004 Colin Walters <walters@redhat.com> - 0.7.1-2
548- Remove BuildRequires on autoconf and libvorbis-devel
549
550* Mon Mar 29 2004 Colin Walters <walters@redhat.com> - 0.7.1-1
551- New major version - I know we are past major version slush, but
552  this should have been done two weeks ago along with the GNOME 2.6
553  upload.  As upstream author as well, I believe this version is
554  good enough for FC2.
555- Remove --disable-mp3
556- Remove id3, flac variables
557- Remove GStreamer major version patch
558- Fix typo in description
559
560* Tue Mar 16 2004 Jeremy Katz <katzj@redhat.com> - 0.6.8-2
561- rebuild for new gstreamer
562
563* Thu Mar 11 2004 Alex Larsson <alexl@redhat.com> 0.6.8-1
564- update to 0.6.8
565
566* Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
567- rebuilt
568
569* Mon Mar  1 2004 Alexander Larsson <alexl@redhat.com> 0.6.7-1
570- update to 0.6.7
571
572* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
573- rebuilt
574
575* Mon Jan 12 2004 Colin Walters <walters@verbum.org> 0.6.4-1
576- New upstream version
577- Don't re-run the autotools; upstream incorporates newer versions.
578* Tue Oct 28 2003 Jonathan Blandford <jrb@redhat.com> 0.5.4-1
579- new version
580- remove smp_flags
581
582* Fri Oct 24 2003 Jonathan Blandford <jrb@redhat.com> 0.5.3-5
583- remove the initial iradio channels as they all are mp3 based.
584
585* Wed Oct  8 2003 Matthias Saou <matthias@rpmforge.net> 0.5.3-3
586- Fix category from Development/Libraries to Applications/Multimedia.
587- Use bz2 instead of gz as ftp.gnome.org has both, 300k saved in the src.rpm.
588- Fix SCHEMES vs. SCHEMAS in the post scriplet.
589- Added gstreamer-plugins-devel, libvorbis-devel, scrollkeeper and gettext deps.
590- Removed unnecessary date expansion define.
591- Updated description, including mp3 reference removal.
592- Added libid3tag and flac optional support for convenient rebuild.
593- Removed obsolete omf.make and xmldocs.make (included ones are the same now).
594
595* Mon Sep 22 2003 Jonathan Blandford <jrb@redhat.com> 0.5.3-1
596- new version
597- use %{_sysconfdir} instead of /etc
598
599* Wed Jan 22 2003 Tim Powers <timp@redhat.com>
600- rebuilt
601
602* Wed Dec 18 2002 Jonathan Blandford <jrb@redhat.com>
603- gave up on other archs for the Beta
604- new version
605- remove werror and add missing files
606
607* Thu Nov  7 2002 Jeremy Katz <katzj@redhat.com>
608- update to newer cvs snap
609
610* Mon Sep 23 2002 Jeremy Katz <katzj@redhat.com>
611- update to cvs snap
612
613* Sun Sep 22 2002 Jeremy Katz <katzj@redhat.com>
614- use %%(lang)
615
616* Sun Aug 11 2002 Jeremy Katz <katzj@redhat.com>
617- fix post to actually install the schema
618
619* Sat Jun 22 2002 Christian F.K. Schaller <Uraeus@linuxrising.org>
620- Added gconf file
621- Added i18n directory
622
623* Sat Jun 15 2002 Christian F.K. Schaller <Uraeus@linuxrising.org>
624- Updated for new rewrite of rhythmbox, thanks to Jeroen
625
626* Mon Mar 18 2002 Jorn Baayen <jorn@nl.linux.org>
627- removed bonobo dependency
628* Sat Mar 02 2002 Christian Schaller <Uraeus@linuxrising.org>
629- created new spec file
Note: See TracBrowser for help on using the repository browser.