source: projects/specs/trunk/r/rhythmbox/rhythmbox-vl.spec @ 7786

Revision 7786, 19.8 KB checked in by Takemikaduchi, 11 years ago (diff)

new upstream release

Line 
1# -*- coding: utf-8-unix -*-
2%define desktop_file_utils_version 0.9
3
4%define enable_DLNA_UPnP 0
5
6Summary: Music Management Application
7Summary(ja): 音楽管理アプリケーション
8Name: rhythmbox
9Version: 3.0
10Release: 1%{?_dist_release}
11License: GPL2+ with exceptions and GFDL
12Group: Applications/Multimedia
13URL: http://projects.gnome.org/rhythmbox/
14Source0: http://download.gnome.org/sources/${name}/3.0/%{name}-%{version}.tar.xz
15
16Source101:      rhythmbox-png.tar.bz2
17
18Patch0: rhythmbox-3.0-disable-python3.patch
19
20BuildRoot: %{_tmppath}/%{name}-%{version}-root
21BuildRequires: gtk3-devel
22BuildRequires: avahi-glib-devel >= 0.6
23BuildRequires: brasero-devel >= 2.32.0
24BuildRequires: dbus-glib-devel
25BuildRequires: gstreamer1-plugins-base-devel
26BuildRequires: json-glib-devel
27BuildRequires: libSM-devel
28BuildRequires: libgnome-keyring-devel >= 2.30.0
29BuildRequires: libgpod-devel
30BuildRequires: libgudev1-devel
31BuildRequires: libmusicbrainz3-devel >= 3.0.2
32BuildRequires: libnotify-devel
33BuildRequires: libsoup-devel
34BuildRequires: pygobject3-devel
35BuildRequires: totem-pl-parser-devel
36BuildRequires: WebKit3-gtk-devel
37BuildRequires: libpeas-devel
38BuildRequires: clutter-gtk-devel
39BuildRequires: clutter-gst-devel
40BuildRequires: libmx-devel
41BuildRequires: check-devel
42BuildRequires: libmtp-devel
43BuildRequires: libtdb-devel
44BuildRequires: grilo-devel
45BuildRequires: libdmapsharing-devel
46BuildRequires: lirc
47BuildRequires: gnome-doc-utils >= 0.3.2
48BuildRequires: yelp-tools
49
50Requires: libgpod
51Requires: libnotify
52Requires: lirc
53Requires: libmtp
54Requires: brasero
55Requires: libgnome-keyring
56%if %{enable_DLNA_UPnP}
57Requires: python-Coherence
58%endif
59Requires: desktop-file-utils >= %{desktop_file_utils_version}
60
61# # gstreamer-plugins-ffmpeg and gstreamer-plugins-ugly package provided by
62# # self-build-gstreamer-plugins-ffmpeg and self-build-gstreamer-plugins-ugly,
63# # respectively.
64# Requires: self-build-gstreamer-plugins-ffmpeg
65# Requires: self-build-gstreamer-plugins-ugly
66
67Vendor: Project Vine
68Distribution: Vine Linux
69
70
71%description
72Rhythmbox is an integrated music management application based on the powerful
73GStreamer media framework. It has a number of features, including an easy to
74use music browser, searching and sorting, comprehensive audio format support
75through GStreamer, Internet Radio support, playlists and more.
76
77Rhythmbox is extensible through a plugin system.
78
79%description -l ja
80Rhythmbox は、強力な GStreamer メディアフレームワークに基づいている
81統合音楽管理アプリケーションです。
82見やすいユーザインターフェースを備え、検索や整列ができ、
83GStreamer により数多くの音声フォーマットをサポート、
84インターネットラジオをサポート、プレイリスト管理などの
85数多くの特徴を持ちます。
86
87%package devel
88Summary: Development tools for rhythmbox applications.
89Summary(ja): rhythmbox アプリケーションの開発用ファイル
90Group: Development/Libraries
91Requires: %{name} = %{version}-%{release}
92Requires: pkgconfig
93Requires: libxml2-devel
94Requires: glib2-devel
95Requires: gtk3-devel
96Requires: libsoup-devel
97Requires: totem-pl-parser-devel
98Requires: gstreamer1-devel
99
100%description devel
101Header files and libraries for building a extension library for the rhythmbox.
102
103%description devel -l ja
104
105%prep
106%setup -q
107%patch0 -p1
108tar xjf %{SOURCE101}
109
110%build
111autoreconf -if
112intltoolize --force --copy
113%configure --with-ipod \
114    --with-mtp \
115    --enable-lirc \
116    --disable-python \
117    --disable-vala \
118    --disable-browser-plugin \
119    --disable-static \
120    --enable-browser-plugin \
121    --without-hal
122%__make %{?_smp_mflags}
123
124%install
125%__rm -rf $RPM_BUILD_ROOT
126%__make install DESTDIR=$RPM_BUILD_ROOT
127
128%__rm -f $RPM_BUILD_ROOT%{_libdir}/bonobo/*.{a,la}
129%__rm -f $RPM_BUILD_ROOT%{_libdir}/bonobo/librb-nautilus-context-menu.so
130%__rm -f $RPM_BUILD_ROOT%{_libdir}/lib*.{a,la}
131%__rm -f $RPM_BUILD_ROOT%{_libdir}/rhythmbox/plugins/*.{a,la}
132%__rm -f $RPM_BUILD_ROOT%{_libdir}/rhythmbox/plugins/*/*.{a,la}
133%__rm -f $RPM_BUILD_ROOT%{_libdir}/librhythmbox-core.{a,la}
134%__rm -f $RPM_BUILD_ROOT%{_libdir}/mozilla/plugins/*.{a,la}
135
136## Don't package DLNA/UPnP plugin
137%if !%{enable_DLNA_UPnP}
138%__rm -rf $RPM_BUILD_ROOT%{_libdir}/rhythmbox/plugins/upnp_coherence
139%endif
140
141%find_lang %{name} --all-name --with-gnome
142
143
144# Don't package api docs
145%__rm -rf $RPM_BUILD_ROOT%{_datadir}/gtk-doc/
146
147# And don't package vala
148%__rm -f %{buildroot}%{_libdir}/rhythmbox/plugins/libsample-vala.so \
149        %{buildroot}%{_libdir}/rhythmbox/plugins/sample-vala.rb-plugin
150
151# remove sample plugins
152rm -rf $RPM_BUILD_ROOT/%{_libdir}/%{name}/sample-plugins
153
154%clean
155%__rm -rf $RPM_BUILD_ROOT
156
157%post
158/sbin/ldconfig
159update-desktop-database -q
160touch --no-create %{_datadir}/icons/hicolor
161if [ -x /usr/bin/gtk-update-icon-cache ]; then
162  gtk-update-icon-cache -q %{_datadir}/icons/hicolor
163fi
164
165%postun
166/sbin/ldconfig
167update-desktop-database -q
168touch --no-create %{_datadir}/icons/hicolor
169if [ -x /usr/bin/gtk-update-icon-cache ]; then
170  gtk-update-icon-cache -q %{_datadir}/icons/hicolor
171fi
172glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
173
174%posttrans
175glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
176
177
178%files -f %{name}.lang
179%defattr(-, root, root)
180%doc AUTHORS COPYING ChangeLog README NEWS
181%{_bindir}/*
182%{_libdir}/girepository-1.0/*.typelib
183%{_libdir}/lib*.so.*
184%{_libdir}/mozilla/plugins/librhythmbox-itms-detection-plugin.so
185%{_libdir}/rhythmbox/plugins
186%{_datadir}/applications/rhythmbox.desktop
187%{_datadir}/applications/rhythmbox-device.desktop
188%{_datadir}/dbus-1/services/org.gnome.Rhythmbox3.service
189%{_datadir}/glib-2.0/schemas/org.gnome.rhythmbox.gschema.xml
190%{_datadir}/icons/*
191%{_datadir}/rhythmbox
192%{_mandir}/man1/*
193%{_libexecdir}/rhythmbox-metadata
194
195%files devel
196%defattr(-, root, root)
197%{_includedir}/%{name}/*
198%{_libdir}/*.so
199%{_libdir}/pkgconfig/*.pc
200%{_datadir}/gir-1.0/*.gir
201
202
203%changelog
204* Fri Sep 06 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0-1
205- new upstream release
206- add Patch0 (rhythmbox-3.0-disable-python3.patch)
207
208* Sun Apr 21 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.99.1-1
209- new upstream release
210- add BuildRequies: yelp-tools
211- change BuildRequires: gstreamer1-plugins-base-devel instead of gstreamer-plugins-base-devel
212
213* Sun Mar 24 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.98-2
214- rebuild with libimobiledevice-1.1.5
215
216* Mon Oct 01 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.98-1
217- new upstream release
218- add BuildRequires: grilo-devel, libdmapsharing-devel
219
220* Tue Jun 05 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.97-1
221- new upstream release
222
223* Wed Apr 18 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.96-1
224- new upstream release
225
226* Sat Jan 21 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.95-1
227- new upstream release
228- add BuildRequires: gtk3-devel, libtdb-devel, pygobject3-devel
229- remove BuildRequires: gnome-vfs2-devel, gstreamer-python-devel, libffi-devel, libgnome-media-profiles-devel, libgnomeui-devel, libsexy-devel, popt-devel, python-devel, pygtk2-devel, sqlite3-devel
230
231* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.3-4
232- rebuild with cogl-0.8.0
233
234* Wed Aug 17 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.3-3
235- rebuild with libnotify-0.7
236- change BuildRequires: libmusicbrainz3-devel instead of libmusicbrainz-devel
237- change BuildRequires: libgnome-media-profiles-devel instead of gnome-media-devel
238- add BuildRequires: WebKit3-gtk-devel, libpeas-devel, clutter-gtk-devel, clutter-gst-devel, libmx-devel
239- add Patch0 (rhythmbox-0.13.3-git20110809.patch)
240- add Source101 (rhythmbox-png.tar.bz2)
241
242* Fri Aug 12 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.3-2
243- add BuildRequires: json-glib-devel
244- remove unrecognized configure option (--with-dbus, --with-cd-burning, --with-metadata-helper)
245
246* Sun Jan 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.3-1
247- new upstream release
248- change BuildRequires: gstreamer-python-devel instead of gstreamer-python
249
250* Sat Nov 06 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.2-1
251- new upstream release
252
253* Wed Oct 06 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.1-3
254- rebuild with brasero-2.32.0
255
256* Sun Sep 26 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.1-2
257- rebuild with rpm-4.8.1 for pkg-config file
258
259* Sun Sep 12 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.1-1
260- new upstream release
261- fix %files (add rhythmbox-device.desktop)
262
263* Sun Aug 29 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.0-1
264- new upstream release
265- change BuildRequires: gnome-media-devel instead of gnome-media
266- add devel package
267- drop Patch0
268
269* Sun Mar 14 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.12.8-1
270- new upstream release
271- drop Patch1, Patch2, Patch3
272- change BuildRequires: nautilus-cd-burner -> brasero-devel
273- change Requires: nautilus-cd-burner -> brasero
274- change BuildRequires: hal-devel -> libgudev1-devel
275- change BuildRequires: gnome-keyring-devel -> libgnome-keyring-devel
276- change Requires: gnome-keyring -> libgnome-keyring
277- add configure option (--without-hal)
278
279* Mon Feb 15 2010 Shu KONNO <owa@bg.wakwak.com> 0.12.6-2
280- rebuilt with new environment
281
282* Thu Jan 14 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.12.6-1
283- new upstream release
284  - dropped upstreamed/obsolete patches
285  - added patches applied Fedora development
286
287* Sun Oct 04 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.12.5-1
288- new upstream release
289- added configure options:
290  --disable-vala
291  --disable-browser-plugin
292
293* Thu Jul 30 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.12.2-2
294- added Japanese description
295
296* Thu Jul 02 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.12.2-1
297- new upstream release
298  - dropped rb-disable-power-plugin-by-default.patch
299- added BuildRequires:
300  - libSM-devel
301  - gnome-media
302
303* Wed Jun 10 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.12.1-2
304- rebuild with libgpod-0.7.2
305
306* Sun May 03 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.12.1-1
307- new upstream release
308- corrected License tag
309- dropped rhythmbox-0.11.6-libmtp.patch
310- added BuildRequires:
311  - sqlite3-devel
312  - libffi-devel
313
314* Sat Jan 10 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.11.6-2
315- defined enable_DLNA_UPnP = 0: unpacked DLNA/UPnP plugin
316- applied rhythmbox-0.11.6-libmtp.patch
317- added Requires:
318  - libgpod
319  - libnotify
320  - libsexy
321  - lirc
322  - libmtp
323  - libgnomeui
324  - nautilus-cd-burner
325  - gstreamer-python
326  - gnome-vfs2
327  - gnome-themes
328  - gnome-keyring
329  - python-Coherence, if enable_DLNA_UPnP = 1
330- added BuildRequires:
331  - libnotify-devel
332  - libsexy-devel
333  - lirc
334  - libmtp-devel
335  - gnome-vfs2-devel, instead of gnome-vfs2
336  - gnome-keyring-devel
337- dropped --with-internal-libsexy in configure options
338- added in configure options:
339  --with-mtp --with-libnautilus-burn --enable-lirc --disable-static
340- added %%preun to remove the schema
341
342* Sun Jan 04 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.11.6-1
343- new upstream release
344- changed to --with-metadata-helper in configure options
345- added BuildRequires:
346  - gstreamer-python
347  - intltool >= 0.35.0
348  - popt-devel
349
350* Sat Aug 09 2008 Shu KONNO <owa@bg.wakwak.com> 0.11.2-1vl5
351- added BuildRequires: totem-pl-parser-devel, instead of totem-devel
352- rebuilt with python-2.5.2
353- applied new versioning policy
354- spec in utf-8
355
356* Sun Jan 06 2008 Shu KONNO <owa@bg.wakwak.com> 0.11.2-0vl2
357- rebuilt with libgpod-0.6.0
358
359* Sun Aug 26 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.11.2-0vl1
360- new upstream release
361
362* Wed Jun 27 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.11.1-0vl1
363- new upstream release
364
365* Tue May 29 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.10.0-0vl2
366- rebuilt with new toolchain and libgpod-0.4.2
367- add BuildRequires: dbus-glib-devel
368
369* Sat Apr 28 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.10.0-0vl1
370- new upstream release
371
372* Wed Mar 21 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.8-0vl2
373- rebuilt for VineSeed
374
375* Wed Mar 21 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.8-0vl1
376- new upstream release
377- added --enable-python option to %%configure
378- added Requires: gnome-python
379
380* Sun Jan 21 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.7-0vl1
381- new upstream release
382- built with libsoup 2.2.99
383
384* Thu Nov 23 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.6-0vl4
385- added --with-cd-burner to configure
386- added BuildRequires: libsexy-devel hal-devel libsoup-devel
387
388* Wed Oct 25 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.9.6-0vl3
389- add BuildRequires:
390  - gnome-doc-utils >= 0.3.2
391  - python-devel
392  - pygtk2-devel
393  - check >= 0.8.2
394
395* Tue Oct 24 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.9.6-0vl2
396- rebuild with gnutls-1.4.1
397
398* Sun Oct  1 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.6-0vl1
399- new upstream release
400
401* Mon Jun 19 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.5-0vl1
402- new upstream release
403- run scrollkeeper-update at %post and %postun
404- added BuildRequires: libnotify-devel
405
406* Sun May 14 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.4.1-0vl1
407- new upstream release (dropped patch0)
408- added --without-metadata-helper at configure
409
410* Mon Mar 13 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.3.1-0vl1
411- Initial build for Vine Linux based on FC pacakge
412
413* Fri Mar 03 2006 Ray Strode <rstrode@redhat.com> - 0.9.3.1-2
414- add patch from James "Doc" Livingston to stop a hang
415  for new users (bug 183883)
416
417* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 0.9.3.1-1.2
418- bump again for double-long bug on ppc(64)
419
420* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 0.9.3.1-1.1
421- rebuilt for new gcc4.1 snapshot and glibc changes
422
423* Sat Feb  4 2006 Christopher Aillon <caillon@redhat.com> 0.9.3.1-1
424- Update to 0.9.3.1
425- Use gstreamer (0.10)
426
427* Wed Feb  1 2006 Christopher Aillon <caillon@redhat.com> 0.9.3-2
428- Remove hack for 173869, as its no longer needed.
429
430* Wed Feb  1 2006 Christopher Aillon <caillon@redhat.com> 0.9.3-1
431- 0.9.3
432
433* Wed Feb  1 2006 Christopher Aillon <caillon@redhat.com> 0.9.2.cvs20060201-1
434- Newer CVS snapshot
435
436* Sun Jan 22 2006 Christopher Aillon <caillon@redhat.com> 0.9.2.cvs20060123-1
437- Update to latest CVS
438- Add hack to workaround bug #173869
439
440* Thu Jan 19 2006 Christopher Aillon <caillon@redhat.com> 0.9.2-8
441- Rebuild, now that gstreamer08-plugins has been fixed
442
443* Thu Jan 19 2006 Ray Strode <rstrode@redhat.com> 0.9.2-7
444- bonobo multilib issue (bug 156982)
445
446* Wed Jan 04 2006 John (J5) Palmieri <johnp@redhat.com> 0.9.2-5
447- rebuild with ipod support
448
449* Tue Jan 03 2006 Jesse Keating <jkeating@redhat.com> 0.9.2-4
450- rebuilt again
451
452* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
453- rebuilt
454
455* Mon Dec  5 2005 Matthias Clasen <mclasen@redhat.com>
456- rebuild
457
458* Thu Dec 01 2005 John (J5) Palmieri <johnp@redhat.com>
459- rebuild for new dbus
460
461* Wed Nov 30 2005 Matthias Clasen <mclasen@redhat.com>
462- Update to 0.9.2
463
464* Tue Oct 25 2005 Matthias Clasen <mclasen@redhat.com>
465- Update to 0.9.1
466
467* Fri Sep 02 2005 Colin Walters <walters@redhat.com>
468- Add configure flags --with-bonobo --with-dbus
469- BR nautilus-cd-burner-devel
470- New upstream CVS snapshot for testing
471- Drop IDL file and ui .xml
472- Add dbus service file
473- Drop upstreamed rhythmbox-bluecurve.tar.gz
474- Drop upstreamed rhythmbox-0.8.8-cell-renderer.patch
475
476* Mon Jun 13 2005 Colin Walters <walters@redhat.com> - 0.8.8-3
477- Add Bluecurve-ized icons from Jeff Schroeder (157716)
478- Add rhythmbox-0.8.8-cell-renderer.patch to remove use of custom
479  cell renderer for playback icon (no longer necessary) and
480  changes the rating renderer to work with non-b&w icons
481
482* Mon Mar 14 2005 Colin Walters <walters@redhat.com> - 0.8.8-2
483- Rebuild for GCC4
484
485* Tue Oct 05 2004 Colin Walters <walters@redhat.com> - 0.8.8-1
486- New upstream version
487- Remove librb-nautilus-context-menu.so, killed upstream
488
489* Thu Sep 30 2004 Christopher Aillon <caillon@redhat.com> 0.8.7-2
490- PreReq desktop-file-utils >= 0.9
491
492* Wed Sep 29 2004 Colin Walters <walters@redhat.com> - 0.8.7-1
493- New upstream version
494
495* Sat Sep 18 2004 Colin Walters <walters@redhat.com> - 0.8.6-2
496- Fix postun to use correct syntax, thanks Nils Philippsen
497
498* Sat Sep 18 2004 Colin Walters <walters@redhat.com> - 0.8.6-1
499- New upstream version
500- Call update-desktop-database in post and postun
501
502* Thu Jun 24 2004 Colin Walters <walters@redhat.com> - 0.8.5-1
503- New upstream version
504
505* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
506- rebuilt
507
508* Tue May 18 2004 Colin Walters <walters@redhat.com> - 0.8.4-1
509- New upstream version
510- Remove backported patches
511- Gratuitiously bump various BuildRequires versions
512
513* Mon May 10 2004 Colin Walters <walters@redhat.com> - 0.8.3-4
514- Remove code to unregister GConf schema for now (Closes: #122532)
515
516* Fri May 07 2004 Colin Walters <walters@redhat.com> - 0.8.3-3
517- Apply tiny patch from 0.8 arch to fix GConf key used
518  for initial sorting
519
520* Fri May 07 2004 Colin Walters <walters@redhat.com> - 0.8.3-2
521- Apply patch from 0.8 arch tree to fix a number of memleaks
522
523* Sun May 02 2004 Colin Walters <walters@redhat.com> - 0.8.3-1
524- Update to 0.8.3: fixes showstopper bug with internet radio
525
526* Fri Apr 30 2004 Colin Walters <walters@redhat.com> - 0.8.2-1
527- Update to 0.8.2
528- Fix Source url
529- Add smp_mflags
530- Bump BuildRequires on gstreamer to 0.8.1
531
532* Fri Apr 23 2004 Colin Walters <walters@redhat.com> - 0.8.1-2
533- Uninstall GConf schemas on removal
534
535* Tue Apr 20 2004 Colin Walters <walters@redhat.com> - 0.8.1-1
536- Update to 0.8.1
537
538* Fri Apr 16 2004 Colin Walters <walters@redhat.com> - 0.8.0-1
539- Update to 0.8.0
540
541* Fri Apr 02 2004 Colin Walters <walters@redhat.com> - 0.7.2-1
542- Update to 0.7.2
543
544* Mon Mar 29 2004 Colin Walters <walters@redhat.com> - 0.7.1-2
545- Remove BuildRequires on autoconf and libvorbis-devel
546
547* Mon Mar 29 2004 Colin Walters <walters@redhat.com> - 0.7.1-1
548- New major version - I know we are past major version slush, but
549  this should have been done two weeks ago along with the GNOME 2.6
550  upload.  As upstream author as well, I believe this version is
551  good enough for FC2.
552- Remove --disable-mp3
553- Remove id3, flac variables
554- Remove GStreamer major version patch
555- Fix typo in description
556
557* Tue Mar 16 2004 Jeremy Katz <katzj@redhat.com> - 0.6.8-2
558- rebuild for new gstreamer
559
560* Thu Mar 11 2004 Alex Larsson <alexl@redhat.com> 0.6.8-1
561- update to 0.6.8
562
563* Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
564- rebuilt
565
566* Mon Mar  1 2004 Alexander Larsson <alexl@redhat.com> 0.6.7-1
567- update to 0.6.7
568
569* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
570- rebuilt
571
572* Mon Jan 12 2004 Colin Walters <walters@verbum.org> 0.6.4-1
573- New upstream version
574- Don't re-run the autotools; upstream incorporates newer versions.
575* Tue Oct 28 2003 Jonathan Blandford <jrb@redhat.com> 0.5.4-1
576- new version
577- remove smp_flags
578
579* Fri Oct 24 2003 Jonathan Blandford <jrb@redhat.com> 0.5.3-5
580- remove the initial iradio channels as they all are mp3 based.
581
582* Wed Oct  8 2003 Matthias Saou <matthias@rpmforge.net> 0.5.3-3
583- Fix category from Development/Libraries to Applications/Multimedia.
584- Use bz2 instead of gz as ftp.gnome.org has both, 300k saved in the src.rpm.
585- Fix SCHEMES vs. SCHEMAS in the post scriplet.
586- Added gstreamer-plugins-devel, libvorbis-devel, scrollkeeper and gettext deps.
587- Removed unnecessary date expansion define.
588- Updated description, including mp3 reference removal.
589- Added libid3tag and flac optional support for convenient rebuild.
590- Removed obsolete omf.make and xmldocs.make (included ones are the same now).
591
592* Mon Sep 22 2003 Jonathan Blandford <jrb@redhat.com> 0.5.3-1
593- new version
594- use %{_sysconfdir} instead of /etc
595
596* Wed Jan 22 2003 Tim Powers <timp@redhat.com>
597- rebuilt
598
599* Wed Dec 18 2002 Jonathan Blandford <jrb@redhat.com>
600- gave up on other archs for the Beta
601- new version
602- remove werror and add missing files
603
604* Thu Nov  7 2002 Jeremy Katz <katzj@redhat.com>
605- update to newer cvs snap
606
607* Mon Sep 23 2002 Jeremy Katz <katzj@redhat.com>
608- update to cvs snap
609
610* Sun Sep 22 2002 Jeremy Katz <katzj@redhat.com>
611- use %%(lang)
612
613* Sun Aug 11 2002 Jeremy Katz <katzj@redhat.com>
614- fix post to actually install the schema
615
616* Sat Jun 22 2002 Christian F.K. Schaller <Uraeus@linuxrising.org>
617- Added gconf file
618- Added i18n directory
619
620* Sat Jun 15 2002 Christian F.K. Schaller <Uraeus@linuxrising.org>
621- Updated for new rewrite of rhythmbox, thanks to Jeroen
622
623* Mon Mar 18 2002 Jorn Baayen <jorn@nl.linux.org>
624- removed bonobo dependency
625* Sat Mar 02 2002 Christian Schaller <Uraeus@linuxrising.org>
626- created new spec file
Note: See TracBrowser for help on using the repository browser.