source: projects/specs/trunk/r/rhythmbox/rhythmbox-vl.spec @ 623

Revision 623, 18.0 KB checked in by Takemikaduchi, 14 years ago (diff)

takemikaduchi fix and add spec file

Line 
1# -*- coding: utf-8-unix -*-
2%define desktop_file_utils_version 0.9
3
4%define enable_DLNA_UPnP 0
5
6Summary: Music Management Application
7Summary(ja): 音楽管理アプリケーション
8Name: rhythmbox
9Version: 0.12.7
10Release: 1%{?_dist_release}
11License: GPL2+ with exceptions and GFDL
12Group: Applications/Multimedia
13URL: http://projects.gnome.org/rhythmbox/
14Source: http://download.gnome.org/sources/rhythmbox/0.12/%{name}-%{version}.tar.bz2
15
16# https://bugzilla.gnome.org/show_bug.cgi?id=596615
17Patch0: rb-no-HEAD-for-podcasts.patch
18# https://bugzilla.redhat.com/show_bug.cgi?id=540672
19# https://bugzilla.gnome.org/show_bug.cgi?id=602140
20Patch1: rb-webkit-crasher.patch
21# https://bugzilla.redhat.com/show_bug.cgi?id=546188
22Patch2: 0001-Fix-crasher-when-MusicBrainz-can-t-read-a-disc.patch
23# https://bugzilla.gnome.org/show_bug.cgi?id=601524
24# https://bugzilla.gnome.org/show_bug.cgi?id=602957
25Patch3: rb-playbin2-track-changes.patch
26
27BuildRoot: %{_tmppath}/%{name}-%{version}-root
28BuildRequires: libgpod-devel
29BuildRequires: libgnomeui-devel >= 2.18.0
30BuildRequires: nautilus-cd-burner
31BuildRequires: gstreamer-plugins-base-devel >= 0.10
32BuildRequires: gettext, rarian-compat
33BuildRequires: totem-pl-parser-devel
34BuildRequires: sqlite3-devel
35BuildRequires: libffi-devel
36BuildRequires: gnome-vfs2-devel >= 2.18.0
37BuildRequires: avahi-glib-devel >= 0.6
38BuildRequires: libmusicbrainz-devel >= 2.1.0
39BuildRequires: libnotify-devel
40BuildRequires: libsexy-devel
41BuildRequires: hal-devel
42BuildRequires: libsoup-devel
43BuildRequires: dbus-devel >= 1.0
44BuildRequires: dbus-glib-devel
45BuildRequires: gnome-doc-utils >= 0.3.2
46BuildRequires: python-devel, pygtk2-devel
47BuildRequires: check >= 0.8.2
48BuildRequires: intltool >= 0.35.0
49BuildRequires: gstreamer-python
50BuildRequires: popt-devel
51BuildRequires: lirc
52BuildRequires: libmtp-devel
53BuildRequires: gnome-keyring-devel
54BuildRequires: gnome-media
55BuildRequires: libSM-devel
56Requires: libgpod
57Requires: libnotify
58Requires: libsexy
59Requires: lirc
60Requires: libmtp
61Requires: libgnomeui
62Requires: nautilus-cd-burner
63Requires: gnome-python gnome-vfs2
64Requires: gnome-themes
65Requires: gnome-keyring
66Requires: gstreamer-python
67%if %{enable_DLNA_UPnP}
68Requires: python-Coherence
69%endif
70Requires: desktop-file-utils >= %{desktop_file_utils_version}
71Requires: scrollkeeper GConf2
72
73# # gstreamer-plugins-ffmpeg and gstreamer-plugins-ugly package provided by
74# # self-build-gstreamer-plugins-ffmpeg and self-build-gstreamer-plugins-ugly,
75# # respectively.
76# Requires: self-build-gstreamer-plugins-ffmpeg
77# Requires: self-build-gstreamer-plugins-ugly
78
79
80%description
81Rhythmbox is an integrated music management application based on the powerful
82GStreamer media framework. It has a number of features, including an easy to
83use music browser, searching and sorting, comprehensive audio format support
84through GStreamer, Internet Radio support, playlists and more.
85
86Rhythmbox is extensible through a plugin system.
87
88%description -l ja
89Rhythmbox は、強力な GStreamer メディアフレームワークに基づいている
90統合音楽管理アプリケーションです。
91見やすいユーザインターフェースを備え、検索や整列ができ、
92GStreamer により数多くの音声フォーマットをサポート、
93インターネットラジオをサポート、プレイリスト管理などの
94数多くの特徴を持ちます。
95
96%prep
97%setup -q
98%patch0 -p1 -b .http-head
99## %patch1 -p1 -b .webkit
100## %patch2 -p1 -b .mb-crasher
101## %patch3 -p1 -b .track-change-hang
102# autoreconf -i
103
104# Use the installed louie, not the one in Coherence
105find plugins/coherence/upnp_coherence/ -type f \
106    -exec %__sed -i 's/coherence.extern.louie as louie/louie/' '{}' ';'
107
108%build
109# work around a gstreamer bug
110/usr/bin/gst-inspect-0.10 --print-all >& /dev/null || :
111
112%configure --with-ipod \
113    --with-mtp \
114    --with-dbus \
115    --with-mdns=avahi \
116    --with-libnautilus-burn \
117    --with-cd-burning \
118    --with-metadata-helper \
119    --enable-lirc \
120    --enable-python \
121    --disable-vala \
122    --disable-browser-plugin \
123    --disable-static \
124    --disable-scrollkeeper \
125    --disable-schemas-install
126%__make %{?_smp_mflags}
127
128%install
129%__rm -rf $RPM_BUILD_ROOT
130export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
131%__make install DESTDIR=$RPM_BUILD_ROOT
132unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
133
134%__rm -f $RPM_BUILD_ROOT%{_libdir}/bonobo/*.{a,la}
135%__rm -f $RPM_BUILD_ROOT%{_libdir}/bonobo/librb-nautilus-context-menu.so
136%__rm -f $RPM_BUILD_ROOT%{_libdir}/lib*.{a,la}
137%__rm -f $RPM_BUILD_ROOT%{_libdir}/rhythmbox/plugins/*.{a,la}
138%__rm -f $RPM_BUILD_ROOT%{_libdir}/rhythmbox/plugins/*/*.{a,la}
139%__rm -f $RPM_BUILD_ROOT%{_libdir}/librhythmbox-core.{a,la}
140%__rm -f $RPM_BUILD_ROOT%{_libdir}/mozilla/plugins/*.{a,la}
141
142## Don't package DLNA/UPnP plugin
143%if !%{enable_DLNA_UPnP}
144%__rm -rf $RPM_BUILD_ROOT%{_libdir}/rhythmbox/plugins/upnp_coherence
145%endif
146
147%find_lang %{name}
148
149
150# Don't package api docs
151%__rm -rf $RPM_BUILD_ROOT%{_datadir}/gtk-doc/
152
153# Don't package scrollkeeper catalogs
154%__rm -rf $RPM_BUILD_ROOT%{_localstatedir}
155
156# And don't package vala
157%__rm -f %{buildroot}%{_libdir}/rhythmbox/plugins/libsample-vala.so \
158        %{buildroot}%{_libdir}/rhythmbox/plugins/sample-vala.rb-plugin
159
160# save space by linking identical images in translated docs
161helpdir=$RPM_BUILD_ROOT%{_datadir}/gnome/help/%{name}
162for f in $helpdir/C/figures/*.png; do
163  b="$(basename $f)"
164  for d in $helpdir/*; do
165    if [ -d "$d" -a "$d" != "$helpdir/C" ]; then
166      g="$d/figures/$b"
167      if [ -f "$g" ]; then
168        if cmp -s $f $g; then
169          %__rm "$g"; ln -s "../../C/figures/$b" "$g"
170        fi
171      fi
172    fi
173  done
174done
175
176
177%clean
178%__rm -rf $RPM_BUILD_ROOT
179
180%post
181/sbin/ldconfig
182export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
183gconftool-2 --makefile-install-rule %{_sysconfdir}/gconf/schemas/rhythmbox.schemas >/dev/null
184update-desktop-database -q
185scrollkeeper-update -q
186touch --no-create %{_datadir}/icons/hicolor
187if [ -x /usr/bin/gtk-update-icon-cache ]; then
188  gtk-update-icon-cache -q %{_datadir}/icons/hicolor
189fi
190
191%preun
192if [ "$1" -eq 0 ]; then
193    export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
194    gconftool-2 --makefile-uninstall-rule \
195      %{_sysconfdir}/gconf/schemas/rhythmbox.schemas > /dev/null || :
196fi
197
198%postun
199/sbin/ldconfig
200update-desktop-database -q
201scrollkeeper-update -q
202touch --no-create %{_datadir}/icons/hicolor
203if [ -x /usr/bin/gtk-update-icon-cache ]; then
204  gtk-update-icon-cache -q %{_datadir}/icons/hicolor
205fi
206
207
208%files -f %{name}.lang
209%defattr(-, root, root)
210%doc AUTHORS COPYING ChangeLog README NEWS
211%{_sysconfdir}/gconf/schemas/rhythmbox.schemas
212%{_bindir}/*
213%{_libdir}/lib*.so*
214%{_libdir}/rhythmbox/plugins
215%{_datadir}/applications/rhythmbox.desktop
216%{_datadir}/dbus-1/services/org.gnome.Rhythmbox.service
217%{_datadir}/gnome/help/rhythmbox
218%{_datadir}/icons/*
219%{_datadir}/omf/rhythmbox
220%{_datadir}/rhythmbox
221%{_mandir}/man1/*
222%{_libexecdir}/rhythmbox-metadata
223
224
225%changelog
226* Sun Mar 14 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.12.7-1
227- new upstream release
228- drop Patch1, Patch2, Patch3
229
230* Mon Feb 15 2010 Shu KONNO <owa@bg.wakwak.com> 0.12.6-2
231- rebuilt with new environment
232
233* Thu Jan 14 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.12.6-1
234- new upstream release
235  - dropped upstreamed/obsolete patches
236  - added patches applied Fedora development
237
238* Sun Oct 04 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.12.5-1
239- new upstream release
240- added configure options:
241  --disable-vala
242  --disable-browser-plugin
243
244* Thu Jul 30 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.12.2-2
245- added Japanese description
246
247* Thu Jul 02 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.12.2-1
248- new upstream release
249  - dropped rb-disable-power-plugin-by-default.patch
250- added BuildRequires:
251  - libSM-devel
252  - gnome-media
253
254* Wed Jun 10 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.12.1-2
255- rebuild with libgpod-0.7.2
256
257* Sun May 03 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.12.1-1
258- new upstream release
259- corrected License tag
260- dropped rhythmbox-0.11.6-libmtp.patch
261- added BuildRequires:
262  - sqlite3-devel
263  - libffi-devel
264
265* Sat Jan 10 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.11.6-2
266- defined enable_DLNA_UPnP = 0: unpacked DLNA/UPnP plugin
267- applied rhythmbox-0.11.6-libmtp.patch
268- added Requires:
269  - libgpod
270  - libnotify
271  - libsexy
272  - lirc
273  - libmtp
274  - libgnomeui
275  - nautilus-cd-burner
276  - gstreamer-python
277  - gnome-vfs2
278  - gnome-themes
279  - gnome-keyring
280  - python-Coherence, if enable_DLNA_UPnP = 1
281- added BuildRequires:
282  - libnotify-devel
283  - libsexy-devel
284  - lirc
285  - libmtp-devel
286  - gnome-vfs2-devel, instead of gnome-vfs2
287  - gnome-keyring-devel
288- dropped --with-internal-libsexy in configure options
289- added in configure options:
290  --with-mtp --with-libnautilus-burn --enable-lirc --disable-static
291- added %%preun to remove the schema
292
293* Sun Jan 04 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.11.6-1
294- new upstream release
295- changed to --with-metadata-helper in configure options
296- added BuildRequires:
297  - gstreamer-python
298  - intltool >= 0.35.0
299  - popt-devel
300
301* Sat Aug 09 2008 Shu KONNO <owa@bg.wakwak.com> 0.11.2-1vl5
302- added BuildRequires: totem-pl-parser-devel, instead of totem-devel
303- rebuilt with python-2.5.2
304- applied new versioning policy
305- spec in utf-8
306
307* Sun Jan 06 2008 Shu KONNO <owa@bg.wakwak.com> 0.11.2-0vl2
308- rebuilt with libgpod-0.6.0
309
310* Sun Aug 26 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.11.2-0vl1
311- new upstream release
312
313* Wed Jun 27 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.11.1-0vl1
314- new upstream release
315
316* Tue May 29 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.10.0-0vl2
317- rebuilt with new toolchain and libgpod-0.4.2
318- add BuildRequires: dbus-glib-devel
319
320* Sat Apr 28 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.10.0-0vl1
321- new upstream release
322
323* Wed Mar 21 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.8-0vl2
324- rebuilt for VineSeed
325
326* Wed Mar 21 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.8-0vl1
327- new upstream release
328- added --enable-python option to %%configure
329- added Requires: gnome-python
330
331* Sun Jan 21 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.7-0vl1
332- new upstream release
333- built with libsoup 2.2.99
334
335* Thu Nov 23 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.6-0vl4
336- added --with-cd-burner to configure
337- added BuildRequires: libsexy-devel hal-devel libsoup-devel
338
339* Wed Oct 25 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.9.6-0vl3
340- add BuildRequires:
341  - gnome-doc-utils >= 0.3.2
342  - python-devel
343  - pygtk2-devel
344  - check >= 0.8.2
345
346* Tue Oct 24 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.9.6-0vl2
347- rebuild with gnutls-1.4.1
348
349* Sun Oct  1 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.6-0vl1
350- new upstream release
351
352* Mon Jun 19 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.5-0vl1
353- new upstream release
354- run scrollkeeper-update at %post and %postun
355- added BuildRequires: libnotify-devel
356
357* Sun May 14 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.4.1-0vl1
358- new upstream release (dropped patch0)
359- added --without-metadata-helper at configure
360
361* Mon Mar 13 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.3.1-0vl1
362- Initial build for Vine Linux based on FC pacakge
363
364* Fri Mar 03 2006 Ray Strode <rstrode@redhat.com> - 0.9.3.1-2
365- add patch from James "Doc" Livingston to stop a hang
366  for new users (bug 183883)
367
368* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 0.9.3.1-1.2
369- bump again for double-long bug on ppc(64)
370
371* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 0.9.3.1-1.1
372- rebuilt for new gcc4.1 snapshot and glibc changes
373
374* Sat Feb  4 2006 Christopher Aillon <caillon@redhat.com> 0.9.3.1-1
375- Update to 0.9.3.1
376- Use gstreamer (0.10)
377
378* Wed Feb  1 2006 Christopher Aillon <caillon@redhat.com> 0.9.3-2
379- Remove hack for 173869, as its no longer needed.
380
381* Wed Feb  1 2006 Christopher Aillon <caillon@redhat.com> 0.9.3-1
382- 0.9.3
383
384* Wed Feb  1 2006 Christopher Aillon <caillon@redhat.com> 0.9.2.cvs20060201-1
385- Newer CVS snapshot
386
387* Sun Jan 22 2006 Christopher Aillon <caillon@redhat.com> 0.9.2.cvs20060123-1
388- Update to latest CVS
389- Add hack to workaround bug #173869
390
391* Thu Jan 19 2006 Christopher Aillon <caillon@redhat.com> 0.9.2-8
392- Rebuild, now that gstreamer08-plugins has been fixed
393
394* Thu Jan 19 2006 Ray Strode <rstrode@redhat.com> 0.9.2-7
395- bonobo multilib issue (bug 156982)
396
397* Wed Jan 04 2006 John (J5) Palmieri <johnp@redhat.com> 0.9.2-5
398- rebuild with ipod support
399
400* Tue Jan 03 2006 Jesse Keating <jkeating@redhat.com> 0.9.2-4
401- rebuilt again
402
403* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
404- rebuilt
405
406* Mon Dec  5 2005 Matthias Clasen <mclasen@redhat.com>
407- rebuild
408
409* Thu Dec 01 2005 John (J5) Palmieri <johnp@redhat.com>
410- rebuild for new dbus
411
412* Wed Nov 30 2005 Matthias Clasen <mclasen@redhat.com>
413- Update to 0.9.2
414
415* Tue Oct 25 2005 Matthias Clasen <mclasen@redhat.com>
416- Update to 0.9.1
417
418* Fri Sep 02 2005 Colin Walters <walters@redhat.com>
419- Add configure flags --with-bonobo --with-dbus
420- BR nautilus-cd-burner-devel
421- New upstream CVS snapshot for testing
422- Drop IDL file and ui .xml
423- Add dbus service file
424- Drop upstreamed rhythmbox-bluecurve.tar.gz
425- Drop upstreamed rhythmbox-0.8.8-cell-renderer.patch
426
427* Fri Jun 13 2005 Colin Walters <walters@redhat.com> - 0.8.8-3
428- Add Bluecurve-ized icons from Jeff Schroeder (157716)
429- Add rhythmbox-0.8.8-cell-renderer.patch to remove use of custom
430  cell renderer for playback icon (no longer necessary) and
431  changes the rating renderer to work with non-b&w icons
432
433* Mon Mar 14 2005 Colin Walters <walters@redhat.com> - 0.8.8-2
434- Rebuild for GCC4
435
436* Tue Oct 05 2004 Colin Walters <walters@redhat.com> - 0.8.8-1
437- New upstream version
438- Remove librb-nautilus-context-menu.so, killed upstream
439
440* Thu Sep 30 2004 Christopher Aillon <caillon@redhat.com> 0.8.7-2
441- PreReq desktop-file-utils >= 0.9
442
443* Sat Sep 29 2004 Colin Walters <walters@redhat.com> - 0.8.7-1
444- New upstream version
445
446* Sat Sep 18 2004 Colin Walters <walters@redhat.com> - 0.8.6-2
447- Fix postun to use correct syntax, thanks Nils Philippsen
448
449* Sat Sep 18 2004 Colin Walters <walters@redhat.com> - 0.8.6-1
450- New upstream version
451- Call update-desktop-database in post and postun
452
453* Thu Jun 24 2004 Colin Walters <walters@redhat.com> - 0.8.5-1
454- New upstream version
455
456* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
457- rebuilt
458
459* Tue May 18 2004 Colin Walters <walters@redhat.com> - 0.8.4-1
460- New upstream version
461- Remove backported patches
462- Gratuitiously bump various BuildRequires versions
463
464* Mon May 10 2004 Colin Walters <walters@redhat.com> - 0.8.3-4
465- Remove code to unregister GConf schema for now (Closes: #122532)
466
467* Thu May 07 2004 Colin Walters <walters@redhat.com> - 0.8.3-3
468- Apply tiny patch from 0.8 arch to fix GConf key used
469  for initial sorting
470
471* Thu May 07 2004 Colin Walters <walters@redhat.com> - 0.8.3-2
472- Apply patch from 0.8 arch tree to fix a number of memleaks
473
474* Thu May 02 2004 Colin Walters <walters@redhat.com> - 0.8.3-1
475- Update to 0.8.3: fixes showstopper bug with internet radio
476
477* Thu Apr 30 2004 Colin Walters <walters@redhat.com> - 0.8.2-1
478- Update to 0.8.2
479- Fix Source url
480- Add smp_mflags
481- Bump BuildRequires on gstreamer to 0.8.1
482
483* Tue Apr 23 2004 Colin Walters <walters@redhat.com> - 0.8.1-2
484- Uninstall GConf schemas on removal
485
486* Tue Apr 20 2004 Colin Walters <walters@redhat.com> - 0.8.1-1
487- Update to 0.8.1
488
489* Fri Apr 16 2004 Colin Walters <walters@redhat.com> - 0.8.0-1
490- Update to 0.8.0
491
492* Fri Apr 02 2004 Colin Walters <walters@redhat.com> - 0.7.2-1
493- Update to 0.7.2
494
495* Mon Mar 29 2004 Colin Walters <walters@redhat.com> - 0.7.1-2
496- Remove BuildRequires on autoconf and libvorbis-devel
497
498* Mon Mar 29 2004 Colin Walters <walters@redhat.com> - 0.7.1-1
499- New major version - I know we are past major version slush, but
500  this should have been done two weeks ago along with the GNOME 2.6
501  upload.  As upstream author as well, I believe this version is
502  good enough for FC2.
503- Remove --disable-mp3
504- Remove id3, flac variables
505- Remove GStreamer major version patch
506- Fix typo in description
507
508* Tue Mar 16 2004 Jeremy Katz <katzj@redhat.com> - 0.6.8-2
509- rebuild for new gstreamer
510
511* Thu Mar 11 2004 Alex Larsson <alexl@redhat.com> 0.6.8-1
512- update to 0.6.8
513
514* Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
515- rebuilt
516
517* Mon Mar  1 2004 Alexander Larsson <alexl@redhat.com> 0.6.7-1
518- update to 0.6.7
519
520* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
521- rebuilt
522
523* Mon Jan 12 2004 Colin Walters <walters@verbum.org> 0.6.4-1
524- New upstream version
525- Don't re-run the autotools; upstream incorporates newer versions.
526* Tue Oct 28 2003 Jonathan Blandford <jrb@redhat.com> 0.5.4-1
527- new version
528- remove smp_flags
529
530* Fri Oct 24 2003 Jonathan Blandford <jrb@redhat.com> 0.5.3-5
531- remove the initial iradio channels as they all are mp3 based.
532
533* Wed Oct  8 2003 Matthias Saou <matthias@rpmforge.net> 0.5.3-3
534- Fix category from Development/Libraries to Applications/Multimedia.
535- Use bz2 instead of gz as ftp.gnome.org has both, 300k saved in the src.rpm.
536- Fix SCHEMES vs. SCHEMAS in the post scriplet.
537- Added gstreamer-plugins-devel, libvorbis-devel, scrollkeeper and gettext deps.
538- Removed unnecessary date expansion define.
539- Updated description, including mp3 reference removal.
540- Added libid3tag and flac optional support for convenient rebuild.
541- Removed obsolete omf.make and xmldocs.make (included ones are the same now).
542
543* Mon Sep 22 2003 Jonathan Blandford <jrb@redhat.com> 0.5.3-1
544- new version
545- use %{_sysconfdir} instead of /etc
546
547* Wed Jan 22 2003 Tim Powers <timp@redhat.com>
548- rebuilt
549
550* Wed Dec 18 2002 Jonathan Blandford <jrb@redhat.com>
551- gave up on other archs for the Beta
552- new version
553- remove werror and add missing files
554
555* Thu Nov  7 2002 Jeremy Katz <katzj@redhat.com>
556- update to newer cvs snap
557
558* Mon Sep 23 2002 Jeremy Katz <katzj@redhat.com>
559- update to cvs snap
560
561* Sun Sep 22 2002 Jeremy Katz <katzj@redhat.com>
562- use %%(lang)
563
564* Sun Aug 11 2002 Jeremy Katz <katzj@redhat.com>
565- fix post to actually install the schema
566
567* Sat Jun 22 2002 Christian F.K. Schaller <Uraeus@linuxrising.org>
568- Added gconf file
569- Added i18n directory
570
571* Sat Jun 15 2002 Christian F.K. Schaller <Uraeus@linuxrising.org>
572- Updated for new rewrite of rhythmbox, thanks to Jeroen
573
574* Mon Mar 18 2002 Jorn Baayen <jorn@nl.linux.org>
575- removed bonobo dependency
576* Sat Mar 02 2002 Christian Schaller <Uraeus@linuxrising.org>
577- created new spec file
Note: See TracBrowser for help on using the repository browser.