source: projects/specs/trunk/r/rhythmbox/rhythmbox-vl.spec @ 2547

Revision 2547, 19.1 KB checked in by Takemikaduchi, 13 years ago (diff)

new upstream release

Line 
1# -*- coding: utf-8-unix -*-
2%define desktop_file_utils_version 0.9
3
4%define enable_DLNA_UPnP 0
5
6Summary: Music Management Application
7Summary(ja): 音楽管理アプリケーション
8Name: rhythmbox
9Version: 0.13.3
10Release: 1%{?_dist_release}
11License: GPL2+ with exceptions and GFDL
12Group: Applications/Multimedia
13URL: http://projects.gnome.org/rhythmbox/
14Source: http://download.gnome.org/sources/rhythmbox/0.13/%{name}-%{version}.tar.bz2
15
16BuildRoot: %{_tmppath}/%{name}-%{version}-root
17BuildRequires: libgpod-devel
18BuildRequires: libgnomeui-devel >= 2.18.0
19BuildRequires: brasero-devel >= 2.32.0
20BuildRequires: gstreamer-plugins-base-devel >= 0.10
21BuildRequires: gettext, rarian-compat
22BuildRequires: totem-pl-parser-devel
23BuildRequires: sqlite3-devel
24BuildRequires: libffi-devel
25BuildRequires: gnome-vfs2-devel >= 2.18.0
26BuildRequires: avahi-glib-devel >= 0.6
27BuildRequires: libmusicbrainz-devel >= 2.1.0
28BuildRequires: libnotify-devel
29BuildRequires: libsexy-devel
30BuildRequires: libgudev1-devel
31BuildRequires: libsoup-devel
32BuildRequires: dbus-devel >= 1.0
33BuildRequires: dbus-glib-devel
34BuildRequires: gnome-doc-utils >= 0.3.2
35BuildRequires: python-devel, pygtk2-devel
36BuildRequires: check >= 0.8.2
37BuildRequires: intltool >= 0.35.0
38BuildRequires: gstreamer-python-devel
39BuildRequires: popt-devel
40BuildRequires: lirc
41BuildRequires: libmtp-devel
42BuildRequires: libgnome-keyring-devel >= 2.30.0
43BuildRequires: gnome-media-devel
44BuildRequires: libSM-devel
45Requires: libgpod
46Requires: libnotify
47Requires: libsexy
48Requires: lirc
49Requires: libmtp
50Requires: libgnomeui
51Requires: brasero
52Requires: gnome-python gnome-vfs2
53Requires: gnome-themes
54Requires: libgnome-keyring
55Requires: gstreamer-python
56%if %{enable_DLNA_UPnP}
57Requires: python-Coherence
58%endif
59Requires: desktop-file-utils >= %{desktop_file_utils_version}
60Requires: scrollkeeper GConf2
61
62# # gstreamer-plugins-ffmpeg and gstreamer-plugins-ugly package provided by
63# # self-build-gstreamer-plugins-ffmpeg and self-build-gstreamer-plugins-ugly,
64# # respectively.
65# Requires: self-build-gstreamer-plugins-ffmpeg
66# Requires: self-build-gstreamer-plugins-ugly
67
68
69%description
70Rhythmbox is an integrated music management application based on the powerful
71GStreamer media framework. It has a number of features, including an easy to
72use music browser, searching and sorting, comprehensive audio format support
73through GStreamer, Internet Radio support, playlists and more.
74
75Rhythmbox is extensible through a plugin system.
76
77%description -l ja
78Rhythmbox は、強力な GStreamer メディアフレームワークに基づいている
79統合音楽管理アプリケーションです。
80見やすいユーザインターフェースを備え、検索や整列ができ、
81GStreamer により数多くの音声フォーマットをサポート、
82インターネットラジオをサポート、プレイリスト管理などの
83数多くの特徴を持ちます。
84
85%package devel
86Summary: Development tools for rhythmbox applications.
87Summary(ja): rhythmbox アプリケーションの開発用ファイル
88Group: Development/Libraries
89Requires: %{name} = %{version}-%{release}
90Requires: pkgconfig
91Requires: glib2-devel
92Requires: gtk2-devel
93Requires: libsoup-devel
94Requires: gnome-media-devel
95Requires: totem-pl-parser-devel
96Requires: gstreamer-devel
97
98%description devel
99Header files and libraries for building a extension library for the rhythmbox.
100
101%description devel -l ja
102
103%prep
104%setup -q
105# autoreconf -i
106
107# Use the installed louie, not the one in Coherence
108find plugins/coherence/upnp_coherence/ -type f \
109    -exec %__sed -i 's/coherence.extern.louie as louie/louie/' '{}' ';'
110
111%build
112# work around a gstreamer bug
113/usr/bin/gst-inspect-0.10 --print-all >& /dev/null || :
114
115%configure --with-ipod \
116    --with-mtp \
117    --with-dbus \
118    --with-mdns=avahi \
119    --with-libnautilus-burn \
120    --with-cd-burning \
121    --with-metadata-helper \
122    --enable-lirc \
123    --enable-python \
124    --disable-vala \
125    --disable-browser-plugin \
126    --disable-static \
127    --disable-scrollkeeper \
128    --disable-schemas-install \
129    --without-hal
130%__make %{?_smp_mflags}
131
132%install
133%__rm -rf $RPM_BUILD_ROOT
134export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
135%__make install DESTDIR=$RPM_BUILD_ROOT
136unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
137
138%__rm -f $RPM_BUILD_ROOT%{_libdir}/bonobo/*.{a,la}
139%__rm -f $RPM_BUILD_ROOT%{_libdir}/bonobo/librb-nautilus-context-menu.so
140%__rm -f $RPM_BUILD_ROOT%{_libdir}/lib*.{a,la}
141%__rm -f $RPM_BUILD_ROOT%{_libdir}/rhythmbox/plugins/*.{a,la}
142%__rm -f $RPM_BUILD_ROOT%{_libdir}/rhythmbox/plugins/*/*.{a,la}
143%__rm -f $RPM_BUILD_ROOT%{_libdir}/librhythmbox-core.{a,la}
144%__rm -f $RPM_BUILD_ROOT%{_libdir}/mozilla/plugins/*.{a,la}
145
146## Don't package DLNA/UPnP plugin
147%if !%{enable_DLNA_UPnP}
148%__rm -rf $RPM_BUILD_ROOT%{_libdir}/rhythmbox/plugins/upnp_coherence
149%endif
150
151%find_lang %{name}
152
153
154# Don't package api docs
155%__rm -rf $RPM_BUILD_ROOT%{_datadir}/gtk-doc/
156
157# Don't package scrollkeeper catalogs
158%__rm -rf $RPM_BUILD_ROOT%{_localstatedir}
159
160# And don't package vala
161%__rm -f %{buildroot}%{_libdir}/rhythmbox/plugins/libsample-vala.so \
162        %{buildroot}%{_libdir}/rhythmbox/plugins/sample-vala.rb-plugin
163
164# save space by linking identical images in translated docs
165helpdir=$RPM_BUILD_ROOT%{_datadir}/gnome/help/%{name}
166for f in $helpdir/C/figures/*.png; do
167  b="$(basename $f)"
168  for d in $helpdir/*; do
169    if [ -d "$d" -a "$d" != "$helpdir/C" ]; then
170      g="$d/figures/$b"
171      if [ -f "$g" ]; then
172        if cmp -s $f $g; then
173          %__rm "$g"; ln -s "../../C/figures/$b" "$g"
174        fi
175      fi
176    fi
177  done
178done
179
180
181%clean
182%__rm -rf $RPM_BUILD_ROOT
183
184%post
185/sbin/ldconfig
186export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
187gconftool-2 --makefile-install-rule %{_sysconfdir}/gconf/schemas/rhythmbox.schemas >/dev/null
188update-desktop-database -q
189scrollkeeper-update -q
190touch --no-create %{_datadir}/icons/hicolor
191if [ -x /usr/bin/gtk-update-icon-cache ]; then
192  gtk-update-icon-cache -q %{_datadir}/icons/hicolor
193fi
194
195%preun
196if [ "$1" -eq 0 ]; then
197    export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
198    gconftool-2 --makefile-uninstall-rule \
199      %{_sysconfdir}/gconf/schemas/rhythmbox.schemas > /dev/null || :
200fi
201
202%postun
203/sbin/ldconfig
204update-desktop-database -q
205scrollkeeper-update -q
206touch --no-create %{_datadir}/icons/hicolor
207if [ -x /usr/bin/gtk-update-icon-cache ]; then
208  gtk-update-icon-cache -q %{_datadir}/icons/hicolor
209fi
210
211
212%files -f %{name}.lang
213%defattr(-, root, root)
214%doc AUTHORS COPYING ChangeLog README NEWS
215%{_sysconfdir}/gconf/schemas/rhythmbox.schemas
216%{_bindir}/*
217%{_libdir}/lib*.so.*
218%{_libdir}/rhythmbox/plugins
219%{_datadir}/applications/rhythmbox.desktop
220%{_datadir}/applications/rhythmbox-device.desktop
221%{_datadir}/dbus-1/services/org.gnome.Rhythmbox.service
222%{_datadir}/gnome/help/rhythmbox
223%{_datadir}/icons/*
224%{_datadir}/omf/rhythmbox
225%{_datadir}/rhythmbox
226%{_mandir}/man1/*
227%{_libexecdir}/rhythmbox-metadata
228
229%files devel
230%defattr(-, root, root)
231%{_includedir}/%{name}/*
232%{_libdir}/*.so
233%{_libdir}/pkgconfig/*.pc
234
235
236%changelog
237* Sun Jan 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.3-1
238- new upstream release
239- change BuildRequires: gstreamer-python-devel instead of gstreamer-python
240
241* Sat Nov 06 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.2-1
242- new upstream release
243
244* Wed Oct 06 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.1-3
245- rebuild with brasero-2.32.0
246
247* Sun Sep 26 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.1-2
248- rebuild with rpm-4.8.1 for pkg-config file
249
250* Sun Sep 12 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.1-1
251- new upstream release
252- fix %files (add rhythmbox-device.desktop)
253
254* Sun Aug 29 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.0-1
255- new upstream release
256- change BuildRequires: gnome-media-devel instead of gnome-media
257- add devel package
258- drop Patch0
259
260* Sun Mar 14 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.12.8-1
261- new upstream release
262- drop Patch1, Patch2, Patch3
263- change BuildRequires: nautilus-cd-burner -> brasero-devel
264- change Requires: nautilus-cd-burner -> brasero
265- change BuildRequires: hal-devel -> libgudev1-devel
266- change BuildRequires: gnome-keyring-devel -> libgnome-keyring-devel
267- change Requires: gnome-keyring -> libgnome-keyring
268- add configure option (--without-hal)
269
270* Mon Feb 15 2010 Shu KONNO <owa@bg.wakwak.com> 0.12.6-2
271- rebuilt with new environment
272
273* Thu Jan 14 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.12.6-1
274- new upstream release
275  - dropped upstreamed/obsolete patches
276  - added patches applied Fedora development
277
278* Sun Oct 04 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.12.5-1
279- new upstream release
280- added configure options:
281  --disable-vala
282  --disable-browser-plugin
283
284* Thu Jul 30 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.12.2-2
285- added Japanese description
286
287* Thu Jul 02 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.12.2-1
288- new upstream release
289  - dropped rb-disable-power-plugin-by-default.patch
290- added BuildRequires:
291  - libSM-devel
292  - gnome-media
293
294* Wed Jun 10 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.12.1-2
295- rebuild with libgpod-0.7.2
296
297* Sun May 03 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.12.1-1
298- new upstream release
299- corrected License tag
300- dropped rhythmbox-0.11.6-libmtp.patch
301- added BuildRequires:
302  - sqlite3-devel
303  - libffi-devel
304
305* Sat Jan 10 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.11.6-2
306- defined enable_DLNA_UPnP = 0: unpacked DLNA/UPnP plugin
307- applied rhythmbox-0.11.6-libmtp.patch
308- added Requires:
309  - libgpod
310  - libnotify
311  - libsexy
312  - lirc
313  - libmtp
314  - libgnomeui
315  - nautilus-cd-burner
316  - gstreamer-python
317  - gnome-vfs2
318  - gnome-themes
319  - gnome-keyring
320  - python-Coherence, if enable_DLNA_UPnP = 1
321- added BuildRequires:
322  - libnotify-devel
323  - libsexy-devel
324  - lirc
325  - libmtp-devel
326  - gnome-vfs2-devel, instead of gnome-vfs2
327  - gnome-keyring-devel
328- dropped --with-internal-libsexy in configure options
329- added in configure options:
330  --with-mtp --with-libnautilus-burn --enable-lirc --disable-static
331- added %%preun to remove the schema
332
333* Sun Jan 04 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.11.6-1
334- new upstream release
335- changed to --with-metadata-helper in configure options
336- added BuildRequires:
337  - gstreamer-python
338  - intltool >= 0.35.0
339  - popt-devel
340
341* Sat Aug 09 2008 Shu KONNO <owa@bg.wakwak.com> 0.11.2-1vl5
342- added BuildRequires: totem-pl-parser-devel, instead of totem-devel
343- rebuilt with python-2.5.2
344- applied new versioning policy
345- spec in utf-8
346
347* Sun Jan 06 2008 Shu KONNO <owa@bg.wakwak.com> 0.11.2-0vl2
348- rebuilt with libgpod-0.6.0
349
350* Sun Aug 26 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.11.2-0vl1
351- new upstream release
352
353* Wed Jun 27 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.11.1-0vl1
354- new upstream release
355
356* Tue May 29 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.10.0-0vl2
357- rebuilt with new toolchain and libgpod-0.4.2
358- add BuildRequires: dbus-glib-devel
359
360* Sat Apr 28 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.10.0-0vl1
361- new upstream release
362
363* Wed Mar 21 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.8-0vl2
364- rebuilt for VineSeed
365
366* Wed Mar 21 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.8-0vl1
367- new upstream release
368- added --enable-python option to %%configure
369- added Requires: gnome-python
370
371* Sun Jan 21 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.7-0vl1
372- new upstream release
373- built with libsoup 2.2.99
374
375* Thu Nov 23 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.6-0vl4
376- added --with-cd-burner to configure
377- added BuildRequires: libsexy-devel hal-devel libsoup-devel
378
379* Wed Oct 25 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.9.6-0vl3
380- add BuildRequires:
381  - gnome-doc-utils >= 0.3.2
382  - python-devel
383  - pygtk2-devel
384  - check >= 0.8.2
385
386* Tue Oct 24 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.9.6-0vl2
387- rebuild with gnutls-1.4.1
388
389* Sun Oct  1 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.6-0vl1
390- new upstream release
391
392* Mon Jun 19 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.5-0vl1
393- new upstream release
394- run scrollkeeper-update at %post and %postun
395- added BuildRequires: libnotify-devel
396
397* Sun May 14 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.4.1-0vl1
398- new upstream release (dropped patch0)
399- added --without-metadata-helper at configure
400
401* Mon Mar 13 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.3.1-0vl1
402- Initial build for Vine Linux based on FC pacakge
403
404* Fri Mar 03 2006 Ray Strode <rstrode@redhat.com> - 0.9.3.1-2
405- add patch from James "Doc" Livingston to stop a hang
406  for new users (bug 183883)
407
408* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 0.9.3.1-1.2
409- bump again for double-long bug on ppc(64)
410
411* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 0.9.3.1-1.1
412- rebuilt for new gcc4.1 snapshot and glibc changes
413
414* Sat Feb  4 2006 Christopher Aillon <caillon@redhat.com> 0.9.3.1-1
415- Update to 0.9.3.1
416- Use gstreamer (0.10)
417
418* Wed Feb  1 2006 Christopher Aillon <caillon@redhat.com> 0.9.3-2
419- Remove hack for 173869, as its no longer needed.
420
421* Wed Feb  1 2006 Christopher Aillon <caillon@redhat.com> 0.9.3-1
422- 0.9.3
423
424* Wed Feb  1 2006 Christopher Aillon <caillon@redhat.com> 0.9.2.cvs20060201-1
425- Newer CVS snapshot
426
427* Sun Jan 22 2006 Christopher Aillon <caillon@redhat.com> 0.9.2.cvs20060123-1
428- Update to latest CVS
429- Add hack to workaround bug #173869
430
431* Thu Jan 19 2006 Christopher Aillon <caillon@redhat.com> 0.9.2-8
432- Rebuild, now that gstreamer08-plugins has been fixed
433
434* Thu Jan 19 2006 Ray Strode <rstrode@redhat.com> 0.9.2-7
435- bonobo multilib issue (bug 156982)
436
437* Wed Jan 04 2006 John (J5) Palmieri <johnp@redhat.com> 0.9.2-5
438- rebuild with ipod support
439
440* Tue Jan 03 2006 Jesse Keating <jkeating@redhat.com> 0.9.2-4
441- rebuilt again
442
443* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
444- rebuilt
445
446* Mon Dec  5 2005 Matthias Clasen <mclasen@redhat.com>
447- rebuild
448
449* Thu Dec 01 2005 John (J5) Palmieri <johnp@redhat.com>
450- rebuild for new dbus
451
452* Wed Nov 30 2005 Matthias Clasen <mclasen@redhat.com>
453- Update to 0.9.2
454
455* Tue Oct 25 2005 Matthias Clasen <mclasen@redhat.com>
456- Update to 0.9.1
457
458* Fri Sep 02 2005 Colin Walters <walters@redhat.com>
459- Add configure flags --with-bonobo --with-dbus
460- BR nautilus-cd-burner-devel
461- New upstream CVS snapshot for testing
462- Drop IDL file and ui .xml
463- Add dbus service file
464- Drop upstreamed rhythmbox-bluecurve.tar.gz
465- Drop upstreamed rhythmbox-0.8.8-cell-renderer.patch
466
467* Fri Jun 13 2005 Colin Walters <walters@redhat.com> - 0.8.8-3
468- Add Bluecurve-ized icons from Jeff Schroeder (157716)
469- Add rhythmbox-0.8.8-cell-renderer.patch to remove use of custom
470  cell renderer for playback icon (no longer necessary) and
471  changes the rating renderer to work with non-b&w icons
472
473* Mon Mar 14 2005 Colin Walters <walters@redhat.com> - 0.8.8-2
474- Rebuild for GCC4
475
476* Tue Oct 05 2004 Colin Walters <walters@redhat.com> - 0.8.8-1
477- New upstream version
478- Remove librb-nautilus-context-menu.so, killed upstream
479
480* Thu Sep 30 2004 Christopher Aillon <caillon@redhat.com> 0.8.7-2
481- PreReq desktop-file-utils >= 0.9
482
483* Sat Sep 29 2004 Colin Walters <walters@redhat.com> - 0.8.7-1
484- New upstream version
485
486* Sat Sep 18 2004 Colin Walters <walters@redhat.com> - 0.8.6-2
487- Fix postun to use correct syntax, thanks Nils Philippsen
488
489* Sat Sep 18 2004 Colin Walters <walters@redhat.com> - 0.8.6-1
490- New upstream version
491- Call update-desktop-database in post and postun
492
493* Thu Jun 24 2004 Colin Walters <walters@redhat.com> - 0.8.5-1
494- New upstream version
495
496* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
497- rebuilt
498
499* Tue May 18 2004 Colin Walters <walters@redhat.com> - 0.8.4-1
500- New upstream version
501- Remove backported patches
502- Gratuitiously bump various BuildRequires versions
503
504* Mon May 10 2004 Colin Walters <walters@redhat.com> - 0.8.3-4
505- Remove code to unregister GConf schema for now (Closes: #122532)
506
507* Thu May 07 2004 Colin Walters <walters@redhat.com> - 0.8.3-3
508- Apply tiny patch from 0.8 arch to fix GConf key used
509  for initial sorting
510
511* Thu May 07 2004 Colin Walters <walters@redhat.com> - 0.8.3-2
512- Apply patch from 0.8 arch tree to fix a number of memleaks
513
514* Thu May 02 2004 Colin Walters <walters@redhat.com> - 0.8.3-1
515- Update to 0.8.3: fixes showstopper bug with internet radio
516
517* Thu Apr 30 2004 Colin Walters <walters@redhat.com> - 0.8.2-1
518- Update to 0.8.2
519- Fix Source url
520- Add smp_mflags
521- Bump BuildRequires on gstreamer to 0.8.1
522
523* Tue Apr 23 2004 Colin Walters <walters@redhat.com> - 0.8.1-2
524- Uninstall GConf schemas on removal
525
526* Tue Apr 20 2004 Colin Walters <walters@redhat.com> - 0.8.1-1
527- Update to 0.8.1
528
529* Fri Apr 16 2004 Colin Walters <walters@redhat.com> - 0.8.0-1
530- Update to 0.8.0
531
532* Fri Apr 02 2004 Colin Walters <walters@redhat.com> - 0.7.2-1
533- Update to 0.7.2
534
535* Mon Mar 29 2004 Colin Walters <walters@redhat.com> - 0.7.1-2
536- Remove BuildRequires on autoconf and libvorbis-devel
537
538* Mon Mar 29 2004 Colin Walters <walters@redhat.com> - 0.7.1-1
539- New major version - I know we are past major version slush, but
540  this should have been done two weeks ago along with the GNOME 2.6
541  upload.  As upstream author as well, I believe this version is
542  good enough for FC2.
543- Remove --disable-mp3
544- Remove id3, flac variables
545- Remove GStreamer major version patch
546- Fix typo in description
547
548* Tue Mar 16 2004 Jeremy Katz <katzj@redhat.com> - 0.6.8-2
549- rebuild for new gstreamer
550
551* Thu Mar 11 2004 Alex Larsson <alexl@redhat.com> 0.6.8-1
552- update to 0.6.8
553
554* Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
555- rebuilt
556
557* Mon Mar  1 2004 Alexander Larsson <alexl@redhat.com> 0.6.7-1
558- update to 0.6.7
559
560* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
561- rebuilt
562
563* Mon Jan 12 2004 Colin Walters <walters@verbum.org> 0.6.4-1
564- New upstream version
565- Don't re-run the autotools; upstream incorporates newer versions.
566* Tue Oct 28 2003 Jonathan Blandford <jrb@redhat.com> 0.5.4-1
567- new version
568- remove smp_flags
569
570* Fri Oct 24 2003 Jonathan Blandford <jrb@redhat.com> 0.5.3-5
571- remove the initial iradio channels as they all are mp3 based.
572
573* Wed Oct  8 2003 Matthias Saou <matthias@rpmforge.net> 0.5.3-3
574- Fix category from Development/Libraries to Applications/Multimedia.
575- Use bz2 instead of gz as ftp.gnome.org has both, 300k saved in the src.rpm.
576- Fix SCHEMES vs. SCHEMAS in the post scriplet.
577- Added gstreamer-plugins-devel, libvorbis-devel, scrollkeeper and gettext deps.
578- Removed unnecessary date expansion define.
579- Updated description, including mp3 reference removal.
580- Added libid3tag and flac optional support for convenient rebuild.
581- Removed obsolete omf.make and xmldocs.make (included ones are the same now).
582
583* Mon Sep 22 2003 Jonathan Blandford <jrb@redhat.com> 0.5.3-1
584- new version
585- use %{_sysconfdir} instead of /etc
586
587* Wed Jan 22 2003 Tim Powers <timp@redhat.com>
588- rebuilt
589
590* Wed Dec 18 2002 Jonathan Blandford <jrb@redhat.com>
591- gave up on other archs for the Beta
592- new version
593- remove werror and add missing files
594
595* Thu Nov  7 2002 Jeremy Katz <katzj@redhat.com>
596- update to newer cvs snap
597
598* Mon Sep 23 2002 Jeremy Katz <katzj@redhat.com>
599- update to cvs snap
600
601* Sun Sep 22 2002 Jeremy Katz <katzj@redhat.com>
602- use %%(lang)
603
604* Sun Aug 11 2002 Jeremy Katz <katzj@redhat.com>
605- fix post to actually install the schema
606
607* Sat Jun 22 2002 Christian F.K. Schaller <Uraeus@linuxrising.org>
608- Added gconf file
609- Added i18n directory
610
611* Sat Jun 15 2002 Christian F.K. Schaller <Uraeus@linuxrising.org>
612- Updated for new rewrite of rhythmbox, thanks to Jeroen
613
614* Mon Mar 18 2002 Jorn Baayen <jorn@nl.linux.org>
615- removed bonobo dependency
616* Sat Mar 02 2002 Christian Schaller <Uraeus@linuxrising.org>
617- created new spec file
Note: See TracBrowser for help on using the repository browser.