source: projects/specs/trunk/r/rhythmbox/rhythmbox-vl.spec @ 2182

Revision 2182, 19.0 KB checked in by Takemikaduchi, 14 years ago (diff)

libXpm:create compat32 package, task-compiz: fix package version, others: new upstream release

Line 
1# -*- coding: utf-8-unix -*-
2%define desktop_file_utils_version 0.9
3
4%define enable_DLNA_UPnP 0
5
6Summary: Music Management Application
7Summary(ja): 音楽管理アプリケーション
8Name: rhythmbox
9Version: 0.13.2
10Release: 1%{?_dist_release}
11License: GPL2+ with exceptions and GFDL
12Group: Applications/Multimedia
13URL: http://projects.gnome.org/rhythmbox/
14Source: http://download.gnome.org/sources/rhythmbox/0.13/%{name}-%{version}.tar.bz2
15
16BuildRoot: %{_tmppath}/%{name}-%{version}-root
17BuildRequires: libgpod-devel
18BuildRequires: libgnomeui-devel >= 2.18.0
19BuildRequires: brasero-devel >= 2.32.0
20BuildRequires: gstreamer-plugins-base-devel >= 0.10
21BuildRequires: gettext, rarian-compat
22BuildRequires: totem-pl-parser-devel
23BuildRequires: sqlite3-devel
24BuildRequires: libffi-devel
25BuildRequires: gnome-vfs2-devel >= 2.18.0
26BuildRequires: avahi-glib-devel >= 0.6
27BuildRequires: libmusicbrainz-devel >= 2.1.0
28BuildRequires: libnotify-devel
29BuildRequires: libsexy-devel
30BuildRequires: libgudev1-devel
31BuildRequires: libsoup-devel
32BuildRequires: dbus-devel >= 1.0
33BuildRequires: dbus-glib-devel
34BuildRequires: gnome-doc-utils >= 0.3.2
35BuildRequires: python-devel, pygtk2-devel
36BuildRequires: check >= 0.8.2
37BuildRequires: intltool >= 0.35.0
38BuildRequires: gstreamer-python
39BuildRequires: popt-devel
40BuildRequires: lirc
41BuildRequires: libmtp-devel
42BuildRequires: libgnome-keyring-devel >= 2.30.0
43BuildRequires: gnome-media-devel
44BuildRequires: libSM-devel
45Requires: libgpod
46Requires: libnotify
47Requires: libsexy
48Requires: lirc
49Requires: libmtp
50Requires: libgnomeui
51Requires: brasero
52Requires: gnome-python gnome-vfs2
53Requires: gnome-themes
54Requires: libgnome-keyring
55Requires: gstreamer-python
56%if %{enable_DLNA_UPnP}
57Requires: python-Coherence
58%endif
59Requires: desktop-file-utils >= %{desktop_file_utils_version}
60Requires: scrollkeeper GConf2
61
62# # gstreamer-plugins-ffmpeg and gstreamer-plugins-ugly package provided by
63# # self-build-gstreamer-plugins-ffmpeg and self-build-gstreamer-plugins-ugly,
64# # respectively.
65# Requires: self-build-gstreamer-plugins-ffmpeg
66# Requires: self-build-gstreamer-plugins-ugly
67
68
69%description
70Rhythmbox is an integrated music management application based on the powerful
71GStreamer media framework. It has a number of features, including an easy to
72use music browser, searching and sorting, comprehensive audio format support
73through GStreamer, Internet Radio support, playlists and more.
74
75Rhythmbox is extensible through a plugin system.
76
77%description -l ja
78Rhythmbox は、強力な GStreamer メディアフレームワークに基づいている
79統合音楽管理アプリケーションです。
80見やすいユーザインターフェースを備え、検索や整列ができ、
81GStreamer により数多くの音声フォーマットをサポート、
82インターネットラジオをサポート、プレイリスト管理などの
83数多くの特徴を持ちます。
84
85%package devel
86Summary: Development tools for rhythmbox applications.
87Summary(ja): rhythmbox アプリケーションの開発用ファイル
88Group: Development/Libraries
89Requires: %{name} = %{version}-%{release}
90Requires: pkgconfig
91Requires: glib2-devel
92Requires: gtk2-devel
93Requires: libsoup-devel
94Requires: gnome-media-devel
95Requires: totem-pl-parser-devel
96Requires: gstreamer-devel
97
98%description devel
99Header files and libraries for building a extension library for the rhythmbox.
100
101%description devel -l ja
102
103%prep
104%setup -q
105# autoreconf -i
106
107# Use the installed louie, not the one in Coherence
108find plugins/coherence/upnp_coherence/ -type f \
109    -exec %__sed -i 's/coherence.extern.louie as louie/louie/' '{}' ';'
110
111%build
112# work around a gstreamer bug
113/usr/bin/gst-inspect-0.10 --print-all >& /dev/null || :
114
115%configure --with-ipod \
116    --with-mtp \
117    --with-dbus \
118    --with-mdns=avahi \
119    --with-libnautilus-burn \
120    --with-cd-burning \
121    --with-metadata-helper \
122    --enable-lirc \
123    --enable-python \
124    --disable-vala \
125    --disable-browser-plugin \
126    --disable-static \
127    --disable-scrollkeeper \
128    --disable-schemas-install \
129    --without-hal
130%__make %{?_smp_mflags}
131
132%install
133%__rm -rf $RPM_BUILD_ROOT
134export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
135%__make install DESTDIR=$RPM_BUILD_ROOT
136unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
137
138%__rm -f $RPM_BUILD_ROOT%{_libdir}/bonobo/*.{a,la}
139%__rm -f $RPM_BUILD_ROOT%{_libdir}/bonobo/librb-nautilus-context-menu.so
140%__rm -f $RPM_BUILD_ROOT%{_libdir}/lib*.{a,la}
141%__rm -f $RPM_BUILD_ROOT%{_libdir}/rhythmbox/plugins/*.{a,la}
142%__rm -f $RPM_BUILD_ROOT%{_libdir}/rhythmbox/plugins/*/*.{a,la}
143%__rm -f $RPM_BUILD_ROOT%{_libdir}/librhythmbox-core.{a,la}
144%__rm -f $RPM_BUILD_ROOT%{_libdir}/mozilla/plugins/*.{a,la}
145
146## Don't package DLNA/UPnP plugin
147%if !%{enable_DLNA_UPnP}
148%__rm -rf $RPM_BUILD_ROOT%{_libdir}/rhythmbox/plugins/upnp_coherence
149%endif
150
151%find_lang %{name}
152
153
154# Don't package api docs
155%__rm -rf $RPM_BUILD_ROOT%{_datadir}/gtk-doc/
156
157# Don't package scrollkeeper catalogs
158%__rm -rf $RPM_BUILD_ROOT%{_localstatedir}
159
160# And don't package vala
161%__rm -f %{buildroot}%{_libdir}/rhythmbox/plugins/libsample-vala.so \
162        %{buildroot}%{_libdir}/rhythmbox/plugins/sample-vala.rb-plugin
163
164# save space by linking identical images in translated docs
165helpdir=$RPM_BUILD_ROOT%{_datadir}/gnome/help/%{name}
166for f in $helpdir/C/figures/*.png; do
167  b="$(basename $f)"
168  for d in $helpdir/*; do
169    if [ -d "$d" -a "$d" != "$helpdir/C" ]; then
170      g="$d/figures/$b"
171      if [ -f "$g" ]; then
172        if cmp -s $f $g; then
173          %__rm "$g"; ln -s "../../C/figures/$b" "$g"
174        fi
175      fi
176    fi
177  done
178done
179
180
181%clean
182%__rm -rf $RPM_BUILD_ROOT
183
184%post
185/sbin/ldconfig
186export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
187gconftool-2 --makefile-install-rule %{_sysconfdir}/gconf/schemas/rhythmbox.schemas >/dev/null
188update-desktop-database -q
189scrollkeeper-update -q
190touch --no-create %{_datadir}/icons/hicolor
191if [ -x /usr/bin/gtk-update-icon-cache ]; then
192  gtk-update-icon-cache -q %{_datadir}/icons/hicolor
193fi
194
195%preun
196if [ "$1" -eq 0 ]; then
197    export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
198    gconftool-2 --makefile-uninstall-rule \
199      %{_sysconfdir}/gconf/schemas/rhythmbox.schemas > /dev/null || :
200fi
201
202%postun
203/sbin/ldconfig
204update-desktop-database -q
205scrollkeeper-update -q
206touch --no-create %{_datadir}/icons/hicolor
207if [ -x /usr/bin/gtk-update-icon-cache ]; then
208  gtk-update-icon-cache -q %{_datadir}/icons/hicolor
209fi
210
211
212%files -f %{name}.lang
213%defattr(-, root, root)
214%doc AUTHORS COPYING ChangeLog README NEWS
215%{_sysconfdir}/gconf/schemas/rhythmbox.schemas
216%{_bindir}/*
217%{_libdir}/lib*.so.*
218%{_libdir}/rhythmbox/plugins
219%{_datadir}/applications/rhythmbox.desktop
220%{_datadir}/applications/rhythmbox-device.desktop
221%{_datadir}/dbus-1/services/org.gnome.Rhythmbox.service
222%{_datadir}/gnome/help/rhythmbox
223%{_datadir}/icons/*
224%{_datadir}/omf/rhythmbox
225%{_datadir}/rhythmbox
226%{_mandir}/man1/*
227%{_libexecdir}/rhythmbox-metadata
228
229%files devel
230%defattr(-, root, root)
231%{_includedir}/%{name}/*
232%{_libdir}/*.so
233%{_libdir}/pkgconfig/*.pc
234
235
236%changelog
237* Sat Nov 06 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.2-1
238- new upstream release
239
240* Wed Oct 06 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.1-3
241- rebuild with brasero-2.32.0
242
243* Sun Sep 26 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.1-2
244- rebuild with rpm-4.8.1 for pkg-config file
245
246* Sun Sep 12 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.1-1
247- new upstream release
248- fix %files (add rhythmbox-device.desktop)
249
250* Sun Aug 29 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.0-1
251- new upstream release
252- change BuildRequires: gnome-media-devel instead of gnome-media
253- add devel package
254- drop Patch0
255
256* Sun Mar 14 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.12.8-1
257- new upstream release
258- drop Patch1, Patch2, Patch3
259- change BuildRequires: nautilus-cd-burner -> brasero-devel
260- change Requires: nautilus-cd-burner -> brasero
261- change BuildRequires: hal-devel -> libgudev1-devel
262- change BuildRequires: gnome-keyring-devel -> libgnome-keyring-devel
263- change Requires: gnome-keyring -> libgnome-keyring
264- add configure option (--without-hal)
265
266* Mon Feb 15 2010 Shu KONNO <owa@bg.wakwak.com> 0.12.6-2
267- rebuilt with new environment
268
269* Thu Jan 14 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.12.6-1
270- new upstream release
271  - dropped upstreamed/obsolete patches
272  - added patches applied Fedora development
273
274* Sun Oct 04 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.12.5-1
275- new upstream release
276- added configure options:
277  --disable-vala
278  --disable-browser-plugin
279
280* Thu Jul 30 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.12.2-2
281- added Japanese description
282
283* Thu Jul 02 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.12.2-1
284- new upstream release
285  - dropped rb-disable-power-plugin-by-default.patch
286- added BuildRequires:
287  - libSM-devel
288  - gnome-media
289
290* Wed Jun 10 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.12.1-2
291- rebuild with libgpod-0.7.2
292
293* Sun May 03 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.12.1-1
294- new upstream release
295- corrected License tag
296- dropped rhythmbox-0.11.6-libmtp.patch
297- added BuildRequires:
298  - sqlite3-devel
299  - libffi-devel
300
301* Sat Jan 10 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.11.6-2
302- defined enable_DLNA_UPnP = 0: unpacked DLNA/UPnP plugin
303- applied rhythmbox-0.11.6-libmtp.patch
304- added Requires:
305  - libgpod
306  - libnotify
307  - libsexy
308  - lirc
309  - libmtp
310  - libgnomeui
311  - nautilus-cd-burner
312  - gstreamer-python
313  - gnome-vfs2
314  - gnome-themes
315  - gnome-keyring
316  - python-Coherence, if enable_DLNA_UPnP = 1
317- added BuildRequires:
318  - libnotify-devel
319  - libsexy-devel
320  - lirc
321  - libmtp-devel
322  - gnome-vfs2-devel, instead of gnome-vfs2
323  - gnome-keyring-devel
324- dropped --with-internal-libsexy in configure options
325- added in configure options:
326  --with-mtp --with-libnautilus-burn --enable-lirc --disable-static
327- added %%preun to remove the schema
328
329* Sun Jan 04 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.11.6-1
330- new upstream release
331- changed to --with-metadata-helper in configure options
332- added BuildRequires:
333  - gstreamer-python
334  - intltool >= 0.35.0
335  - popt-devel
336
337* Sat Aug 09 2008 Shu KONNO <owa@bg.wakwak.com> 0.11.2-1vl5
338- added BuildRequires: totem-pl-parser-devel, instead of totem-devel
339- rebuilt with python-2.5.2
340- applied new versioning policy
341- spec in utf-8
342
343* Sun Jan 06 2008 Shu KONNO <owa@bg.wakwak.com> 0.11.2-0vl2
344- rebuilt with libgpod-0.6.0
345
346* Sun Aug 26 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.11.2-0vl1
347- new upstream release
348
349* Wed Jun 27 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.11.1-0vl1
350- new upstream release
351
352* Tue May 29 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.10.0-0vl2
353- rebuilt with new toolchain and libgpod-0.4.2
354- add BuildRequires: dbus-glib-devel
355
356* Sat Apr 28 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.10.0-0vl1
357- new upstream release
358
359* Wed Mar 21 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.8-0vl2
360- rebuilt for VineSeed
361
362* Wed Mar 21 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.8-0vl1
363- new upstream release
364- added --enable-python option to %%configure
365- added Requires: gnome-python
366
367* Sun Jan 21 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.7-0vl1
368- new upstream release
369- built with libsoup 2.2.99
370
371* Thu Nov 23 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.6-0vl4
372- added --with-cd-burner to configure
373- added BuildRequires: libsexy-devel hal-devel libsoup-devel
374
375* Wed Oct 25 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.9.6-0vl3
376- add BuildRequires:
377  - gnome-doc-utils >= 0.3.2
378  - python-devel
379  - pygtk2-devel
380  - check >= 0.8.2
381
382* Tue Oct 24 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.9.6-0vl2
383- rebuild with gnutls-1.4.1
384
385* Sun Oct  1 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.6-0vl1
386- new upstream release
387
388* Mon Jun 19 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.5-0vl1
389- new upstream release
390- run scrollkeeper-update at %post and %postun
391- added BuildRequires: libnotify-devel
392
393* Sun May 14 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.4.1-0vl1
394- new upstream release (dropped patch0)
395- added --without-metadata-helper at configure
396
397* Mon Mar 13 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.3.1-0vl1
398- Initial build for Vine Linux based on FC pacakge
399
400* Fri Mar 03 2006 Ray Strode <rstrode@redhat.com> - 0.9.3.1-2
401- add patch from James "Doc" Livingston to stop a hang
402  for new users (bug 183883)
403
404* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 0.9.3.1-1.2
405- bump again for double-long bug on ppc(64)
406
407* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 0.9.3.1-1.1
408- rebuilt for new gcc4.1 snapshot and glibc changes
409
410* Sat Feb  4 2006 Christopher Aillon <caillon@redhat.com> 0.9.3.1-1
411- Update to 0.9.3.1
412- Use gstreamer (0.10)
413
414* Wed Feb  1 2006 Christopher Aillon <caillon@redhat.com> 0.9.3-2
415- Remove hack for 173869, as its no longer needed.
416
417* Wed Feb  1 2006 Christopher Aillon <caillon@redhat.com> 0.9.3-1
418- 0.9.3
419
420* Wed Feb  1 2006 Christopher Aillon <caillon@redhat.com> 0.9.2.cvs20060201-1
421- Newer CVS snapshot
422
423* Sun Jan 22 2006 Christopher Aillon <caillon@redhat.com> 0.9.2.cvs20060123-1
424- Update to latest CVS
425- Add hack to workaround bug #173869
426
427* Thu Jan 19 2006 Christopher Aillon <caillon@redhat.com> 0.9.2-8
428- Rebuild, now that gstreamer08-plugins has been fixed
429
430* Thu Jan 19 2006 Ray Strode <rstrode@redhat.com> 0.9.2-7
431- bonobo multilib issue (bug 156982)
432
433* Wed Jan 04 2006 John (J5) Palmieri <johnp@redhat.com> 0.9.2-5
434- rebuild with ipod support
435
436* Tue Jan 03 2006 Jesse Keating <jkeating@redhat.com> 0.9.2-4
437- rebuilt again
438
439* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
440- rebuilt
441
442* Mon Dec  5 2005 Matthias Clasen <mclasen@redhat.com>
443- rebuild
444
445* Thu Dec 01 2005 John (J5) Palmieri <johnp@redhat.com>
446- rebuild for new dbus
447
448* Wed Nov 30 2005 Matthias Clasen <mclasen@redhat.com>
449- Update to 0.9.2
450
451* Tue Oct 25 2005 Matthias Clasen <mclasen@redhat.com>
452- Update to 0.9.1
453
454* Fri Sep 02 2005 Colin Walters <walters@redhat.com>
455- Add configure flags --with-bonobo --with-dbus
456- BR nautilus-cd-burner-devel
457- New upstream CVS snapshot for testing
458- Drop IDL file and ui .xml
459- Add dbus service file
460- Drop upstreamed rhythmbox-bluecurve.tar.gz
461- Drop upstreamed rhythmbox-0.8.8-cell-renderer.patch
462
463* Fri Jun 13 2005 Colin Walters <walters@redhat.com> - 0.8.8-3
464- Add Bluecurve-ized icons from Jeff Schroeder (157716)
465- Add rhythmbox-0.8.8-cell-renderer.patch to remove use of custom
466  cell renderer for playback icon (no longer necessary) and
467  changes the rating renderer to work with non-b&w icons
468
469* Mon Mar 14 2005 Colin Walters <walters@redhat.com> - 0.8.8-2
470- Rebuild for GCC4
471
472* Tue Oct 05 2004 Colin Walters <walters@redhat.com> - 0.8.8-1
473- New upstream version
474- Remove librb-nautilus-context-menu.so, killed upstream
475
476* Thu Sep 30 2004 Christopher Aillon <caillon@redhat.com> 0.8.7-2
477- PreReq desktop-file-utils >= 0.9
478
479* Sat Sep 29 2004 Colin Walters <walters@redhat.com> - 0.8.7-1
480- New upstream version
481
482* Sat Sep 18 2004 Colin Walters <walters@redhat.com> - 0.8.6-2
483- Fix postun to use correct syntax, thanks Nils Philippsen
484
485* Sat Sep 18 2004 Colin Walters <walters@redhat.com> - 0.8.6-1
486- New upstream version
487- Call update-desktop-database in post and postun
488
489* Thu Jun 24 2004 Colin Walters <walters@redhat.com> - 0.8.5-1
490- New upstream version
491
492* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
493- rebuilt
494
495* Tue May 18 2004 Colin Walters <walters@redhat.com> - 0.8.4-1
496- New upstream version
497- Remove backported patches
498- Gratuitiously bump various BuildRequires versions
499
500* Mon May 10 2004 Colin Walters <walters@redhat.com> - 0.8.3-4
501- Remove code to unregister GConf schema for now (Closes: #122532)
502
503* Thu May 07 2004 Colin Walters <walters@redhat.com> - 0.8.3-3
504- Apply tiny patch from 0.8 arch to fix GConf key used
505  for initial sorting
506
507* Thu May 07 2004 Colin Walters <walters@redhat.com> - 0.8.3-2
508- Apply patch from 0.8 arch tree to fix a number of memleaks
509
510* Thu May 02 2004 Colin Walters <walters@redhat.com> - 0.8.3-1
511- Update to 0.8.3: fixes showstopper bug with internet radio
512
513* Thu Apr 30 2004 Colin Walters <walters@redhat.com> - 0.8.2-1
514- Update to 0.8.2
515- Fix Source url
516- Add smp_mflags
517- Bump BuildRequires on gstreamer to 0.8.1
518
519* Tue Apr 23 2004 Colin Walters <walters@redhat.com> - 0.8.1-2
520- Uninstall GConf schemas on removal
521
522* Tue Apr 20 2004 Colin Walters <walters@redhat.com> - 0.8.1-1
523- Update to 0.8.1
524
525* Fri Apr 16 2004 Colin Walters <walters@redhat.com> - 0.8.0-1
526- Update to 0.8.0
527
528* Fri Apr 02 2004 Colin Walters <walters@redhat.com> - 0.7.2-1
529- Update to 0.7.2
530
531* Mon Mar 29 2004 Colin Walters <walters@redhat.com> - 0.7.1-2
532- Remove BuildRequires on autoconf and libvorbis-devel
533
534* Mon Mar 29 2004 Colin Walters <walters@redhat.com> - 0.7.1-1
535- New major version - I know we are past major version slush, but
536  this should have been done two weeks ago along with the GNOME 2.6
537  upload.  As upstream author as well, I believe this version is
538  good enough for FC2.
539- Remove --disable-mp3
540- Remove id3, flac variables
541- Remove GStreamer major version patch
542- Fix typo in description
543
544* Tue Mar 16 2004 Jeremy Katz <katzj@redhat.com> - 0.6.8-2
545- rebuild for new gstreamer
546
547* Thu Mar 11 2004 Alex Larsson <alexl@redhat.com> 0.6.8-1
548- update to 0.6.8
549
550* Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
551- rebuilt
552
553* Mon Mar  1 2004 Alexander Larsson <alexl@redhat.com> 0.6.7-1
554- update to 0.6.7
555
556* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
557- rebuilt
558
559* Mon Jan 12 2004 Colin Walters <walters@verbum.org> 0.6.4-1
560- New upstream version
561- Don't re-run the autotools; upstream incorporates newer versions.
562* Tue Oct 28 2003 Jonathan Blandford <jrb@redhat.com> 0.5.4-1
563- new version
564- remove smp_flags
565
566* Fri Oct 24 2003 Jonathan Blandford <jrb@redhat.com> 0.5.3-5
567- remove the initial iradio channels as they all are mp3 based.
568
569* Wed Oct  8 2003 Matthias Saou <matthias@rpmforge.net> 0.5.3-3
570- Fix category from Development/Libraries to Applications/Multimedia.
571- Use bz2 instead of gz as ftp.gnome.org has both, 300k saved in the src.rpm.
572- Fix SCHEMES vs. SCHEMAS in the post scriplet.
573- Added gstreamer-plugins-devel, libvorbis-devel, scrollkeeper and gettext deps.
574- Removed unnecessary date expansion define.
575- Updated description, including mp3 reference removal.
576- Added libid3tag and flac optional support for convenient rebuild.
577- Removed obsolete omf.make and xmldocs.make (included ones are the same now).
578
579* Mon Sep 22 2003 Jonathan Blandford <jrb@redhat.com> 0.5.3-1
580- new version
581- use %{_sysconfdir} instead of /etc
582
583* Wed Jan 22 2003 Tim Powers <timp@redhat.com>
584- rebuilt
585
586* Wed Dec 18 2002 Jonathan Blandford <jrb@redhat.com>
587- gave up on other archs for the Beta
588- new version
589- remove werror and add missing files
590
591* Thu Nov  7 2002 Jeremy Katz <katzj@redhat.com>
592- update to newer cvs snap
593
594* Mon Sep 23 2002 Jeremy Katz <katzj@redhat.com>
595- update to cvs snap
596
597* Sun Sep 22 2002 Jeremy Katz <katzj@redhat.com>
598- use %%(lang)
599
600* Sun Aug 11 2002 Jeremy Katz <katzj@redhat.com>
601- fix post to actually install the schema
602
603* Sat Jun 22 2002 Christian F.K. Schaller <Uraeus@linuxrising.org>
604- Added gconf file
605- Added i18n directory
606
607* Sat Jun 15 2002 Christian F.K. Schaller <Uraeus@linuxrising.org>
608- Updated for new rewrite of rhythmbox, thanks to Jeroen
609
610* Mon Mar 18 2002 Jorn Baayen <jorn@nl.linux.org>
611- removed bonobo dependency
612* Sat Mar 02 2002 Christian Schaller <Uraeus@linuxrising.org>
613- created new spec file
Note: See TracBrowser for help on using the repository browser.