source: projects/specs/trunk/r/rhythmbox/rhythmbox-vl.spec @ 4616

Revision 4616, 19.9 KB checked in by Takemikaduchi, 13 years ago (diff)

X.Org, compiz, GNOME3, etc...

Line 
1# -*- coding: utf-8-unix -*-
2%define desktop_file_utils_version 0.9
3
4%define enable_DLNA_UPnP 0
5
6Summary: Music Management Application
7Summary(ja): 音楽管理アプリケーション
8Name: rhythmbox
9Version: 0.13.3
10Release: 3%{?_dist_release}
11License: GPL2+ with exceptions and GFDL
12Group: Applications/Multimedia
13URL: http://projects.gnome.org/rhythmbox/
14Source0: http://download.gnome.org/sources/rhythmbox/0.13/%{name}-%{version}.tar.bz2
15
16Source101:      rhythmbox-png.tar.bz2
17
18Patch0:         rhythmbox-0.13.3-git20110809.patch
19
20BuildRoot: %{_tmppath}/%{name}-%{version}-root
21BuildRequires: avahi-glib-devel >= 0.6
22BuildRequires: brasero-devel >= 2.32.0
23BuildRequires: dbus-devel >= 1.0
24BuildRequires: dbus-glib-devel
25BuildRequires: gnome-vfs2-devel >= 2.18.0
26BuildRequires: gstreamer-plugins-base-devel >= 0.10
27BuildRequires: gstreamer-python-devel
28BuildRequires: json-glib-devel
29BuildRequires: libSM-devel
30BuildRequires: libffi-devel
31BuildRequires: libgnome-keyring-devel >= 2.30.0
32BuildRequires: libgnome-media-profiles-devel
33BuildRequires: libgnomeui-devel >= 2.18.0
34BuildRequires: libgpod-devel
35BuildRequires: libgudev1-devel
36BuildRequires: libmusicbrainz3-devel >= 3.0.2
37BuildRequires: libnotify-devel
38BuildRequires: libsexy-devel
39BuildRequires: libsoup-devel
40BuildRequires: popt-devel
41BuildRequires: python-devel, pygtk2-devel
42BuildRequires: sqlite3-devel
43BuildRequires: totem-pl-parser-devel
44BuildRequires: WebKit3-gtk-devel
45BuildRequires: libpeas-devel
46BuildRequires: clutter-gtk-devel
47BuildRequires: clutter-gst-devel
48BuildRequires: libmx-devel
49BuildRequires: check >= 0.8.2
50BuildRequires: gettext, rarian-compat
51BuildRequires: gnome-doc-utils >= 0.3.2
52BuildRequires: intltool >= 0.35.0
53BuildRequires: libmtp-devel
54BuildRequires: lirc
55Requires: libgpod
56Requires: libnotify
57Requires: libsexy
58Requires: lirc
59Requires: libmtp
60Requires: libgnomeui
61Requires: brasero
62Requires: gnome-python gnome-vfs2
63Requires: gnome-themes
64Requires: libgnome-keyring
65Requires: gstreamer-python
66%if %{enable_DLNA_UPnP}
67Requires: python-Coherence
68%endif
69Requires: desktop-file-utils >= %{desktop_file_utils_version}
70Requires: scrollkeeper GConf2
71
72# # gstreamer-plugins-ffmpeg and gstreamer-plugins-ugly package provided by
73# # self-build-gstreamer-plugins-ffmpeg and self-build-gstreamer-plugins-ugly,
74# # respectively.
75# Requires: self-build-gstreamer-plugins-ffmpeg
76# Requires: self-build-gstreamer-plugins-ugly
77
78Vendor: Project Vine
79Distribution: Vine Linux
80
81
82%description
83Rhythmbox is an integrated music management application based on the powerful
84GStreamer media framework. It has a number of features, including an easy to
85use music browser, searching and sorting, comprehensive audio format support
86through GStreamer, Internet Radio support, playlists and more.
87
88Rhythmbox is extensible through a plugin system.
89
90%description -l ja
91Rhythmbox は、強力な GStreamer メディアフレームワークに基づいている
92統合音楽管理アプリケーションです。
93見やすいユーザインターフェースを備え、検索や整列ができ、
94GStreamer により数多くの音声フォーマットをサポート、
95インターネットラジオをサポート、プレイリスト管理などの
96数多くの特徴を持ちます。
97
98%package devel
99Summary: Development tools for rhythmbox applications.
100Summary(ja): rhythmbox アプリケーションの開発用ファイル
101Group: Development/Libraries
102Requires: %{name} = %{version}-%{release}
103Requires: pkgconfig
104Requires: glib2-devel
105Requires: gtk2-devel
106Requires: libsoup-devel
107Requires: libgnome-media-profiles-devel
108Requires: totem-pl-parser-devel
109Requires: gstreamer-devel
110
111%description devel
112Header files and libraries for building a extension library for the rhythmbox.
113
114%description devel -l ja
115
116%prep
117%setup -q
118%patch0 -p1 -b .git20110730
119tar xjf %{SOURCE101}
120
121# Use the installed louie, not the one in Coherence
122find plugins/coherence/upnp_coherence/ -type f \
123    -exec %__sed -i 's/coherence.extern.louie as louie/louie/' '{}' ';'
124
125%build
126# work around a gstreamer bug
127/usr/bin/gst-inspect-0.10 --print-all >& /dev/null || :
128
129libtoolize --force --copy
130autoreconf
131%configure --with-ipod \
132    --with-mtp \
133    --with-mdns=avahi \
134    --with-libnautilus-burn \
135    --enable-lirc \
136    --enable-python \
137    --disable-vala \
138    --disable-browser-plugin \
139    --disable-static \
140    --disable-scrollkeeper \
141    --disable-schemas-install \
142    --without-hal
143%__make %{?_smp_mflags}
144
145%install
146%__rm -rf $RPM_BUILD_ROOT
147export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
148%__make install DESTDIR=$RPM_BUILD_ROOT
149unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
150
151%__rm -f $RPM_BUILD_ROOT%{_libdir}/bonobo/*.{a,la}
152%__rm -f $RPM_BUILD_ROOT%{_libdir}/bonobo/librb-nautilus-context-menu.so
153%__rm -f $RPM_BUILD_ROOT%{_libdir}/lib*.{a,la}
154%__rm -f $RPM_BUILD_ROOT%{_libdir}/rhythmbox/plugins/*.{a,la}
155%__rm -f $RPM_BUILD_ROOT%{_libdir}/rhythmbox/plugins/*/*.{a,la}
156%__rm -f $RPM_BUILD_ROOT%{_libdir}/librhythmbox-core.{a,la}
157%__rm -f $RPM_BUILD_ROOT%{_libdir}/mozilla/plugins/*.{a,la}
158
159## Don't package DLNA/UPnP plugin
160%if !%{enable_DLNA_UPnP}
161%__rm -rf $RPM_BUILD_ROOT%{_libdir}/rhythmbox/plugins/upnp_coherence
162%endif
163
164%find_lang %{name}
165
166
167# Don't package api docs
168%__rm -rf $RPM_BUILD_ROOT%{_datadir}/gtk-doc/
169
170# Don't package scrollkeeper catalogs
171%__rm -rf $RPM_BUILD_ROOT%{_localstatedir}
172
173# And don't package vala
174%__rm -f %{buildroot}%{_libdir}/rhythmbox/plugins/libsample-vala.so \
175        %{buildroot}%{_libdir}/rhythmbox/plugins/sample-vala.rb-plugin
176
177# save space by linking identical images in translated docs
178helpdir=$RPM_BUILD_ROOT%{_datadir}/gnome/help/%{name}
179for f in $helpdir/C/figures/*.png; do
180  b="$(basename $f)"
181  for d in $helpdir/*; do
182    if [ -d "$d" -a "$d" != "$helpdir/C" ]; then
183      g="$d/figures/$b"
184      if [ -f "$g" ]; then
185        if cmp -s $f $g; then
186          %__rm "$g"; ln -s "../../C/figures/$b" "$g"
187        fi
188      fi
189    fi
190  done
191done
192
193
194%clean
195%__rm -rf $RPM_BUILD_ROOT
196
197%post
198/sbin/ldconfig
199update-desktop-database -q
200scrollkeeper-update -q
201touch --no-create %{_datadir}/icons/hicolor
202if [ -x /usr/bin/gtk-update-icon-cache ]; then
203  gtk-update-icon-cache -q %{_datadir}/icons/hicolor
204fi
205
206%postun
207/sbin/ldconfig
208update-desktop-database -q
209scrollkeeper-update -q
210touch --no-create %{_datadir}/icons/hicolor
211if [ -x /usr/bin/gtk-update-icon-cache ]; then
212  gtk-update-icon-cache -q %{_datadir}/icons/hicolor
213fi
214glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
215
216%posttrans
217glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
218
219
220%files -f %{name}.lang
221%defattr(-, root, root)
222%doc AUTHORS COPYING ChangeLog README NEWS
223%{_bindir}/*
224%{_libdir}/girepository-1.0/*.typelib
225%{_libdir}/lib*.so.*
226%{_libdir}/rhythmbox/plugins
227%{_datadir}/applications/rhythmbox.desktop
228%{_datadir}/applications/rhythmbox-device.desktop
229%{_datadir}/dbus-1/services/org.gnome.Rhythmbox.service
230%{_datadir}/glib-2.0/schemas/org.gnome.rhythmbox.gschema.xml
231%{_datadir}/gnome/help/rhythmbox
232%{_datadir}/icons/*
233%{_datadir}/omf/rhythmbox
234%{_datadir}/rhythmbox
235%{_mandir}/man1/*
236%{_libexecdir}/rhythmbox-metadata
237
238%files devel
239%defattr(-, root, root)
240%{_includedir}/%{name}/*
241%{_libdir}/*.so
242%{_libdir}/pkgconfig/*.pc
243%{_datadir}/gir-1.0/*.gir
244
245
246%changelog
247* Wed Aug 17 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.3-3
248- rebuild with libnotify-0.7
249- change BuildRequires: libmusicbrainz3-devel instead of libmusicbrainz-devel
250- change BuildRequires: libgnome-media-profiles-devel instead of gnome-media-devel
251- add BuildRequires: WebKit3-gtk-devel, libpeas-devel, clutter-gtk-devel, clutter-gst-devel, libmx-devel
252- add Patch0 (rhythmbox-0.13.3-git20110809.patch)
253- add Source101 (rhythmbox-png.tar.bz2)
254
255* Fri Aug 12 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.3-2
256- add BuildRequires: json-glib-devel
257- remove unrecognized configure option (--with-dbus, --with-cd-burning, --with-metadata-helper)
258
259* Sun Jan 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.3-1
260- new upstream release
261- change BuildRequires: gstreamer-python-devel instead of gstreamer-python
262
263* Sat Nov 06 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.2-1
264- new upstream release
265
266* Wed Oct 06 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.1-3
267- rebuild with brasero-2.32.0
268
269* Sun Sep 26 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.1-2
270- rebuild with rpm-4.8.1 for pkg-config file
271
272* Sun Sep 12 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.1-1
273- new upstream release
274- fix %files (add rhythmbox-device.desktop)
275
276* Sun Aug 29 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.0-1
277- new upstream release
278- change BuildRequires: gnome-media-devel instead of gnome-media
279- add devel package
280- drop Patch0
281
282* Sun Mar 14 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.12.8-1
283- new upstream release
284- drop Patch1, Patch2, Patch3
285- change BuildRequires: nautilus-cd-burner -> brasero-devel
286- change Requires: nautilus-cd-burner -> brasero
287- change BuildRequires: hal-devel -> libgudev1-devel
288- change BuildRequires: gnome-keyring-devel -> libgnome-keyring-devel
289- change Requires: gnome-keyring -> libgnome-keyring
290- add configure option (--without-hal)
291
292* Mon Feb 15 2010 Shu KONNO <owa@bg.wakwak.com> 0.12.6-2
293- rebuilt with new environment
294
295* Thu Jan 14 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.12.6-1
296- new upstream release
297  - dropped upstreamed/obsolete patches
298  - added patches applied Fedora development
299
300* Sun Oct 04 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.12.5-1
301- new upstream release
302- added configure options:
303  --disable-vala
304  --disable-browser-plugin
305
306* Thu Jul 30 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.12.2-2
307- added Japanese description
308
309* Thu Jul 02 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.12.2-1
310- new upstream release
311  - dropped rb-disable-power-plugin-by-default.patch
312- added BuildRequires:
313  - libSM-devel
314  - gnome-media
315
316* Wed Jun 10 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.12.1-2
317- rebuild with libgpod-0.7.2
318
319* Sun May 03 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.12.1-1
320- new upstream release
321- corrected License tag
322- dropped rhythmbox-0.11.6-libmtp.patch
323- added BuildRequires:
324  - sqlite3-devel
325  - libffi-devel
326
327* Sat Jan 10 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.11.6-2
328- defined enable_DLNA_UPnP = 0: unpacked DLNA/UPnP plugin
329- applied rhythmbox-0.11.6-libmtp.patch
330- added Requires:
331  - libgpod
332  - libnotify
333  - libsexy
334  - lirc
335  - libmtp
336  - libgnomeui
337  - nautilus-cd-burner
338  - gstreamer-python
339  - gnome-vfs2
340  - gnome-themes
341  - gnome-keyring
342  - python-Coherence, if enable_DLNA_UPnP = 1
343- added BuildRequires:
344  - libnotify-devel
345  - libsexy-devel
346  - lirc
347  - libmtp-devel
348  - gnome-vfs2-devel, instead of gnome-vfs2
349  - gnome-keyring-devel
350- dropped --with-internal-libsexy in configure options
351- added in configure options:
352  --with-mtp --with-libnautilus-burn --enable-lirc --disable-static
353- added %%preun to remove the schema
354
355* Sun Jan 04 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.11.6-1
356- new upstream release
357- changed to --with-metadata-helper in configure options
358- added BuildRequires:
359  - gstreamer-python
360  - intltool >= 0.35.0
361  - popt-devel
362
363* Sat Aug 09 2008 Shu KONNO <owa@bg.wakwak.com> 0.11.2-1vl5
364- added BuildRequires: totem-pl-parser-devel, instead of totem-devel
365- rebuilt with python-2.5.2
366- applied new versioning policy
367- spec in utf-8
368
369* Sun Jan 06 2008 Shu KONNO <owa@bg.wakwak.com> 0.11.2-0vl2
370- rebuilt with libgpod-0.6.0
371
372* Sun Aug 26 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.11.2-0vl1
373- new upstream release
374
375* Wed Jun 27 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.11.1-0vl1
376- new upstream release
377
378* Tue May 29 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.10.0-0vl2
379- rebuilt with new toolchain and libgpod-0.4.2
380- add BuildRequires: dbus-glib-devel
381
382* Sat Apr 28 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.10.0-0vl1
383- new upstream release
384
385* Wed Mar 21 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.8-0vl2
386- rebuilt for VineSeed
387
388* Wed Mar 21 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.8-0vl1
389- new upstream release
390- added --enable-python option to %%configure
391- added Requires: gnome-python
392
393* Sun Jan 21 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.7-0vl1
394- new upstream release
395- built with libsoup 2.2.99
396
397* Thu Nov 23 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.6-0vl4
398- added --with-cd-burner to configure
399- added BuildRequires: libsexy-devel hal-devel libsoup-devel
400
401* Wed Oct 25 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.9.6-0vl3
402- add BuildRequires:
403  - gnome-doc-utils >= 0.3.2
404  - python-devel
405  - pygtk2-devel
406  - check >= 0.8.2
407
408* Tue Oct 24 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.9.6-0vl2
409- rebuild with gnutls-1.4.1
410
411* Sun Oct  1 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.6-0vl1
412- new upstream release
413
414* Mon Jun 19 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.5-0vl1
415- new upstream release
416- run scrollkeeper-update at %post and %postun
417- added BuildRequires: libnotify-devel
418
419* Sun May 14 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.4.1-0vl1
420- new upstream release (dropped patch0)
421- added --without-metadata-helper at configure
422
423* Mon Mar 13 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.3.1-0vl1
424- Initial build for Vine Linux based on FC pacakge
425
426* Fri Mar 03 2006 Ray Strode <rstrode@redhat.com> - 0.9.3.1-2
427- add patch from James "Doc" Livingston to stop a hang
428  for new users (bug 183883)
429
430* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 0.9.3.1-1.2
431- bump again for double-long bug on ppc(64)
432
433* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 0.9.3.1-1.1
434- rebuilt for new gcc4.1 snapshot and glibc changes
435
436* Sat Feb  4 2006 Christopher Aillon <caillon@redhat.com> 0.9.3.1-1
437- Update to 0.9.3.1
438- Use gstreamer (0.10)
439
440* Wed Feb  1 2006 Christopher Aillon <caillon@redhat.com> 0.9.3-2
441- Remove hack for 173869, as its no longer needed.
442
443* Wed Feb  1 2006 Christopher Aillon <caillon@redhat.com> 0.9.3-1
444- 0.9.3
445
446* Wed Feb  1 2006 Christopher Aillon <caillon@redhat.com> 0.9.2.cvs20060201-1
447- Newer CVS snapshot
448
449* Sun Jan 22 2006 Christopher Aillon <caillon@redhat.com> 0.9.2.cvs20060123-1
450- Update to latest CVS
451- Add hack to workaround bug #173869
452
453* Thu Jan 19 2006 Christopher Aillon <caillon@redhat.com> 0.9.2-8
454- Rebuild, now that gstreamer08-plugins has been fixed
455
456* Thu Jan 19 2006 Ray Strode <rstrode@redhat.com> 0.9.2-7
457- bonobo multilib issue (bug 156982)
458
459* Wed Jan 04 2006 John (J5) Palmieri <johnp@redhat.com> 0.9.2-5
460- rebuild with ipod support
461
462* Tue Jan 03 2006 Jesse Keating <jkeating@redhat.com> 0.9.2-4
463- rebuilt again
464
465* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
466- rebuilt
467
468* Mon Dec  5 2005 Matthias Clasen <mclasen@redhat.com>
469- rebuild
470
471* Thu Dec 01 2005 John (J5) Palmieri <johnp@redhat.com>
472- rebuild for new dbus
473
474* Wed Nov 30 2005 Matthias Clasen <mclasen@redhat.com>
475- Update to 0.9.2
476
477* Tue Oct 25 2005 Matthias Clasen <mclasen@redhat.com>
478- Update to 0.9.1
479
480* Fri Sep 02 2005 Colin Walters <walters@redhat.com>
481- Add configure flags --with-bonobo --with-dbus
482- BR nautilus-cd-burner-devel
483- New upstream CVS snapshot for testing
484- Drop IDL file and ui .xml
485- Add dbus service file
486- Drop upstreamed rhythmbox-bluecurve.tar.gz
487- Drop upstreamed rhythmbox-0.8.8-cell-renderer.patch
488
489* Fri Jun 13 2005 Colin Walters <walters@redhat.com> - 0.8.8-3
490- Add Bluecurve-ized icons from Jeff Schroeder (157716)
491- Add rhythmbox-0.8.8-cell-renderer.patch to remove use of custom
492  cell renderer for playback icon (no longer necessary) and
493  changes the rating renderer to work with non-b&w icons
494
495* Mon Mar 14 2005 Colin Walters <walters@redhat.com> - 0.8.8-2
496- Rebuild for GCC4
497
498* Tue Oct 05 2004 Colin Walters <walters@redhat.com> - 0.8.8-1
499- New upstream version
500- Remove librb-nautilus-context-menu.so, killed upstream
501
502* Thu Sep 30 2004 Christopher Aillon <caillon@redhat.com> 0.8.7-2
503- PreReq desktop-file-utils >= 0.9
504
505* Sat Sep 29 2004 Colin Walters <walters@redhat.com> - 0.8.7-1
506- New upstream version
507
508* Sat Sep 18 2004 Colin Walters <walters@redhat.com> - 0.8.6-2
509- Fix postun to use correct syntax, thanks Nils Philippsen
510
511* Sat Sep 18 2004 Colin Walters <walters@redhat.com> - 0.8.6-1
512- New upstream version
513- Call update-desktop-database in post and postun
514
515* Thu Jun 24 2004 Colin Walters <walters@redhat.com> - 0.8.5-1
516- New upstream version
517
518* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
519- rebuilt
520
521* Tue May 18 2004 Colin Walters <walters@redhat.com> - 0.8.4-1
522- New upstream version
523- Remove backported patches
524- Gratuitiously bump various BuildRequires versions
525
526* Mon May 10 2004 Colin Walters <walters@redhat.com> - 0.8.3-4
527- Remove code to unregister GConf schema for now (Closes: #122532)
528
529* Thu May 07 2004 Colin Walters <walters@redhat.com> - 0.8.3-3
530- Apply tiny patch from 0.8 arch to fix GConf key used
531  for initial sorting
532
533* Thu May 07 2004 Colin Walters <walters@redhat.com> - 0.8.3-2
534- Apply patch from 0.8 arch tree to fix a number of memleaks
535
536* Thu May 02 2004 Colin Walters <walters@redhat.com> - 0.8.3-1
537- Update to 0.8.3: fixes showstopper bug with internet radio
538
539* Thu Apr 30 2004 Colin Walters <walters@redhat.com> - 0.8.2-1
540- Update to 0.8.2
541- Fix Source url
542- Add smp_mflags
543- Bump BuildRequires on gstreamer to 0.8.1
544
545* Tue Apr 23 2004 Colin Walters <walters@redhat.com> - 0.8.1-2
546- Uninstall GConf schemas on removal
547
548* Tue Apr 20 2004 Colin Walters <walters@redhat.com> - 0.8.1-1
549- Update to 0.8.1
550
551* Fri Apr 16 2004 Colin Walters <walters@redhat.com> - 0.8.0-1
552- Update to 0.8.0
553
554* Fri Apr 02 2004 Colin Walters <walters@redhat.com> - 0.7.2-1
555- Update to 0.7.2
556
557* Mon Mar 29 2004 Colin Walters <walters@redhat.com> - 0.7.1-2
558- Remove BuildRequires on autoconf and libvorbis-devel
559
560* Mon Mar 29 2004 Colin Walters <walters@redhat.com> - 0.7.1-1
561- New major version - I know we are past major version slush, but
562  this should have been done two weeks ago along with the GNOME 2.6
563  upload.  As upstream author as well, I believe this version is
564  good enough for FC2.
565- Remove --disable-mp3
566- Remove id3, flac variables
567- Remove GStreamer major version patch
568- Fix typo in description
569
570* Tue Mar 16 2004 Jeremy Katz <katzj@redhat.com> - 0.6.8-2
571- rebuild for new gstreamer
572
573* Thu Mar 11 2004 Alex Larsson <alexl@redhat.com> 0.6.8-1
574- update to 0.6.8
575
576* Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
577- rebuilt
578
579* Mon Mar  1 2004 Alexander Larsson <alexl@redhat.com> 0.6.7-1
580- update to 0.6.7
581
582* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
583- rebuilt
584
585* Mon Jan 12 2004 Colin Walters <walters@verbum.org> 0.6.4-1
586- New upstream version
587- Don't re-run the autotools; upstream incorporates newer versions.
588* Tue Oct 28 2003 Jonathan Blandford <jrb@redhat.com> 0.5.4-1
589- new version
590- remove smp_flags
591
592* Fri Oct 24 2003 Jonathan Blandford <jrb@redhat.com> 0.5.3-5
593- remove the initial iradio channels as they all are mp3 based.
594
595* Wed Oct  8 2003 Matthias Saou <matthias@rpmforge.net> 0.5.3-3
596- Fix category from Development/Libraries to Applications/Multimedia.
597- Use bz2 instead of gz as ftp.gnome.org has both, 300k saved in the src.rpm.
598- Fix SCHEMES vs. SCHEMAS in the post scriplet.
599- Added gstreamer-plugins-devel, libvorbis-devel, scrollkeeper and gettext deps.
600- Removed unnecessary date expansion define.
601- Updated description, including mp3 reference removal.
602- Added libid3tag and flac optional support for convenient rebuild.
603- Removed obsolete omf.make and xmldocs.make (included ones are the same now).
604
605* Mon Sep 22 2003 Jonathan Blandford <jrb@redhat.com> 0.5.3-1
606- new version
607- use %{_sysconfdir} instead of /etc
608
609* Wed Jan 22 2003 Tim Powers <timp@redhat.com>
610- rebuilt
611
612* Wed Dec 18 2002 Jonathan Blandford <jrb@redhat.com>
613- gave up on other archs for the Beta
614- new version
615- remove werror and add missing files
616
617* Thu Nov  7 2002 Jeremy Katz <katzj@redhat.com>
618- update to newer cvs snap
619
620* Mon Sep 23 2002 Jeremy Katz <katzj@redhat.com>
621- update to cvs snap
622
623* Sun Sep 22 2002 Jeremy Katz <katzj@redhat.com>
624- use %%(lang)
625
626* Sun Aug 11 2002 Jeremy Katz <katzj@redhat.com>
627- fix post to actually install the schema
628
629* Sat Jun 22 2002 Christian F.K. Schaller <Uraeus@linuxrising.org>
630- Added gconf file
631- Added i18n directory
632
633* Sat Jun 15 2002 Christian F.K. Schaller <Uraeus@linuxrising.org>
634- Updated for new rewrite of rhythmbox, thanks to Jeroen
635
636* Mon Mar 18 2002 Jorn Baayen <jorn@nl.linux.org>
637- removed bonobo dependency
638* Sat Mar 02 2002 Christian Schaller <Uraeus@linuxrising.org>
639- created new spec file
Note: See TracBrowser for help on using the repository browser.