source: projects/specs/trunk/r/rhpl/rhpl-vl.spec @ 521

Revision 521, 22.8 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%{!?python_sitearch: %define python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
2
3Summary: Library of python code used by programs in Vine Linux
4Summary(ja): Vine Linux で利用する python コードライブラリ
5Name: rhpl
6Version: 0.216
7Release: 4%{?_dist_release}
8Source0: %{name}-%{version}.tar.bz2
9Patch0: %{name}-0.216-compat.patch
10License: GPL
11Group: System Environment/Libraries
12BuildRoot: %{_tmppath}/%{name}-root
13BuildRequires: python-devel, gettext
14Requires: python >= %(%{__python} -c "import sys; print sys.version[:3]")
15Requires: pyxf86config >= 0.3.2
16
17%description
18The rhpl package contains Python code used by programs in Vine Linux.
19
20%prep
21%setup -q
22%patch0 -p1 -b .compat
23
24perl -pi -e 's/python2.3/python2.4/g' Makefile.inc src/*
25perl -pi -e 's/xgettext /xgettext --from-code=UTF-8 /g' po/Makefile
26
27%build
28%__make
29
30%install
31rm -rf $RPM_BUILD_ROOT
32make DESTDIR=${RPM_BUILD_ROOT} install
33
34%find_lang %name
35
36%clean
37rm -rf $RPM_BUILD_ROOT
38
39%files -f %{name}.lang
40%defattr(-,root,root)
41%doc README COPYING
42%{python_sitearch}/rhpl
43
44%changelog
45* Tue Feb 02 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 0.216-4
46- rebuild with python-2.6
47
48* Wed Mar 11 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.216-3
49- disable deprecate warning in log.py
50
51* Tue Feb 24 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.216-2
52- add comps.py from rhpl-0.146.3
53
54* Mon Aug 11 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.216-1
55- new upstream release
56
57* Tue May 22 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.148.3-0vl17
58- add "--from-code" option to xgettext
59
60* Thu Nov 16 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.148.3-0vl16
61- update vine patch
62  - add some fontpath (<BTS:371>)
63  - add nv panel size detection code.
64
65* Wed Nov 01 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.148.3-0vl15
66- update vine patch
67  - remove unsupported (larger) display from Modes list.
68
69* Tue Oct 31 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.148.3-0vl14
70- update vine patch
71  - set desired_resolution from LCD panel resolution.
72
73* Wed Oct 25 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.148.3-0vl13
74- apply new compare_resolution algorism for all arch. (<BTS:301>)
75
76* Sun Oct 08 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.148.3-0vl12
77- update vine patch
78  - fix radeon panel size detection code.
79
80* Wed Sep 20 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.148.3-0vl11
81- don't apply Patch60 on ppc
82
83* Wed Sep 20 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.148.3-0vl10
84- add more extra modelines
85
86* Wed Sep 20 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.148.3-0vl9
87- add extra modeline to extramodes
88
89* Thu Sep 14 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.148.3-0vl8
90- add Patch50 to guess unprobed mouse as generic mouse.
91
92* Fri Sep 08 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.148.3-0vl7
93- add Patch40 for ppc
94
95* Sat Sep 02 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.148.3-0vl6
96- add Patch30 to modifiy keyboard_models
97
98* Thu Aug 31 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.148.3-0vl5
99- update vine patch
100  - detect i810 panel size
101
102* Tue Aug 29 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.148.3-0vl4
103- update vine patch
104  - add more display resolutions
105
106* Thu Aug 24 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.148.3-0vl3
107- replace obsolete gtk.{TRUE,FALSE} with {True,False}
108
109* Tue Aug 22 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.148.3-0vl2
110- fix default X settings
111- add VMWare monitor hacks
112
113* Wed Aug 16 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.148.3-0vl1
114- initial build for Vine Linux
115
116* Fri Jul  8 2005 Jeremy Katz <katzj@redhat.com> - 0.148.3-1
117- fix indic keyboards (#158139)
118
119* Wed Nov 17 2004 Jeremy Katz <katzj@redhat.com> - 0.148.2-1
120- add patch from Jim Parsons to add executil.execWithCaptureErrorStatus as
121  needed by system-config-lvm
122
123* Tue Nov 16 2004 Paul Nasrat <pnasrat@redhat.com> - 0.148.1-1
124- RHEL4 remove synaptics
125
126* Wed Oct 13 2004 Paul Nasrat <pnasrat@redhat.com> - 0.148-1
127- Indic keyboard fixups
128- Multi-input synaptics
129- require synaptics
130- Less verbose ddcprobe
131
132* Thu Sep 30 2004 Harald Hoyer <harald@redhat.com> - 0.147-1
133- let Conf.ConfModules use modprobe.conf name and format (bug 131952)
134- use network script resolv.conf merger/changer (bug 132485)
135
136* Fri Sep 24 2004 Jeremy Katz <katzj@redhat.com>
137- require python (#133462)
138
139* Wed Sep 22 2004 Jeremy Katz <katzj@redhat.com> - 0.146-1
140- add synaptics support (pnasrat)
141- add arabic and indic keyboards (pnasrat)
142
143* Fri Jun 18 2004 Jeremy Katz <katzj@redhat.com> - 0.145-1
144- improved lib64 detection, rebuild with gcc 3.4
145
146* Wed May  5 2004 Jeremy Katz <katzj@redhat.com> - 0.144-1
147- open cd device with O_NONBLOCK so eject ioctl works (#122524)
148
149* Tue Apr 20 2004 Brent Fox <bfox@redhat.com> 0.143-1
150- Do not write out XkbRules line to config file, as it is unnecessary to hard
151  code the rules file, which has a built in default which should always
152  work. (#120858)
153
154* Fri Apr 16 2004 Jeremy Katz <katzj@redhat.com> - 0.142-1
155- more XFree86->xorg
156
157* Thu Apr 15 2004 Jeremy Katz <katzj@redhat.com> - 0.141-1
158- xserver.py: workaround libxf86config not writing out the monitor stuff
159  we tell it to (#120950)
160
161* Wed Apr 14 2004 Jeremy Katz <katzj@redhat.com> - 0.140-1
162- translate.py: one more try at string encoding madness (#119391)
163
164* Tue Apr 13 2004 Jeremy Katz <katzj@redhat.com> - 0.139-1
165- videocard.py: fixups for VESA handling on x86_64
166- videocard.py, xserver.py: XFree86 -> Xorg changes
167
168* Wed Mar 17 2004 Bill Nottingham <notting@redhat.com> 0.138-1
169- mouse.py cleanups
170
171* Tue Mar 16 2004 Bill Nottingham <notting@redhat.com> 0.135-1
172- remove old default keymap when writing config (#116852)
173
174* Tue Mar  9 2004 Brent Fox <bfox@redhat.com> 0.134-1
175- user fr-latin9 for the X keymap too (bug #113672)
176
177* Tue Mar  9 2004 Jeremy Katz <katzj@redhat.com> - 0.133-1
178- use vesa for unknown cards on x86_64
179
180* Fri Mar  5 2004 Brent Fox <bfox@redhat.com> 0.132-1
181- use fr-latin9 instead of fr-latin0 (bug #113672)
182
183* Thu Mar  4 2004 Jeremy Katz <katzj@redhat.com> - 0.131-1
184- switch some default keyboard layouts (#117007)
185
186* Thu Mar  4 2004 Brent Fox <bfox@redhat.com> 0.130-1
187- strip out refresh rate data (bug #117327)
188
189* Wed Mar  3 2004 Brent Fox <bfox@redhat.com> 0.129-1
190- enable DRI extentions for all i386, x86_64, and ia64 systems (bug #115672)
191- vmware doesn't do 24bpp (#117375)
192- fix for savage + lcds (#117079)
193
194* Thu Feb 26 2004 Brent Fox <bfox@redhat.com> 0.128-1
195- add some hooks to xhwstate.py to get PCI bus ID info
196
197* Fri Feb 20 2004 Brent Fox <bfox@redhat.com> 0.127-2
198- correct a typo
199
200* Fri Feb 20 2004 Brent Fox <bfox@redhat.com> 0.127-1
201- changes to mouse handling in xhwstate.py
202
203* Wed Feb 18 2004 Jeremy Katz <katzj@redhat.com> 0.126-1
204- minor tweak for mouse stuff
205
206* Fri Feb 13 2004 Brent Fox <bfox@redhat.com> 0.125.1-1
207- use hu_qwerty for Hungarian (101 key) (bug #114629)
208
209* Thu Jan 22 2004 Jeremy Katz <katzj@redhat.com> 0.124.1-1
210- translate.py: minor tweaks
211
212* Tue Jan 20 2004 Jeremy Katz <katzj@redhat.com> 0.124-1
213- translate.py: return UTF-8 encoded strings (#113202)
214
215* Thu Jan  8 2004 Brent Fox <bfox@redhat.com> 0.123.1-1
216- add an entry for Korean keyboards (bug #112024)
217
218* Tue Jan  6 2004 Jeremy Katz <katzj@redhat.com>
219- mark keyboard model names as keyboard|name to make them differ
220  from language names (#84969)
221
222* Tue Dec 16 2003 Jeremy Katz <katzj@redhat.com>
223- use EISA if name doesn't exist in ddc data (#112281)
224
225* Fri Nov 14 2003 Jeremy Katz <katzj@redhat.com> 0.122.2-1
226- more python2.3
227
228* Sat Nov  8 2003 Jeremy Katz <katzj@redhat.com> 0.122.1-1
229- more python 2.3 fixups
230
231* Thu Nov  6 2003 Jeremy Katz <katzj@redhat.com> 0.122-1
232- python 2.3
233
234* Tue Oct 21 2003 Jeremy Katz <katzj@redhat.com> 0.121-1
235- don't try to use 24bpp on old hardware (#105713)
236
237* Thu Oct 16 2003 Brent Fox <bfox@redhat.com> 0.120-1
238- mouse.py - add two entries for optical mice
239
240* Thu Oct 16 2003 Jeremy Katz <katzj@redhat.com> 0.119-1
241- keyboard_models.py: fix greek keyboard layout (#100773)
242
243* Wed Oct 15 2003 Jeremy Katz <katzj@redhat.com> 0.118-1
244- translate.py: assume UTF-8 if we can't figure out the encoding of a mofile
245
246* Thu Oct  8 2003 Michael Fulbright <msf@redhat.com> 0.117-1
247- xhwstate.py - dont write out video ram option to XF86Config
248
249* Thu Oct  2 2003 Brent Fox <bfox@redhat.com> 0.116-1
250- videocard.py: added pci busID functions
251
252* Tue Sep 30 2003 Jeremy Katz <katzj@redhat.com> 0.115-1
253- mouse.py: add new API and make sane to use for translation
254
255* Thu Sep 25 2003 Harald Hoyer <harald@redhat.de> 0.114-1
256- preserve comments in modules.conf #76640
257
258* Tue Sep 23 2003 Michael Fulbright <msf@redhat.com>
259- fix bug dealing with determining video modes supported by a monitor
260
261* Mon Sep  8 2003 Jeremy Katz <katzj@redhat.com>
262- use RPM_OPT_FLAGS (#103970)
263
264* Thu Sep 04 2003 Harald Hoyer <harald@redhat.de> 0.112-1
265- fixed ConfPAP.getfields()
266
267* Thu Sep 04 2003 Michael Fulbright <msf@redhat.com> 0.111-1
268- fixes for bugzilla #103353
269
270* Tue Sep 02 2003 Michael Fulbright <msf@redhat.com> 0.111-1
271- fixes to X setup code
272
273* Fri Aug 29 2003 Harald Hoyer <harald@redhat.de> 0.110-1
274- removed memory leak
275
276* Wed Jul 16 2003 Jeremy Katz <katzj@redhat.com> 0.110-1
277- add an interface for adding packages to groups
278
279* Mon Jul 14 2003 Jeremy Katz <katzj@redhat.com> 0.109-1
280- multilib on ia64
281
282* Wed Jul 09 2003 Harald Hoyer <harald@redhat.de> 0.108-3
283- rebuilt with all files updated from cvs
284
285* Tue Jul  8 2003 Jeremy Katz <katzj@redhat.com> 0.108-1
286- comps.py: preserve xml doc/nodes
287- translate.py: make it so we can use translations from update disks in
288  anaconda
289
290* Thu Jun 12 2003 Brent Fox <bfox@redhat.com> 0.107-1
291- add a get_xconfig() method to xhwstate.py
292
293* Tue Jun 10 2003 Harald Hoyer <harald@redhat.de> 0.106-1
294- better regexp in Conf.py
295- strip filename from subject
296
297* Fri Jun  6 2003 Jeremy Katz <katzj@redhat.com> 0.105-1
298- more biarch fun
299
300* Wed Jun  4 2003 Jeremy Katz <katzj@redhat.com> 0.104-1
301- add ppc64[ip]series
302
303* Wed Jun  4 2003 Jeremy Katz <katzj@redhat.com> 0.103.1-1
304- arch.py tweaks
305
306* Fri May 30 2003 Jeremy Katz <katzj@redhat.com> 0.103-1
307- comps.py extensions for biarch
308
309* Fri May 23 2003 Jeremy Katz <katzj@redhat.com> 0.102.1-1
310- fix tyop
311
312* Fri May 23 2003 Jeremy Katz <katzj@redhat.com> 0.102-1
313- add arch.py
314
315* Wed May 21 2003 Harald Hoyer <harald@redhat.de> 0.101.1-1
316- strip quotes from PAP/CHAP server also
317- Conf.py, cope with lines at the end of the file, that have no newline
318- speedup some things
319
320* Wed May 07 2003 Michael Fulbright <msf@redhat.com> 0.100.1-1
321- fixed simpleconfig.py and how it uppercases keys
322
323* Tue Apr 29 2003 Harald Hoyer <harald@redhat.com> 0.99.1-1
324- genClass and ethtool updates
325
326* Thu Apr 24 2003 Brent Fox <bfox@redhat.com> 0.98.1-2
327- strip an invalid char from monitor name (bug #87588)
328
329* Wed Apr 23 2003 Jeremy Katz <katzj@redhat.com> 0.98.1-1
330- revert broken part of pseries fb change
331
332* Mon Apr 21 2003 Jeremy Katz <katzj@redhat.com> 0.98-1
333- handle headless case better
334
335* Fri Apr 18 2003 Jeremy Katz <katzj@redhat.com> 0.97-1
336- fixes so that framebuffer can work for use on ppc machines
337
338* Thu Apr  3 2003 Brent Fox <bfox@redhat.com> 0.96-2
339- update the list of dri drivers from mharris
340
341* Thu Apr  3 2003 Brent Fox <bfox@redhat.com> 0.96-1
342- add ati and i810 to dri supported list in xhwstate.py
343
344* Wed Apr  2 2003 Brent Fox <bfox@redhat.com> 0.95-1
345- allow dialog size to be passed into firstboot_gui_window
346
347* Thu Feb 27 2003 Bill Nottingham <notting@redhat.com> 0.94-1
348- make py_bind_textdomain_codeset not segfault on ia64 (#85334)
349
350* Mon Feb 24 2003 Jeremy Katz <katzj@redhat.com> 0.93-1
351- mouse.py (mouseWindow): try to ensure we have a locale that
352  we can do linedrawing chars for (#84908)
353
354* Wed Feb 12 2003 Brent Fox <bfox@redhat.com> 0.92-1
355- add grp_led:scroll to all lines with XkbOptions (bug #82096)
356
357* Tue Feb 11 2003 Brent Fox <bfox@redhat.com> 0.91-1
358- convert all toggles to grp:shift_toggle (bug #79287)
359
360* Fri Feb  7 2003 Brent Fox <bfox@redhat.com> 0.90-1
361- add grp_led:scroll to all Russian keyboards
362
363* Fri Feb  7 2003 Brent Fox <bfox@redhat.com> 0.89-1
364- add translate.textdomain('rhpl') to fix bug #69760
365
366* Thu Feb  6 2003 Matt Wilson <msw@redhat.com> 0.88-1
367- only reset the mouse if you have to
368
369* Thu Feb  6 2003 Brent Fox <bfox@redhat.com> 0.87-1
370- load additional us keymap for all ru keyboards in keyboard_models.py
371- make sure the kbd option gets set in keyboard.py
372
373* Thu Feb  6 2003 Brent Fox <bfox@redhat.com> 0.86-1
374- use sv-latin1 for swedish keyboards (bug #80508)
375
376* Wed Feb  5 2003 Matt Wilson <msw@redhat.com> 0.85-1
377- autodetect ps/2 wheel mice (#81902)
378
379* Wed Feb  5 2003 Brent Fox <bfox@redhat.com> 0.84-1
380- if there are no display Modes in the XF86Config file, create one and default to 800x600 (bug #83314)
381
382* Tue Feb 04 2003 Harald Hoyer <harald@redhat.de> 0.83-1
383- ConfPAP fix for quotation
384
385* Fri Jan 31 2003 Jeremy Katz <katzj@redhat.com> 0.81-2
386- fix typo
387
388* Fri Jan 31 2003 Adrian Likins <alikins@redhat.com>
389- added get_ipaddr, get_netmask, get_broadcast
390  to ethtool module
391
392* Fri Jan 31 2003 Harald Hoyer <harald@redhat.de>
393- added some BuildRequires
394
395* Thu Jan 30 2003 Jeremy Katz <katzj@redhat.com> 0.80-1
396- default non-i386 arches to 8 megs of videoram
397
398* Wed Jan 22 2003 Brent Fox <bfox@redhat.com> 0.79-1
399- add us keymap and XkbOptions to non-latin keymaps in keyboard_models.py
400- change keyboard.py to handle the XkbOptions field
401
402* Mon Jan 20 2003 Michael Fulbright <msf@redhat.com> 0.78-1
403- improved code for LCD guessing
404
405* Fri Jan 17 2003 Michael Fulbright <msf@redhat.com> 0.77-1
406- added code to xserver.py to guess LCD size using guesslcd.py
407
408* Fri Jan 17 2003 Brent Fox <bfox@redhat.com> 0.76-1
409- changes to firstbootGuiWindow.py for new firstboot look
410
411* Tue Jan 14 2003 Michal Fulbright <msf@redhat.com> 0.75-1
412- fix xserver.py to include keyboard import
413
414* Fri Jan 10 2003 Brent Fox <bfox@redhat.com> 0.74-2
415- change se-latin1 kbd to se-fi-lat6 according to bug #80508
416
417* Fri Jan  3 2003 Brent Fox <bfox@redhat.com> 0.74-1
418- default to pc105 for most keyboards
419
420* Thu Jan  2 2003 Jeremy Katz <katzj@redhat.com> 0.73-3
421- make the translate.py change less noisy
422
423* Thu Jan  2 2003 Jeremy Katz <katzj@redhat.com> 0.73-2
424- typo fix
425
426* Wed Jan  1 2003 Jeremy Katz <katzj@redhat.com> 0.73-1
427- discid.py: add readFromBuffer
428
429* Sun Dec 29 2002 Jeremy Katz <katzj@redhat.com>
430- translate.py: if we fail, at least gracefully fall back instead of
431  causing a traceback (#76104)
432
433* Thu Dec 19 2002 Harald Hoyer <harald@redhat.de> 0.72-1
434- added exception.py
435
436* Tue Dec 17 2002 Jeremy Katz <katzj@redhat.com> 0.71-2
437- fix silly typo
438
439* Tue Dec 17 2002 Jeremy Katz <katzj@redhat.com> 0.71-1
440- simpleconfig.py: gracefully handle non-existent config files
441
442* Mon Dec 16 2002 Harald Hoyer <harald@redhat.de> 0.70-1
443- _setParent() in GenClass::__setitem__
444
445* Fri Dec 13 2002 Jeremy Katz <katzj@redhat.com> 0.69-1
446- only probe for the mouse once to fix mouse probing problems
447- make keyboard names more consistent (#79354)
448
449* Thu Dec 12 2002 Harald Hoyer <harald@redhat.de> 0.68-1
450- genClass: slicing of anonymous lists
451- executil: dup2 more output redirectors
452
453* Tue Nov 26 2002 Michael Fulbright <msf@redhat.com> 0.67-1
454- Fixed issue related to not defaulting to sane monitor values if monitor
455  was not probed.
456
457* Tue Nov 26 2002 Phil Knirsch <pknirsch@redhat.com> 0.66-1
458- Fixed -fpic handling for s390 and s390x.
459
460* Thu Nov 21 2002 Michael Fulbright <msf@redhat.com> 0.65-1
461- added some code to handle the no mouse setup better
462
463* Thu Nov 21 2002 Florian La Roche <Florian.LaRoche@redhat.de>
464- do not require pyxf86config for mainframe
465
466* Tue Nov 19 2002 Michael Fulbright <msf@redhat.com> 0.64-1
467- Added new xserver.py which has code to help get X up and running from scratch
468
469* Tue Nov 19 2002 Jeremy Katz <katzj@redhat.com> 0.63-2
470- rebuild for all arches
471
472* Fri Nov 15 2002 Brent Fox <bfox@redhat.com> 0.63-1
473- Added Latin American (la-latin1) keyboard
474
475* Thu Nov 14 2002 Harald Hoyer <harald@redhat.de> 0.62-1
476- removed Alchemist dependency from genClass
477- executil extended
478
479* Tue Nov 12 2002 Michael Fulbright <msf@redhat.com> 0.61-1
480- big changes as we moved alot of code from redhat-config-xfree86 into xhwstate.py
481
482* Tue Nov  5 2002 Jeremy Katz <katzj@redhat.com> 0.59-1
483- access Cards database in /usr/share/hwdata instead of
484  /usr/X11R6/lib/X11 (#73899)
485- excludearch x86_64 until python is fixed
486
487* Fri Nov  1 2002 Jeremy Katz <katzj@redhat.com> 0.58-1
488- add macedonian keyboard (#76902)
489- find loadkeys for anaconda (#75329)
490
491* Thu Oct 31 2002 Brent Fox <bfox@redhat.com> 0.57-1
492- Mark keyboard names for translations
493
494* Mon Oct 21 2002 Brent Fox <bfox@redhat.com> 0.56-1
495- Use cz_qwerty keymap for Czech qwerty keyboards
496
497* Thu Oct 10 2002 Jeremy Katz <katzj@redhat.com> 0.55-2
498- rebuild so that we actually get object files for the correct architectures
499
500* Wed Oct  9 2002 Dan Walsh <dwalsh@redhat.de> 0.55-1
501- removed chmod from ConfSMB.py file protection should remain the same
502
503* Tue Oct  8 2002 Harald Hoyer <harald@redhat.de> 0.54-1
504- removed fd/socket leaking
505
506* Tue Oct 08 2002 Phil Knirsch <pknirsch@redhat.com> 0.53-2
507- Integreated Karsten Hopp's 64bit bigendian patch for s390x.
508
509* Fri Oct  4 2002 Brent Fox <bfox@redhat.com> 0.53-1
510- Allow window icon to be passed into stand_alone in firstboot_gui_window.py
511
512* Thu Oct  3 2002 Jeremy Katz <katzj@redhat.com> 0.52-2
513- fixup installation into %%{_libdir}/python2.2/
514
515* Thu Oct  3 2002 Jeremy Katz <katzj@redhat.com> 0.52-1
516- iconvmodule.c: PyObject_asReadBuffer() expects *int while iconv()
517  expects size_t.
518
519* Thu Aug 29 2002 Jeremy Katz <katzj@redhat.com> 0.51-1
520- src/keyboard_models.py: fix romanian console keymap (#72952)
521
522* Wed Aug 28 2002 Jeremy Katz <katzj@redhat.com> 0.50-1
523- diskutil.py: update /etc/mtab
524
525* Fri Aug 23 2002 Michael Fulbright <msf@redhat.com> 0.49-1
526- videocard.py: Use unsupported VGA compatible card entry if card unknown
527
528* Thu Aug 22 2002 Brent Fox <bfox@redhat.com> 0.48-1
529- translate.py: add ability to set codeset for textdomains not pulled in by us
530
531* Thu Aug 22 2002 Brent Fox <bfox@redhat.com> 0.47-1
532- fix another typo in translate.py
533
534* Thu Aug 22 2002 Jeremy Katz <katzj@redhat.com> 0.46-1
535- fix a typo in translate.py
536
537* Thu Aug 22 2002 Jeremy Katz <katzj@redhat.com> 0.45-1
538- minor mouse fixups (#70289, #71893)
539
540* Wed Aug 21 2002 Michael Fulbright <msf@redhat.com> 0.44-1
541- added sanity check to ddcprobe'd range values
542
543* Tue Aug 20 2002 Harald Hoyer <harald@redhat.de> 0.43-1
544- fixed genClass.py:toContext()
545- ValueError -> TypeError in checkType
546
547* Fri Aug 16 2002 Brent Fox <bfox@redhat.com> 0.42-1
548- Mark window title for translations in firstboot_gui_window
549
550* Fri Aug 16 2002 Jeremy Katz <katzj@redhat.com> 0.41-1
551- translate.py fixes
552- "None - None" is back, but as "No mouse"
553
554* Thu Aug 15 2002 Jeremy Katz <katzj@redhat.com> 0.40-1
555- comps.py: handle translated category names
556
557* Wed Aug 14 2002 Harald Hoyer <harald@redhat.de>
558- added iwconfig-support to ethtool
559
560* Wed Aug 14 2002 Brent Fox <bfox@redhat.com> 0.37-1
561- Call destroy() when a firstboot window exits
562
563* Mon Aug 12 2002 Jeremy Katz <katzj@redhat.com> 0.36-1
564- add generic wheel mouse types
565- add bad hack to handle packages which should only be installed
566  if another package is installed
567
568* Sun Aug 11 2002 Brent Fox <bfox@redhat.com> 0.35-1
569- Create US International keymap line for bug 71105
570
571* Sun Aug 11 2002 Brent Fox <bfox@redhat.com> 0.34-2
572- Fix typo that I made with the last build
573
574* Sun Aug 11 2002 Brent Fox <bfox@redhat.com> 0.34-1
575- Fix Brazilian abnt2 keyboard map for bug 70351
576
577* Tue Aug  6 2002 Michael Fulbright <msf@redhat.com>
578- added sanity checks for sync rates
579
580* Fri Aug  2 2002 Jeremy Katz <katzj@redhat.com>
581- keyboard_models.py: be-latin2 isn't a valid keymap
582
583* Wed Jul 31 2002 Jeremy Katz <katzj@redhat.com> 0.32-1
584- add losetup, unlosetup, and getUnusedLoop to diskutil
585
586* Tue Jul 30 2002 Brent Fox <bfox@redhat.com> 0.31-1
587- remove some dead code
588- make the font big for firstboot_gui_window titles
589
590* Thu Jul 25 2002 Jeremy Katz <katzj@redhat.com> 0.30-1
591- mouse.py: don't enable emulate three buttons on the fly (#68129)
592
593* Thu Jul 25 2002 Jeremy Katz <katzj@redhat.com> 0.29-1
594- translate.py: set up default langs based on environment
595
596* Wed Jul 24 2002 Jonathan Blandford  <jrb@redhat.com> 0.28-1
597* add GenericError.py
598
599* Wed Jul 24 2002 Jeremy Katz <katzj@redhat.com> 0.27-2
600- actually install _diskutil.so
601
602* Wed Jul 24 2002 Jeremy Katz <katzj@redhat.com> 0.27-1
603- diskutil.py, diskutil.c: add some simple disk utility methods (mount,
604  umount, sync, ejectCdrom)
605
606* Mon Jul 22 2002 Jeremy Katz <katzj@redhat.com> 0.26-1
607- comps.py: add support for reading group hierarchy
608
609* Thu Jul 17 2002 Brent Fox <bfox@redhat.com> 0.25-1
610- Make firstboot windows use GtkDialog instead of GtkWindow
611
612* Wed Jul 17 2002 Brent Fox <bfox@redhat.com> 0.24-3
613- Change Poland keyboard to Polish.  Bug #68520
614
615* Wed Jul 17 2002 Michael Fulbright <msf@redhat.com> 0.24-2
616- minor typo fix
617
618* Wed Jul 17 2002 Michael Fulbright <msf@redhat.com> 0.24-1
619- executil.py: add getfd() function
620
621* Tue Jul 16 2002 Jeremy Katz <katzj@redhat.com> 0.23-1
622- comps.py: add metapkg support
623
624* Tue Jul 16 2002 Brent Fox <bfox@redhat.com> 0.22-2
625- Call loadkeys if the binary exists when changing keymaps
626
627* Mon Jul 15 2002 Jeremy Katz <katzj@redhat.com> 0.21-1
628- fix jp106 entry in keyboard_models
629- add method to get list of supported keyboard maps
630
631* Sat Jul 13 2002 Brent Fox <bfox@redhat.com> 0.20-1
632- Small change in firstboot_gui_window.py to center popup windows
633
634* Wed Jul 10 2002 Brent Fox <bfox@redhat.com> 0.19-1
635- Added a Greek keyboard to keyboard_models.py
636
637* Wed Jul 10 2002 Alexander Larsson <alexl@redhat.com> 0.18-1
638- Fixed bug in monitor resoultion support code
639
640* Mon Jul  1 2002 Harald Hoyer <harald@redhat.de> 0.16-1
641- updated Conf*.py
642- updated genClass
643- added ethtool
644
645* Fri Jun 28 2002 Jeremy Katz <katzj@redhat.com> 0.15-1
646- comps.py: use libxml2 for xml parsing instead of expat
647
648* Fri Jun 28 2002 Jeremy Katz <katzj@redhat.com> 0.14-1
649- only setxkbmap if $DISPLAY is set
650
651* Thu Jun 27 2002 Jeremy Katz <katzj@redhat.com> 0.13-1
652- add parser for new comps file
653
654* Wed Jun 26 2002 Michael Fulbright <msf@redhat.com> 0.12-1
655- Fix bug of uninitialized data in Mouse class
656
657* Tue Jun 25 2002 Brent Fox <bfox@redhat.com> 0.11-3
658- Allow a window title to be passed in
659
660* Wed Jun 19 2002 Brent Fox <bfox@redhat.com> 0.9-4
661- Fixed line for German keyboards in keyboard_models.py
662
663* Tue Jun 18 2002 Brent Fox <bfox@redhat.com> 0.9-3
664- Remove cancel button from firstboot_gui_window
665
666* Tue Jun 18 2002 Brent Fox <bfox@redhat.com> 0.9-2
667- Provide a way to pass keymap name back to firstboot
668- Fix error in Slovakian keymap line in keyboard_models.py
669
670* Wed Jun 12 2002 Jeremy Katz <katzj@redhat.com>
671- use cz-lat2 for Czechoslovakian keybaord map (#66354)
672
673* Tue Jun 04 2002 Michael Fulbright <msf@redhat.com>
674- fixed bug referencing ddcDevice and videoram in card.
675
676* Tue May 28 2002 Jeremy Katz <katzj@redhat.com>
677- removed kbd.py, added keyboard.py
678
679* Fri May 24 2002 Michael Fulbright <msf@redhat.com>
680- Added kbd.py
681
682* Thu May 23 2002 Alex Larsson <alexl@redhat.com>
683- Added /usr/share/rhpl to files list
684
685* Thu May 23 2002 Michael Fulbright <msf@redhat.com>
686- added log.py, videocard.py, mouse.py, monitor.py, simpleconfig.py
687
688* Wed May 22 2002 Jeremy Katz <katzj@redhat.com>
689- Initial build.
690
691
Note: See TracBrowser for help on using the repository browser.