source: projects/specs/trunk/r/rhpl/rhpl-vl.spec @ 5701

Revision 5701, 23.5 KB checked in by Takemikaduchi, 12 years ago (diff)

python-2.7.2

Line 
1%{!?python_sitearch: %define python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
2
3Summary: Library of python code used by programs in Vine Linux
4Summary(ja): Vine Linux で利用する python コードライブラリ
5Name: rhpl
6Version: 0.216
7Release: 8%{?_dist_release}
8Source0: %{name}-%{version}.tar.bz2
9Patch0: %{name}-0.216-compat.patch
10Patch1: %{name}-0.216-pmac.patch
11License: GPL
12Group: System Environment/Libraries
13BuildRoot: %{_tmppath}/%{name}-root
14BuildRequires: python-devel, gettext
15BuildRequires: wireless-tools-devel
16Requires: python >= %(%{__python} -c "import sys; print sys.version[:3]")
17Requires: pyxf86config >= 0.3.2
18
19%description
20The rhpl package contains Python code used by programs in Vine Linux.
21
22Vendor: Project Vine
23Distribution: Vine Linux
24Packager: daisuke
25
26%prep
27%setup -q
28%patch0 -p1 -b .compat
29%patch1 -p1 -b .pmac
30
31# this line is no more need?
32perl -pi -e 's/python2.3/python2.4/g' Makefile.inc src/*
33perl -pi -e 's/xgettext /xgettext --from-code=UTF-8 /g' po/Makefile
34
35%build
36%__make
37
38%install
39rm -rf $RPM_BUILD_ROOT
40make DESTDIR=${RPM_BUILD_ROOT} install
41
42%find_lang %name
43
44%clean
45rm -rf $RPM_BUILD_ROOT
46
47%files -f %{name}.lang
48%defattr(-,root,root)
49%doc README COPYING
50%{python_sitearch}/rhpl
51
52%changelog
53* Sun Feb 19 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.216-8
54- rebuild with python-2.7.2
55
56* Wed Apr 20 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.216-7
57- rebuild for Vine 6
58
59* Wed Mar 31 2010 Shu KONNO <owa@bg.wakwak.com> 0.216-6
60- updated release number
61- import Vine5.1 changes
62  * Wed Jan 27 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.216-5
63  - add BuildRequires: wireless-tools-devel
64  * Wed Sep  9 2009 MATSUBAYSHI Kohji <shaolin@vinelinux.org> 0.216-4
65  - add Patch1: implement getPPCMachineName()
66
67* Tue Feb 02 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 0.216-4
68- rebuild with python-2.6
69
70* Wed Mar 11 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.216-3
71- disable deprecate warning in log.py
72
73* Tue Feb 24 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.216-2
74- add comps.py from rhpl-0.146.3
75
76* Mon Aug 11 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.216-1
77- new upstream release
78
79* Tue May 22 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.148.3-0vl17
80- add "--from-code" option to xgettext
81
82* Thu Nov 16 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.148.3-0vl16
83- update vine patch
84  - add some fontpath (<BTS:371>)
85  - add nv panel size detection code.
86
87* Wed Nov 01 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.148.3-0vl15
88- update vine patch
89  - remove unsupported (larger) display from Modes list.
90
91* Tue Oct 31 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.148.3-0vl14
92- update vine patch
93  - set desired_resolution from LCD panel resolution.
94
95* Wed Oct 25 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.148.3-0vl13
96- apply new compare_resolution algorism for all arch. (<BTS:301>)
97
98* Sun Oct 08 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.148.3-0vl12
99- update vine patch
100  - fix radeon panel size detection code.
101
102* Wed Sep 20 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.148.3-0vl11
103- don't apply Patch60 on ppc
104
105* Wed Sep 20 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.148.3-0vl10
106- add more extra modelines
107
108* Wed Sep 20 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.148.3-0vl9
109- add extra modeline to extramodes
110
111* Thu Sep 14 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.148.3-0vl8
112- add Patch50 to guess unprobed mouse as generic mouse.
113
114* Fri Sep 08 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.148.3-0vl7
115- add Patch40 for ppc
116
117* Sat Sep 02 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.148.3-0vl6
118- add Patch30 to modifiy keyboard_models
119
120* Thu Aug 31 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.148.3-0vl5
121- update vine patch
122  - detect i810 panel size
123
124* Tue Aug 29 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.148.3-0vl4
125- update vine patch
126  - add more display resolutions
127
128* Thu Aug 24 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.148.3-0vl3
129- replace obsolete gtk.{TRUE,FALSE} with {True,False}
130
131* Tue Aug 22 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.148.3-0vl2
132- fix default X settings
133- add VMWare monitor hacks
134
135* Wed Aug 16 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.148.3-0vl1
136- initial build for Vine Linux
137
138* Fri Jul  8 2005 Jeremy Katz <katzj@redhat.com> - 0.148.3-1
139- fix indic keyboards (#158139)
140
141* Wed Nov 17 2004 Jeremy Katz <katzj@redhat.com> - 0.148.2-1
142- add patch from Jim Parsons to add executil.execWithCaptureErrorStatus as
143  needed by system-config-lvm
144
145* Tue Nov 16 2004 Paul Nasrat <pnasrat@redhat.com> - 0.148.1-1
146- RHEL4 remove synaptics
147
148* Wed Oct 13 2004 Paul Nasrat <pnasrat@redhat.com> - 0.148-1
149- Indic keyboard fixups
150- Multi-input synaptics
151- require synaptics
152- Less verbose ddcprobe
153
154* Thu Sep 30 2004 Harald Hoyer <harald@redhat.com> - 0.147-1
155- let Conf.ConfModules use modprobe.conf name and format (bug 131952)
156- use network script resolv.conf merger/changer (bug 132485)
157
158* Fri Sep 24 2004 Jeremy Katz <katzj@redhat.com>
159- require python (#133462)
160
161* Wed Sep 22 2004 Jeremy Katz <katzj@redhat.com> - 0.146-1
162- add synaptics support (pnasrat)
163- add arabic and indic keyboards (pnasrat)
164
165* Fri Jun 18 2004 Jeremy Katz <katzj@redhat.com> - 0.145-1
166- improved lib64 detection, rebuild with gcc 3.4
167
168* Wed May  5 2004 Jeremy Katz <katzj@redhat.com> - 0.144-1
169- open cd device with O_NONBLOCK so eject ioctl works (#122524)
170
171* Tue Apr 20 2004 Brent Fox <bfox@redhat.com> 0.143-1
172- Do not write out XkbRules line to config file, as it is unnecessary to hard
173  code the rules file, which has a built in default which should always
174  work. (#120858)
175
176* Fri Apr 16 2004 Jeremy Katz <katzj@redhat.com> - 0.142-1
177- more XFree86->xorg
178
179* Thu Apr 15 2004 Jeremy Katz <katzj@redhat.com> - 0.141-1
180- xserver.py: workaround libxf86config not writing out the monitor stuff
181  we tell it to (#120950)
182
183* Wed Apr 14 2004 Jeremy Katz <katzj@redhat.com> - 0.140-1
184- translate.py: one more try at string encoding madness (#119391)
185
186* Tue Apr 13 2004 Jeremy Katz <katzj@redhat.com> - 0.139-1
187- videocard.py: fixups for VESA handling on x86_64
188- videocard.py, xserver.py: XFree86 -> Xorg changes
189
190* Wed Mar 17 2004 Bill Nottingham <notting@redhat.com> 0.138-1
191- mouse.py cleanups
192
193* Tue Mar 16 2004 Bill Nottingham <notting@redhat.com> 0.135-1
194- remove old default keymap when writing config (#116852)
195
196* Tue Mar  9 2004 Brent Fox <bfox@redhat.com> 0.134-1
197- user fr-latin9 for the X keymap too (bug #113672)
198
199* Tue Mar  9 2004 Jeremy Katz <katzj@redhat.com> - 0.133-1
200- use vesa for unknown cards on x86_64
201
202* Fri Mar  5 2004 Brent Fox <bfox@redhat.com> 0.132-1
203- use fr-latin9 instead of fr-latin0 (bug #113672)
204
205* Thu Mar  4 2004 Jeremy Katz <katzj@redhat.com> - 0.131-1
206- switch some default keyboard layouts (#117007)
207
208* Thu Mar  4 2004 Brent Fox <bfox@redhat.com> 0.130-1
209- strip out refresh rate data (bug #117327)
210
211* Wed Mar  3 2004 Brent Fox <bfox@redhat.com> 0.129-1
212- enable DRI extentions for all i386, x86_64, and ia64 systems (bug #115672)
213- vmware doesn't do 24bpp (#117375)
214- fix for savage + lcds (#117079)
215
216* Thu Feb 26 2004 Brent Fox <bfox@redhat.com> 0.128-1
217- add some hooks to xhwstate.py to get PCI bus ID info
218
219* Fri Feb 20 2004 Brent Fox <bfox@redhat.com> 0.127-2
220- correct a typo
221
222* Fri Feb 20 2004 Brent Fox <bfox@redhat.com> 0.127-1
223- changes to mouse handling in xhwstate.py
224
225* Wed Feb 18 2004 Jeremy Katz <katzj@redhat.com> 0.126-1
226- minor tweak for mouse stuff
227
228* Fri Feb 13 2004 Brent Fox <bfox@redhat.com> 0.125.1-1
229- use hu_qwerty for Hungarian (101 key) (bug #114629)
230
231* Thu Jan 22 2004 Jeremy Katz <katzj@redhat.com> 0.124.1-1
232- translate.py: minor tweaks
233
234* Tue Jan 20 2004 Jeremy Katz <katzj@redhat.com> 0.124-1
235- translate.py: return UTF-8 encoded strings (#113202)
236
237* Thu Jan  8 2004 Brent Fox <bfox@redhat.com> 0.123.1-1
238- add an entry for Korean keyboards (bug #112024)
239
240* Tue Jan  6 2004 Jeremy Katz <katzj@redhat.com>
241- mark keyboard model names as keyboard|name to make them differ
242  from language names (#84969)
243
244* Tue Dec 16 2003 Jeremy Katz <katzj@redhat.com>
245- use EISA if name doesn't exist in ddc data (#112281)
246
247* Fri Nov 14 2003 Jeremy Katz <katzj@redhat.com> 0.122.2-1
248- more python2.3
249
250* Sat Nov  8 2003 Jeremy Katz <katzj@redhat.com> 0.122.1-1
251- more python 2.3 fixups
252
253* Thu Nov  6 2003 Jeremy Katz <katzj@redhat.com> 0.122-1
254- python 2.3
255
256* Tue Oct 21 2003 Jeremy Katz <katzj@redhat.com> 0.121-1
257- don't try to use 24bpp on old hardware (#105713)
258
259* Thu Oct 16 2003 Brent Fox <bfox@redhat.com> 0.120-1
260- mouse.py - add two entries for optical mice
261
262* Thu Oct 16 2003 Jeremy Katz <katzj@redhat.com> 0.119-1
263- keyboard_models.py: fix greek keyboard layout (#100773)
264
265* Wed Oct 15 2003 Jeremy Katz <katzj@redhat.com> 0.118-1
266- translate.py: assume UTF-8 if we can't figure out the encoding of a mofile
267
268* Thu Oct  8 2003 Michael Fulbright <msf@redhat.com> 0.117-1
269- xhwstate.py - dont write out video ram option to XF86Config
270
271* Thu Oct  2 2003 Brent Fox <bfox@redhat.com> 0.116-1
272- videocard.py: added pci busID functions
273
274* Tue Sep 30 2003 Jeremy Katz <katzj@redhat.com> 0.115-1
275- mouse.py: add new API and make sane to use for translation
276
277* Thu Sep 25 2003 Harald Hoyer <harald@redhat.de> 0.114-1
278- preserve comments in modules.conf #76640
279
280* Tue Sep 23 2003 Michael Fulbright <msf@redhat.com>
281- fix bug dealing with determining video modes supported by a monitor
282
283* Mon Sep  8 2003 Jeremy Katz <katzj@redhat.com>
284- use RPM_OPT_FLAGS (#103970)
285
286* Thu Sep 04 2003 Harald Hoyer <harald@redhat.de> 0.112-1
287- fixed ConfPAP.getfields()
288
289* Thu Sep 04 2003 Michael Fulbright <msf@redhat.com> 0.111-1
290- fixes for bugzilla #103353
291
292* Tue Sep 02 2003 Michael Fulbright <msf@redhat.com> 0.111-1
293- fixes to X setup code
294
295* Fri Aug 29 2003 Harald Hoyer <harald@redhat.de> 0.110-1
296- removed memory leak
297
298* Wed Jul 16 2003 Jeremy Katz <katzj@redhat.com> 0.110-1
299- add an interface for adding packages to groups
300
301* Mon Jul 14 2003 Jeremy Katz <katzj@redhat.com> 0.109-1
302- multilib on ia64
303
304* Wed Jul 09 2003 Harald Hoyer <harald@redhat.de> 0.108-3
305- rebuilt with all files updated from cvs
306
307* Tue Jul  8 2003 Jeremy Katz <katzj@redhat.com> 0.108-1
308- comps.py: preserve xml doc/nodes
309- translate.py: make it so we can use translations from update disks in
310  anaconda
311
312* Thu Jun 12 2003 Brent Fox <bfox@redhat.com> 0.107-1
313- add a get_xconfig() method to xhwstate.py
314
315* Tue Jun 10 2003 Harald Hoyer <harald@redhat.de> 0.106-1
316- better regexp in Conf.py
317- strip filename from subject
318
319* Fri Jun  6 2003 Jeremy Katz <katzj@redhat.com> 0.105-1
320- more biarch fun
321
322* Wed Jun  4 2003 Jeremy Katz <katzj@redhat.com> 0.104-1
323- add ppc64[ip]series
324
325* Wed Jun  4 2003 Jeremy Katz <katzj@redhat.com> 0.103.1-1
326- arch.py tweaks
327
328* Fri May 30 2003 Jeremy Katz <katzj@redhat.com> 0.103-1
329- comps.py extensions for biarch
330
331* Fri May 23 2003 Jeremy Katz <katzj@redhat.com> 0.102.1-1
332- fix tyop
333
334* Fri May 23 2003 Jeremy Katz <katzj@redhat.com> 0.102-1
335- add arch.py
336
337* Wed May 21 2003 Harald Hoyer <harald@redhat.de> 0.101.1-1
338- strip quotes from PAP/CHAP server also
339- Conf.py, cope with lines at the end of the file, that have no newline
340- speedup some things
341
342* Wed May 07 2003 Michael Fulbright <msf@redhat.com> 0.100.1-1
343- fixed simpleconfig.py and how it uppercases keys
344
345* Tue Apr 29 2003 Harald Hoyer <harald@redhat.com> 0.99.1-1
346- genClass and ethtool updates
347
348* Thu Apr 24 2003 Brent Fox <bfox@redhat.com> 0.98.1-2
349- strip an invalid char from monitor name (bug #87588)
350
351* Wed Apr 23 2003 Jeremy Katz <katzj@redhat.com> 0.98.1-1
352- revert broken part of pseries fb change
353
354* Mon Apr 21 2003 Jeremy Katz <katzj@redhat.com> 0.98-1
355- handle headless case better
356
357* Fri Apr 18 2003 Jeremy Katz <katzj@redhat.com> 0.97-1
358- fixes so that framebuffer can work for use on ppc machines
359
360* Thu Apr  3 2003 Brent Fox <bfox@redhat.com> 0.96-2
361- update the list of dri drivers from mharris
362
363* Thu Apr  3 2003 Brent Fox <bfox@redhat.com> 0.96-1
364- add ati and i810 to dri supported list in xhwstate.py
365
366* Wed Apr  2 2003 Brent Fox <bfox@redhat.com> 0.95-1
367- allow dialog size to be passed into firstboot_gui_window
368
369* Thu Feb 27 2003 Bill Nottingham <notting@redhat.com> 0.94-1
370- make py_bind_textdomain_codeset not segfault on ia64 (#85334)
371
372* Mon Feb 24 2003 Jeremy Katz <katzj@redhat.com> 0.93-1
373- mouse.py (mouseWindow): try to ensure we have a locale that
374  we can do linedrawing chars for (#84908)
375
376* Wed Feb 12 2003 Brent Fox <bfox@redhat.com> 0.92-1
377- add grp_led:scroll to all lines with XkbOptions (bug #82096)
378
379* Tue Feb 11 2003 Brent Fox <bfox@redhat.com> 0.91-1
380- convert all toggles to grp:shift_toggle (bug #79287)
381
382* Fri Feb  7 2003 Brent Fox <bfox@redhat.com> 0.90-1
383- add grp_led:scroll to all Russian keyboards
384
385* Fri Feb  7 2003 Brent Fox <bfox@redhat.com> 0.89-1
386- add translate.textdomain('rhpl') to fix bug #69760
387
388* Thu Feb  6 2003 Matt Wilson <msw@redhat.com> 0.88-1
389- only reset the mouse if you have to
390
391* Thu Feb  6 2003 Brent Fox <bfox@redhat.com> 0.87-1
392- load additional us keymap for all ru keyboards in keyboard_models.py
393- make sure the kbd option gets set in keyboard.py
394
395* Thu Feb  6 2003 Brent Fox <bfox@redhat.com> 0.86-1
396- use sv-latin1 for swedish keyboards (bug #80508)
397
398* Wed Feb  5 2003 Matt Wilson <msw@redhat.com> 0.85-1
399- autodetect ps/2 wheel mice (#81902)
400
401* Wed Feb  5 2003 Brent Fox <bfox@redhat.com> 0.84-1
402- if there are no display Modes in the XF86Config file, create one and default to 800x600 (bug #83314)
403
404* Tue Feb 04 2003 Harald Hoyer <harald@redhat.de> 0.83-1
405- ConfPAP fix for quotation
406
407* Fri Jan 31 2003 Jeremy Katz <katzj@redhat.com> 0.81-2
408- fix typo
409
410* Fri Jan 31 2003 Adrian Likins <alikins@redhat.com>
411- added get_ipaddr, get_netmask, get_broadcast
412  to ethtool module
413
414* Fri Jan 31 2003 Harald Hoyer <harald@redhat.de>
415- added some BuildRequires
416
417* Thu Jan 30 2003 Jeremy Katz <katzj@redhat.com> 0.80-1
418- default non-i386 arches to 8 megs of videoram
419
420* Wed Jan 22 2003 Brent Fox <bfox@redhat.com> 0.79-1
421- add us keymap and XkbOptions to non-latin keymaps in keyboard_models.py
422- change keyboard.py to handle the XkbOptions field
423
424* Mon Jan 20 2003 Michael Fulbright <msf@redhat.com> 0.78-1
425- improved code for LCD guessing
426
427* Fri Jan 17 2003 Michael Fulbright <msf@redhat.com> 0.77-1
428- added code to xserver.py to guess LCD size using guesslcd.py
429
430* Fri Jan 17 2003 Brent Fox <bfox@redhat.com> 0.76-1
431- changes to firstbootGuiWindow.py for new firstboot look
432
433* Tue Jan 14 2003 Michal Fulbright <msf@redhat.com> 0.75-1
434- fix xserver.py to include keyboard import
435
436* Fri Jan 10 2003 Brent Fox <bfox@redhat.com> 0.74-2
437- change se-latin1 kbd to se-fi-lat6 according to bug #80508
438
439* Fri Jan  3 2003 Brent Fox <bfox@redhat.com> 0.74-1
440- default to pc105 for most keyboards
441
442* Thu Jan  2 2003 Jeremy Katz <katzj@redhat.com> 0.73-3
443- make the translate.py change less noisy
444
445* Thu Jan  2 2003 Jeremy Katz <katzj@redhat.com> 0.73-2
446- typo fix
447
448* Wed Jan  1 2003 Jeremy Katz <katzj@redhat.com> 0.73-1
449- discid.py: add readFromBuffer
450
451* Sun Dec 29 2002 Jeremy Katz <katzj@redhat.com>
452- translate.py: if we fail, at least gracefully fall back instead of
453  causing a traceback (#76104)
454
455* Thu Dec 19 2002 Harald Hoyer <harald@redhat.de> 0.72-1
456- added exception.py
457
458* Tue Dec 17 2002 Jeremy Katz <katzj@redhat.com> 0.71-2
459- fix silly typo
460
461* Tue Dec 17 2002 Jeremy Katz <katzj@redhat.com> 0.71-1
462- simpleconfig.py: gracefully handle non-existent config files
463
464* Mon Dec 16 2002 Harald Hoyer <harald@redhat.de> 0.70-1
465- _setParent() in GenClass::__setitem__
466
467* Fri Dec 13 2002 Jeremy Katz <katzj@redhat.com> 0.69-1
468- only probe for the mouse once to fix mouse probing problems
469- make keyboard names more consistent (#79354)
470
471* Thu Dec 12 2002 Harald Hoyer <harald@redhat.de> 0.68-1
472- genClass: slicing of anonymous lists
473- executil: dup2 more output redirectors
474
475* Tue Nov 26 2002 Michael Fulbright <msf@redhat.com> 0.67-1
476- Fixed issue related to not defaulting to sane monitor values if monitor
477  was not probed.
478
479* Tue Nov 26 2002 Phil Knirsch <pknirsch@redhat.com> 0.66-1
480- Fixed -fpic handling for s390 and s390x.
481
482* Thu Nov 21 2002 Michael Fulbright <msf@redhat.com> 0.65-1
483- added some code to handle the no mouse setup better
484
485* Thu Nov 21 2002 Florian La Roche <Florian.LaRoche@redhat.de>
486- do not require pyxf86config for mainframe
487
488* Tue Nov 19 2002 Michael Fulbright <msf@redhat.com> 0.64-1
489- Added new xserver.py which has code to help get X up and running from scratch
490
491* Tue Nov 19 2002 Jeremy Katz <katzj@redhat.com> 0.63-2
492- rebuild for all arches
493
494* Fri Nov 15 2002 Brent Fox <bfox@redhat.com> 0.63-1
495- Added Latin American (la-latin1) keyboard
496
497* Thu Nov 14 2002 Harald Hoyer <harald@redhat.de> 0.62-1
498- removed Alchemist dependency from genClass
499- executil extended
500
501* Tue Nov 12 2002 Michael Fulbright <msf@redhat.com> 0.61-1
502- big changes as we moved alot of code from redhat-config-xfree86 into xhwstate.py
503
504* Tue Nov  5 2002 Jeremy Katz <katzj@redhat.com> 0.59-1
505- access Cards database in /usr/share/hwdata instead of
506  /usr/X11R6/lib/X11 (#73899)
507- excludearch x86_64 until python is fixed
508
509* Fri Nov  1 2002 Jeremy Katz <katzj@redhat.com> 0.58-1
510- add macedonian keyboard (#76902)
511- find loadkeys for anaconda (#75329)
512
513* Thu Oct 31 2002 Brent Fox <bfox@redhat.com> 0.57-1
514- Mark keyboard names for translations
515
516* Mon Oct 21 2002 Brent Fox <bfox@redhat.com> 0.56-1
517- Use cz_qwerty keymap for Czech qwerty keyboards
518
519* Thu Oct 10 2002 Jeremy Katz <katzj@redhat.com> 0.55-2
520- rebuild so that we actually get object files for the correct architectures
521
522* Wed Oct  9 2002 Dan Walsh <dwalsh@redhat.de> 0.55-1
523- removed chmod from ConfSMB.py file protection should remain the same
524
525* Tue Oct  8 2002 Harald Hoyer <harald@redhat.de> 0.54-1
526- removed fd/socket leaking
527
528* Tue Oct 08 2002 Phil Knirsch <pknirsch@redhat.com> 0.53-2
529- Integreated Karsten Hopp's 64bit bigendian patch for s390x.
530
531* Fri Oct  4 2002 Brent Fox <bfox@redhat.com> 0.53-1
532- Allow window icon to be passed into stand_alone in firstboot_gui_window.py
533
534* Thu Oct  3 2002 Jeremy Katz <katzj@redhat.com> 0.52-2
535- fixup installation into %%{_libdir}/python2.2/
536
537* Thu Oct  3 2002 Jeremy Katz <katzj@redhat.com> 0.52-1
538- iconvmodule.c: PyObject_asReadBuffer() expects *int while iconv()
539  expects size_t.
540
541* Thu Aug 29 2002 Jeremy Katz <katzj@redhat.com> 0.51-1
542- src/keyboard_models.py: fix romanian console keymap (#72952)
543
544* Wed Aug 28 2002 Jeremy Katz <katzj@redhat.com> 0.50-1
545- diskutil.py: update /etc/mtab
546
547* Fri Aug 23 2002 Michael Fulbright <msf@redhat.com> 0.49-1
548- videocard.py: Use unsupported VGA compatible card entry if card unknown
549
550* Thu Aug 22 2002 Brent Fox <bfox@redhat.com> 0.48-1
551- translate.py: add ability to set codeset for textdomains not pulled in by us
552
553* Thu Aug 22 2002 Brent Fox <bfox@redhat.com> 0.47-1
554- fix another typo in translate.py
555
556* Thu Aug 22 2002 Jeremy Katz <katzj@redhat.com> 0.46-1
557- fix a typo in translate.py
558
559* Thu Aug 22 2002 Jeremy Katz <katzj@redhat.com> 0.45-1
560- minor mouse fixups (#70289, #71893)
561
562* Wed Aug 21 2002 Michael Fulbright <msf@redhat.com> 0.44-1
563- added sanity check to ddcprobe'd range values
564
565* Tue Aug 20 2002 Harald Hoyer <harald@redhat.de> 0.43-1
566- fixed genClass.py:toContext()
567- ValueError -> TypeError in checkType
568
569* Fri Aug 16 2002 Brent Fox <bfox@redhat.com> 0.42-1
570- Mark window title for translations in firstboot_gui_window
571
572* Fri Aug 16 2002 Jeremy Katz <katzj@redhat.com> 0.41-1
573- translate.py fixes
574- "None - None" is back, but as "No mouse"
575
576* Thu Aug 15 2002 Jeremy Katz <katzj@redhat.com> 0.40-1
577- comps.py: handle translated category names
578
579* Wed Aug 14 2002 Harald Hoyer <harald@redhat.de>
580- added iwconfig-support to ethtool
581
582* Wed Aug 14 2002 Brent Fox <bfox@redhat.com> 0.37-1
583- Call destroy() when a firstboot window exits
584
585* Mon Aug 12 2002 Jeremy Katz <katzj@redhat.com> 0.36-1
586- add generic wheel mouse types
587- add bad hack to handle packages which should only be installed
588  if another package is installed
589
590* Sun Aug 11 2002 Brent Fox <bfox@redhat.com> 0.35-1
591- Create US International keymap line for bug 71105
592
593* Sun Aug 11 2002 Brent Fox <bfox@redhat.com> 0.34-2
594- Fix typo that I made with the last build
595
596* Sun Aug 11 2002 Brent Fox <bfox@redhat.com> 0.34-1
597- Fix Brazilian abnt2 keyboard map for bug 70351
598
599* Tue Aug  6 2002 Michael Fulbright <msf@redhat.com>
600- added sanity checks for sync rates
601
602* Fri Aug  2 2002 Jeremy Katz <katzj@redhat.com>
603- keyboard_models.py: be-latin2 isn't a valid keymap
604
605* Wed Jul 31 2002 Jeremy Katz <katzj@redhat.com> 0.32-1
606- add losetup, unlosetup, and getUnusedLoop to diskutil
607
608* Tue Jul 30 2002 Brent Fox <bfox@redhat.com> 0.31-1
609- remove some dead code
610- make the font big for firstboot_gui_window titles
611
612* Thu Jul 25 2002 Jeremy Katz <katzj@redhat.com> 0.30-1
613- mouse.py: don't enable emulate three buttons on the fly (#68129)
614
615* Thu Jul 25 2002 Jeremy Katz <katzj@redhat.com> 0.29-1
616- translate.py: set up default langs based on environment
617
618* Wed Jul 24 2002 Jonathan Blandford  <jrb@redhat.com> 0.28-1
619* add GenericError.py
620
621* Wed Jul 24 2002 Jeremy Katz <katzj@redhat.com> 0.27-2
622- actually install _diskutil.so
623
624* Wed Jul 24 2002 Jeremy Katz <katzj@redhat.com> 0.27-1
625- diskutil.py, diskutil.c: add some simple disk utility methods (mount,
626  umount, sync, ejectCdrom)
627
628* Mon Jul 22 2002 Jeremy Katz <katzj@redhat.com> 0.26-1
629- comps.py: add support for reading group hierarchy
630
631* Thu Jul 17 2002 Brent Fox <bfox@redhat.com> 0.25-1
632- Make firstboot windows use GtkDialog instead of GtkWindow
633
634* Wed Jul 17 2002 Brent Fox <bfox@redhat.com> 0.24-3
635- Change Poland keyboard to Polish.  Bug #68520
636
637* Wed Jul 17 2002 Michael Fulbright <msf@redhat.com> 0.24-2
638- minor typo fix
639
640* Wed Jul 17 2002 Michael Fulbright <msf@redhat.com> 0.24-1
641- executil.py: add getfd() function
642
643* Tue Jul 16 2002 Jeremy Katz <katzj@redhat.com> 0.23-1
644- comps.py: add metapkg support
645
646* Tue Jul 16 2002 Brent Fox <bfox@redhat.com> 0.22-2
647- Call loadkeys if the binary exists when changing keymaps
648
649* Mon Jul 15 2002 Jeremy Katz <katzj@redhat.com> 0.21-1
650- fix jp106 entry in keyboard_models
651- add method to get list of supported keyboard maps
652
653* Sat Jul 13 2002 Brent Fox <bfox@redhat.com> 0.20-1
654- Small change in firstboot_gui_window.py to center popup windows
655
656* Wed Jul 10 2002 Brent Fox <bfox@redhat.com> 0.19-1
657- Added a Greek keyboard to keyboard_models.py
658
659* Wed Jul 10 2002 Alexander Larsson <alexl@redhat.com> 0.18-1
660- Fixed bug in monitor resoultion support code
661
662* Mon Jul  1 2002 Harald Hoyer <harald@redhat.de> 0.16-1
663- updated Conf*.py
664- updated genClass
665- added ethtool
666
667* Fri Jun 28 2002 Jeremy Katz <katzj@redhat.com> 0.15-1
668- comps.py: use libxml2 for xml parsing instead of expat
669
670* Fri Jun 28 2002 Jeremy Katz <katzj@redhat.com> 0.14-1
671- only setxkbmap if $DISPLAY is set
672
673* Thu Jun 27 2002 Jeremy Katz <katzj@redhat.com> 0.13-1
674- add parser for new comps file
675
676* Wed Jun 26 2002 Michael Fulbright <msf@redhat.com> 0.12-1
677- Fix bug of uninitialized data in Mouse class
678
679* Tue Jun 25 2002 Brent Fox <bfox@redhat.com> 0.11-3
680- Allow a window title to be passed in
681
682* Wed Jun 19 2002 Brent Fox <bfox@redhat.com> 0.9-4
683- Fixed line for German keyboards in keyboard_models.py
684
685* Tue Jun 18 2002 Brent Fox <bfox@redhat.com> 0.9-3
686- Remove cancel button from firstboot_gui_window
687
688* Tue Jun 18 2002 Brent Fox <bfox@redhat.com> 0.9-2
689- Provide a way to pass keymap name back to firstboot
690- Fix error in Slovakian keymap line in keyboard_models.py
691
692* Wed Jun 12 2002 Jeremy Katz <katzj@redhat.com>
693- use cz-lat2 for Czechoslovakian keybaord map (#66354)
694
695* Tue Jun 04 2002 Michael Fulbright <msf@redhat.com>
696- fixed bug referencing ddcDevice and videoram in card.
697
698* Tue May 28 2002 Jeremy Katz <katzj@redhat.com>
699- removed kbd.py, added keyboard.py
700
701* Fri May 24 2002 Michael Fulbright <msf@redhat.com>
702- Added kbd.py
703
704* Thu May 23 2002 Alex Larsson <alexl@redhat.com>
705- Added /usr/share/rhpl to files list
706
707* Thu May 23 2002 Michael Fulbright <msf@redhat.com>
708- added log.py, videocard.py, mouse.py, monitor.py, simpleconfig.py
709
710* Wed May 22 2002 Jeremy Katz <katzj@redhat.com>
711- Initial build.
712
713
Note: See TracBrowser for help on using the repository browser.